收集 Infoblox DNS 記錄
本文說明如何使用 Bindplane 代理程式,將 Infoblox DNS 記錄擷取至 Google Security Operations。
剖析器會從 Infoblox DNS SYSLOG 和 CEF 格式的記錄中擷取欄位。它會使用 grok 和/或 kv 剖析記錄訊息,然後將這些值對應至統合式資料模型 (UDM)。並設定事件來源和類型的預設中繼資料值。
事前準備
請確認您已完成下列事前準備事項:
- Google SecOps 執行個體
- Windows Server 2016 以上版本,或搭載
systemd的 Linux 主機 - 如果是在 Proxy 後方執行,請確認防火牆通訊埠已按照 Bindplane 代理程式規定開啟
- Infoblox Grid Manager 網頁介面的特殊存取權
取得 Bindplane 代理程式的 Google SecOps 憑證
如要向 Google SecOps 驗證 Bindplane 代理程式,請選擇下列其中一種方法:
- 新部署作業:使用 Chronicle API (選項 1)。
- 舊版部署作業:繼續使用擷取驗證檔案 (選項 2),直到 Ingestion API 於 2027 年 7 月 20 日停用。
方法 1:為 Chronicle API 建立服務帳戶 (建議)
- 登入 Google Cloud 控制台,選取連結至 Google SecOps 執行個體的 Google Cloud 專案。
- 依序前往「IAM & Admin」(IAM 與管理) >「Service Accounts」(服務帳戶)。
- 按一下「建立服務帳戶」。
- 提供下列設定詳細資料:
- 「Service account name」(服務帳戶名稱):輸入帳戶名稱 (例如
bindplane-ingest)。 - 「服務帳戶說明」:輸入說明 (例如
Bindplane agent log ingestion)。
- 「Service account name」(服務帳戶名稱):輸入帳戶名稱 (例如
- 點按「Create and continue」(建立並繼續)。
- 在「將專案存取權授予這個服務帳戶」部分,按一下「選取角色」,然後選取「Chronicle 編輯者」。
- 依序點選「繼續」和「完成」。
- 按一下您建立的服務帳戶,然後前往「金鑰」分頁。
- 依序點選「新增金鑰」>「建立新的金鑰」。
- 選取「JSON」,然後點選「建立」。金鑰檔案會下載到電腦。
- 將金鑰檔案儲存為 Bindplane 收集器目錄中的
ingestion-auth.json(Linux 上的/opt/observiq-otel-collector/ingestion-auth.json或 Windows 上的C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json),或更新config.yaml中的creds_file_path,使其與儲存路徑相符。 - 依序前往「IAM & Admin」(IAM 與管理) >「Settings」(設定),然後複製「Project number」(專案編號)。設定匯出工具時會用到。
方法 2:下載擷取驗證檔案 (舊版)
- 登入 Google SecOps 控制台。
- 依序前往「SIEM 設定」>「收集代理程式」。
- 下載擷取驗證檔案。
- 將檔案安全地儲存在要安裝 Bindplane 代理程式的系統中。
取得 Google SecOps 客戶 ID
- 登入 Google SecOps 控制台。
- 依序前往「SIEM 設定」 > 「設定檔」。
- 複製並儲存「機構詳細資料」專區中的「客戶 ID」。
安裝 Bindplane 代理程式
請按照下列操作說明,在 Windows 或 Linux 作業系統上安裝 Bindplane 代理程式。
Windows 安裝
- 以管理員身分開啟命令提示字元或 PowerShell。
執行下列指令:
msiexec /i "https://github.com/observIQ/bindplane-agent/releases/latest/download/observiq-otel-collector.msi" /quiet等待安裝完成。
執行下列指令,確認安裝成功:
sc query observiq-otel-collector服務應顯示為「RUNNING」。
安裝 Linux
- 開啟具有 root 或 sudo 權限的終端機。
執行下列指令:
sudo sh -c "$(curl -fsSlL https://github.com/observiq/bindplane-agent/releases/latest/download/install_unix.sh)" install_unix.sh等待安裝完成。
執行下列指令,確認安裝成功:
sudo systemctl status observiq-otel-collector服務應顯示為「active (running)」。
其他安裝資源
如需其他安裝選項和疑難排解資訊,請參閱 Bindplane 代理程式安裝指南。
設定 Bindplane 代理程式,擷取系統記錄並傳送至 Google SecOps
找出設定檔
Linux:
sudo nano /opt/observiq-otel-collector/config.yamlWindows:
notepad "C:\Program Files\observIQ OpenTelemetry Collector\config.yaml"
編輯設定檔
將
config.yaml的全部內容替換為下列設定:receivers: udplog: listen_address: "0.0.0.0:514" exporters: chronicle/chronicle_w_labels: protocol: https # Region of your instance, for example us, europe, asia-southeast1 location: <LOCATION> # Project number of the Google Cloud project linked to the instance project: '<PROJECT_NUMBER>' compression: gzip creds_file_path: '/path/to/ingestion-authentication-file.json' customer_id: 'YOUR_CUSTOMER_ID' endpoint: chronicle.googleapis.com log_type: 'INFOBLOX_DNS' raw_log_field: body ingestion_labels: service: pipelines: logs/source0__chronicle_w_labels-0: receivers: - udplog exporters: - chronicle/chronicle_w_labels
設定參數
替換下列預留位置:
接收器設定:
udplog:使用udplog進行 UDP 系統記錄,或使用tcplog進行 TCP 系統記錄0.0.0.0:要監聽的 IP 位址 (0.0.0.0表示監聽所有介面)514:要監聽的通訊埠編號 (標準 syslog 通訊埠)
匯出工具設定:
creds_file_path:服務帳戶 JSON 金鑰檔案的完整路徑 (選項 1):- Linux:
/opt/observiq-otel-collector/ingestion-auth.json - Windows:
C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json
- Linux:
YOUR_CUSTOMER_ID:「取得客戶 ID」部分的客戶 IDlocation:將<LOCATION>替換為 Google SecOps 執行個體的區域 (例如us、europe或asia-southeast1)。匯出工具會以這個值做為chronicle.googleapis.com的前置字元。如需完整清單,請參閱「區域性端點」。project:將<PROJECT_NUMBER>替換為「IAM 與管理」>「設定」中的專案編號。endpoint:維持設為chronicle.googleapis.com。log_type:記錄類型,與 Chronicle 中顯示的完全一致 (INFOBLOX_DNS)
舊版 Ingestion API 匯出工具
如果您使用選項 2 的擷取驗證檔案,請將
exporters區塊替換為下列內容。將creds_file_path設為擷取驗證檔案的路徑。如果執行個體位於美國境外,請將malachiteingestion-pa.googleapis.com替換為區域端點 (例如europe-malachiteingestion-pa.googleapis.com)。exporters: chronicle/chronicle_w_labels: compression: gzip creds_file_path: '/path/to/ingestion-authentication-file.json' customer_id: 'YOUR_CUSTOMER_ID' endpoint: malachiteingestion-pa.googleapis.com log_type: 'INFOBLOX_DNS' raw_log_field: body ingestion_labels:
儲存設定檔
- 編輯完成後,請儲存檔案:
- Linux:依序按下
Ctrl+O、Enter和Ctrl+X - Windows:依序點選「檔案」>「儲存」
- Linux:依序按下
重新啟動 Bindplane 代理程式,套用變更
如要在 Linux 中重新啟動 Bindplane 代理程式,請執行下列指令:
sudo systemctl restart observiq-otel-collector確認服務正在執行:
sudo systemctl status observiq-otel-collector檢查記錄是否有錯誤:
sudo journalctl -u observiq-otel-collector -f
如要在 Windows 中重新啟動 Bindplane 代理程式,請選擇下列其中一個選項:
以管理員身分開啟命令提示字元或 PowerShell:
net stop observiq-otel-collector && net start observiq-otel-collector服務控制台:
- 按下
Win+R,輸入services.msc,然後按下 Enter 鍵。 - 找出「observIQ OpenTelemetry Collector」。
- 按一下滑鼠右鍵,然後選取「重新啟動」。
確認服務正在執行:
sc query observiq-otel-collector檢查記錄是否有錯誤:
type "C:\Program Files\observIQ OpenTelemetry Collector\log\collector.log"
- 按下
在 Infoblox DNS 設定 Syslog 轉送
本節適用於地端部署 Infoblox NIOS。如果是 Infoblox BloxOne (雲端) 部署作業,請改用下方的「設定 Infoblox BloxOne (資料連接器)」一節。
- 登入 Infoblox Grid Manager 網頁介面。
- 依序前往「Grid」>「Grid Manager」>「Members」。
- 選取要設定的成員,然後按一下「Edit」(編輯)。
- 前往「監控」分頁。
- 在「系統記錄檔」下方,按一下「新增」,即可新增系統記錄檔伺服器。
- 請提供下列設定詳細資料:
- 地址:輸入 Bindplane 代理程式主機的 IP 位址。
- 通訊埠:輸入
514。 - 傳輸:選取「UDP」。
- 節點 ID:選取 Infoblox 節點 (適用於高可用性配對)。
- 嚴重程度:選取「資訊」 (或偏好的嚴重程度)。
- 設施:選取 local0 (或偏好的設施)。
- 啟用下列記錄類別:
- DNS 查詢:依序前往「Grid DNS Properties」>「Logging」,然後勾選「Log DNS Queries」。
- DNS 回應:勾選「Log DNS Responses」(記錄 DNS 回應)。
- DHCP:在「Grid DHCP Properties」下方啟用 DHCP 記錄。
- 稽核:在「Grid Properties」 > 「Monitoring」下方啟用稽核記錄。
- 按一下「Save & Close」。
- 視需要重新啟動 DNS 服務。
- 檢查 Bindplane 代理程式記錄,確認系統記錄訊息是否已傳送。
設定 Infoblox BloxOne (資料連接器),轉送 DNS 記錄
如果是 Infoblox BloxOne (雲端) 部署作業,請使用 Infoblox 資料連接器,透過 Syslog 將 DNS 查詢和回應記錄檔以 CEF 格式轉送至您先前設定的 Bindplane 代理程式。
- 如果尚未部署 Infoblox 資料連接器,請按照「部署 Data Connector 解決方案」指南操作。
- 登入 Infoblox Portal。
- 依序前往「整合」 > 「資料連接器」。
- 在「Destination Configuration」(目的地設定) 分頁中,從「Create」(建立) 下拉式選單選取「Syslog」。
- 在「Create Syslog Destination Configuration」(建立 Syslog 目的地設定) 精靈中,提供下列設定詳細資料:
- 名稱:輸入可區分這個目的地的名稱 (例如
secops-bindplane)。 - 狀態:使用滑桿啟用目的地。
- 格式:選取「CEF」。
- FQDN/IP:輸入 Bindplane 代理程式主機的 IP 位址。
- Port:輸入 Bindplane syslog 接收器監聽的通訊埠 (例如
514)。 - 「Protocol」:選取與 Bindplane syslog 接收器相符的通訊協定 (「UDP」或「TCP」)。
- 名稱:輸入可區分這個目的地的名稱 (例如
- 按一下「Save & Close」。
- 選取「來源」分頁標籤,確認 DNS 查詢和回應來源可用。Infoblox Threat Defense 已預先設定,不需設定。如果是通用 DDI 或地端部署 NIOS DNS 來源,請先按照「設定來源」指南在此設定來源。
- 選取「流量流程設定」分頁標籤,按一下「建立」,然後提供下列設定詳細資料:
- 名稱:輸入描述性名稱 (例如
dns-to-secops)。 - 來源:選取 DNS 查詢和回應來源 (「Infoblox Threat Defense」查詢/回應記錄,或「Universal DDI」DNS 查詢/回應記錄)。
- Destination:選取您建立的系統記錄目的地。
- 服務執行個體:選取資料連接器服務執行個體 (可視需要新增次要執行個體,用於容錯移轉)。
- 狀態:使用滑桿啟用流量。
- 名稱:輸入描述性名稱 (例如
- 按一下「Save & Close」。
UDM 對應表
| 記錄欄位 | UDM 對應 | 邏輯 |
|---|---|---|
message |
about |
對應:CEF: → about |
deviceNtDomain |
about.administrative_domain |
已重新命名/對應 |
deviceExternalId |
about.asset.asset_id |
直接對應 |
device_product |
about.asset.asset_id |
直接對應 |
device_vendor |
about.asset.asset_id |
直接對應 |
fileHash |
about.file.full_path |
直接對應 |
filePath |
about.file.full_path |
已重新命名/對應 |
_hash |
about.file.sha256 |
已重新命名/對應 |
fileHash |
about.file.sha256 |
已重新命名/對應 |
fsize |
about.file.size |
已重新命名/對應 |
dvchost |
about.hostname |
已重新命名/對應 |
ips |
about.ip |
已合併 |
message |
about.ip |
已對應:CEF: → ips |
dvc_mac |
about.mac |
對應:slot → mac_address |
dvcmac |
about.mac |
已合併 |
mac_address |
about.mac |
已合併 |
message |
about.mac |
對應:CEF: → mac_address,CEF: → dvcmac |
deviceTranslatedAddress |
about.nat_ip |
已合併 |
message |
about.nat_ip |
對應:CEF: → deviceTranslatedAddress |
Emne |
about.process.command_line |
直接對應 |
Path |
about.process.command_line |
直接對應 |
Subject |
about.process.command_line |
直接對應 |
deviceProcessName |
about.process.command_line |
已重新命名/對應 |
dvcpid |
about.process.pid |
已重新命名/對應 |
message |
about.resource.attribute.permissions |
對應:CEF: → permissions |
permissions |
about.resource.attribute.permissions |
已合併 |
_field |
additional.fields |
已合併 |
additional_cfp1 |
additional.fields |
已合併 |
additional_cfp2 |
additional.fields |
已合併 |
additional_cfp3 |
additional.fields |
已合併 |
additional_cfp4 |
additional.fields |
已合併 |
additional_cn1 |
additional.fields |
已合併 |
additional_cn2 |
additional.fields |
已合併 |
additional_cn3 |
additional.fields |
已合併 |
additional_cs1 |
additional.fields |
已合併 |
additional_cs2 |
additional.fields |
已合併 |
additional_cs3 |
additional.fields |
已合併 |
additional_cs4 |
additional.fields |
已合併 |
additional_cs5 |
additional.fields |
已合併 |
additional_cs6 |
additional.fields |
已合併 |
additional_cs7 |
additional.fields |
已合併 |
additional_devicePayloadId |
additional.fields |
已合併 |
additional_eventId |
additional.fields |
已合併 |
additional_flexString1 |
additional.fields |
已合併 |
additional_fname |
additional.fields |
已合併 |
allow_recursion_label |
additional.fields |
已合併 |
auth_type_label |
additional.fields |
已合併 |
create_ptr_for_bulk_hosts_label |
additional.fields |
已合併 |
create_ptr_for_hosts_label |
additional.fields |
已合併 |
cs2 |
additional.fields |
對應:arc_test → additional_cs2 |
cs5_label |
additional.fields |
已合併 |
ddns_principal_group_label |
additional.fields |
已合併 |
exclude_subobj_label |
additional.fields |
已合併 |
is_multimaster_label |
additional.fields |
已合併 |
locked_label |
additional.fields |
已合併 |
message |
additional.fields |
對應值 (共 34 個,例如 CEF: → additional_eventId、CEF: → `additional_devicePayl... |
mgm_private_label |
additional.fields |
已合併 |
ms_ad_integrated_label |
additional.fields |
已合併 |
network_view_label |
additional.fields |
已合併 |
object_type |
additional.fields |
對應值 (共 12 個,例如 DnsView → allow_recursion_label、DnsView → `ddns_princip... |
use_ssh_keys_label |
additional.fields |
已合併 |
view_label |
additional.fields |
已合併 |
zone_format_label |
additional.fields |
已合併 |
_intermediary |
intermediary |
已合併 |
message |
intermediary |
對應:CEF: → _intermediary |
description |
metadata.description |
直接對應 |
msg |
metadata.description |
已重新命名/對應 |
Generated |
metadata.event_timestamp |
剖析為 yyyy-MM-ddTHH:mm:ss |
Received |
metadata.event_timestamp |
已剖析為 yyyy-MM-ddTHH:mm:ss |
datetime |
metadata.event_timestamp |
已剖析為 dd-MMM-yyyy HH:mm:ss.SSS |
rt |
metadata.event_timestamp |
剖析為 yyyy-MM-ddTHH:mm:ssZ |
syslog_timestamp |
metadata.event_timestamp |
剖析為 MMM d HH:mm:ss |
event_name |
metadata.event_type |
已對應:"LogSpyware","LogPredictiveMachineLearning" → SCAN_UNCATEGORIZED |
event_type |
metadata.event_type |
已重新命名/對應 |
has_user |
metadata.event_type |
已對應:true → USER_UNCATEGORIZED |
message |
metadata.event_type |
對應:CEF: → PROCESS_UNCATEGORIZED、CEF: → SCAN_UNCATEGORIZED、CEF: → `USER_UNCA... |
device_event_class_id |
metadata.product_event_type |
直接對應 |
event_name |
metadata.product_event_type |
直接對應 |
evt_type |
metadata.product_event_type |
直接對應 |
object_type |
metadata.product_event_type |
直接對應 |
externalId |
metadata.product_log_id |
直接對應 |
device_product |
metadata.product_name |
直接對應 |
message |
metadata.product_name |
已對應:CEF: → Infoblox DNS |
device_version |
metadata.product_version |
直接對應 |
device_vendor |
metadata.vendor_name |
已重新命名/對應 |
message |
metadata.vendor_name |
對應:CEF: → INFOBLOX |
app_protocol_output |
network.application_protocol |
直接對應 |
message |
network.application_protocol |
已對應:CEF: → DNS |
deviceDirection |
network.direction |
對應:0 → INBOUND,1 → OUTBOUND |
message |
network.direction |
對應:CEF: → INBOUND,CEF: → OUTBOUND |
answers1 |
network.dns.answers |
已合併 |
answers2 |
network.dns.answers |
已合併 |
dns_answer |
network.dns.answers |
已合併 |
message |
network.dns.answers |
對應:CEF: → dns_answer、CEF: → answers1、CEF: → answers2 |
msg2 |
network.dns.answers |
已對應:; → dns_answer |
authority |
network.dns.authority |
已合併 |
dns_authority |
network.dns.authority |
已合併 |
message |
network.dns.authority |
已對應:CEF: → dns_authority、CEF: → authority |
dns_question |
network.dns.questions |
已合併 |
message |
network.dns.questions |
對應:CEF: → dns_question |
dns.response_code |
network.dns.response_code |
已重新命名/對應 |
requestMethod |
network.http.method |
已重新命名/對應 |
requestClientApplication |
network.http.user_agent |
已重新命名/對應 |
ip_protocol_out |
network.ip_protocol |
直接對應 |
protocol |
network.ip_protocol |
直接對應 |
in |
network.received_bytes |
已重新命名/對應 |
out |
network.sent_bytes |
已重新命名/對應 |
sntdom |
principal.administrative_domain |
已重新命名/對應 |
sourceServiceName |
principal.application |
已重新命名/對應 |
src_host |
principal.asset.hostname |
直接對應 |
src_ip |
principal.asset.hostname |
直接對應 |
message |
principal.asset.ip |
對應:CEF: → src_ip |
src_ip |
principal.asset.ip |
已合併 |
Group_name |
principal.group.group_display_name |
直接對應 |
Gruppenavn |
principal.group.group_display_name |
直接對應 |
Device_name |
principal.hostname |
直接對應 |
Enhetsnavn |
principal.hostname |
直接對應 |
shost |
principal.hostname |
已重新命名/對應 |
src_host |
principal.hostname |
直接對應 |
src_ip |
principal.hostname |
直接對應 |
message |
principal.ip |
對應:CEF: → principal_ip、CEF: → shost、CEF: → src_ip |
principal_ip |
principal.ip |
已合併 |
shost |
principal.ip |
已合併 |
src_ip |
principal.ip |
已合併 |
InfobloxB1Region |
principal.location.country_or_region |
直接對應 |
mac |
principal.mac |
已合併 |
message |
principal.mac |
已對應:CEF: → mac |
message |
principal.nat_ip |
對應:CEF: → sourceTranslatedAddress |
sourceTranslatedAddress |
principal.nat_ip |
已合併 |
sourceTranslatedPort |
principal.nat_port |
已重新命名/對應 |
spt |
principal.port |
已重新命名/對應 |
src_port |
principal.port |
直接對應 |
sproc |
principal.process.command_line |
已重新命名/對應 |
spid |
principal.process.pid |
已重新命名/對應 |
message |
principal.user.attribute.roles |
對應:CEF: → principal_role |
principal_role |
principal.user.attribute.roles |
已合併 |
suser |
principal.user.user_display_name |
直接對應 |
actor_details |
principal.user.userid |
直接對應 |
suid |
principal.user.userid |
已重新命名/對應 |
message |
security_result |
已對應:CEF: → security_result、CEF: → sec_result |
sec_result |
security_result |
已合併 |
_action |
security_result.action |
已合併 |
act |
security_result.action |
對應:accept → _action,deny → _action |
message |
security_result.action |
已對應:CEF: → _action |
Action_Taken |
security_result.action_details |
直接對應 |
act |
security_result.action_details |
直接對應 |
cat |
security_result.category_details |
已合併 |
message |
security_result.category_details |
已對應:CEF: → cat |
Scan_Type |
security_result.description |
直接對應 |
Type |
security_result.description |
直接對應 |
msg_data_2 |
security_result.description |
直接對應 |
infection_channel_label |
security_result.detection_fields |
已合併 |
message |
security_result.detection_fields |
對應值 (共 7 個,例如 CEF: → operation_label、CEF: → operasjon_label、CEF: ... |
operasjon_label |
security_result.detection_fields |
已合併 |
operation_label |
security_result.detection_fields |
已合併 |
permission_label |
security_result.detection_fields |
已合併 |
spyware_Grayware_Type_label |
security_result.detection_fields |
已合併 |
threat_probability_label |
security_result.detection_fields |
已合併 |
tillatelse_label |
security_result.detection_fields |
已合併 |
mwProfile |
security_result.rule_name |
直接對應 |
message |
security_result.severity |
對應:CEF: → LOW、CEF: → MEDIUM、CEF: → HIGH、CEF: → CRITICAL |
severity |
security_result.severity |
對應:"0", "1", "2", "3", "LOW" → LOW、`"4", "5", "6", "MEDIUM", "SUBSTANTIAL", "INFO"... |
Result |
security_result.summary |
直接對應 |
appcategory |
security_result.summary |
直接對應 |
reason |
security_result.summary |
已重新命名/對應 |
Spyware |
security_result.threat_name |
直接對應 |
Unknown_Threat |
security_result.threat_name |
直接對應 |
Virus_Malware_Name |
security_result.threat_name |
直接對應 |
oldFilePath |
src.file.full_path |
已重新命名/對應 |
oldFileSize |
src.file.size |
已重新命名/對應 |
message |
src.resource.attribute.permissions |
對應:CEF: → old_permissions |
old_permissions |
src.resource.attribute.permissions |
已合併 |
dntdom |
target.administrative_domain |
已重新命名/對應 |
destinationServiceName |
target.application |
已重新命名/對應 |
dst_ip |
target.asset.hostname |
直接對應 |
dst_ip1 |
target.asset.hostname |
直接對應 |
dst_ip1 |
target.asset.ip |
已合併 |
message |
target.asset.ip |
已對應:CEF: → dst_ip1 |
message |
target.asset.mac |
對應:CEF: → target_mac |
target_mac |
target.asset.mac |
已對應:^([0-9A-Fa-f]{2}[:-]){5}[0-9A-Fa-f]{2}$ → target_mac |
dst_ip |
target.hostname |
直接對應 |
dst_ip1 |
target.hostname |
直接對應 |
fqdn |
target.hostname |
直接對應 |
temp_dhost |
target.hostname |
直接對應 |
IPv6_Address |
target.ip |
已合併 |
dst_ip |
target.ip |
已合併 |
dst_ip1 |
target.ip |
已合併 |
ipv6 |
target.ip |
對應:- → IPv6_Address |
message |
target.ip |
對應:CEF: → dst_ip、CEF: → IPv6_Address、CEF: → dst_ip1 |
mac_address |
target.mac |
已合併 |
message |
target.mac |
已對應:CEF: → mac_address、CEF: → target_mac |
target_mac |
target.mac |
對應:^([0-9A-Fa-f]{2}[:-]){5}[0-9A-Fa-f]{2}$ → target_mac |
destination_translated_address |
target.nat_ip |
已合併 |
message |
target.nat_ip |
已對應:CEF: → destination_translated_address |
destinationTranslatedPort |
target.nat_port |
已重新命名/對應 |
dpt |
target.port |
已重新命名/對應 |
dst_port |
target.port |
直接對應 |
dproc |
target.process.command_line |
已重新命名/對應 |
File_name |
target.process.file.full_path |
直接對應 |
Infected_Resource |
target.process.file.full_path |
直接對應 |
Object |
target.process.file.full_path |
直接對應 |
Objekt |
target.process.file.full_path |
直接對應 |
dpid |
target.process.pid |
已重新命名/對應 |
message |
target.resource.attribute.labels |
已對應:CEF: → resource_Type_label |
resource_Type_label |
target.resource.attribute.labels |
已合併 |
name |
target.resource.name |
直接對應 |
object_name |
target.resource.name |
直接對應 |
request |
target.url |
直接對應 |
message |
target.user.attribute.roles |
對應:CEF: → target_role |
target_role |
target.user.attribute.roles |
已合併 |
group_id |
target.user.group_identifiers |
已合併 |
message |
target.user.group_identifiers |
對應:CEF: → group_id |
object_type |
target.user.group_identifiers |
已對應:AdminMember → group_id |
CustomerName |
target.user.user_display_name |
直接對應 |
name |
target.user.user_display_name |
已重新命名/對應 |
temp_duser |
target.user.user_display_name |
直接對應 |
Bruker |
target.user.userid |
直接對應 |
User_value |
target.user.userid |
直接對應 |
object_name |
target.user.userid |
直接對應 |
temp_duid |
target.user.userid |
直接對應 |
| 不適用 | metadata.event_type |
常數:PROCESS_UNCATEGORIZED |
| 不適用 | metadata.product_name |
常數:Infoblox DNS |
| 不適用 | metadata.vendor_name |
常數:INFOBLOX |
| 不適用 | network.application_protocol |
常數:DNS |
| 不適用 | network.direction |
常數:INBOUND |
| 不適用 | security_result.severity |
常數:LOW |
dns_domain |
dns.answers.name |
從變更記錄對應 |
ttl_data |
dns.answers.ttl |
從變更記錄對應 |
dns_query_type |
dns.answer.type |
從變更記錄對應 |
dns_class |
dns.answer.class |
從變更記錄對應 |
intermediary_ip" or "intermediary_host |
dns.answer.data |
從變更記錄對應 |
變更記錄
還有其他問題嗎?向社群成員和 Google SecOps 專家尋求解答。