收集 Kaspersky Endpoint Security 日志
本文档介绍了如何使用 Bindplane 将 Kaspersky Endpoint Security 日志注入到 Google Security Operations。Kaspersky Endpoint Security 可为运行 Windows、macOS 和 Linux 的端点提供多层防护,抵御恶意软件、勒索软件、漏洞利用和高级威胁。Kaspersky Security Center (KSC) 是一个集中式管理控制台,可汇总来自所有受管理端点的事件,并支持 syslog 转发以实现 SIEM 集成。
准备工作
请确保满足以下前提条件:
- Google SecOps 实例。
- 搭载 systemd 的 Windows 2016 或更高版本或 Linux 主机。
- 如果在代理后面运行,请确保防火墙端口已根据 Bindplane 代理要求打开。
- 对 Kaspersky Security Center (KSC) 管理控制台或 Web 控制台的特权访问权限。
- 已安装 SIEM 集成组件的 Kaspersky Security Center 14 或更高版本。
获取 Google SecOps 注入身份验证文件
- 登录 Google SecOps 控制台。
- 依次前往 SIEM 设置 > 收集代理。
- 下载数据注入身份验证文件。
- 将文件安全地保存在将要安装 Bindplane 的系统上。
获取 Google SecOps 客户 ID
- 登录 Google SecOps 控制台。
- 依次前往 SIEM 设置 > 配置文件。
- 复制并保存组织详细信息部分中的客户 ID。
安装 Bindplane 代理
按照以下说明在 Windows 或 Linux 操作系统上安装 Bindplane 代理。
Windows 安装
- 以管理员身份打开命令提示符或 PowerShell。
运行以下命令:
msiexec /i "https://github.com/observIQ/bindplane-agent/releases/latest/download/observiq-otel-collector.msi" /quiet
Linux 安装
- 打开具有 root 或 sudo 权限的终端。
运行以下命令:
sudo sh -c "$(curl -fsSlL https://github.com/observiq/bindplane-agent/releases/latest/download/install_unix.sh)" install_unix.sh
其他安装资源
如需了解其他安装选项,请参阅此安装指南。
配置 Bindplane 代理以注入 Syslog 并将其发送到 Google SecOps
访问配置文件:
- 找到
config.yaml文件。通常,它位于 Linux 上的/observiq-otel-collector/目录中或 Windows 上的安装目录中。 - 使用文本编辑器(例如
nano、vi或记事本)打开该文件。
- 找到
按如下方式修改
config.yaml文件:receivers: tcplog: # Replace the port and IP address as required listen_address: "0.0.0.0:514" exporters: chronicle/chronicle_w_labels: compression: gzip # Adjust the path to the credentials file you downloaded in Step 1 creds_file_path: '/path/to/ingestion-authentication-file.json' # Replace with your actual customer ID from Step 2 customer_id: <PLACEHOLDER_CUSTOMER_ID> endpoint: malachiteingestion-pa.googleapis.com # Add optional ingestion labels for better organization log_type: 'KASPERSKY_AV' raw_log_field: body ingestion_labels: service: pipelines: logs/source0__chronicle_w_labels-0: receivers: - tcplog exporters: - chronicle/chronicle_w_labels
- 根据基础架构的需要替换端口和 IP 地址。
- 将
<PLACEHOLDER_CUSTOMER_ID>替换为实际的客户 ID。 - 将
/path/to/ingestion-authentication-file.json更新为获取 Google SecOps 注入身份验证文件部分中保存身份验证文件的文件路径。
重启 Bindplane 代理以应用更改
如需在 Linux 中重启 Bindplane 代理,请执行以下操作:
运行以下命令:
sudo systemctl restart observiq-otel-collector验证服务是否正在运行:
sudo systemctl status observiq-otel-collector检查日志是否存在错误:
sudo journalctl -u observiq-otel-collector -f
如需在 Windows 中重启 Bindplane 代理,请执行以下操作:
请从下列选项中选择一项:
- 以管理员身份运行命令提示符或 PowerShell:
net stop observiq-otel-collector && net start observiq-otel-collector- 服务控制台:
- 按
Win+R,输入services.msc,然后按 Enter 键。 - 找到 observIQ OpenTelemetry 收集器。
- 右键点击并选择重新启动。
- 按
验证服务是否正在运行:
sc query observiq-otel-collector检查日志是否存在错误:
type "C:\Program Files\observIQ OpenTelemetry Collector\log\collector.log"
配置 Kaspersky Security Center syslog 转发
- 登录 Kaspersky Security Center Web Console 或打开管理控制台 (MMC)。
- 依次前往管理服务器 > 属性(或右键点击“管理服务器”节点,然后选择属性)。
- 在属性窗口中,依次前往事件导出 > SIEM。
- 选中自动将事件导出到 SIEM 系统数据库复选框。
- 提供以下配置详细信息:
- SIEM 系统:选择其他。
- SIEM 系统服务器地址:输入 Bindplane 代理主机(例如
192.168.1.100)的 IP 地址。 - SIEM 系统服务器端口:输入
514(或在 Bindplane 中配置的端口)。 - 协议:选择 TCP。
- 格式:选择 Syslog(CEF 格式)。
点击要导出的事件,选择要转发的事件类别:
- 选中严重事件复选框。
- 选中功能性故障复选框。
- 选中警告复选框。
- 选中信息复选框。
点击 OK 以保存 SIEM 导出配置。
依次前往管理服务器 > 事件。
通过检查 Bindplane 代理日志,验证事件是否显示以及 syslog 传送是否处于活动状态。
如需了解更多详情,请参阅 Kaspersky Security Center 文档中的 SIEM 集成。
UDM 映射表
| 日志字段 | UDM 映射 | 逻辑 |
|---|---|---|
message |
about |
已映射:CEF:0 → about |
deviceNtDomain |
about.administrative_domain |
已重命名/已映射 |
deviceExternalId |
about.asset.asset_id |
直接映射 |
device_product |
about.asset.asset_id |
直接映射 |
device_vendor |
about.asset.asset_id |
直接映射 |
fileHash |
about.file.full_path |
直接映射 |
filePath |
about.file.full_path |
已重命名/已映射 |
_hash |
about.file.sha256 |
已重命名/已映射 |
fileHash |
about.file.sha256 |
已重命名/已映射 |
fsize |
about.file.size |
已重命名/已映射 |
dvchost |
about.hostname |
已重命名/已映射 |
ips |
about.ip |
已合并 |
message |
about.ip |
已映射:CEF:0 → ips |
dvc_mac |
about.mac |
已映射:slot → mac_address |
dvcmac |
about.mac |
已合并 |
mac_address |
about.mac |
已合并 |
message |
about.mac |
已映射:CEF:0 → mac_address、CEF:0 → dvcmac |
deviceTranslatedAddress |
about.nat_ip |
已合并 |
message |
about.nat_ip |
已映射:CEF:0 → deviceTranslatedAddress |
Emne |
about.process.command_line |
直接映射 |
Path |
about.process.command_line |
直接映射 |
Subject |
about.process.command_line |
直接映射 |
deviceProcessName |
about.process.command_line |
已重命名/已映射 |
dvcpid |
about.process.pid |
已重命名/已映射 |
message |
about.resource.attribute.permissions |
已映射:CEF:0 → permissions |
permissions |
about.resource.attribute.permissions |
已合并 |
additional_cfp1 |
additional.fields |
已合并 |
additional_cfp2 |
additional.fields |
已合并 |
additional_cfp3 |
additional.fields |
已合并 |
additional_cfp4 |
additional.fields |
已合并 |
additional_cn1 |
additional.fields |
已合并 |
additional_cn2 |
additional.fields |
已合并 |
additional_cn3 |
additional.fields |
已合并 |
additional_cs1 |
additional.fields |
已合并 |
additional_cs2 |
additional.fields |
已合并 |
additional_cs3 |
additional.fields |
已合并 |
additional_cs4 |
additional.fields |
已合并 |
additional_cs5 |
additional.fields |
已合并 |
additional_cs6 |
additional.fields |
已合并 |
additional_cs7 |
additional.fields |
已合并 |
additional_devicePayloadId |
additional.fields |
已合并 |
additional_eventId |
additional.fields |
已合并 |
additional_flexString1 |
additional.fields |
已合并 |
additional_fname |
additional.fields |
已合并 |
cn1_label |
additional.fields |
已合并 |
cs2 |
additional.fields |
已映射:arc_test → additional_cs2 |
cs5_label |
additional.fields |
已合并 |
cs9_label |
additional.fields |
已合并 |
event_component_label |
additional.fields |
已合并 |
event_type_label |
additional.fields |
已合并 |
kl_event_status_label |
additional.fields |
已合并 |
message |
additional.fields |
映射的值(总共 25 个,例如 CEF:0 → additional_eventId、CEF:0 → `additional_devicePa... |
tdn_label |
additional.fields |
已合并 |
message |
extensions.vulns.vulnerabilities |
已映射:CEF:0 → vulnerabilities |
vulnerabilities |
extensions.vulns.vulnerabilities |
已合并 |
message |
intermediary |
已映射:CEF:0 → intermediary |
intermediary_host |
intermediary.hostname |
直接映射 |
intermediary_hostname |
intermediary.hostname |
直接映射 |
meta_description |
metadata.description |
直接映射 |
msg |
metadata.description |
已重命名/已映射 |
Generated |
metadata.event_timestamp |
解析为 yyyy-MM-ddTHH:mm:ss |
Received |
metadata.event_timestamp |
解析为 yyyy-MM-ddTHH:mm:ss |
formatted_timestamp |
metadata.event_timestamp |
解析为 yyyy-MM-ddTHH:mm:ss Z |
rt |
metadata.event_timestamp |
解析为 yyyy-MM-ddTHH:mm:ssZ |
time |
metadata.event_timestamp |
解析为 ISO8601 |
ts |
metadata.event_timestamp |
解析为 ISO8601 |
event_name |
metadata.event_type |
已映射:"LogSpyware","LogPredictiveMachineLearning" → SCAN_UNCATEGORIZED |
event_type |
metadata.event_type |
直接映射 |
event_type_set |
metadata.event_type |
已映射:false → NETWORK_CONNECTION、false → STATUS_UPDATE |
message |
metadata.event_type |
映射值(共 7 个,例如 CEF:0 → PROCESS_UNCATEGORIZED、CEF:0 → `SCAN_UNCATEGORIZE... |
target_hostname_present |
metadata.event_type |
已映射:true → USER_UNCATEGORIZED |
device_event_class_id |
metadata.product_event_type |
直接映射 |
et |
metadata.product_event_type |
直接映射 |
event_name |
metadata.product_event_type |
直接映射 |
product_event_type |
metadata.product_event_type |
直接映射 |
externalId |
metadata.product_log_id |
直接映射 |
device_product |
metadata.product_name |
直接映射 |
message |
metadata.product_name |
已映射:CEF:0 → SecurityCenter、CEF:0 → KASPERSKY_AV |
device_version |
metadata.product_version |
直接映射 |
device_vendor |
metadata.vendor_name |
已重命名/已映射 |
message |
metadata.vendor_name |
已映射:CEF:0 → KasperskyLab、CEF:0 → KASPERSKY |
app_protocol_output |
network.application_protocol |
直接映射 |
message |
network.application_protocol |
已映射:CEF:0 → HTTP |
protocol |
network.application_protocol |
已映射:(?i)http → HTTP |
deviceDirection |
network.direction |
映射:0 → INBOUND,1 → OUTBOUND |
message |
network.direction |
已映射:CEF:0 → INBOUND、CEF:0 → OUTBOUND |
method |
network.http.method |
直接映射 |
requestMethod |
network.http.method |
已重命名/已映射 |
url |
network.http.referral_url |
直接映射 |
Application |
network.http.user_agent |
直接映射 |
description |
network.http.user_agent |
直接映射 |
requestClientApplication |
network.http.user_agent |
已重命名/已映射 |
ip_protocol_out |
network.ip_protocol |
直接映射 |
in |
network.received_bytes |
已重命名/已映射 |
out |
network.sent_bytes |
已重命名/已映射 |
domain |
principal.administrative_domain |
直接映射 |
sntdom |
principal.administrative_domain |
已重命名/已映射 |
sourceServiceName |
principal.application |
已重命名/已映射 |
ip |
principal.asset.ip |
已合并 |
message |
principal.asset.ip |
已映射:CEF:0 → ip |
Group_name |
principal.group.group_display_name |
直接映射 |
Gruppenavn |
principal.group.group_display_name |
直接映射 |
Device_name |
principal.hostname |
直接映射 |
Enhetsnavn |
principal.hostname |
直接映射 |
description |
principal.hostname |
直接映射 |
hdn |
principal.hostname |
直接映射 |
host_name |
principal.hostname |
直接映射 |
shost |
principal.hostname |
已重命名/已映射 |
hip |
principal.ip |
已合并 |
ip |
principal.ip |
已合并 |
message |
principal.ip |
已映射:CEF:0 → principal_ip、CEF:0 → shost、CEF:0 → ip、CEF:0 → hip |
principal_ip |
principal.ip |
已合并 |
shost |
principal.ip |
已合并 |
mac |
principal.mac |
已合并 |
message |
principal.mac |
已映射:CEF:0 → mac |
message |
principal.nat_ip |
已映射:CEF:0 → sourceTranslatedAddress |
sourceTranslatedAddress |
principal.nat_ip |
已合并 |
sourceTranslatedPort |
principal.nat_port |
已重命名/已映射 |
spt |
principal.port |
已重命名/已映射 |
sproc |
principal.process.command_line |
已重命名/已映射 |
Process ID |
principal.process.pid |
直接映射 |
spid |
principal.process.pid |
已重命名/已映射 |
message |
principal.user.attribute.roles |
已映射:CEF:0 → principal_role |
principal_role |
principal.user.attribute.roles |
已合并 |
p7 |
principal.user.user_display_name |
直接映射 |
suser |
principal.user.user_display_name |
直接映射 |
user_name |
principal.user.user_display_name |
直接映射 |
username |
principal.user.user_display_name |
直接映射 |
suid |
principal.user.userid |
已重命名/已映射 |
message |
security_result |
已映射:CEF:0 → security_result |
gn_label |
security_result.about.labels |
已合并 |
label_task_name |
security_result.about.labels |
已合并 |
message |
security_result.about.labels |
已映射:CEF:0 → gn_label、CEF:0 → rtid_labels、CEF:0 → label_task_name |
rtid_labels |
security_result.about.labels |
已合并 |
_action |
security_result.action |
已合并 |
act |
security_result.action |
映射:accept → _action,deny → _action |
message |
security_result.action |
已映射:CEF:0 → _action、CEF:0 → sr_action |
sr_action |
security_result.action |
已合并 |
Action_Taken |
security_result.action_details |
直接映射 |
act |
security_result.action_details |
直接映射 |
Content category |
security_result.category_details |
已合并 |
cat |
security_result.category_details |
已合并 |
et |
security_result.category_details |
已合并 |
message |
security_result.category_details |
已映射:CEF:0 → cat、CEF:0 → Content category、CEF:0 → et |
Result description |
security_result.description |
已重命名/已映射 |
Rule |
security_result.description |
直接映射 |
Scan_Type |
security_result.description |
直接映射 |
Type |
security_result.description |
直接映射 |
description |
security_result.description |
直接映射 |
label |
security_result.description |
直接映射 |
msg_data_2 |
security_result.description |
直接映射 |
bid_id_label |
security_result.detection_fields |
已合并 |
certificate_verification_status_label |
security_result.detection_fields |
已合并 |
et2_label |
security_result.detection_fields |
已合并 |
exchange_label |
security_result.detection_fields |
已合并 |
ifm_ori_label |
security_result.detection_fields |
已合并 |
infection_channel_label |
security_result.detection_fields |
已合并 |
message |
security_result.detection_fields |
映射值(总共 20 个,例如 CEF:0 → operation_label、CEF:0 → operasjon_label、`CEF... |
object_name_label |
security_result.detection_fields |
已合并 |
object_path_label |
security_result.detection_fields |
已合并 |
object_type_label |
security_result.detection_fields |
已合并 |
operasjon_label |
security_result.detection_fields |
已合并 |
operation_label |
security_result.detection_fields |
已合并 |
permission_label |
security_result.detection_fields |
已合并 |
pub_label |
security_result.detection_fields |
已合并 |
publisher_id_label |
security_result.detection_fields |
已合并 |
sec_id_label |
security_result.detection_fields |
已合并 |
site_id_label |
security_result.detection_fields |
已合并 |
spyware_Grayware_Type_label |
security_result.detection_fields |
已合并 |
threat_probability_label |
security_result.detection_fields |
已合并 |
tillatelse_label |
security_result.detection_fields |
已合并 |
xrtb_id_label |
security_result.detection_fields |
已合并 |
mwProfile |
security_result.rule_name |
直接映射 |
p5 |
security_result.rule_name |
直接映射 |
message |
security_result.severity |
已映射:CEF:0 → LOW、CEF:0 → MEDIUM、CEF:0 → HIGH、CEF:0 → CRITICAL |
severity |
security_result.severity |
映射:"0", "1", "2", "3", "LOW" → LOW,`"4", "5", "6", "MEDIUM", "SUBSTANTIAL", "INFO"... |
Erreur |
security_result.summary |
直接映射 |
Reason |
security_result.summary |
直接映射 |
Result |
security_result.summary |
直接映射 |
appcategory |
security_result.summary |
直接映射 |
cs10 |
security_result.summary |
直接映射 |
reason |
security_result.summary |
已重命名/已映射 |
summary |
security_result.summary |
直接映射 |
Spyware |
security_result.threat_name |
直接映射 |
Type |
security_result.threat_name |
直接映射 |
Unknown_Threat |
security_result.threat_name |
直接映射 |
Virus_Malware_Name |
security_result.threat_name |
直接映射 |
oldFilePath |
src.file.full_path |
已重命名/已映射 |
oldFileSize |
src.file.size |
已重命名/已映射 |
message |
src.resource.attribute.permissions |
已映射:CEF:0 → old_permissions |
old_permissions |
src.resource.attribute.permissions |
已合并 |
dntdom |
target.administrative_domain |
已重命名/已映射 |
destinationServiceName |
target.application |
已重命名/已映射 |
name |
target.file.full_path |
直接映射 |
file_name |
target.file.names |
已合并 |
message |
target.file.names |
已映射:CEF:0 → file_name |
temp_dhost |
target.hostname |
直接映射 |
IPv6_Address |
target.ip |
已合并 |
dst_ip |
target.ip |
已合并 |
ipv6 |
target.ip |
已映射:- → IPv6_Address |
message |
target.ip |
已映射:CEF:0 → dst_ip、CEF:0 → IPv6_Address |
mac_address |
target.mac |
已合并 |
message |
target.mac |
已映射:CEF:0 → mac_address |
destination_translated_address |
target.nat_ip |
已合并 |
message |
target.nat_ip |
已映射:CEF:0 → destination_translated_address |
destinationTranslatedPort |
target.nat_port |
已重命名/已映射 |
dpt |
target.port |
已重命名/已映射 |
dproc |
target.process.command_line |
已重命名/已映射 |
Application path |
target.process.file.full_path |
直接映射 |
File_name |
target.process.file.full_path |
直接映射 |
Infected_Resource |
target.process.file.full_path |
直接映射 |
Name |
target.process.file.full_path |
直接映射 |
Nom |
target.process.file.full_path |
直接映射 |
Object |
target.process.file.full_path |
直接映射 |
Objekt |
target.process.file.full_path |
直接映射 |
application_path |
target.process.file.full_path |
直接映射 |
p2 |
target.process.file.full_path |
直接映射 |
MD5 |
target.process.file.md5 |
直接映射 |
MD5 file hash |
target.process.file.md5 |
直接映射 |
md5 |
target.process.file.md5 |
直接映射 |
File SHA256 hash |
target.process.file.sha256 |
直接映射 |
SHA256 |
target.process.file.sha256 |
直接映射 |
p1 |
target.process.file.sha256 |
直接映射 |
dpid |
target.process.pid |
已重命名/已映射 |
process_id |
target.process.pid |
直接映射 |
cs4_label |
target.resource.attribute.labels |
已合并 |
message |
target.resource.attribute.labels |
已映射:CEF:0 → resource_Type_label、CEF:0 → cs4_label |
resource_Type_label |
target.resource.attribute.labels |
已合并 |
Component |
target.resource.name |
直接映射 |
message |
target.resource.type |
映射:CEF:0 → DATABASE,Content category source → DATABASE |
source |
target.resource.type |
已映射:databases → DATABASE |
Requested web page |
target.url |
直接映射 |
request |
target.url |
直接映射 |
message |
target.user.attribute.roles |
已映射:CEF:0 → target_role |
target_role |
target.user.attribute.roles |
已合并 |
CustomerName |
target.user.user_display_name |
直接映射 |
temp_duser |
target.user.user_display_name |
直接映射 |
Bruker |
target.user.userid |
直接映射 |
User_value |
target.user.userid |
直接映射 |
temp_duid |
target.user.userid |
直接映射 |
| 不适用 | metadata.event_type |
常量:PROCESS_UNCATEGORIZED |
| 不适用 | metadata.product_name |
常量:SecurityCenter |
| 不适用 | metadata.vendor_name |
常量:KasperskyLab |
| 不适用 | network.application_protocol |
常量:HTTP |
| 不适用 | network.direction |
常量:INBOUND |
| 不适用 | security_result.severity |
常量:LOW |
| 不适用 | target.resource.type |
常量:DATABASE |
cs9 |
event.idm.read_only_udm.additional.fields |
从变更日志映射 |
cn1 |
event.idm.read_only_udm.additional.fields |
从变更日志映射 |
kl_event_status |
event.idm.read_only_udm.additional.fields |
从变更日志映射 |
cs10 |
event.idm.read_only_udm.security_result.summary |
从变更日志映射 |
cs4 |
event.idm.read_only_udm.target.resource.attribute.labels |
从变更日志映射 |
vendor_name |
event.idm.read_only_udm.metadata.vendor_name |
从变更日志映射 |
product_name |
event.idm.read_only_udm.metadata.product_name |
从变更日志映射 |
Event_Component |
additional.fields |
从变更日志映射 |
EventType |
additional.fields |
从变更日志映射 |
threat_level |
vulnerabilities.severity_details |
从变更日志映射 |
Hachage SHA256", "p1 |
target.process.file.sha256 |
从变更日志映射 |
Hachage MD5", "md5 |
target.process.file.md5 |
从变更日志映射 |
intermediary |
event.idm.read_only_udm.intermediary |
从变更日志映射 |
更新日志
需要更多帮助?获得社区成员和 Google SecOps 专业人士的解答。