收集 Kea DHCP 日志

支持:

本文档介绍了如何使用 Bindplane 代理将 Kea DHCP 日志注入 Google Security Operations。

ISC Kea 是一款开源 DHCP 服务器,可为 IPv4/IPv6 地址管理生成租约分配、续订和释放日志。解析器会从 Kea DHCP 日志消息中提取字段,并将其映射到 Unified Data Model (UDM),包括 DHCP 特定的网络属性、正文和目标标识符以及安全结果元数据。

准备工作

请确保满足以下前提条件:

  • Google SecOps 实例
  • Windows Server 2016 或更高版本,或者具有 systemd 的 Linux 主机
  • Bindplane 代理与 Kea DHCP 服务器之间的网络连接
  • 如果通过代理运行,请确保防火墙端口根据 Bindplane 代理要求处于打开状态
  • 对 Kea DHCP 服务器主机(根或 sudo)的特权访问权限

获取 Google SecOps 注入身份验证文件

  1. 登录 Google SecOps 控制台。
  2. 前往 SIEM 设置 > 收集代理
  3. 下载数据注入身份验证文件
  4. 将文件安全地保存在将安装 Bindplane 的系统上。

获取 Google SecOps 客户 ID

  1. 登录 Google SecOps 控制台。
  2. 前往 SIEM 设置 > 个人资料
  3. 组织详细信息 部分复制并保存客户 ID

安装 Bindplane 代理

按照以下说明在 Windows 或 Linux 操作系统上安装 Bindplane 代理。

Windows 安装

  1. 以管理员身份打开命令提示符PowerShell
  2. 运行以下命令:

    msiexec /i "https://github.com/observIQ/bindplane-agent/releases/latest/download/observiq-otel-collector.msi" /quiet
    
  3. 等待安装完成。

  4. 运行以下命令,验证安装是否成功:

    sc query observiq-otel-collector
    

    该服务应显示为正在运行

Linux 安装

  1. 打开具有根权限或 sudo 权限的终端。
  2. 运行以下命令:

    sudo sh -c "$(curl -fsSlL https://github.com/observiq/bindplane-agent/releases/latest/download/install_unix.sh)" install_unix.sh
    
  3. 等待安装完成。

  4. 运行以下命令,验证安装是否成功:

    sudo systemctl status observiq-otel-collector
    

    该服务应显示为活跃 (正在运行)

其他安装资源

如需了解其他安装选项和问题排查,请参阅 Bindplane 代理安装指南

配置 Bindplane 代理以注入 syslog 并发送到 Google SecOps

找到配置文件

  • Linux

    sudo nano /opt/observiq-otel-collector/config.yaml
    
  • Windows

    notepad "C:\Program Files\observIQ OpenTelemetry Collector\config.yaml"
    

修改配置文件

  • config.yaml 的全部内容替换为以下配置:

    receivers:
        udplog:
            listen_address: "0.0.0.0:514"
    
    exporters:
        chronicle/kea_dhcp:
            compression: gzip
            creds_file_path: '/etc/bindplane-agent/ingestion-auth.json'
            customer_id: '<customer_id>'
            endpoint: malachiteingestion-pa.googleapis.com
            log_type: KEA_DHCP
            raw_log_field: body
    
    service:
        pipelines:
            logs/kea_dhcp:
                receivers:
                    - udplog
                exporters:
                    - chronicle/kea_dhcp
    

配置参数

替换以下占位符:

  • 接收器配置

    • udplog:基于协议的接收器类型:
      • UDP syslog 的 udplog
      • TCP syslog 的 tcplog
      • RFC 3164/5424 syslog 的 syslog
    • 0.0.0.0:要监听的 IP 地址:
      • 0.0.0.0 以监听所有接口(推荐)
      • 特定 IP 地址以监听一个接口
    • 514:要监听的端口号(例如 51415146514
  • 导出器配置

    • <customer_id>:上一步中的客户 ID
    • malachiteingestion-pa.googleapis.com:区域级端点网址:
      • 美国malachiteingestion-pa.googleapis.com
      • 欧洲: europe-malachiteingestion-pa.googleapis.com
      • 亚洲: asia-southeast1-malachiteingestion-pa.googleapis.com
      • 如需查看完整列表,请参阅区域级端点
    • 根据平台调整 creds_file_path
      • Linux: /etc/bindplane-agent/ingestion-auth.json
      • Windows: C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json

保存配置文件

  • 修改后,保存文件:
    • Linux:按 Ctrl+O,然后按 Enter,再按 Ctrl+X
    • Windows:依次点击文件 > 保存

重启 Bindplane 代理以应用更改

  • 如需在 Linux 中重启 Bindplane 代理,请运行以下命令:

    sudo systemctl restart observiq-otel-collector
    
    1. 验证服务正在运行:

      sudo systemctl status observiq-otel-collector
      
    2. 检查日志中的错误:

      sudo journalctl -u observiq-otel-collector -f
      
  • 如需在 Windows 中重启 Bindplane 代理,请选择以下选项之一:

    • 以管理员身份运行命令提示符或 PowerShell:

      net stop observiq-otel-collector && net start observiq-otel-collector
      
    • 服务控制台:

      1. Win+R,输入 services.msc,然后按 Enter 键。
      2. 找到 observIQ OpenTelemetry Collector
      3. 右键点击并选择重启
      4. 验证服务正在运行:

        sc query observiq-otel-collector
        
      5. 检查日志中的错误:

        type "C:\Program Files\observIQ OpenTelemetry Collector\log\collector.log"
        

配置 Kea DHCP syslog 转发

Kea DHCP 会将日志写入服务器上的本地文件。配置 syslog 输出,以便将这些日志转发到 Bindplane 代理。

  1. 打开 Kea DHCP 配置文件(通常为 kea-dhcp4.confkea-dhcp6.conf)。
  2. 找到 loggers 部分。
  3. 添加或修改记录器条目以使用 syslog 输出,例如:

    {
        "loggers": [
            {
                "name": "kea-dhcp4",
                "output_options": [
                    {
                        "output": "syslog:kea-dhcp4"
                    }
                ],
                "severity": "INFO"
            }
        ]
    }
    
  4. 保存配置文件。

  5. 配置系统 syslog 守护程序(例如 rsyslog),以将 Kea 日志转发到 Bindplane 代理。修改 /etc/rsyslog.d/kea-forward.conf

    :programname, isequal, "kea-dhcp4" @BINDPLANE_AGENT_IP:514
    
  6. 重启 rsyslog 服务:

    sudo systemctl restart rsyslog
    
  7. 重启 Kea DHCP 服务:

    sudo systemctl restart kea-dhcp4-server
    

UDM 映射表

日志字段 UDM 映射 逻辑
metadata.event_type 事件类型
product_event metadata.product_event_type 特定于产品的事件类型
network.application_protocol 应用协议
mac network.dhcp.chaddr 客户端硬件地址
client_ip network.dhcp.ciaddr 客户端 IP 地址
lease_time network.dhcp.lease_time_seconds 租约时长(秒)
network.dhcp.opcode DHCP 操作码
src_ip network.dhcp.requested_address 请求的 IP 地址
network.dhcp.type DHCP 消息类型
src_ip network.dhcp.yiaddr 您的 IP 地址
client_ip observer.ip 观察器 IP 地址
host principal.hostname 正文主机名
client_ip principal.ip 正文 IP 地址
mac principal.mac 正文 MAC 地址
src_port principal.port 正文端口
security_result.severity 安全结果的严重程度
desc security_result.summary 安全结果摘要
domain_name target.hostname 目标主机名
dest_port target.port 目标端口
metadata.product_name 产品名称
metadata.vendor_name 供应商名称

更新日志

查看此解析器的更新日志

需要更多帮助?获得社区成员和 Google SecOps 专业人士的解答。