收集 Kea DHCP 記錄
本文說明如何使用 Bindplane 代理程式,將 Kea DHCP 記錄擷取至 Google Security Operations。
ISC Kea 是開放原始碼的 DHCP 伺服器,可產生 IPv4/IPv6 位址管理的租用分配、續約和釋出記錄。剖析器會從 Kea DHCP 記錄訊息中擷取欄位,並對應至 Unified Data Model (UDM),包括 DHCP 專屬網路屬性、主體和目標 ID,以及安全性結果中繼資料。
事前準備
請確認您已完成下列事前準備事項:
- Google SecOps 執行個體
- Windows Server 2016 以上版本,或搭載
systemd的 Linux 主機 - Bindplane 代理程式與 Kea DHCP 伺服器之間的網路連線
- 如果透過 Proxy 執行,請確保防火牆通訊埠已根據 Bindplane 代理程式需求開啟
- Kea DHCP 伺服器主機的特殊存取權 (root 或 sudo)
取得 Google SecOps 擷取驗證檔案
- 登入 Google SecOps 控制台。
- 依序前往「SIEM 設定」>「收集代理程式」。
- 下載擷取驗證檔案。
將檔案安全地儲存在要安裝 Bindplane 的系統上。
取得 Google SecOps 客戶 ID
- 登入 Google SecOps 控制台。
- 依序前往「SIEM 設定」>「設定檔」。
複製並儲存「機構詳細資料」部分中的客戶 ID。
安裝 Bindplane 代理程式
請按照下列操作說明,在 Windows 或 Linux 作業系統上安裝 Bindplane 代理程式。
Windows 安裝
- 以管理員身分開啟「命令提示字元」或「PowerShell」。
執行下列指令:
msiexec /i "https://github.com/observIQ/bindplane-agent/releases/latest/download/observiq-otel-collector.msi" /quiet等待安裝完成。
執行下列指令,確認安裝成功:
sc query observiq-otel-collector服務應顯示為「RUNNING」。
Linux 安裝
- 開啟具有根層級或 sudo 權限的終端機。
執行下列指令:
sudo sh -c "$(curl -fsSlL https://github.com/observiq/bindplane-agent/releases/latest/download/install_unix.sh)" install_unix.sh等待安裝完成。
執行下列指令,確認安裝成功:
sudo systemctl status observiq-otel-collector服務應顯示為有效 (執行中)。
其他安裝資源
如需其他安裝選項和疑難排解資訊,請參閱 Bindplane 代理程式安裝指南。
設定 Bindplane 代理程式,擷取系統記錄檔並傳送至 Google SecOps
找出設定檔
Linux:
sudo nano /opt/observiq-otel-collector/config.yamlWindows:
notepad "C:\Program Files\observIQ OpenTelemetry Collector\config.yaml"
編輯設定檔
將
config.yaml的所有內容替換為下列設定:receivers: udplog: listen_address: "0.0.0.0:514" exporters: chronicle/kea_dhcp: compression: gzip creds_file_path: '/etc/bindplane-agent/ingestion-auth.json' customer_id: '<customer_id>' endpoint: malachiteingestion-pa.googleapis.com log_type: KEA_DHCP raw_log_field: body service: pipelines: logs/kea_dhcp: receivers: - udplog exporters: - chronicle/kea_dhcp
設定參數
替換下列預留位置:
接收器設定:
udplog:根據通訊協定的接收器類型:udplog(適用於 UDP 系統記錄檔)tcplog適用於 TCP Syslogsyslog適用於 RFC 3164/5424 syslog
0.0.0.0:要接聽的 IP 位址:0.0.0.0,監聽所有介面 (建議)- 在一個介面上接聽的特定 IP 位址
514:要接聽的通訊埠號碼 (例如514、1514、6514)
匯出工具設定:
<customer_id>:先前步驟中的客戶 IDmalachiteingestion-pa.googleapis.com:區域端點網址:- 美國:
malachiteingestion-pa.googleapis.com - 歐洲:
europe-malachiteingestion-pa.googleapis.com - 亞洲:
asia-southeast1-malachiteingestion-pa.googleapis.com - 如需完整清單,請參閱「區域端點」
- 美國:
- 根據平台調整
creds_file_path:- Linux:
/etc/bindplane-agent/ingestion-auth.json - Windows:
C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json
- Linux:
儲存設定檔
- 編輯完成後,請儲存檔案:
- Linux:依序按下
Ctrl+O、Enter和Ctrl+X - Windows:依序點選「檔案」>「儲存」
- Linux:依序按下
重新啟動 Bindplane 代理程式,以套用變更
如要在 Linux 中重新啟動 Bindplane 代理程式,請執行下列指令:
sudo systemctl restart observiq-otel-collector確認服務正在執行:
sudo systemctl status observiq-otel-collector檢查記錄中是否有錯誤:
sudo journalctl -u observiq-otel-collector -f
如要在 Windows 中重新啟動 Bindplane 代理程式,請選擇下列其中一個選項:
以管理員身分開啟命令提示字元或 PowerShell:
net stop observiq-otel-collector && net start observiq-otel-collector服務控制台:
- 按下
Win+R,輸入services.msc,然後按下 Enter 鍵。 - 找出 observIQ OpenTelemetry Collector。
- 按一下滑鼠右鍵,然後選取「重新啟動」。
確認服務正在執行:
sc query observiq-otel-collector檢查記錄中是否有錯誤:
type "C:\Program Files\observIQ OpenTelemetry Collector\log\collector.log"
- 按下
設定 Kea DHCP 系統記錄檔轉送
Kea DHCP 會將記錄寫入伺服器上的本機檔案。請設定系統記錄輸出,將這些記錄轉送至 Bindplane 代理程式。
- 開啟 Kea DHCP 設定檔 (通常為
kea-dhcp4.conf或kea-dhcp6.conf)。 - 找出
loggers部分。 新增或修改記錄器項目,即可使用系統記錄輸出內容,例如:
{ "loggers": [ { "name": "kea-dhcp4", "output_options": [ { "output": "syslog:kea-dhcp4" } ], "severity": "INFO" } ] }儲存設定檔。
設定系統 syslog 精靈 (例如
rsyslog),將 Kea 記錄轉送至 Bindplane 代理程式。編輯「/etc/rsyslog.d/kea-forward.conf」::programname, isequal, "kea-dhcp4" @BINDPLANE_AGENT_IP:514重新啟動 rsyslog 服務:
sudo systemctl restart rsyslog重新啟動 Kea DHCP 服務:
sudo systemctl restart kea-dhcp4-server
UDM 對應表
| 記錄欄位 | UDM 對應 | 邏輯 |
|---|---|---|
| metadata.event_type | 活動類型 | |
| product_event | metadata.product_event_type | 產品專屬事件類型 |
| network.application_protocol | 應用程式通訊協定 | |
| mac | network.dhcp.chaddr | 用戶端硬體位址 |
| client_ip | network.dhcp.ciaddr | 用戶端 IP 位址 |
| lease_time | network.dhcp.lease_time_seconds | 租用時間 (秒) |
| network.dhcp.opcode | DHCP opcode | |
| src_ip | network.dhcp.requested_address | 要求的 IP 位址 |
| network.dhcp.type | DHCP 訊息類型 | |
| src_ip | network.dhcp.yiaddr | 您的 IP 位址 |
| client_ip | observer.ip | 觀察者 IP 位址 |
| 主機 | principal.hostname | 主要主機名稱 |
| client_ip | principal.ip | 主體 IP 位址 |
| mac | principal.mac | 主要 MAC 位址 |
| src_port | principal.port | 主要通訊埠 |
| security_result.severity | 安全性結果的嚴重程度 | |
| 遞減 | security_result.summary | 安全性結果摘要 |
| domain_name | target.hostname | 目標主機名稱 |
| dest_port | target.port | 目標通訊埠 |
| metadata.product_name | 產品名稱 | |
| metadata.vendor_name | 供應商名稱 |
變更記錄
還有其他問題嗎?向社群成員和 Google SecOps 專業人員尋求答案。