收集 LogonBox 日志

支持:

本文档介绍了如何使用 Bindplane 将 LogonBox 日志注入 Google Security Operations。

LogonBox 是一个自助式密码管理和身份验证平台。它会为重设密码、身份验证事件和管理员操作生成审核日志。解析器会将 LogonBox 审核数据映射到统一数据模型 (UDM),捕获用户身份、身份验证事件、资源修改和群组管理操作。

准备工作

请确保满足以下前提条件:

  • Google SecOps 实例
  • Windows Server 2016 或更高版本,或者具有 systemd 的 Linux 主机
  • Bindplane 代理与 LogonBox 服务器之间的网络连接
  • 如果通过代理运行,请确保防火墙端口根据 Bindplane 代理要求处于开放状态
  • 对 LogonBox 管理控制台的特权访问权限

获取 Bindplane 代理的 Google SecOps 凭据

如需对 Bindplane 代理进行 Google SecOps 身份验证,请选择以下方法之一:

  • 新部署:使用 Chronicle API(方法 1)。
  • 旧版部署:继续使用注入身份验证文件(方法 2),直到注入 API 于 2027 年 7 月 20 日停用为止。
  1. 登录 Google Cloud 控制台,然后选择与您的 Google SecOps 实例关联的 Google Cloud 项目。
  2. 依次前往 IAM 和管理 > 服务账号。
  3. 点击创建服务账号 。
  4. 提供以下配置详细信息:
    • 服务账号名称:输入账号的名称(例如 bindplane-ingest)。
    • 服务账号说明:输入说明(例如 Bindplane agent log ingestion)。
  5. 点击创建并继续 。
  6. 在向此服务帐号授予对项目的访问权限 部分,点击选择角色 ,然后选择 Chronicle Editor 。
  7. 点击继续 ,然后点击完成 。
  8. 点击您创建的服务帐号,然后前往密钥 标签页。
  9. 依次点击添加密钥 > 创建新密钥。
  10. 选择 JSON ,然后点击创建 。密钥文件会下载到您的计算机上。
  11. 将密钥文件另存为 Bindplane 收集器目录中的 ingestion-auth.json(在 Linux 上为 /opt/observiq-otel-collector/ingestion-auth.json,在 Windows 上为 C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json),或者更新 creds_file_path 在 config.yaml 中以与您保存该文件的路径匹配。
  12. 依次前往 IAM 和管理 > 设置 ,然后复制项目编号 。您需要此编号进行导出器配置。

方法 2:下载注入身份验证文件(旧版)

  1. 登录 Google SecOps 控制台。
  2. 依次前往 SIEM 设置 > 收集代理。
  3. 下载注入身份验证文件 。
  4. 将该文件安全地保存在将安装 Bindplane 代理的系统上。

获取 Google SecOps 客户 ID

  1. 登录 Google SecOps 控制台。
  2. 依次前往 SIEM 设置 > 个人资料。
  3. 从组织详细信息 部分复制并保存客户 ID 。

安装 Bindplane 代理

按照以下说明在 Windows 或 Linux 操作系统上安装 Bindplane 代理。

Windows 安装

  1. 以管理员身份打开命令提示符 或 PowerShell 。
  2. 运行以下命令:

    msiexec /i "https://github.com/observIQ/bindplane-agent/releases/latest/download/observiq-otel-collector.msi" /quiet
    
  3. 等待安装完成。

  4. 运行以下命令,验证安装是否成功:

    sc query observiq-otel-collector
    

该服务应显示为正在运行 。

Linux 安装

  1. 使用 root 或 sudo 权限打开终端。
  2. 运行以下命令:

    sudo sh -c "$(curl -fsSlL https://github.com/observiq/bindplane-agent/releases/latest/download/install_unix.sh)" install_unix.sh
    
  3. 等待安装完成。

  4. 运行以下命令,验证安装是否成功:

    sudo systemctl status observiq-otel-collector
    

该服务应显示为活跃 (正在运行) 。

其他安装资源

如需了解其他安装选项和问题排查信息,请参阅 Bindplane 代理安装指南。

配置 Bindplane 代理以注入 syslog 并发送到 Google SecOps

找到配置文件

  • Linux:

    sudo nano /opt/observiq-otel-collector/config.yaml
    
  • Windows:

    notepad "C:\Program Files\observIQ OpenTelemetry Collector\config.yaml"
    

修改配置文件

  • 将 config.yaml 的全部内容替换为以下配置:

    receivers:
      udplog:
        listen_address: "0.0.0.0:514"
    
    exporters:
      chronicle/logonbox:
        protocol: https
        # Region of your instance, for example us, europe, asia-southeast1
        location: <LOCATION>
        # Project number of the Google Cloud project linked to the instance
        project: '<PROJECT_NUMBER>'
        compression: gzip
        creds_file_path: '/opt/observiq-otel-collector/ingestion-auth.json'
        customer_id: '<customer_id>'
        endpoint: chronicle.googleapis.com
        log_type: LOGONBOX
        raw_log_field: body
    
    service:
      pipelines:
        logs/logonbox:
          receivers:
            - udplog
          exporters:
            - chronicle/logonbox
    

配置参数

替换以下占位符:

  • 接收器配置:

    • udplog:基于协议的接收器类型:
      • UDP syslog 的 udplog
      • TCP syslog 的 tcplog
      • RFC 3164/5424 syslog 的 syslog
    • 0.0.0.0:要监听的 IP 地址:
      • 0.0.0.0,用于监听所有接口(推荐)
      • 用于监听一个接口的特定 IP 地址
    • 514:要监听的端口号(例如 514、1514、6514)
  • 导出器配置:

    • <customer_id>:上一步中的客户 ID
    • location:将 <LOCATION> 替换为 Google SecOps 实例的区域(例如 us、europe 或 asia-southeast1)。导出器会使用此值为 chronicle.googleapis.com 添加前缀。如需查看完整列表,请参阅区域级端点。
    • project:将 <PROJECT_NUMBER> 替换为 IAM 和管理 > 设置 中的项目编号。
    • endpoint:保持设置为 chronicle.googleapis.com。
    • 根据平台调整 creds_file_path 以指向服务帐号 JSON 密钥文件的路径(方法 1):
      • Linux: /opt/observiq-otel-collector/ingestion-auth.json
      • Windows: C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json

旧版注入 API 导出器

  • 如果您使用方法 2 中的注入身份验证文件,请将 exporters 代码块替换为以下内容。将 creds_file_path 设置为注入身份验证文件的路径,如果您的实例位于美国境外,请将 malachiteingestion-pa.googleapis.com 替换为您的 区域级端点(例如 europe-malachiteingestion-pa.googleapis.com)。

    exporters:
      chronicle/logonbox:
        compression: gzip
        creds_file_path: '/opt/observiq-otel-collector/ingestion-auth.json'
        customer_id: '<customer_id>'
        endpoint: malachiteingestion-pa.googleapis.com
        log_type: LOGONBOX
        raw_log_field: body
    

保存配置文件

  • 修改后,保存文件:
    • Linux:按 Ctrl+O,然后按 Enter,再按 Ctrl+X
    • Windows:依次点击文件 > 保存

重启 Bindplane 代理以应用更改

如需在 Linux 中重启 Bindplane 代理,请执行以下操作:

  1. 运行以下命令:

    sudo systemctl restart observiq-otel-collector
    
  2. 验证服务是否正在运行:

    sudo systemctl status observiq-otel-collector
    
  3. 检查日志中的错误:

    sudo journalctl -u observiq-otel-collector -f
    

如需在 Windows 中重启 Bindplane 代理,请执行以下操作:

  1. 请从下列选项中选择一项:

    • 以管理员身份运行命令提示符或 PowerShell:
    net stop observiq-otel-collector && net start observiq-otel-collector
    
    • “服务”控制台:
      1. 按 Win+R,输入 services.msc,然后按 Enter 键。
      2. 找到 observIQ OpenTelemetry Collector 。
      3. 右键点击并选择重启 。
  2. 验证服务是否正在运行:

    sc query observiq-otel-collector
    
  3. 检查日志中的错误:

    type "C:\Program Files\observIQ OpenTelemetry Collector\log\collector.log"
    

配置 LogonBox syslog 转发

  1. 以管理员身份登录 LogonBox 管理控制台。
  2. 依次前往报告 > 审核日志。
  3. 配置 syslog 导出设置:
    • Syslog 服务器:输入 Bindplane 代理主机(例如 192.168.1.100)的 IP 地址。
    • 端口:输入 514(必须与 Bindplane 接收器端口匹配)。
    • 协议:选择 UDP (必须与 Bindplane 接收器类型匹配)。
  4. 选择要转发的事件类别(例如重设密码、身份验证、用户和群组管理)。
  5. 点击保存 。

UDM 映射表

日志字段 UDM 映射 逻辑
additional.fields 根据条件从 attr_associatedPrincipals_label、sAMAccountName_label、attr_local_label、msDS-PrincipalName_label、attr_realmType_label、attr_selfCreated_label、attr_administrative_label 合并
attr_principalDesc、desc metadata.description 如果 product_event_type 与 changePassword|SessionService 匹配,则取自 attr_principalDesc;否则,如果 attr_principalDesc 不为空,则取自 attr_principalDesc;否则,取自 desc
event_type metadata.event_type 在条件逻辑根据 product_event_type 和 presence 标志设置后,直接从 event_type 复制值
product_event_type metadata.product_event_type 直接复制值
metadata.product_name 设置为“LogonBox”
metadata.vendor_name 设置为“LOGONBOX”
network.application_protocol 如果 product_event_type 与 AnswerService 匹配且满足条件,则设置为“DNS”
dns_answer network.dns.answers 从 dns_answer 合并
dns_question network.dns.questions 从 dns_question 合并
attr_userAgent、attr_userAgentVersion network.http.parsed_user_agent 如果两者都存在,则从 attr_userAgent 和 attr_userAgentVersion 连接;否则,从 attr_userAgent 连接,然后转换为 parseduseragent 并重命名
attr_userAgent、attr_userAgentVersion network.http.user_agent 如果两者都存在,则从 attr_userAgent 和 attr_userAgentVersion 连接;否则,从 attr_userAgent 连接
hostname principal.asset.hostname 直接复制值
attr_ipAddress principal.asset.ip 直接复制值
hostname principal.hostname 直接复制值
attr_ipAddress principal.ip 直接复制值
attr_os principal.platform 如果与 (?i)LINUX|MAC|WINDOWS 匹配,则设置为大写
attr_osVersion principal.platform_version 如果不与 (?i)unknown 匹配,则直接复制值
attr_principalRealm_label、attr_unassignedRoles_label、attr_assignedRoles_label、attr_oldResourceName_label、attr_roles_label、attr_resumedPrincipalName_label、attr_resumedPrincipalRealm_label、attr_resumedPrincipal_label、attr_module_label、reconcile_map_label、users_map_label、groups_map_label、createUser_map_label、user_map_label、mobile_map_label principal.resource.attribute.labels 根据条件从 attr_principalRealm、attr_unassignedRoles、attr_assignedRoles、attr_oldResourceName、attr_roles、attr_resumedPrincipalName、attr_resumedPrincipalRealm、attr_resumedPrincipal、attr_module 创建的各种标签以及来自 reconcile、users、groups、createUser、user、mobile 的映射合并
attr_resourceName principal.resource.name 直接复制值
attr_resourceId principal.resource.product_object_id 直接复制值
mail principal.user.email_addresses 如果 mail 是有效的电子邮件地址,则合并
ImmutableID、attr_uuid principal.user.product_object_id 如果 product_event_type 与 changePassword|userUpdated|userCreated|setPassword|answer|accountUnlockNoSuspension 匹配,则取自 ImmutableID;否则,取自 attr_uuid
attr_scheme principal.user.role_name 直接复制值
attr_principalDesc principal.user.user_display_name 如果 product_event_type 与 changePassword|SessionService 匹配,则直接复制值
attr_principalName principal.user.userid 直接复制值
authy_code_length_label、authy_window_length_label、authy_step_size_label、msauthenticator_code_length_label、msauthenticator_window_length_label、msauthenticator_step_size_label、googleUser_code_length_label、googleUser_window_length_label、googleUser_step_size_label security_result.detection_fields 如果存在,则从 authy.code.length、authy.window.length、authy.step.size、msauthenticator.code.length、msauthenticator.window.length、msauthenticator.step.size、googleUser.code.length、googleUser.window.length、googleUser.step.size 创建的标签合并
cn target.resource.attribute.labels 从 cn 创建的 full_name_label 和从 attr_disabledRealm 创建的 attr_disabledRealm_label 合并
attr_lastModified target.resource.attribute.last_update_time 使用 ISO8601 或 d MMM yyyy HH:mm:ss 从 attr_lastModified 解析的日期
attr_created target.resource.attribute.creation_time 使用 ISO8601 或 d MMM yyyy HH:mm:ss 从 attr_created 解析的日期
givenName target.user.first_name 直接复制值
ou target.user.group_identifiers 如果 product_event_type 与 userUpdated|userCreated|changePassword|setPassword|answer|accountUnlockNoSuspension 匹配,则从 ou 合并
sn target.user.last_name 直接复制值
attr_uuid、attr_disabledPrincipal target.user.product_object_id 如果 product_event_type 与 userUpdated|userCreated|changePassword|setPassword|answer|accountUnlockNoSuspension 或 groupCreated|groupUpdated 或 attr_group 或 group 匹配,则取自 attr_uuid;否则,如果 accountDisabled,则取自 attr_disabledPrincipal
displayName、description target.user.user_display_name 如果 displayName 不为空,则取自 displayName;否则,如果 product_event_type 与 userUpdated|userCreated|changePassword|setPassword|answer|accountUnlockNoSuspension 匹配,则取自 description
userPrincipalName、attr_user、attr_associatedPrincipals、attr_disabledPrincipalName target.user.userid 如果 product_event_type 与 userUpdated|userCreated|changePassword|setPassword|answer|accountUnlockNoSuspension 匹配,则取自 userPrincipalName;否则,如果未设置,则取自 attr_user;否则,如果 groupCreated|groupUpdated 或 attr_group,则取自 attr_associatedPrincipals;否则,如果 group,则取自 attr_user;否则,如果 accountDisabled,则取自 attr_disabledPrincipalName
attr_group target.group.group_display_name 如果 product_event_type 与 groupCreated|groupUpdated 匹配或存在 attr_group,则直接复制值
attr_uuid target.group.product_object_id 如果 product_event_type 与 groupCreated|groupUpdated 匹配或存在 attr_group,则直接复制值

更新日志

查看此解析器的更新日志

需要更多帮助?获得社区成员和 Google SecOps 专业人士的解答。