收集 LogonBox 記錄

支援的服務:

本文說明如何使用 Bindplane,將 LogonBox 記錄檔擷取至 Google Security Operations。

LogonBox 是自助式密碼管理和身分驗證平台。這項服務會產生重設密碼、身分驗證事件和管理員動作的稽核記錄。剖析器會將 LogonBox 稽核資料對應至 Unified Data Model (UDM),擷取使用者身分、驗證事件、資源修改和群組管理作業。

事前準備

請確認您已完成下列事前準備事項:

  • Google SecOps 執行個體
  • Windows Server 2016 以上版本,或搭載 systemd 的 Linux 主機
  • Bindplane 代理程式與 LogonBox 伺服器之間的網路連線
  • 如果透過 Proxy 執行,請確保防火牆通訊埠已根據 Bindplane 代理程式需求開啟
  • LogonBox 管理控制台的特殊存取權

取得 Bindplane 代理程式的 Google SecOps 憑證

如要向 Google SecOps 驗證 Bindplane 代理程式,請選擇下列其中一種方法:

  • 新部署作業:使用 Chronicle API (選項 1)。
  • 舊版部署作業:繼續使用擷取驗證檔案 (選項 2),直到 Ingestion API 於 2027 年 7 月 20 日停用。
  1. 登入 Google Cloud 控制台,選取連結至 Google SecOps 執行個體的 Google Cloud 專案。
  2. 依序前往「IAM & Admin」(IAM 與管理) >「Service Accounts」(服務帳戶)。
  3. 按一下「建立服務帳戶」。
  4. 提供下列設定詳細資料:
    • 「Service account name」(服務帳戶名稱):輸入帳戶名稱 (例如 bindplane-ingest)。
    • 「服務帳戶說明」:輸入說明 (例如 Bindplane agent log ingestion)。
  5. 點按「Create and continue」(建立並繼續)。
  6. 在「將專案存取權授予這個服務帳戶」部分,按一下「選取角色」,然後選取「Chronicle 編輯者」。
  7. 依序點選「繼續」和「完成」。
  8. 按一下您建立的服務帳戶,然後前往「金鑰」分頁。
  9. 依序點選「新增金鑰」>「建立新的金鑰」。
  10. 選取「JSON」,然後按一下「建立」。金鑰檔案會下載到電腦。
  11. 將金鑰檔案儲存為 Bindplane 收集器目錄中的 ingestion-auth.json (Linux 上的 /opt/observiq-otel-collector/ingestion-auth.json 或 Windows 上的 C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json),或更新 config.yaml 中的 creds_file_path,使其與儲存路徑相符。
  12. 依序前往「IAM & Admin」(IAM 與管理) >「Settings」(設定),然後複製「Project number」(專案編號)。設定匯出工具時會用到。

方法 2:下載擷取驗證檔案 (舊版)

  1. 登入 Google SecOps 控制台。
  2. 依序前往「SIEM Settings」 > 「Collection Agents」。
  3. 下載擷取驗證檔案。
  4. 將檔案安全地儲存在要安裝 Bindplane 代理程式的系統中。

取得 Google SecOps 客戶 ID

  1. 登入 Google SecOps 控制台。
  2. 依序前往「SIEM 設定」 > 「設定檔」。
  3. 複製並儲存「機構詳細資料」部分的客戶 ID。

安裝 Bindplane 代理程式

請按照下列操作說明,在 Windows 或 Linux 作業系統上安裝 Bindplane 代理程式。

Windows 安裝

  1. 以管理員身分開啟命令提示字元或 PowerShell。
  2. 執行下列指令:

    msiexec /i "https://github.com/observIQ/bindplane-agent/releases/latest/download/observiq-otel-collector.msi" /quiet
    
  3. 等待安裝完成。

  4. 執行下列指令,確認安裝成功:

    sc query observiq-otel-collector
    

服務應顯示為「RUNNING」。

Linux 安裝

  1. 開啟具有根層級或 sudo 權限的終端機。
  2. 執行下列指令:

    sudo sh -c "$(curl -fsSlL https://github.com/observiq/bindplane-agent/releases/latest/download/install_unix.sh)" install_unix.sh
    
  3. 等待安裝完成。

  4. 執行下列指令,確認安裝成功:

    sudo systemctl status observiq-otel-collector
    

服務應顯示為「active (running)」。

其他安裝資源

如需其他安裝選項和疑難排解資訊,請參閱 Bindplane 代理程式安裝指南。

設定 Bindplane 代理,擷取系統記錄檔並傳送至 Google SecOps

找出設定檔

  • Linux:

    sudo nano /opt/observiq-otel-collector/config.yaml
    
  • Windows:

    notepad "C:\Program Files\observIQ OpenTelemetry Collector\config.yaml"
    

編輯設定檔

  • 將 config.yaml 的全部內容替換為下列設定:

    receivers:
      udplog:
        listen_address: "0.0.0.0:514"
    
    exporters:
      chronicle/logonbox:
        protocol: https
        # Region of your instance, for example us, europe, asia-southeast1
        location: <LOCATION>
        # Project number of the Google Cloud project linked to the instance
        project: '<PROJECT_NUMBER>'
        compression: gzip
        creds_file_path: '/opt/observiq-otel-collector/ingestion-auth.json'
        customer_id: '<customer_id>'
        endpoint: chronicle.googleapis.com
        log_type: LOGONBOX
        raw_log_field: body
    
    service:
      pipelines:
        logs/logonbox:
          receivers:
            - udplog
          exporters:
            - chronicle/logonbox
    

設定參數

請替換下列預留位置:

  • 接收器設定:

    • udplog:依通訊協定區分的接收端類型:
      • UDP syslog 的 udplog
      • tcplog (適用於 TCP syslog)
      • syslog (適用於 RFC 3164/5424 syslog)
    • 0.0.0.0:要監聽的 IP 位址:
      • 0.0.0.0 在所有介面接聽電話 (建議)
      • 在一個介面上接聽的特定 IP 位址
    • 514:要監聽的通訊埠編號 (例如 514、1514、6514)
  • Exporter 設定:

    • <customer_id>:先前步驟中的客戶 ID
    • location:將 <LOCATION> 替換為 Google SecOps 執行個體的區域 (例如 us、europe 或 asia-southeast1)。匯出工具會在這個值前面加上 chronicle.googleapis.com。如需完整清單,請參閱「區域性端點」。
    • project:依序前往「IAM 與管理」>「設定」,然後將 <PROJECT_NUMBER> 替換為專案編號。
    • endpoint:維持設為 chronicle.googleapis.com。
    • 根據平台,將 creds_file_path 調整為服務帳戶 JSON 金鑰檔案的路徑 (選項 1):
      • Linux:/opt/observiq-otel-collector/ingestion-auth.json
      • Windows:C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json

舊版 Ingestion API 匯出工具

  • 如果您使用方式 2 的擷取驗證檔案,請將 exporters 區塊替換成下列內容。將 creds_file_path 設為擷取驗證檔案的路徑。如果執行個體位於美國境外,請將 malachiteingestion-pa.googleapis.com 替換為區域端點 (例如 europe-malachiteingestion-pa.googleapis.com)。

    exporters:
      chronicle/logonbox:
        compression: gzip
        creds_file_path: '/opt/observiq-otel-collector/ingestion-auth.json'
        customer_id: '<customer_id>'
        endpoint: malachiteingestion-pa.googleapis.com
        log_type: LOGONBOX
        raw_log_field: body
    

儲存設定檔

  • 編輯完成後,請儲存檔案:
    • Linux:依序按下 Ctrl+O、Enter 和 Ctrl+X
    • Windows:依序點選「檔案」>「儲存」

重新啟動 Bindplane 代理程式,套用變更

如要在 Linux 中重新啟動 Bindplane 代理程式,請按照下列步驟操作:

  1. 執行下列指令:

    sudo systemctl restart observiq-otel-collector
    
  2. 確認服務是否正在執行:

    sudo systemctl status observiq-otel-collector
    
  3. 查看記錄檔是否有錯誤:

    sudo journalctl -u observiq-otel-collector -f
    

如要在 Windows 中重新啟動 Bindplane 代理程式,請按照下列步驟操作:

  1. 您可以選擇下列其中一個選項:

    • 以管理員身分開啟命令提示字元或 PowerShell:
    net stop observiq-otel-collector && net start observiq-otel-collector
    
    • 服務控制台:
      1. 按下 Win+R,輸入 services.msc,然後按下 Enter 鍵。
      2. 找出「observIQ OpenTelemetry Collector」。
      3. 按一下滑鼠右鍵,然後選取「重新啟動」。
  2. 確認服務正在執行:

    sc query observiq-otel-collector
    
  3. 查看記錄檔是否有錯誤:

    type "C:\Program Files\observIQ OpenTelemetry Collector\log\collector.log"
    

設定 LogonBox syslog 轉送

  1. 以管理員身分登入 LogonBox 管理控制台。
  2. 依序前往「報表」>「稽核記錄」。
  3. 設定 syslog 匯出設定:
    • Syslog Server:輸入 Bindplane 代理程式主機的 IP 位址 (例如 192.168.1.100)。
    • 「Port」(通訊埠):輸入 514 (必須與 BindPlane 接收器通訊埠相符)。
    • 「Protocol」(通訊協定):選取「UDP」(必須與 Bindplane 接收器類型相符)。
  4. 選取要轉送的事件類別 (例如重設密碼、身分驗證、使用者和群組管理)。
  5. 按一下 [儲存]。

UDM 對應表

記錄欄位 UDM 對應 邏輯
additional.fields 根據條件,從 attr_associatedPrincipals_label、sAMAccountName_label、attr_local_label、msDS-PrincipalName_label、attr_realmType_label、attr_selfCreated_label、attr_administrative_label 合併
attr_principalDesc、desc metadata.description 如果 product_event_type 符合 changePassword|SessionService,則為 attr_principalDesc 的值;否則,如果 attr_principalDesc 不為空白,則為該值;否則為 desc 的值
event_type metadata.event_type 條件邏輯根據 product_event_type 和 presence 標記設定 event_type 後,直接從 event_type 複製的值
product_event_type metadata.product_event_type 直接複製值
metadata.product_name 設為「LogonBox」
metadata.vendor_name 設為「LOGONBOX」
network.application_protocol 如果 product_event_type 與 AnswerService 相符且符合條件,則設為「DNS」
dns_answer network.dns.answers 從 dns_answer 合併
dns_question network.dns.questions 從 dns_question 合併
attr_userAgent, attr_userAgentVersion network.http.parsed_user_agent 如果 attr_userAgent 和 attr_userAgentVersion 同時存在,則串連這兩者,否則串連 attr_userAgent,然後轉換為 parseduseragent 並重新命名
attr_userAgent, attr_userAgentVersion network.http.user_agent 如果 attr_userAgent 和 attr_userAgentVersion 同時存在,則串連這兩者,否則串連 attr_userAgent
主機名稱 principal.asset.hostname 直接複製值
attr_ipAddress principal.asset.ip 直接複製值
主機名稱 principal.hostname 直接複製值
attr_ipAddress principal.ip 直接複製值
attr_os principal.platform 如果符合 (?i)LINUX|MAC|WINDOWS,則設為大寫
attr_osVersion principal.platform_version 如果與 (?i)unknown 不符,則直接複製值
attr_principalRealm_label, attr_unassignedRoles_label, attr_assignedRoles_label, attr_oldResourceName_label, attr_roles_label, attr_resumedPrincipalName_label, attr_resumedPrincipalRealm_label, attr_resumedPrincipal_label, attr_module_label, reconcile_map_label, users_map_label, groups_map_label, createUser_map_label, user_map_label, mobile_map_label principal.resource.attribute.labels 合併自多個標籤,這些標籤是根據條件,從 attr_principalRealm、attr_unassignedRoles、attr_assignedRoles、attr_oldResourceName、attr_roles、attr_resumedPrincipalName、attr_resumedPrincipalRealm、attr_resumedPrincipal、attr_module 建立,以及從 reconcile、users、groups、createUser、user、mobile 對應而來
attr_resourceName principal.resource.name 直接複製值
attr_resourceId principal.resource.product_object_id 直接複製值
郵件 principal.user.email_addresses 如果郵件是有效的電子郵件,則會合併
ImmutableID、attr_uuid principal.user.product_object_id 如果 product_event_type 符合 changePassword|userUpdated|userCreated|setPassword|answer|accountUnlockNoSuspension,則為 ImmutableID 的值,否則為 attr_uuid 的值
attr_scheme principal.user.role_name 直接複製值
attr_principalDesc principal.user.user_display_name 如果 product_event_type 與 changePassword|SessionService 相符,則直接複製值
attr_principalName principal.user.userid 直接複製值
authy_code_length_label、authy_window_length_label、authy_step_size_label、msauthenticator_code_length_label、msauthenticator_window_length_label、msauthenticator_step_size_label、googleUser_code_length_label、googleUser_window_length_label、googleUser_step_size_label security_result.detection_fields 如果存在,則從 authy.code.length、authy.window.length、authy.step.size、msauthenticator.code.length、msauthenticator.window.length、msauthenticator.step.size、googleUser.code.length、googleUser.window.length、googleUser.step.size 建立的標籤合併
cn target.resource.attribute.labels 合併自 cn 建立的 full_name_label,以及 attr_disabledRealm 建立的 attr_disabledRealm_label
attr_lastModified target.resource.attribute.last_update_time 使用 ISO8601 或 d MMM yyyy HH:mm:ss 從 attr_lastModified 剖析的日期
attr_created target.resource.attribute.creation_time 使用 ISO8601 或 d MMM yyyy HH:mm:ss 從 attr_created 剖析的日期
givenName target.user.first_name 直接複製值
ou target.user.group_identifiers 如果 product_event_type 符合 userUpdated|userCreated|changePassword|setPassword|answer|accountUnlockNoSuspension,則從 ou 合併
sn target.user.last_name 直接複製值
attr_uuid、attr_disabledPrincipal target.user.product_object_id 如果 product_event_type 符合 userUpdated|userCreated|changePassword|setPassword|answer|accountUnlockNoSuspension 或 groupCreated|groupUpdated 或 attr_group 或 group,則為 attr_uuid 的值,否則在 accountDisabled 的情況下為 attr_disabledPrincipal 的值
displayName、description target.user.user_display_name 如果 displayName 不為空白,則為 displayName 的值,否則為 description 的值 (如果 product_event_type 符合 userUpdated|userCreated|changePassword|setPassword|answer|accountUnlockNoSuspension)
userPrincipalName、attr_user、attr_associatedPrincipals、attr_disabledPrincipalName target.user.userid 如果 product_event_type 符合 userUpdated|userCreated|changePassword|setPassword|answer|accountUnlockNoSuspension,則為 userPrincipalName 的值;如果未設定,則為 attr_user;如果 groupCreated|groupUpdated 或 attr_group,則為 attr_associatedPrincipals;如果是 group,則為 attr_user;如果是 accountDisabled,則為 attr_disabledPrincipalName
attr_group target.group.group_display_name 如果 product_event_type 與 groupCreated|groupUpdated 相符,或存在 attr_group,則直接複製值
attr_uuid target.group.product_object_id 如果 product_event_type 與 groupCreated|groupUpdated 相符,或有 attr_group,則直接複製值

變更記錄

查看這個剖析器的變更記錄

還有其他問題嗎?向社群成員和 Google SecOps 專家尋求解答。