收集 Lookout Mobile Endpoint Security 記錄

支援:

本文說明如何使用 Bindplane 代理程式,將 Lookout Mobile Endpoint Security 記錄檔擷取至 Google Security Operations。

Lookout Mobile Endpoint Security (MES) 是全方位的行動安全解決方案,可保護 iOS、Android 和 ChromeOS 裝置,免受網路釣魚、惡意軟體、網路攻擊和裝置安全漏洞的威脅。這項服務會運用 AI 驅動的威脅情報偵測及防範行動威脅,同時維護使用者隱私。Lookout MES 支援透過 syslog,將 CEF (通用事件格式) 的安全性事件轉送至外部 SIEM 系統。

事前準備

請確認您符合下列必要條件:

  • Google SecOps 執行個體
  • Windows Server 2016 以上版本,或搭載 systemd 的 Linux 主機
  • Bindplane 代理程式與 Lookout MES SIEM 連接器主機之間的網路連線
  • 如果透過 Proxy 執行,請確保防火牆通訊埠已根據 Bindplane 代理程式需求開啟
  • Lookout MES 控制台的管理員存取權
  • 在 Lookout MES 控制台中產生的應用程式金鑰,用於 SIEM 連接器驗證

取得 Bindplane 代理程式的 Google SecOps 憑證

如要向 Google SecOps 驗證 Bindplane 代理程式,請選擇下列其中一種方法:

  • 新部署作業:使用 Chronicle API (選項 1)。
  • 舊版部署作業:在 2027 年 7 月 20 日停用 Ingestion API 前,請繼續使用擷取驗證檔案 (選項 2)。
  1. 登入 Google Cloud 控制台,選取連結至 Google SecOps 執行個體的 Google Cloud 專案。
  2. 依序前往 「IAM & Admin」(IAM 與管理) >「Service Accounts」(服務帳戶)。
  3. 按一下「建立服務帳戶」。
  4. 提供下列設定詳細資料:
    • 「Service account name」(服務帳戶名稱):輸入帳戶名稱 (例如 bindplane-ingest)。
    • 服務帳戶說明:輸入說明 (例如 Bindplane agent log ingestion)。
  5. 點按「Create and continue」(建立並繼續)。
  6. 在「將專案存取權授予這個服務帳戶」部分,按一下「選取角色」,然後選取「Chronicle 編輯者」。
  7. 依序點選「繼續」和「完成」。
  8. 按一下您建立的服務帳戶,然後前往「金鑰」分頁。
  9. 依序點選「新增金鑰」>「建立新的金鑰」。
  10. 選取「JSON」,然後按一下「建立」。金鑰檔案會下載到電腦。
  11. 將金鑰檔案儲存為 Bindplane 收集器目錄中的 ingestion-auth.json (Linux 上的 /opt/observiq-otel-collector/ingestion-auth.json 或 Windows 上的 C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json),或更新 config.yaml 中的 creds_file_path,使其與儲存路徑相符。
  12. 依序前往「IAM 與管理」>「設定」,然後複製「專案編號」。匯出工具設定時會用到。

方法 2:下載擷取驗證檔案 (舊版)

  1. 登入 Google SecOps 控制台。
  2. 依序前往「SIEM Settings」 > 「Collection Agents」。
  3. 下載擷取驗證檔案。
  4. 將檔案安全地儲存在要安裝 Bindplane 代理程式的系統中。

取得 Google SecOps 客戶 ID

  1. 登入 Google SecOps 控制台。
  2. 依序前往「SIEM 設定」>「設定檔」。
  3. 複製並儲存「機構詳細資料」部分的客戶 ID。

安裝 Bindplane 代理程式

請按照下列操作說明,在 Windows 或 Linux 作業系統上安裝 Bindplane 代理程式。

Windows 安裝

  1. 以管理員身分開啟「命令提示字元」或「PowerShell」。
  2. 執行下列指令:

    msiexec /i "https://github.com/observIQ/bindplane-agent/releases/latest/download/observiq-otel-collector.msi" /quiet
    
  3. 等待安裝完成。

  4. 執行下列指令,確認安裝成功:

    sc query observiq-otel-collector
    

服務應顯示為「RUNNING」。

安裝 Linux

  1. 開啟具有根層級或 sudo 權限的終端機。
  2. 執行下列指令:

    sudo sh -c "$(curl -fsSlL https://github.com/observiq/bindplane-agent/releases/latest/download/install_unix.sh)" install_unix.sh
    
  3. 等待安裝完成。

  4. 執行下列指令,確認安裝成功:

    sudo systemctl status observiq-otel-collector
    

服務應顯示為「active (running)」。

其他安裝資源

如需其他安裝選項和疑難排解資訊,請參閱 Bindplane 代理程式安裝指南。

設定 Bindplane 代理程式,擷取系統記錄並傳送至 Google SecOps

找出設定檔

  • Linux:

    sudo nano /opt/observiq-otel-collector/config.yaml
    
  • Windows:

    notepad "C:\Program Files\observIQ OpenTelemetry Collector\config.yaml"
    

編輯設定檔

  • 將 config.yaml 的全部內容替換為下列設定:

    receivers:
      tcplog:
        listen_address: "0.0.0.0:6514"
    
    exporters:
      chronicle/lookout_mes:
        protocol: https
        # Region of your instance, for example us, europe, asia-southeast1
        location: <LOCATION>
        # Project number of the Google Cloud project linked to the instance
        project: '<PROJECT_NUMBER>'
        compression: gzip
        creds_file_path: '/opt/observiq-otel-collector/ingestion-auth.json'
        customer_id: '<customer_id>'
        endpoint: chronicle.googleapis.com
        log_type: LOOKOUT_MOBILE_ENDPOINT_SECURITY
        raw_log_field: body
        ingestion_labels:
          log_type: LOOKOUT_MOBILE_ENDPOINT_SECURITY
    
    service:
      pipelines:
        logs/lookout_mes_to_chronicle:
          receivers:
            - tcplog
          exporters:
            - chronicle/lookout_mes
    

設定參數

請替換下列預留位置:

  • 接收器設定:

    • listen_address:要接聽的 IP 位址和通訊埠:
      • 0.0.0.0 會監聽所有介面
      • 建議使用通訊埠 6514 傳送支援 TLS 的 syslog;您也可以視需要使用 514 或 1514
    • 建議使用 tcplog 接收器,因為 Lookout SIEM 連接器支援 TCP syslog,且 TCP 可確保 CEF 事件可靠傳送
  • Exporter 設定:

    • creds_file_path:服務帳戶 JSON 金鑰檔案的完整路徑 (選項 1):
      • Linux:/opt/observiq-otel-collector/ingestion-auth.json
      • Windows:C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json
    • customer_id:您的 Google SecOps 客戶 ID
    • location:將 <LOCATION> 替換為 Google SecOps 執行個體的區域 (例如 us、europe 或 asia-southeast1)。匯出工具會在這個值前面加上 chronicle.googleapis.com。如需完整清單,請參閱「區域性端點」。
    • project:依序前往「IAM 與管理」>「設定」,然後將 <PROJECT_NUMBER> 替換為專案編號。
    • endpoint:請將此值設為 chronicle.googleapis.com。

舊版 Ingestion API 匯出工具

  • 如果您使用選項 2 的擷取驗證檔案,請將 exporters 區塊替換為下列內容。將 creds_file_path 設為擷取驗證檔案的路徑,如果您的執行個體位於美國境外,請將 malachiteingestion-pa.googleapis.com 替換為區域端點 (例如 europe-malachiteingestion-pa.googleapis.com)。

    exporters:
      chronicle/lookout_mes:
        compression: gzip
        creds_file_path: '/opt/observiq-otel-collector/ingestion-auth.json'
        customer_id: '<customer_id>'
        endpoint: malachiteingestion-pa.googleapis.com
        log_type: LOOKOUT_MOBILE_ENDPOINT_SECURITY
        raw_log_field: body
        ingestion_labels:
          log_type: LOOKOUT_MOBILE_ENDPOINT_SECURITY
    

儲存設定檔

  • 編輯完畢後,請儲存檔案:

    • Linux:依序按下 Ctrl+O、Enter 和 Ctrl+X
    • Windows:依序點選「檔案」 > 「儲存」

重新啟動 Bindplane 代理程式,套用變更

  • 如要在 Linux 重新啟動 Bindplane 代理程式,請執行下列指令:

    sudo systemctl restart observiq-otel-collector
    
    1. 確認服務正在執行:

      sudo systemctl status observiq-otel-collector
      
    2. 檢查記錄是否有錯誤:

      sudo journalctl -u observiq-otel-collector -f
      
  • 如要在 Windows 中重新啟動 Bindplane 代理程式,請選擇下列其中一個選項:

    • 以管理員身分開啟命令提示字元或 PowerShell:

      net stop observiq-otel-collector && net start observiq-otel-collector
      
  • 服務控制台:

    1. 按下 Win+R,輸入 services.msc,然後按下 Enter 鍵。
    2. 找出「observIQ OpenTelemetry Collector」。
    3. 按一下滑鼠右鍵,然後選取「重新啟動」。
    4. 確認服務是否正在執行:

       ```cmd
       sc query observiq-otel-collector
       ```
      
    5. 查看記錄檔是否有錯誤:

       ```cmd
       type "C:\Program Files\observIQ OpenTelemetry Collector\log\collector.log"
       ```
      

設定 Lookout Mobile Endpoint Security syslog 轉送

Lookout MES 會使用 SIEM 連接器應用程式,透過系統記錄檔以 CEF 格式匯出安全事件。SIEM 連接器會向 Lookout Mobile Risk API 進行驗證、擷取威脅事件,並以 CEF 格式的系統記錄訊息轉送至 Bindplane 代理程式。

為 SIEM 連接器產生應用程式金鑰

  1. 前往 https://app.lookout.com 登入 Lookout MES 控制台。

  2. 在左側導覽列中,依序前往「系統」> 應用程式金鑰」。

  3. 按一下右上角的「Generate Key」。

  4. 在「Label」(標籤) 欄位中輸入描述性名稱 (例如 Bindplane-Chronicle-CEF)。

  5. 點選「下一步」。

  6. 按一下「Click to Copy Application Key to Clipboard」,複製產生的應用程式金鑰。

    重要事項:請立即複製並儲存應用程式金鑰。關閉這個對話方塊後,就無法再次擷取這組金鑰。

  7. 記下「系統」設定中的「企業 GUID」。這是您專屬的 Lookout 租戶 ID。

安裝及設定 Lookout SIEM 連接器

  1. 從 Lookout 說明入口網站下載 Lookout SIEM 連接器應用程式,或與 Lookout Enterprise 支援團隊聯絡,取得最新發布套件。
  2. 在主機上安裝 SIEM 連接器,該主機必須具備 Lookout API 端點 (https://api.lookout.com) 和 Bindplane 代理程式的網路存取權。
  3. 開啟 SIEM 連接器設定檔。
  4. 提供下列設定詳細資料:

    • 應用程式金鑰:您在 Lookout MES 控制台產生的應用程式金鑰
    • 企業 GUID:Lookout 租戶 ID
    • API 基準網址:https://api.lookout.com
    • 輸出格式:選取「CEF」
    • 「傳輸通訊協定」:選取「TCP」
    • Syslog 伺服器主機:輸入 Bindplane 代理程式主機的 IP 位址 (例如 192.168.1.100)
    • Syslog 伺服器通訊埠:輸入與 Bindplane 代理程式接收器設定相符的通訊埠編號 (例如 6514)
  5. 儲存設定檔。

  6. 啟動 SIEM 連接器服務。

確認系統記錄傳送

  1. 檢查 SIEM 連接器記錄,確認系統從 Lookout Mobile Risk API 擷取事件,並轉送至 Bindplane 代理程式。
  2. 在 Bindplane 代理程式主機上,檢查代理程式記錄,確認是否收到 CEF 事件:

    Linux:

    sudo journalctl -u observiq-otel-collector -f
    

    Windows:

    type "C:\Program Files\observIQ OpenTelemetry Collector\log\collector.log"
    
  3. 在 Google SecOps 控制台中,確認 Lookout Mobile Endpoint Security 事件是否顯示在搜尋結果中。

UDM 對應表

記錄欄位 UDM 對應 邏輯
deviceNtDomain about.administrative_domain 直接複製值
deviceExternalId about.asset.asset_id 從 device_vendor、device_product、deviceExternalId 串連
filePath about.file.full_path filePath 中的值,或 fileHash 中的值 (如果不是雜湊)
fileHash about.file.full_path
fname about.file.names 直接複製值
_hash about.file.sha256 來自 _hash 或 fileHash 的值
fileHash about.file.sha256
fsize about.file.size 已轉換為 uinteger
dvchost about.hostname 直接複製值
dvc about.ip 分割及驗證後,從 dvc 擷取的 IP
dvcmac about.mac 直接複製值
deviceTranslatedAddress about.nat_ip 直接複製值
deviceProcessName about.process.command_line 來自 deviceProcessName、Subject、Emne 或 Path 的值
主旨 about.process.command_line
Emne about.process.command_line
路徑 about.process.command_line
dvcpid about.process.pid 直接複製值
filePermission about.resource.attribute.permissions 直接複製值
device_security_result about.security_result 直接複製值
已接收 metadata.collected_timestamp 從「已接收」剖析,使用 yyyy-MM-ddTHH:mm:ss 日期格式
msg metadata.description 直接複製值
file_full_path metadata.event_type 如果已設定 file_full_path,請設為 SCAN_UNCATEGORIZED;如果存在 principal_hostname、principal_ip、principal_mac,請設為 STATUS_UPDATE;否則請設為 GENERIC_EVENT;如果存在 has_principal_user,請設為 USER_UNCATEGORIZED;如果存在 has_principal_host,請設為 STATUS_UPDATE
principal_hostname metadata.event_type
has_principal_user metadata.event_type
principal_ip metadata.event_type
principal_mac metadata.event_type
device_event_class_id metadata.product_event_type 從 device_event_class_id - event_name 或 type 串連
event_name metadata.product_event_type
類型 metadata.product_event_type
externalId metadata.product_log_id 來自 externalId 或 target.id 的值
target.id metadata.product_log_id
device_product metadata.product_name 直接複製值
device_version metadata.product_version 直接複製值
device_vendor metadata.vendor_name 直接複製值
app_protocol_src network.application_protocol 使用預先定義的通訊協定規則,從 app_protocol_src 對應
deviceDirection network.direction 設為 0 代表「INBOUND」,設為 1 代表「OUTBOUND」
requestMethod network.http.method 直接複製值
requestClientApplication network.http.user_agent 直接複製值
proto network.ip_protocol 使用 IANA 通訊協定編號,從 protocol_number_src 對應
在 network.received_bytes 已轉換為 uinteger
out network.sent_bytes 已轉換為 uinteger
sntdom principal.administrative_domain 來自 sntdom、Domain 或 Domene 的值
網域 principal.administrative_domain
Domene principal.administrative_domain
sourceServiceName principal.application sourceServiceName 或 details.applicationName 的值
details.applicationName principal.application
協助 principal.asset.asset_id 串連自 metadata.vendor_name、metadata.product_name、aid
_hardware principal.asset.hardware 直接複製值
principal_hostname principal.asset.hostname principal_hostname 的值 (如果不是 IP,則為 Device_name、Enhetsnavn、shost 或 entName)
av principal.asset.platform_software.platform_version 直接複製值
agentZoneURI_label principal.asset.attribute.labels 合併自多個標籤
agentTimeZone_label principal.asset.attribute.labels
agentType_label principal.asset.attribute.labels
agentReceiptTime_label principal.asset.attribute.labels
token_new principal.asset.attribute.labels
details.path principal.file.full_path 直接複製值
Group_name principal.group.group_display_name Group_name 或 Gruppenavn 的值
Gruppenavn principal.group.group_display_name
Device_name principal.hostname 來自 Device_name、Enhetsnavn、shost (如果不是 IP) 或 entName 的值
Enhetsnavn principal.hostname
shost principal.hostname
entName principal.hostname
src principal.ip 如果 IP 有效,則為 src 中的值;如果為 IP,則為 shost;否則為 agt
shost principal.ip
agt principal.ip
smac principal.mac 直接複製值
sourceTranslatedAddress principal.nat_ip 直接複製值
sourceTranslatedPort principal.nat_port 已轉換為整數
target.platform principal.platform 如果是 iOS,請設為 MAC;如果是 Android,請設為 ANDROID
target.osVersion principal.platform_version 直接複製值
spt principal.port 已轉換為整數
sproc principal.process.command_line sproc 或 about.process.command_line 的值
about.process.command_line principal.process.command_line
details.fileName principal.process.file.full_path 直接複製值
spid principal.process.pid 直接複製值
old_permissions principal.resource.attribute.permissions 直接複製值
target.type principal.resource.name 直接複製值
principal_role principal.user.attribute.roles 直接複製值
suser principal.user.user_display_name suser 的值 (如果不是空白),或 CustomerName
CustomerName principal.user.user_display_name
suid principal.user.userid suid 或 target.emailAddress 的值
target.emailAddress principal.user.userid
oldFilePath src.file.full_path 直接複製值
oldFileSize src.file.size 已轉換為 uinteger
old_permissions src.resource.attribute.permissions 直接複製值
dntdom target.administrative_domain 直接複製值
destinationServiceName target.application 直接複製值
target_hostname target.asset.hostname 來自 target_hostname (來自 temp_dhost) 的值
token_new target.asset.attribute.labels Merged from token_new
temp_dhost target.hostname 直接複製值
dst_ip target.ip 直接複製值
mac_address target.mac 直接複製值
destination_translated_address target.nat_ip 直接複製值
destinationTranslatedPort target.nat_port 已轉換為整數
dpt target.port 已轉換為整數
dproc target.process.command_line 直接複製值
file_full_path target.process.file.full_path file_full_path 的值 (來自 File_name、Object、Objekt、Infected_Resource)
dpid target.process.pid 直接複製值
要求 target.url 來自要求或 details.url 的值
details.url target.url
target_role target.user.attribute.roles 直接複製值
temp_duser target.user.user_display_name temp_duser 或 CustomerName 的值
CustomerName target.user.user_display_name
temp_duid target.user.userid temp_duid、User 或 Bruker 的值
使用者 target.user.userid
Bruker target.user.userid
__action security_result.action 如果動作符合 accept/notified/REDIRECTED_USER_MAY_PROCEED/Success,則設為 ALLOW;如果動作符合 deny/blocked/BLOCKED/Failure/Failed,則設為 BLOCK;如果動作符合 Failure,則設為 FAIL
act security_result.action_details Value from act, or details.action, or Action_Taken
details.action security_result.action_details
Action_Taken security_result.action_details
cat security_result.category_details cat 或 sec_result_category_details 的值
sec_result_category_details security_result.category_details
catdt_field security_result.detection_fields 從各種標籤合併
categorySignificance_label security_result.detection_fields
categoryBehavior_label security_result.detection_fields
categoryDeviceGroup_label security_result.detection_fields
categoryOutcome_label security_result.detection_fields
categoryObject_label security_result.detection_fields
operation_label security_result.detection_fields
operasjon_label security_result.detection_fields
permission_label security_result.detection_fields
tillatelse_label security_result.detection_fields
infection_channel_label security_result.detection_fields
spyware_Grayware_Type_label security_result.detection_fields
threat_probability_label security_result.detection_fields
categoryOutcome_label security_result.outcomes 直接複製值
mwProfile security_result.rule_name 直接複製值
嚴重性 security_result.severity 如果分數為 0 到 3/低,則對應至「低」;如果分數為 4 到 6/中/資訊/重大,則對應至「中」;如果分數為 7 到 8/高/嚴重,則對應至「高」;如果分數為 9 到 10/危急/非常高,則對應至「危急」
details.severity security_result.severity
reason security_result.summary 原因、應用程式類別或結果的值
appcategory security_result.summary
結果 security_result.summary
間諜軟體 security_result.threat_name Spyware、Virus_Malware_Name 或 Unknown_Threat 的值
Virus_Malware_Name security_result.threat_name
Unknown_Threat security_result.threat_name
actor.type event.idm.read_only_udm.additional.fields 從變更記錄對應
actor_type event.idm.read_only_udm.additional.fields 從變更記錄對應
changeType event.idm.read_only_udm.additional.fields 從變更記錄對應
id event.idm.read_only_udm.principal.resource.product_object_id 從變更記錄對應
CustomerName event.idm.read_only_udm.target.user.userid 從變更記錄對應
details.type", "details.packageSha", "details.packageName", "details.assessments", "details.activationStatus", "details.securityStatus", and "details.protectionStatus additional.fields 從變更記錄對應
target.manufacturer principal.asset.hardware.manufacturer 從變更記錄對應

變更記錄

查看這個剖析器的變更記錄

還有其他問題嗎?向社群成員和 Google SecOps 專家尋求解答。