收集 ManageEngine AD360 記錄
本文說明如何使用 Bindplane 代理程式,將 ManageEngine AD360 記錄檔擷取至 Google Security Operations。
ManageEngine AD360 是一項整合式身分與存取權管理解決方案,可針對 Active Directory 變更、驗證事件、網路連線和違反安全性政策的行為,產生系統記錄訊息。剖析器會使用 Grok 模式從 Syslog 格式的記錄檔中擷取欄位,並將這些欄位對應至統合式資料模型 (UDM)。
事前準備
請確認您已完成下列事前準備事項:
- Google SecOps 執行個體
- Windows Server 2016 以上版本,或搭載
systemd的 Linux 主機 - Bindplane 代理程式與 ManageEngine AD360 伺服器之間的網路連線
- 如果透過 Proxy 執行,請確保防火牆通訊埠已根據 Bindplane 代理程式需求開啟
- ManageEngine AD360 網頁 UI 的管理員存取權
取得 Bindplane 代理程式的 Google SecOps 憑證
如要向 Google SecOps 驗證 Bindplane 代理程式,請選擇下列其中一種方法:
- 新部署作業:使用 Chronicle API (選項 1)。
- 舊版部署作業:繼續使用擷取驗證檔案 (選項 2),直到 Ingestion API 於 2027 年 7 月 20 日停用。
方法 1:為 Chronicle API 建立服務帳戶 (建議)
- 登入 Google Cloud 控制台,然後選取連結至 Google SecOps 執行個體的 Google Cloud 專案。
- 依序前往「IAM & Admin」(IAM 與管理) >「Service Accounts」(服務帳戶)。
- 按一下「建立服務帳戶」。
- 提供下列設定詳細資料:
- 服務帳戶名稱:輸入帳戶名稱 (例如
bindplane-ingest)。 - 服務帳戶說明:輸入說明 (例如
Bindplane agent log ingestion)。
- 服務帳戶名稱:輸入帳戶名稱 (例如
- 點按「Create and continue」(建立並繼續)。
- 在「將專案存取權授予這個服務帳戶」部分,按一下「選取角色」,然後選取「Chronicle 編輯者」。
- 依序點選「繼續」和「完成」。
- 按一下您建立的服務帳戶,然後前往「金鑰」分頁。
- 依序點選「新增金鑰」>「建立新的金鑰」。
- 選取「JSON」,然後點選「建立」。金鑰檔案會下載到電腦。
- 將金鑰檔案儲存為 Bindplane 收集器目錄中的
ingestion-auth.json(Linux 上的/opt/observiq-otel-collector/ingestion-auth.json或 Windows 上的C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json),或更新config.yaml中的creds_file_path,使其與儲存路徑相符。 - 依序前往「IAM & Admin」(IAM 與管理) >「Settings」(設定),然後複製「Project number」(專案編號)。匯出工具設定時會用到。
方法 2:下載擷取驗證檔案 (舊版)
- 登入 Google SecOps 控制台。
- 依序前往「SIEM Settings」 > 「Collection Agents」。
- 下載擷取驗證檔案。
- 將檔案安全地儲存在要安裝 Bindplane 代理程式的系統上。
取得 Google SecOps 客戶 ID
- 登入 Google SecOps 控制台。
- 依序前往「SIEM 設定」 > 「設定檔」。
複製並儲存「機構詳細資料」部分的客戶 ID。
安裝 Bindplane 代理程式
請按照下列操作說明,在 Windows 或 Linux 作業系統上安裝 Bindplane 代理程式。
Windows 安裝
- 以管理員身分開啟命令提示字元或 PowerShell。
執行下列指令:
msiexec /i "https://github.com/observIQ/bindplane-agent/releases/latest/download/observiq-otel-collector.msi" /quiet等待安裝完成。
執行下列指令,確認安裝成功:
sc query observiq-otel-collector服務應顯示為「RUNNING」。
Linux 安裝
- 開啟具有 root 或 sudo 權限的終端機。
執行下列指令:
sudo sh -c "$(curl -fsSlL https://github.com/observiq/bindplane-agent/releases/latest/download/install_unix.sh)" install_unix.sh等待安裝完成。
執行下列指令,確認安裝成功:
sudo systemctl status observiq-otel-collector服務應顯示為「active (running)」。
其他安裝資源
如需其他安裝選項和疑難排解資訊,請參閱 Bindplane 代理程式安裝指南。
設定 Bindplane 代理程式,擷取系統記錄並傳送至 Google SecOps
找出設定檔
Linux:
sudo nano /opt/observiq-otel-collector/config.yamlWindows:
notepad "C:\Program Files\observIQ OpenTelemetry Collector\config.yaml"
編輯設定檔
將
config.yaml的全部內容替換為下列設定:receivers: udplog: listen_address: "0.0.0.0:514" exporters: chronicle/manage_engine_ad360: protocol: https # Region of your instance, for example us, europe, asia-southeast1 location: <LOCATION> # Project number of the Google Cloud project linked to the instance project: '<PROJECT_NUMBER>' compression: gzip creds_file_path: '/opt/observiq-otel-collector/ingestion-auth.json' customer_id: '<customer_id>' endpoint: chronicle.googleapis.com log_type: MANAGE_ENGINE_AD360 raw_log_field: body service: pipelines: logs/manage_engine_ad360_to_chronicle: receivers: - udplog exporters: - chronicle/manage_engine_ad360
設定參數
替換下列預留位置:
接收器設定:
listen_address:要監聽的 IP 位址和通訊埠:0.0.0.0在所有介面接聽電話 (建議)- 通訊埠
514是標準 syslog 通訊埠 (在 Linux 上需要根目錄;非根目錄請使用1514)
匯出工具設定:
creds_file_path:服務帳戶 JSON 金鑰檔案的完整路徑 (選項 1):- Linux:
/opt/observiq-otel-collector/ingestion-auth.json - Windows:
C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json
- Linux:
customer_id:從 Google SecOps 控制台複製的客戶 IDlocation:將<LOCATION>替換為 Google SecOps 執行個體的區域 (例如us、europe或asia-southeast1)。匯出工具會以這個值做為chronicle.googleapis.com的前置字元。如需完整清單,請參閱「區域性端點」。project:依序前往「IAM 與管理」>「設定」,然後將<PROJECT_NUMBER>替換為專案編號。endpoint:請將此值設為chronicle.googleapis.com。
舊版擷取 API 匯出工具
如果您使用選項 2 的擷取驗證檔案,請將
exporters區塊替換為下列內容。將creds_file_path設為擷取驗證檔案的路徑。如果執行個體位於美國境外,請將malachiteingestion-pa.googleapis.com替換為區域端點 (例如europe-malachiteingestion-pa.googleapis.com)。exporters: chronicle/manage_engine_ad360: compression: gzip creds_file_path: '/opt/observiq-otel-collector/ingestion-auth.json' customer_id: '<customer_id>' endpoint: malachiteingestion-pa.googleapis.com log_type: MANAGE_ENGINE_AD360 raw_log_field: body
儲存設定檔
- 編輯完成後,請儲存檔案:
- Linux:依序按下
Ctrl+O、Enter和Ctrl+X - Windows:依序點選「檔案」 > 「儲存」
- Linux:依序按下
重新啟動 Bindplane 代理程式,套用變更
如要在 Linux 重新啟動 Bindplane 代理程式,請執行下列指令:
sudo systemctl restart observiq-otel-collector確認服務正在執行:
sudo systemctl status observiq-otel-collector檢查記錄是否有錯誤:
sudo journalctl -u observiq-otel-collector -f
如要在 Windows 中重新啟動 Bindplane 代理程式,請選擇下列其中一個選項:
以管理員身分開啟命令提示字元或 PowerShell:
net stop observiq-otel-collector && net start observiq-otel-collector服務控制台:
- 按下
Win+R,輸入services.msc,然後按下 Enter 鍵。 - 找出「observIQ OpenTelemetry Collector」。
- 按一下滑鼠右鍵,然後選取「重新啟動」。
確認服務正在執行:
sc query observiq-otel-collector查看記錄檔是否有錯誤:
type "C:\Program Files\observIQ OpenTelemetry Collector\log\collector.log"
- 按下
設定 ManageEngine AD360 syslog 匯出
- 登入 AD360 網頁 UI。
- 依序前往「Admin」 >「Administration」 >「SIEM Integration」。
- 按一下「ADSelfService」元件旁的「立即設定」連結。
- 請提供下列設定詳細資料:
- 伺服器類型:選取「Syslog」。
- Server Name/IP:輸入 Bindplane 代理程式 IP 位址。
- 「通訊埠」:輸入 Bindplane 代理程式通訊埠編號。
- 「通訊協定」:選取「UDP」。
- Syslog 標準:選取 RFC 5424。
- 按一下「進階」清單。
- Severity:選取「Informational」。
- 按一下「設定」即可儲存。
UDM 對應表
| 記錄欄位 | UDM 對應 | 邏輯 |
|---|---|---|
| AccessControlRuleName | security_result.rule_name | 如果欄位 AccessControlRuleName 存在,則取自該欄位,否則取自欄位 rule_name |
| ACPolicy | security_result.rule_labels.value | 從欄位 ACPolicy 取得的值 |
| 動作 | security_result.action_details | 直接對應至 UDM |
| action_id | security_result.detection_fields.value | 從欄位 action_id 取得的值 |
| application_protocol | network.application_protocol | 直接對應至 UDM |
| 位元組 | network.sent_bytes | 直接對應至 UDM |
| client_ip | principal.ip | 直接對應至 UDM |
| ConnectionID | network.session_id | 如果 connection_id 欄位存在,則從該欄位擷取值,否則從 ConnectionID 欄位擷取值,否則從 ses 欄位擷取值 |
| destination_ip | target.ip | 直接對應至 UDM |
| destination_port | target.port | 直接對應至 UDM |
| DeviceUUID | target.asset_id | 值取自 DeviceUUID 欄位 (如有),否則取自 distinguished_name_device_id 欄位 |
| distinguished_name_device_id | target.asset_id | 如果欄位 DeviceUUID 存在,則取自該欄位,否則取自欄位 distinguished_name_device_id |
| distinguished_name_user | target.user.userid | 直接對應至 UDM |
| 數位服務稅 | target.ip | 值取自 DST 欄位 (如有),否則取自 DstIP 欄位 |
| DPT | target.port | 如果 DPT 欄位存在,則從該欄位擷取值,否則從 DstPort 欄位擷取值,否則從 destination_port 欄位擷取值 |
| DstIP | target.ip | 值取自 DST 欄位 (如有),否則取自 DstIP 欄位 |
| DstPort | target.port | 如果 DPT 欄位存在,則從該欄位擷取值,否則從 DstPort 欄位擷取值,否則從 destination_port 欄位擷取值 |
| EgressInterface | additional.fields.value.string_value | 直接對應至 UDM |
| EgressZone | target.location.name | 直接對應至 UDM |
| EventPriority | security_result.severity | 根據 EventPriority 欄位的值,對應至不同的嚴重程度。 |
| exe | principal.process.command_line | 直接對應至 UDM |
| geoip.city_name | principal.location.city | 直接對應至 UDM |
| geoip.country_name | principal.location.country_or_region | 直接對應至 UDM |
| geoip.latitude | principal.location.region_latitude | 直接對應至 UDM |
| geoip.longitude | principal.location.region_longitude | 直接對應至 UDM |
| http_status | network.http.response_code | 直接對應至 UDM |
| id | metadata.product_log_id | 直接對應至 UDM |
| IngressInterface | additional.fields.value.string_value | 直接對應至 UDM |
| IngressZone | principal.location.name | 直接對應至 UDM |
| LEN | additional.fields.value.string_value | 直接對應至 UDM |
| message_number | 未對應 | |
| NAPPolicy | security_result.rule_labels.value | 值取自「NAPPolicy」欄位 |
| network_direction | network.direction | 直接對應至 UDM |
| OUT | additional.fields.value.string_value | 直接對應至 UDM |
| pid | target.process.pid | 直接對應至 UDM |
| ppid | target.process.parent_process.pid | 直接對應至 UDM |
| PREC | additional.fields.value.string_value | 直接對應至 UDM |
| principal_hostname | principal.hostname | 直接對應至 UDM |
| product_event_type | metadata.product_event_type | 直接對應至 UDM |
| 通訊協定 | network.ip_protocol | 用於填入 PROTO 欄位,然後使用對照表對應至 UDM。 |
| PROTO | network.ip_protocol | 使用以通訊協定號碼為依據的對照表,對應至 UDM。 |
| request_method | network.http.method | 直接對應至 UDM |
| rule_name | security_result.rule_name | 如果欄位 AccessControlRuleName 存在,則取自該欄位,否則取自欄位 rule_name |
| ses | network.session_id | 如果欄位 connection_id 存在,則從該欄位擷取值,否則從欄位 ConnectionID 擷取值,否則從欄位 ses 擷取值 |
| source_ip | principal.ip | 直接對應至 UDM |
| source_port | principal.port | 直接對應至 UDM |
| SPT | principal.port | 值取自 SPT 欄位 (如有),否則取自 SrcPort 欄位,否則取自 source_port 欄位 |
| SRC | principal.ip | 如果欄位 SRC 存在,則取自該欄位的值,否則取自欄位 SrcIP,否則取自欄位 client_ip |
| SrcIP | principal.ip | 如果 SRC 欄位存在,則從該欄位擷取值,否則從 SrcIP 欄位擷取值,否則從 client_ip 欄位擷取值 |
| SrcPort | principal.port | 如果欄位 SPT 存在,則取自該欄位的值,否則取自欄位 SrcPort,否則取自欄位 source_port |
| 時間戳記 | metadata.event_timestamp | 直接對應至 UDM |
| TOS | additional.fields.value.string_value | 直接對應至 UDM |
| 存留時間 | additional.fields.value.string_value | 直接對應至 UDM |
| 網址 | target.url | 直接對應至 UDM |
| user_agent | network.http.user_agent | 直接對應至 UDM |
| WINDOW | additional.fields.value.string_value | 直接對應至 UDM |
| metadata.vendor_name | 值會硬式編碼為 MANAGE_ENGINE_AD360 |
|
| metadata.product_name | 值會硬式編碼為 MANAGE_ENGINE_AD360 |
|
| metadata.log_type | 值已硬式編碼為 MANAGE_ENGINE_AD360 |
|
| metadata.event_type | 如果 SRC 和 DST 欄位皆有,則值會設為 NETWORK_CONNECTION;如果 SRC 或 principal_hostname 欄位有任一者,則值會設為 STATUS_UPDATE。如未符合上述任一條件,則預設為 GENERIC_EVENT。 |
變更記錄
還有其他問題嗎?向社群成員和 Google SecOps 專業人員尋求解答。