收集 Claroty xDome for Healthcare 記錄

支援的國家/地區:

本文說明如何使用 Bindplane 代理程式,將 Claroty xDome for Healthcare 記錄擷取至 Google SecOps。

Claroty xDome for Healthcare (前身為 Medigate 裝置安全平台) 是專為醫療照護產業設計的網路安全平台,可提供醫療物聯網 (XIoT) 裝置的能見度、威脅偵測和風險管理功能。這個平台會監控連線的醫療裝置、找出安全漏洞、偵測異常行為,並提供可據以行動的深入分析資料,協助保護醫療保健網路免於網路威脅。

事前準備

請確認您已完成下列事前準備事項:

  • Google SecOps 執行個體
  • Windows Server 2016 以上版本,或搭載 systemd 的 Linux 主機
  • Bindplane 代理程式與 Claroty xDome for Healthcare 之間的網路連線
  • 如果透過 Proxy 執行,請確保防火牆通訊埠已根據 Bindplane 代理程式需求開啟
  • Claroty xDome for Healthcare 管理主控台的特殊權限存取權
  • Claroty xDome for Healthcare 的管理員或安全管理員角色

取得 Google SecOps 擷取驗證檔案

  1. 登入 Google SecOps 控制台。
  2. 依序前往「SIEM 設定」>「收集代理程式」
  3. 下載擷取驗證檔案。將檔案安全地儲存在要安裝 Bindplane 的系統上。

取得 Google SecOps 客戶 ID

  1. 登入 Google SecOps 控制台。
  2. 依序前往「SIEM 設定」>「設定檔」
  3. 複製並儲存「機構詳細資料」部分中的客戶 ID

安裝 Bindplane 代理程式

請按照下列操作說明,在 Windows 或 Linux 作業系統上安裝 Bindplane 代理程式。

Windows 安裝

  1. 以管理員身分開啟「命令提示字元」或「PowerShell」
  2. 執行下列指令:

    msiexec /i "https://github.com/observIQ/bindplane-agent/releases/latest/download/observiq-otel-collector.msi" /quiet
    
  3. 等待安裝完成。

  4. 執行下列指令,確認安裝成功:

    sc query observiq-otel-collector
    

服務應顯示為「RUNNING」

Linux 安裝

  1. 開啟具有根層級或 sudo 權限的終端機。
  2. 執行下列指令:

    sudo sh -c "$(curl -fsSlL https://github.com/observiq/bindplane-agent/releases/latest/download/install_unix.sh)" install_unix.sh
    
  3. 等待安裝完成。

  4. 執行下列指令,確認安裝成功:

    sudo systemctl status observiq-otel-collector
    

服務應顯示為有效 (執行中)

其他安裝資源

如需其他安裝選項和疑難排解資訊,請參閱 Bindplane 代理程式安裝指南

設定 Bindplane 代理程式,擷取系統記錄檔並傳送至 Google SecOps

找出設定檔

  • Linux:

    sudo nano /etc/bindplane-agent/config.yaml
    
  • Windows:

    notepad "C:\Program Files\observIQ OpenTelemetry Collector\config.yaml"
    

編輯設定檔

  • config.yaml 的所有內容替換為下列設定:

    receivers:
      syslog:
        tcp:
          listen_address: "0.0.0.0:514"
        protocol: rfc5424
    
    exporters:
      chronicle/claroty_xdome:
        compression: gzip
        creds_file_path: '/etc/bindplane-agent/ingestion-auth.json'
        customer_id: 'YOUR_CUSTOMER_ID'
        endpoint: malachiteingestion-pa.googleapis.com
        log_type: MEDIGATE_IOT
        raw_log_field: body
    
    service:
      pipelines:
        logs/claroty_to_chronicle:
          receivers:
            - syslog
          exporters:
            - chronicle/claroty_xdome
    

設定參數

  • 替換下列預留位置:

    • 接收器設定:

      • 接收器已設定為使用 RFC 5424 通訊協定的 TCP 系統記錄檔
      • 監聽位址 0.0.0.0:514 會接受通訊埠 514 上所有介面的連線
      • 如果是 Linux 非根安裝作業,請使用通訊埠 1514,而非 514
    • 匯出工具設定:

    • creds_file_path:擷取驗證檔案的完整路徑:

      • Linux/etc/bindplane-agent/ingestion-auth.json
      • WindowsC:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json
    • customer_id:將 YOUR_CUSTOMER_ID 替換為上一個步驟中的客戶 ID

    • endpoint:區域端點網址:

      • 美國malachiteingestion-pa.googleapis.com
      • 歐洲europe-malachiteingestion-pa.googleapis.com
      • 亞洲asia-southeast1-malachiteingestion-pa.googleapis.com
      • 如需完整清單,請參閱「區域端點
    • log_type:設為 MEDIGATE_IOT (支援 Claroty 和 Medigate 記錄格式)

  • Linux 設定範例

    receivers:
    syslog:
      tcp:
        listen_address: "0.0.0.0:1514"
      protocol: rfc5424
    
    exporters:
    chronicle/claroty_xdome:
      compression: gzip
      creds_file_path: '/etc/bindplane-agent/ingestion-auth.json'
      customer_id: 'a1b2c3d4-e5f6-g7h8-i9j0-k1l2m3n4o5p6'
      endpoint: malachiteingestion-pa.googleapis.com
      log_type: MEDIGATE_IOT
      raw_log_field: body
      ingestion_labels:
        env: production
        source: claroty_xdome
    
    service:
    pipelines:
      logs/claroty_to_chronicle:
        receivers:
          - syslog
        exporters:
          - chronicle/claroty_xdome
    

儲存設定檔

編輯完成後,請儲存檔案:

  • Linux:依序按下 Ctrl+OEnterCtrl+X
  • Windows:依序點選「檔案」>「儲存」

重新啟動 Bindplane 代理程式,以套用變更

如要在 Linux 中重新啟動 Bindplane 代理程式,請執行下列步驟:

  1. 執行下列指令:

    sudo systemctl restart observiq-otel-collector
    
  2. 確認服務正在執行:

    sudo systemctl status observiq-otel-collector
    
  3. 檢查記錄中是否有錯誤:

    sudo journalctl -u observiq-otel-collector -f
    

如要在 Windows 中重新啟動 Bindplane 代理程式,請按照下列步驟操作:

  1. 您可以選擇下列其中一個選項:

    • 以管理員身分開啟命令提示字元或 PowerShell:
    net stop observiq-otel-collector && net start observiq-otel-collector
    
    • 服務控制台:
      1. 按下 Win+R,輸入 services.msc,然後按下 Enter 鍵。
      2. 找出 observIQ OpenTelemetry Collector
      3. 按一下滑鼠右鍵,然後選取「重新啟動」
  2. 確認服務正在執行:

    sc query observiq-otel-collector
    
  3. 檢查記錄中是否有錯誤:

    type "C:\Program Files\observIQ OpenTelemetry Collector\log\collector.log"
    

設定 Claroty xDome,轉送醫療保健系統記錄

登入 Claroty xDome for Healthcare

  1. 登入 Claroty xDome for Healthcare 網頁控制台。
  2. 依序前往「設定」>「系統設定」>「我的整合」

建立新的系統記錄整合

  1. 按一下「新增整合」
  2. 在「整合類型」下拉式選單中,選取「系統記錄」
  3. 請提供下列設定詳細資料:
    • 整合名稱:輸入描述性名稱 (例如 Chronicle-SIEM)。
    • 說明 (選填):輸入 Integration with Google Chronicle SIEM

設定系統記錄伺服器設定

在「Syslog Server」(系統記錄伺服器) 部分,提供下列詳細資料:

  • 主機:輸入 Bindplane 代理程式主機的 IP 位址 (例如 192.168.1.100)。
  • 通訊埠:輸入 514 (如果使用非根 Linux 安裝,則輸入 1514)。
  • 「通訊協定」:選取「TCP」
  • 訊息格式:選取 CEF (通用事件格式)。
  • Syslog 通訊協定標準:選取 RFC 5424

選取要匯出的記錄類型

在「匯出類型」部分,選取要轉送至 Google SecOps 的記錄類型:

  • 快訊:安全性快訊和風險快訊
  • 安全漏洞:CVE 資料和安全漏洞資訊
  • 裝置變更:資產清單變更
  • OT 活動事件:營運技術通訊事件

設定時區

  1. 在「時區」部分,從下拉式選單選取「UTC」

測試並儲存設定

  1. 按一下「測試連線」,驗證與 Bindplane 代理程式的連線。
  2. 確認測試結果顯示「連線成功」
  3. 按一下「儲存」,啟用系統記錄整合。

確認記錄轉送

  1. 等待 5 到 10 分鐘,記錄就會開始流動。
  2. 查看 Bindplane 代理程式記錄,確認是否收到 Syslog 訊息:

    • Linux:
    sudo journalctl -u observiq-otel-collector -f | grep -i claroty
    
    • Windows:
    type "C:\Program Files\observIQ OpenTelemetry Collector\log\collector.log" | findstr /i claroty
    
  3. 登入 Google SecOps 控制台,確認 Claroty xDome for Healthcare 記錄顯示在搜尋結果中。

UDM 對應表

記錄欄位 UDM 對應 邏輯
info_ip_desc about.labels 與活動相關聯的標籤
info.as_org about.labels
info.org about.labels
info.isp about.labels
info.country_code about.labels
info.malicious_anomali_info.itype about.labels
info.malicious_anomali_info.ip about.labels
info.malicious_anomali_info.source about.labels
info.malicious_anomali_info.org about.labels
info.malicious_anomali_info.country about.labels
info.malicious_anomali_info.classification about.labels
info.malicious_anomali_info.maltype about.labels
info.malicious_anomali_info.stream_id about.labels
info.malicious_anomali_info.threat_type about.labels
info.malicious_anomali_info.resource_uri about.labels
info.malicious_anomali_info.threatscore about.labels
info.malicious_anomali_info.confidence about.labels
info.malicious_anomali_info.source_reported_confidence about.labels
info.protocol about.labels
info.human_name about.labels
info.dest.human_name about.labels
info.network about.labels
info.parent_human_name about.labels
info.parent_uid about.labels
target_ip_desc about.labels
label_resource_uri about.labels
label_threatscore about.labels
label_confidence about.labels
label_source_reported_confidence about.labels
alert.mitre_technique_ids additional.fields 事件的其他任意形式中繼資料
alert.mitre_technique_names additional.fields
alert.mitre_technique_enterprise_ids additional.fields
alert.mitre_technique_enterprise_names additional.fields
affected_device.device_type_family additional.fields
affected_device.connection_type_list additional.fields
affected_device.network_list additional.fields
msg_category additional.fields
interface_name additional.fields
interface_type additional.fields
狀態 additional.fields
alert_info.certificate_thumbprint additional.fields
alert_info.certificate_expiry_date additional.fields
alert_info.certificate_start_date additional.fields
alert_info.certificate_type additional.fields
affected_device.management_status additional.fields
affected_device.labels additional.fields
affected_device.site_name additional.fields
events_extra_info.client_id additional.fields
extensions.auth.type extensions.auth.type 驗證類型
主機名稱 intermediary.hostname 中介主機名稱
events_extra_info.malicious_ip_info.malicious_ip intermediary.ip 中介裝置的 IP 位址
incident_type metadata.description 事件說明
文字 metadata.description
events.description metadata.description
metadata.event_type metadata.event_type 活動類型
event_type metadata.product_event_type 產品事件類型
events.type metadata.product_event_type
incident_id metadata.product_log_id 產品記錄 ID
events.id metadata.product_log_id
network.application_protocol network.application_protocol 應用程式通訊協定
network.direction network.direction 網路連線方向
protocol_number_src network.ip_protocol IP 通訊協定
server_name network.tls.client.server_name 用戶端在 TLS 握手期間指出的伺服器名稱
alert_info.certificate_thumbprint network.tls.server.certificate.sha256 伺服器憑證的 SHA256 雜湊
版本 network.tls.version 傳輸層安全標準 (TLS) 版本
proto network.tls.version_protocol TLS 版本通訊協定
info.domain principal.administrative_domain 主體的管理網域
events_extra_info.domain principal.administrative_domain
affected_device.asset_id principal.asset.asset_id 資產的資產 ID
硬體 principal.asset.hardware 資產的硬體
affected_device.device_name principal.asset.hostname 資產的主機名稱
events_extra_info.certificate_info.CN principal.asset.hostname
management_ip principal.asset.ip 資產的 IP 位址
info.ip principal.asset.ip
comm_tuple.src_ip principal.asset.ip
info.tuple.2 principal.asset.ip
info.tuple.3 principal.asset.ip
affected_device.ip_list principal.asset.ip
info.subject_components.CN principal.hostname 主體的主機名稱
affected_device.device_name principal.hostname
events_extra_info.certificate_info.CN principal.hostname
management_ip principal.ip 主體的 IP 位址
info.ip principal.ip
comm_tuple.src_ip principal.ip
info.tuple.2 principal.ip
info.tuple.3 principal.ip
affected_device.ip_list principal.ip
info.subject_components.L principal.location.city 地點所在城市
events_extra_info.certificate_info.L principal.location.city
位置 principal.location.country_or_region 地點的國家/地區
info.subject_components.C principal.location.country_or_region
events_extra_info.certificate_info.C principal.location.country_or_region
info.subject_components.ST principal.location.state 地點所在州/省
events_extra_info.certificate_info.ST principal.location.state
principal.platform principal.platform 主體平台
affected_device.os principal.platform_version 主體的平台版本
device_uid principal.resource.id 資源 ID
info.device_type_family principal.resource.name 資源名稱
affected_device.device_type principal.resource.name
affected_device.uid principal.resource.product_object_id 資源的產品物件 ID
affected_device.device_category principal.resource.resource_subtype 資源的子類型
principal.resource.resource_type principal.resource.resource_type 資源類型
info.device_category principal.resource.type 資源類型
updated_by principal.user.userid 使用者的 Userid
info.login_username principal.user.userid
events_extra_info.sender_id principal.user.userid
events_extra_info.username principal.user.userid
info.malicious_anomali_info.itype security_result.about.labels 與安全性結果相關聯的標籤
info.malicious_anomali_info.ip security_result.about.labels
info.malicious_anomali_info.source security_result.about.labels
info.malicious_anomali_info.org security_result.about.labels
info.malicious_anomali_info.country security_result.about.labels
info.malicious_anomali_info.classification security_result.about.labels
info.malicious_anomali_info.maltype security_result.about.labels
info.malicious_anomali_info.stream_id security_result.about.labels
info.malicious_anomali_info.threat_type security_result.about.labels
events_extra_info.malicious_ip_info.source security_result.about.labels
events_extra_info.malicious_ip_info.threat_type security_result.about.labels
security_result.category security_result.category 安全性結果的類別
alert.category security_result.category_details 安全性結果的類別詳細資料
events_extra_info.malicious_ip_info.type security_result.category_details
events_extra_info.malicious_ip_info.confidence security_result.confidence_details 安全結果的信賴度詳細資料
alert.description security_result.description 安全性結果說明
alert.type_name security_result.detection_fields 與安全性結果相關聯的偵測欄位
alert.device_status security_result.detection_fields
alert.category security_result.detection_fields
alert.description security_result.detection_fields
vulnerability_info.name security_result.detection_fields
vulnerability_info.type security_result.detection_fields
vulnerability_info.release_date security_result.detection_fields
vulnerability_info.cves security_result.detection_fields
vulnerability_info.cvssv3_base_score security_result.detection_fields
vulnerability_info.description security_result.detection_fields
vulnerability_info.affected_products security_result.detection_fields
vulnerability_info.is_known_exploited security_result.detection_fields
vulnerability_device_info.relevance_source security_result.detection_fields
vulnerability_info.cvssv2_base_score security_result.detection_fields
affected_device.device_subcategory security_result.detection_fields
affected_device.retired security_result.detection_fields
affected_device.app_version security_result.detection_fields
events_extra_info.communication_type security_result.detection_fields
events_extra_info.malicious_ip_info.tags security_result.detection_fields
alert_info.certificate_thumbprint security_result.detection_fields
alert_info.certificate_expiry_date security_result.detection_fields
alert_info.certificate_start_date security_result.detection_fields
alert_info.certificate_type security_result.detection_fields
alert.id security_result.rule_id 安全結果的規則 ID
events.alert_id security_result.rule_id
alert.name security_result.rule_name 安全結果的規則名稱
info.malicious_anomali_info.severity security_result.severity 安全性結果的嚴重程度
affected_device.risk_score security_result.severity_details 安全結果的嚴重程度詳細資料
info.malicious_anomali_info.threat_type security_result.threat_name 安全結果的威脅名稱
events_extra_info.malicious_ip_info.threat_type security_result.threat_name
target.asset.hostname target.asset.hostname 目標資產的主機名稱
info.tuple.3 target.asset.ip 目標資產的 IP 位址
info.tuple.2 target.asset.ip
comm_tuple.dst_ip target.asset.ip
info.file_name target.file.full_path 目標檔案的完整路徑
events_extra_info.file_name target.file.full_path
events_extra_info.file_type target.file.mime_type 目標檔案的 MIME 類型
info.fqdn target.hostname 目標的主機名稱
info.tuple.3 target.ip 目標的 IP 位址
info.tuple.2 target.ip
comm_tuple.dst_ip target.ip
國家/地區 target.location.country_or_region 目標地點的國家/地區
info.geolocation target.location.country_or_region
國家/地區 target.location.country_or_region
events_extra_info.geo_location target.location.country_or_region
最終的隱藏狀態 target.location.state 目標位置的狀態
最終的隱藏狀態 target.location.state
target_mac target.mac 目標的 MAC 位址
comm_tuple.dst_mac target.mac
comm_tuple.dst_port target.port 目標通訊埠
dest_device_uid target.resource.id 目標資源的 ID
info.login_username target.user.userid 目標使用者的使用者 ID
events_extra_info.username target.user.userid
metadata.product_name metadata.product_name 產品名稱
metadata.vendor_name metadata.vendor_name 供應商名稱
events.id event.idm.read_only_udm.metadata.product_log_id 從變更記錄對應
affected_device.device_name event.idm.read_only_udm.principal.hostname 從變更記錄對應
affected_device.device_name event.idm.read_only_udm.principal.asset.hostname 從變更記錄對應
management_ip event.idm.read_only_udm.principal.ip 從變更記錄對應
management_ip event.idm.read_only_udm.principal.asset.ip 從變更記錄對應
updated_by event.idm.read_only_udm.principal.user.userid 從變更記錄對應
affected_device.os event.idm.read_only_udm.principal.platform_version 從變更記錄對應
affected_device.management_status event.idm.read_only_udm.principal.resource.attribute.labels 從變更記錄對應
affected_device.labels event.idm.read_only_udm.principal.resource.attribute.labels 從變更記錄對應
events_extra_info.direction event.idm.read_only_udm.network.direction 從變更記錄對應
events_extra_info.ip_protocol event.idm.read_only_udm.network.ip_protocol 從變更記錄對應
events.alert_id event.idm.read_only_udm.security_result.rule_id 從變更記錄對應
affected_device.risk_score event.idm.read_only_udm.security_result.severity_details 從變更記錄對應
events_extra_info.communication_type event.idm.read_only_udm.security_result.detection_fields 從變更記錄對應
vulnerability_info.name", "vulnerability_info.type", "vulnerability_info.release_date", "cve", "vulnerability_info.cvssv3_base_score", "vulnerability_info.description", "vulnerability_info.affected_products", "vulnerability_info.is_known_exploited", "vulnerability_device_info.relevance", "vulnerability_device_info.relevance_source", "vulnerability_info.cvssv2_base_score", "affected_device.device_subcategory", "affected_device.retired", and "affected_device.app_version security_result.detection_fields 從變更記錄對應
alert.type_name", "alert.device_status", "alert_info.certificate_thumbprint", "alert_info.certificate_expiry_date", "alert_info.certificate_start_date", and "alert_info.certificate_type security_result.detection_fields 從變更記錄對應
alert.mitre_technique_ids", "alert.mitre_technique_names", "alert.mitre_technique_enterprise_ids", "alert.mitre_technique_enterprise_names", "affected_device.device_type_family", "affected_device.connection_type_list", and "affected_device.network_list additional.fields 從變更記錄對應
affected_device.mac_list principal.mac 從變更記錄對應
msg_category", "interface_name", "interface_type", and "status additional.fields 從變更記錄對應
event_extra_info.malicious_ip_info.confidence security_result.confidence_details 從變更記錄對應
event_extra_info.malicious_ip_info.last_update target.file.mime_type 從變更記錄對應
event_extra_info.malicious_ip_info.tags security_result.detection_fields 從變更記錄對應
event_extra_info.malicious_ip_info.type security_result.category_details 從變更記錄對應
events.timestamp metadata.event_timestamp 從變更記錄對應
events_extra_info.malicious_ip_info.severity security_result.severity 從變更記錄對應
events_extra_info.client_id" and "affected_device.site_name additional_fields 從變更記錄對應
comm_tuple.src_port principal.port 從變更記錄對應
comm_tuple.src_mac principal.mac 從變更記錄對應
affected_device.manufacturer hardware.manufacturer 從變更記錄對應
affected_device.model hardware.model 從變更記錄對應
metadata.event_type NETWORK_HTTP 從變更記錄對應
metadata.event_type NETWORK_FTP 從變更記錄對應
security_category NETWORK_MALICIOUS 從變更記錄對應
metadata.event_type USER_LOGIN 從變更記錄對應

變更記錄

查看這個剖析器的變更記錄

還有其他問題嗎?向社群成員和 Google SecOps 專業人員尋求答案。