收集 Nasuni File Data Services 服務記錄
本文說明如何使用 Bindplane,將 Nasuni File Data Services 服務記錄擷取至 Google Security Operations。Nasuni File Data Services 是雲端原生檔案資料平台,可取代傳統檔案儲存基礎架構,提供可擴充的雲端式解決方案。這項服務提供檔案存取、檔案共用、保護和全域檔案鎖定功能,可跨邊緣位置使用。Nasuni 會產生檔案作業、存取事件和管理動作的稽核記錄,可透過系統記錄轉送,以利安全監控。
事前準備
請確認您符合下列必要條件:
- Google SecOps 執行個體。
- 搭載 systemd 的 Windows 2016 以上版本或 Linux 主機。
- 如果是在 Proxy 後方執行,請確認防火牆通訊埠已按照 Bindplane 代理程式需求開啟。
- 具備 Nasuni 管理控制台 (NMC) 的管理員權限。
- Nasuni Edge Appliance 韌體 9.0 以上版本。
取得 Bindplane 代理程式的 Google SecOps 憑證
如要向 Google SecOps 驗證 Bindplane 代理程式,請選擇下列其中一種方法:
- 新部署作業:使用 Chronicle API (選項 1)。
- 舊版部署作業:繼續使用擷取驗證檔案 (選項 2),直到 Ingestion API 於 2027 年 7 月 20 日停用。
方法 1:為 Chronicle API 建立服務帳戶 (建議)
- 登入 Google Cloud 控制台,選取連結至 Google SecOps 執行個體的 Google Cloud 專案。
- 依序前往 「IAM & Admin」(IAM 與管理) >「Service Accounts」(服務帳戶)。
- 按一下「建立服務帳戶」。
- 提供下列設定詳細資料:
- 「Service account name」(服務帳戶名稱):輸入帳戶名稱 (例如
bindplane-ingest)。 - 「服務帳戶說明」:輸入說明 (例如
Bindplane agent log ingestion)。
- 「Service account name」(服務帳戶名稱):輸入帳戶名稱 (例如
- 點按「Create and continue」(建立並繼續)。
- 在「將專案存取權授予這個服務帳戶」部分,按一下「選取角色」,然後選取「Chronicle 編輯者」。
- 依序點選「繼續」和「完成」。
- 按一下您建立的服務帳戶,然後前往「金鑰」分頁標籤。
- 依序點選「新增金鑰」>「建立新的金鑰」。
- 選取「JSON」,然後點選「建立」。金鑰檔案會下載到電腦。
- 將金鑰檔案儲存為 Bindplane 收集器目錄中的
ingestion-auth.json(Linux 上的/opt/observiq-otel-collector/ingestion-auth.json或 Windows 上的C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json),或更新config.yaml中的creds_file_path,使其與儲存路徑相符。 - 依序前往「IAM & Admin」(IAM 與管理) >「Settings」(設定),然後複製「Project number」(專案編號)。匯出工具設定時會用到。
方法 2:下載擷取驗證檔案 (舊版)
- 登入 Google SecOps 控制台。
- 依序前往「SIEM Settings」 > 「Collection Agents」。
- 下載擷取驗證檔案。
- 將檔案安全地儲存在要安裝 Bindplane 代理程式的系統上。
取得 Google SecOps 客戶 ID
- 登入 Google SecOps 控制台。
- 依序前往「SIEM Settings」(SIEM 設定) >「Profile」(設定檔)。
- 複製並儲存「機構詳細資料」專區中的「客戶 ID」。
安裝 Bindplane 代理程式
請按照下列操作說明,在 Windows 或 Linux 作業系統上安裝 Bindplane 代理程式。
Windows 安裝
- 以管理員身分開啟命令提示字元或 PowerShell。
執行下列指令:
msiexec /i "https://github.com/observIQ/bindplane-agent/releases/latest/download/observiq-otel-collector.msi" /quiet
Linux 安裝
- 開啟具有根層級或 sudo 權限的終端機。
執行下列指令:
sudo sh -c "$(curl -fsSlL https://github.com/observiq/bindplane-agent/releases/latest/download/install_unix.sh)" install_unix.sh
其他安裝資源
如需其他安裝選項,請參閱這份安裝指南。
設定 Bindplane 代理,擷取系統記錄檔並傳送至 Google SecOps
存取設定檔:
- 找出
config.yaml檔案。通常位於 Linux 的/observiq-otel-collector/目錄,或 Windows 的安裝目錄。 - 使用文字編輯器 (例如
nano、vi或記事本) 開啟檔案。
- 找出
按照下列方式編輯
config.yaml檔案:receivers: tcplog: # Replace the port and IP address as required listen_address: "0.0.0.0:514" exporters: chronicle/chronicle_w_labels: protocol: https # Region of your instance, for example us, europe, asia-southeast1 location: <LOCATION> # Project number of the Google Cloud project linked to the instance project: '<PROJECT_NUMBER>' compression: gzip # Adjust the path to the credentials file you downloaded in Step 1 creds_file_path: '/path/to/ingestion-authentication-file.json' # Replace with your actual customer ID from Step 2 customer_id: <PLACEHOLDER_CUSTOMER_ID> endpoint: chronicle.googleapis.com # Add optional ingestion labels for better organization log_type: 'NASUNI_FILE_SERVICES' raw_log_field: body ingestion_labels: service: pipelines: logs/source0__chronicle_w_labels-0: receivers: - tcplog exporters: - chronicle/chronicle_w_labels
- 請根據基礎架構需求,替換通訊埠和 IP 位址。
- 將
<LOCATION>替換為 Google SecOps 執行個體的區域 (例如us、europe或asia-southeast1)。匯出工具會在這個值前面加上chronicle.googleapis.com。 - 將
<PROJECT_NUMBER>替換為「IAM 與管理」>「設定」中的專案編號。 - 將
<PLACEHOLDER_CUSTOMER_ID>替換為實際的客戶 ID。 - 將
/path/to/ingestion-authentication-file.json更新為服務帳戶金鑰檔案 (選項 1) 的儲存路徑,該檔案位於「取得 Bindplane 代理程式的 Google SecOps 憑證」一節。
舊版 Ingestion API 匯出工具
如果您使用選項 2 的擷取驗證檔案,請將
exporters區塊替換為下列內容。將creds_file_path設為擷取驗證檔案的路徑,如果您的執行個體位於美國境外,請將malachiteingestion-pa.googleapis.com替換為區域端點 (例如europe-malachiteingestion-pa.googleapis.com)。exporters: chronicle/chronicle_w_labels: compression: gzip # Adjust the path to the credentials file you downloaded in Step 1 creds_file_path: '/path/to/ingestion-authentication-file.json' # Replace with your actual customer ID from Step 2 customer_id: <PLACEHOLDER_CUSTOMER_ID> endpoint: malachiteingestion-pa.googleapis.com # Add optional ingestion labels for better organization log_type: 'NASUNI_FILE_SERVICES' raw_log_field: body ingestion_labels:
重新啟動 Bindplane 代理程式,套用變更
如要在 Linux 中重新啟動 Bindplane 代理程式,請執行下列指令:
執行下列指令:
sudo systemctl restart observiq-otel-collector確認服務正在執行:
sudo systemctl status observiq-otel-collector查看記錄檔是否有錯誤:
sudo journalctl -u observiq-otel-collector -f
如要在 Windows 重新啟動 Bindplane 代理程式,請按照下列步驟操作:
您可以選擇下列其中一個選項:
- 以管理員身分開啟命令提示字元或 PowerShell:
net stop observiq-otel-collector && net start observiq-otel-collector- 服務控制台:
- 按下
Win+R,輸入services.msc,然後按下 Enter 鍵。 - 找出「observIQ OpenTelemetry Collector」。
- 按一下滑鼠右鍵,然後選取「重新啟動」。
- 按下
確認服務是否正在執行:
sc query observiq-otel-collector檢查記錄是否有錯誤:
type "C:\Program Files\observIQ OpenTelemetry Collector\log\collector.log"
設定 Nasuni 系統記錄轉送
在 Nasuni Edge Appliance 上設定 syslog
- 登入 Nasuni Management Console (NMC)。
- 依序前往 「Filers」 > 「Filer Settings」。
- 選取要設定的 Nasuni Edge Appliance。
- 前往「系統記錄」Syslog部分。
- 按一下「Add Syslog Server」。
- 提供下列設定詳細資料:
- 伺服器位址:輸入 Bindplane 代理程式主機的 IP 位址 (例如
192.168.1.100)。 - 通訊埠:輸入
514(或在 Bindplane 中設定的通訊埠)。 - 「通訊協定」:選取「TCP」。
- 格式:選取「Syslog (RFC 5424)」(如有) 或「Syslog (RFC 3164)」。
- 伺服器位址:輸入 Bindplane 代理程式主機的 IP 位址 (例如
在「Log Categories」(記錄類別) 部分,啟用下列記錄類型:
- 稽核記錄:檔案存取、建立、刪除和重新命名作業。
- 驗證記錄:使用者驗證事件。
- 系統記錄:設備健康狀態、同步和管理事件。
- 快照記錄:快照建立和刪除事件。
按一下「儲存」,套用系統記錄設定。
重複上述步驟,新增其他 Edge 設備
- 如果有多個 Nasuni Edge Appliance,請為每個裝置重複執行 Syslog 設定。
- 在 NMC 中,依序前往「Filers」>「All Filers」,即可查看所有受管理裝置的清單。
- 將每個設備設定為將記錄轉送至相同的 Bindplane 代理主機和通訊埠。
驗證系統記錄轉送
在 Bindplane 代理程式主機上,檢查代理記錄,確認系統是否收到記錄:
sudo journalctl -u observiq-otel-collector -f在 NMC 中,依序前往 「Filers」 >「Filer Settings」 >「Syslog」,找到已設定的設備。
確認 Syslog 伺服器狀態顯示為「已連線」或「有效」。
詳情請參閱 Nasuni 的 syslog 設定說明文件。
UDM 對應表
| 記錄欄位 | UDM 對應 | 邏輯 |
|---|---|---|
additional_label |
additional.fields |
已合併 |
is_dir_label |
additional.fields |
已合併 |
offset_label |
additional.fields |
已合併 |
sequence_label |
additional.fields |
已合併 |
uid_label |
additional.fields |
已合併 |
volume_label |
additional.fields |
已合併 |
msg |
metadata.description |
直接對應 |
proto |
metadata.description |
直接對應 |
event_timestamp |
metadata.event_timestamp |
剖析為 ISO8601 |
when |
metadata.event_timestamp |
剖析為 yyyy-MM-dd HH:mm:ss |
event_type |
metadata.event_type |
對應:"AUDIT_READDIR", "AUDIT_READ","Read" → FILE_READ,"AUDIT_WRITE","Write" → `FIL... |
has_principal |
metadata.event_type |
對應:true → FILE_READ、true → FILE_MODIFICATION、true → FILE_UNCATEGORIZED、`... |
event_type |
metadata.product_event_type |
直接對應 |
product_log_id |
metadata.product_log_id |
直接對應 |
host |
principal.asset.hostname |
直接對應 |
ipaddr |
principal.asset.ip |
已合併 |
host |
principal.hostname |
直接對應 |
ipaddr |
principal.ip |
已合併 |
prin_port |
principal.port |
直接對應 |
proc_id |
principal.process.pid |
直接對應 |
username |
principal.user.user_display_name |
直接對應 |
sid |
principal.user.windows_sid |
直接對應 |
action |
security_result.action_details |
直接對應 |
application |
target.application |
直接對應 |
path |
target.file.full_path |
直接對應 |
groupname |
target.group.group_display_name |
直接對應 |
gid |
target.group.product_object_id |
直接對應 |
pid |
target.process.pid |
直接對應 |
tid |
target.resource.product_object_id |
直接對應 |
resource |
target.resource.resource_subtype |
直接對應 |
grp |
target.user.group_identifiers |
已合併 |
| 不適用 | metadata.event_type |
常數:FILE_READ |
| 不適用 | metadata.product_name |
常數:Nasuni File Services Platform |
| 不適用 | metadata.vendor_name |
常數:Nasuni |
action |
event.idm.read_only_udm.section_result.action_details |
從變更記錄對應 |
group_identifiers |
event.idm.read_only_udm.target.user.group_identifiers |
從變更記錄對應 |
event_timestamp |
event.idm.read_only_udm.metadata.event_timestamp |
從變更記錄對應 |
ipaddr |
event.idm.read_only_udm.principal.asset.ip |
從變更記錄對應 |
host |
event.idm.read_only_udm.principal.asset.hostname |
從變更記錄對應 |
newpath |
additional.fields |
從變更記錄對應 |
變更記錄
還有其他問題嗎?向社群成員和 Google SecOps 專家尋求解答。