收集 OpenText Access Manager (舊稱 NetIQ Access Manager) 記錄
本文說明如何使用 Bindplane,將 OpenText Access Manager (舊稱 NetIQ Access Manager) 記錄檔擷取至 Google Security Operations。
OpenText Access Manager 是地端部署身分與存取權管理解決方案,可為網頁應用程式和服務提供單一登入 (SSO)、多重驗證、聯盟和以政策為依據的存取控管。這項服務是使用者與受保護資源之間的安全閘道,可在企業環境中強制執行驗證和授權政策。
事前準備
請確認您已完成下列事前準備事項:
- Google SecOps 執行個體。
- 搭載 Windows 2016 以上版本的主機,或搭載
systemd的 Linux 主機。 - 網路連線:如果透過 Proxy 執行,請確保防火牆通訊埠已根據 Bindplane 代理程式需求開啟。
- OpenText Access Manager 管理控制台的特殊權限存取權。
取得 Bindplane 代理程式的 Google SecOps 憑證
如要向 Google SecOps 驗證 Bindplane 代理程式,請選擇下列其中一種方法:
- 新部署作業:使用 Chronicle API (選項 1)。
- 舊版部署作業:繼續使用擷取驗證檔案 (選項 2),直到 Ingestion API 於 2027 年 7 月 20 日停用。
方法 1:為 Chronicle API 建立服務帳戶 (建議)
- 登入 Google Cloud 控制台,選取連結至 Google SecOps 執行個體的 Google Cloud 專案。
- 依序前往「IAM & Admin」(IAM 與管理) >「Service Accounts」(服務帳戶)。
- 按一下「建立服務帳戶」。
- 請提供下列設定詳細資料:
- 「Service account name」(服務帳戶名稱):輸入帳戶名稱 (例如
bindplane-ingest)。 - 服務帳戶說明:輸入說明 (例如
Bindplane agent log ingestion)。
- 「Service account name」(服務帳戶名稱):輸入帳戶名稱 (例如
- 點按「Create and continue」(建立並繼續)。
- 在「將專案存取權授予這個服務帳戶」部分,按一下「選取角色」,然後選取「Chronicle 編輯者」。
- 依序點選「繼續」和「完成」。
- 按一下您建立的服務帳戶,然後前往「金鑰」分頁標籤。
- 依序點選「新增金鑰」>「建立新的金鑰」。
- 選取「JSON」,然後點選「建立」。金鑰檔案會下載到電腦。
- 將金鑰檔案儲存為 Bindplane 收集器目錄中的
ingestion-auth.json(Linux 上的/opt/observiq-otel-collector/ingestion-auth.json或 Windows 上的C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json),或更新config.yaml中的creds_file_path,使其與儲存路徑相符。 - 依序前往「IAM & Admin」(IAM 與管理) >「Settings」(設定),然後複製「Project number」(專案編號)。匯出工具設定時會用到。
方法 2:下載擷取驗證檔案 (舊版)
- 登入 Google SecOps 控制台。
- 依序前往「SIEM Settings」 > 「Collection Agents」。
- 下載擷取驗證檔案。
- 將檔案安全地儲存在要安裝 Bindplane 代理程式的系統上。
取得 Google SecOps 客戶 ID
- 登入 Google SecOps 控制台。
- 依序前往「SIEM 設定」>「設定檔」。
- 複製並儲存「機構詳細資料」專區中的「客戶 ID」。
安裝 Bindplane 代理程式
請按照下列操作說明,在 Windows 或 Linux 作業系統上安裝 Bindplane 代理程式。
Windows 安裝
- 以管理員身分開啟「命令提示字元」或「PowerShell」。
執行下列指令:
msiexec /i "[https://github.com/observIQ/bindplane-agent/releases/latest/download/observiq-otel-collector.msi](https://github.com/observIQ/bindplane-agent/releases/latest/download/observiq-otel-collector.msi)" /quiet
Linux 安裝
- 開啟具有 root 或 sudo 權限的終端機。
執行下列指令:
sudo sh -c "$(curl -fsSlL [https://github.com/observiq/bindplane-agent/releases/latest/download/install_unix.sh](https://github.com/observiq/bindplane-agent/releases/latest/download/install_unix.sh))" install_unix.sh
其他安裝資源
如需其他安裝選項,請參閱這份安裝指南。
設定 Bindplane 代理程式,擷取系統記錄檔並傳送至 Google SecOps
存取設定檔:
- 找出
config.yaml檔案。通常位於 Linux 的/opt/observiq-otel-collector目錄,或 Windows 的安裝目錄。 - 使用文字編輯器 (例如
nano、vi或記事本) 開啟檔案。
- 找出
按照下列方式編輯
config.yaml檔案:receivers: tcplog: listen_address: "0.0.0.0:514" exporters: chronicle/chronicle_w_labels: protocol: https # Region of your instance, for example us, europe, asia-southeast1 location: <LOCATION> # Project number of the Google Cloud project linked to the instance project: '<PROJECT_NUMBER>' compression: gzip # Adjust the path to the credentials file you downloaded in Step 1 creds_file_path: '/path/to/ingestion-authentication-file.json' # Replace with your actual customer ID from Step 2 customer_id: '<customer_id>' endpoint: chronicle.googleapis.com log_type: NETIQ_ACCESS_MANAGER raw_log_field: body ingestion_labels: service: pipelines: logs/source0__chronicle_w_labels-0: receivers: - tcplog exporters: - chronicle/chronicle_w_labels
- 請根據基礎架構需求,替換通訊埠和 IP 位址。
- 將
<LOCATION>替換為 Google SecOps 執行個體的區域 (例如us、europe或asia-southeast1)。匯出工具會在這個值前面加上chronicle.googleapis.com。 - 將
<PROJECT_NUMBER>替換為「IAM 與管理」>「設定」中的專案編號。 - 將
<customer_id>替換為實際的客戶 ID。 - 將
/path/to/ingestion-authentication-file.json更新為先前步驟中儲存服務帳戶金鑰檔案 (選項 1) 的檔案路徑。
舊版擷取 API 匯出工具
如果您使用選項 2 的擷取驗證檔案,請將
exporters區塊替換為下列內容。將creds_file_path設為擷取驗證檔案的路徑。如果執行個體位於美國境外,請將malachiteingestion-pa.googleapis.com替換為區域端點 (例如europe-malachiteingestion-pa.googleapis.com)。exporters: chronicle/chronicle_w_labels: compression: gzip # Adjust the path to the credentials file you downloaded in Step 1 creds_file_path: '/path/to/ingestion-authentication-file.json' # Replace with your actual customer ID from Step 2 customer_id: '<customer_id>' endpoint: malachiteingestion-pa.googleapis.com log_type: NETIQ_ACCESS_MANAGER raw_log_field: body ingestion_labels:
重新啟動 Bindplane 代理程式,套用變更
如要在 Linux 重新啟動 Bindplane 代理程式,請執行下列指令:
sudo systemctl restart observiq-otel-collector如要在 Windows 重新啟動 Bindplane 代理程式,可以使用「服務」控制台,或輸入下列指令:
net stop observiq-otel-collector && net start observiq-otel-collector
設定 OpenText Access Manager 系統記錄轉送
- 登入 OpenText Access Manager 管理控制台。
- 依序前往「稽核」>「系統記錄」。
- 勾選「Enable Syslog」核取方塊。
- 提供下列設定詳細資料:
- 系統記錄伺服器位址:輸入 Bindplane 代理程式主機的 IP 位址。
- 「Port」(通訊埠):輸入
514。 - Facility:選取適當的 syslog 設施 (例如 LOCAL0)。
- 在「稽核事件」部分,選取要轉送的事件類別:
- 驗證事件
- 授權事件
- 管理事件
- 系統事件
- 按一下「Apply」,儲存 syslog 設定。
UDM 對應表
| 記錄欄位 | UDM 對應 | 邏輯 |
|---|---|---|
version |
about.resource.attribute.labels |
已合併 |
_field |
additional.fields |
已合併 |
I |
extensions.auth.type |
已對應:"002E0505","002E001E","002E0046" → AUTHTYPE_UNSPECIFIED、"002E0007","002E000C"... |
host_name |
intermediary.hostname |
直接對應 |
D |
metadata.description |
直接對應 |
stringValue3 |
metadata.description |
直接對應 |
timestamp |
metadata.event_timestamp |
剖析為 RFC 3339 |
I |
metadata.event_type |
已對應:"002E0505","002E001E","002E0046" → USER_LOGIN、002E0525 → `NETWORK_UNCATEGORIZ... |
has_principal |
metadata.event_type |
對應:true → NETWORK_CONNECTION,true → STATUS_UPDATE |
has_user |
metadata.event_type |
已對應:true → USER_UNCATEGORIZED |
id_sub_event |
metadata.product_event_type |
直接對應 |
I |
metadata.product_log_id |
直接對應 |
eventId |
metadata.product_log_id |
直接對應 |
event_id |
metadata.product_log_id |
直接對應 |
product |
metadata.product_name |
直接對應 |
product_version |
metadata.product_version |
直接對應 |
vendor |
metadata.vendor_name |
直接對應 |
T |
network.http.user_agent |
直接對應 |
L |
network.session_id |
直接對應 |
subTarget |
network.session_id |
直接對應 |
F |
principal.application |
直接對應 |
appName |
principal.application |
直接對應 |
host |
principal.asset.hostname |
直接對應 |
host_name |
principal.asset.hostname |
直接對應 |
originator |
principal.asset.hostname |
直接對應 |
src_ip |
principal.asset.ip |
已合併 |
host |
principal.hostname |
直接對應 |
host_name |
principal.hostname |
直接對應 |
originator |
principal.hostname |
直接對應 |
src_ip |
principal.ip |
已合併 |
stringValue1 |
principal.user.userid |
直接對應 |
I |
security_result.action |
已對應:"002E0505","002E001E","002E0046" → security_action、002E0525 → `security_actio... |
security_action |
security_result.action |
已合併 |
name |
security_result.action_details |
直接對應 |
g_label |
security_result.detection_fields |
已合併 |
h_label |
security_result.detection_fields |
已合併 |
impersonatee_session_id_label |
security_result.detection_fields |
已合併 |
m_label |
security_result.detection_fields |
已合併 |
v_label |
security_result.detection_fields |
已合併 |
priority |
security_result.priority_details |
直接對應 |
A |
security_result.rule_id |
直接對應 |
severity |
security_result.severity_details |
對應值 (共 5 個,例如 1 → TRACE、2 → DEBUG、4 → INFO) |
result |
security_result.summary |
直接對應 |
process_name |
target.application |
直接對應 |
dst_ip |
target.asset.ip |
已合併 |
dst_ip |
target.ip |
已合併 |
B |
target.resource.id |
直接對應 |
O |
target.resource.name |
直接對應 |
Y |
target.url |
直接對應 |
_group_identifier |
target.user.group_identifiers |
已合併 |
U |
target.user.userid |
直接對應 |
device_name |
target.user.userid |
直接對應 |
| 不適用 | extensions.auth.type |
常數:AUTHTYPE_UNSPECIFIED |
| 不適用 | metadata.event_type |
常數:USER_LOGIN |
| 不適用 | metadata.product_name |
常數:Netiq_Access_Manager |
| 不適用 | metadata.vendor_name |
常數:Netiq |
| 不適用 | security_result.severity_details |
常數:TRACE |
"2" |
event.idm.read_only_udm.additional.fields |
從變更記錄對應 |
"3" |
event.idm.read_only_udm.additional.fields |
從變更記錄對應 |
"host_name" |
event.idm.read_only_udm.intermediary.hostname |
從變更記錄對應 |
1 |
event.idm.read_only_udm.additional.fields |
從變更記錄對應 |
stringValue2 |
event.idm.read_only_udm.security_result.detection_fields |
從變更記錄對應 |
eventId |
event.idm.read_only_udm.metadata.product_log_id |
從變更記錄對應 |
subTarget |
event.idm.read_only_udm.network.session_id |
從變更記錄對應 |
stringValue1 |
event.idm.read_only_udm.principal.user.userid |
從變更記錄對應 |
stringValue3 |
event.idm.read_only_udm.metadata.description |
從變更記錄對應 |
originator |
event.idm.read_only_udm.principal.asset.hostname |
從變更記錄對應 |
originator |
event.idm.read_only_udm.principal.hostname |
從變更記錄對應 |
G","H","M" and "V |
security_result.detection_fields |
從變更記錄對應 |
L |
event.idm.read_only_udm.network.session_id |
從變更記錄對應 |
T |
event.idm.read_only_udm.network.http.user_agent |
從變更記錄對應 |
變更記錄
還有其他問題嗎?向社群成員和 Google SecOps 專家尋求解答。