收集 Netscout OCI 日志

支持:

本文档介绍了如何使用 Bindplane 将 NETSCOUT nGeniusONE 日志注入 Google Security Operations。

NETSCOUT nGeniusONE(Observer Infrastructure)是一个网络性能监控和流量分析平台,可提供深度数据包检测、网络流量实时可见性和安全威胁检测。该平台支持通过 syslog 转发安全性事件和提醒,包括用于 SIEM 集成的 CEF 格式。

准备工作

请确保满足以下前提条件:

  • Google SecOps 实例
  • Windows Server 2016 或更高版本,或者具有 systemd 的 Linux 主机
  • Bindplane 代理与 NETSCOUT nGeniusONE 服务器之间的网络连接
  • 如果通过代理运行,请确保防火墙端口根据 Bindplane 代理要求处于打开状态
  • 具有管理员权限的 NETSCOUT nGeniusONE 管理控制台的特权访问权限

获取 Bindplane 代理的 Google SecOps 凭据

如需对 Bindplane 代理进行 Google SecOps 身份验证,请选择以下方法之一:

  • 新部署:使用 Chronicle API(方法 1)。
  • 旧版部署:继续使用注入身份验证文件(方法 2),直到注入 API 于 2027 年 7 月 20 日停用为止。
  1. 登录 Google Cloud Google Cloud 控制台,然后选择与您的 Google SecOps 实例关联的 Google Cloud 项目。
  2. 依次前往 IAM 和管理 > 服务账号。
  3. 点击创建服务账号 。
  4. 提供以下配置详细信息:
    • 服务账号名称:输入账号的名称(例如 bindplane-ingest)。
    • 服务账号说明:输入说明(例如 Bindplane agent log ingestion)。
  5. 点击创建并继续 。
  6. 在向此服务帐号授予对项目的访问权限 部分,点击选择角色 ,然后选择 Chronicle Editor 。
  7. 点击继续 ,然后点击完成 。
  8. 点击您创建的服务帐号,然后前往密钥 标签页。
  9. 依次点击添加密钥 > 创建新密钥。
  10. 选择 JSON ,然后点击创建 。密钥文件会下载到您的计算机上。
  11. 将密钥文件另存为 Bindplane 收集器目录中的 ingestion-auth.json(在 Linux 上为 /opt/observiq-otel-collector/ingestion-auth.json,在 Windows 上为 C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json),或者更新 creds_file_path 在 config.yaml 中以与您保存该文件的路径匹配。
  12. 依次前往 IAM 和管理 > 设置 ,然后复制项目编号 。您需要此编号进行导出器配置。

方法 2:下载注入身份验证文件(旧版)

  1. 登录 Google SecOps 控制台。
  2. 依次前往 SIEM 设置 > 收集代理。
  3. 下载注入身份验证文件 。
  4. 将该文件安全地保存在将安装 Bindplane 代理的系统上。

获取 Google SecOps 客户 ID

  1. 登录 Google SecOps 控制台。
  2. 依次前往 SIEM 设置 > 个人资料。
  3. 从组织详细信息 部分复制并保存客户 ID 。

安装 Bindplane 代理

按照以下说明在 Windows 或 Linux 操作系统上安装 Bindplane 代理。

Windows 安装

  1. 以管理员身份打开命令提示符 或 PowerShell 。
  2. 运行以下命令:

    msiexec /i "https://github.com/observIQ/bindplane-agent/releases/latest/download/observiq-otel-collector.msi" /quiet
    
  3. 等待安装完成。

  4. 运行以下命令,验证安装是否成功:

    sc query observiq-otel-collector
    

该服务应显示为正在运行 。

Linux 安装

  1. 使用 root 或 sudo 权限打开终端。
  2. 运行以下命令:

    sudo sh -c "$(curl -fsSlL https://github.com/observiq/bindplane-agent/releases/latest/download/install_unix.sh)" install_unix.sh
    
  3. 等待安装完成。

  4. 运行以下命令,验证安装是否成功:

    sudo systemctl status observiq-otel-collector
    

该服务应显示为活跃(正在运行) 。

其他安装资源

如需了解其他安装选项和问题排查信息,请参阅 Bindplane 代理安装指南。

配置 Bindplane 代理以注入 syslog 并将其发送到 Google SecOps

找到配置文件

  • Linux:

    sudo nano /opt/observiq-otel-collector/config.yaml
    
  • Windows:

    notepad "C:\Program Files\observIQ OpenTelemetry Collector\config.yaml"
    

修改配置文件

  • 将 config.yaml 的全部内容替换为以下配置:

    receivers:
      udplog:
        listen_address: "0.0.0.0:514"
    
    exporters:
      chronicle/netscout_oci:
        protocol: https
        # Region of your instance, for example us, europe, asia-southeast1
        location: <LOCATION>
        # Project number of the Google Cloud project linked to the instance
        project: '<PROJECT_NUMBER>'
        compression: gzip
        creds_file_path: '/opt/observiq-otel-collector/ingestion-auth.json'
        customer_id: '<customer_id>'
        endpoint: chronicle.googleapis.com
        log_type: NETSCOUT_OCI
        raw_log_field: body
        ingestion_labels:
          env: production
    
    service:
      pipelines:
        logs/netscout_to_chronicle:
          receivers:
            - udplog
          exporters:
            - chronicle/netscout_oci
    

配置参数

替换以下占位符:

  • 接收器配置:

    • udplog:基于协议的接收器类型:
      • UDP syslog 的 udplog
      • TCP syslog 的 tcplog
    • 0.0.0.0:要监听的 IP 地址:
      • 0.0.0.0,用于监听所有接口(推荐)
      • 用于监听一个接口的特定 IP 地址
    • 514:要监听的端口号(例如 514、1514、6514)
  • 导出器配置:

    • netscout_oci:导出器的说明性名称
    • creds_file_path:服务帐号 JSON 密钥文件的完整路径(方法 1):
      • Linux: /opt/observiq-otel-collector/ingestion-auth.json
      • Windows: C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json
    • <customer_id>:上一步中的客户 ID
    • location:将 <LOCATION> 替换为 Google SecOps 实例的区域(例如 us、europe 或 asia-southeast1)。导出器会使用此值为 chronicle.googleapis.com 添加前缀。如需查看完整列表,请参阅区域级端点。
    • project:将 <PROJECT_NUMBER> 替换为 IAM 和管理 > 设置 中的项目编号。
    • endpoint:保持设置为 chronicle.googleapis.com。
    • NETSCOUT_OCI:日志类型,与 Chronicle 中显示的内容完全一致
    • ingestion_labels:YAML 格式的可选标签(例如 env: production)
  • 流水线配置:

    • netscout_to_chronicle:流水线的说明性名称

旧版注入 API 导出器

  • 如果您使用方法 2 中的注入身份验证文件,请将 exporters 代码块替换为以下内容。将 creds_file_path 设置为注入身份验证文件的路径,如果您的实例位于美国境外,请将 malachiteingestion-pa.googleapis.com 替换为您的 区域级端点(例如 europe-malachiteingestion-pa.googleapis.com)。

    exporters:
      chronicle/netscout_oci:
        compression: gzip
        creds_file_path: '/opt/observiq-otel-collector/ingestion-auth.json'
        customer_id: '<customer_id>'
        endpoint: malachiteingestion-pa.googleapis.com
        log_type: NETSCOUT_OCI
        raw_log_field: body
        ingestion_labels:
          env: production
    

保存配置文件

  • 修改后,保存文件:
    • Linux:按 Ctrl+O,然后按 Enter,再按 Ctrl+X
    • Windows:依次点击文件 > 保存

重启 Bindplane 代理以应用更改

如需在 Linux 中重启 Bindplane 代理,请执行以下操作:

  1. 运行以下命令:

    sudo systemctl restart observiq-otel-collector
    
  2. 验证服务是否正在运行:

    sudo systemctl status observiq-otel-collector
    
  3. 检查日志中的错误:

    sudo journalctl -u observiq-otel-collector -f
    

如需在 Windows 中重启 Bindplane 代理,请执行以下操作:

  1. 请从下列选项中选择一项:

    • 以管理员身份运行命令提示符或 PowerShell:
    net stop observiq-otel-collector && net start observiq-otel-collector
    
    • 服务控制台:
      1. 按 Win+R,输入 services.msc,然后按 Enter 键。
      2. 找到 observIQ OpenTelemetry Collector 。
      3. 右键点击,然后选择重启 。
  2. 验证服务是否正在运行:

    sc query observiq-otel-collector
    
  3. 检查日志中的错误:

    type "C:\Program Files\observIQ OpenTelemetry Collector\log\collector.log"
    

配置 NETSCOUT nGeniusONE syslog 转发

  1. 使用管理员权限登录 nGeniusONE 管理控制台。
  2. 依次前往设置 > 全局设置 > 通知设置。
  3. 在 Syslog 部分,配置以下内容:
    • Syslog 服务器地址:输入 Bindplane 代理主机(例如 192.168.1.100)的 IP 地址。
    • Syslog 端口:输入 514(必须与 Bindplane 代理接收器端口匹配)。
    • 协议:选择 UDP (必须与 Bindplane 代理接收器类型匹配)。
  4. 选择要转发的事件类型和严重级别。
  5. 点击保存 以应用配置。
  6. 通过检查 Bindplane 代理日志,验证是否收到了 syslog 消息。

UDM 映射表

日志字段 UDM 映射 逻辑
Policy,Classification additional.fields 其他自定义字段
vuln extensions.vulns.vulnerabilities 漏洞列表
desc metadata.description 事件的说明
event_type metadata.event_type 事件类型
type metadata.product_event_type 特定于产品的事件类型
device_version metadata.product_version 产品版本
dvchost,dvc,shost,src,src_iporhost principal.asset.hostname 与主体关联的资产的主机名
dvchost,dvc,shost,src,src_iporhost principal.asset.ip 与主体关联的资产的 IP 地址
dvchost,dvc,shost,src,src_iporhost principal.hostname 与主体关联的主机名
dvchost,dvc,shost,src,src_iporhost principal.ip 与主体关联的 IP 地址
serverPort principal.port 与主体关联的端口号
event_name,Category security_result.category_details 有关类别的其他详细信息
iocDescription security_result.description 安全结果的说明
OmnisSecurityHostType,HostGroupCount,HostGroup,IOCSeverity,IOCConfidence,OmnisSecurityHostCount,OmnisSecurityInterfaceCount,OmnisSecurityViolationCount,App,UserIdentity,mitreTactic,mitreTechnique,srcCount,dstCount,srcHostGroupCount,dstHostGroupCount,interfaceCount,violationCount,dstHostGroup,srcHostGroup security_result.detection_fields 用于检测的字段
security_rule_name security_result.rule_name 触发事件的规则的名称
severity security_result.severity 安全结果的严重级别
App target.application 与目标关联的应用
target_host target.asset.hostname 与目标关联的资产的主机名
target_ip target.asset.ip 与目标关联的资产的 IP 地址
dhost,dst,target_host target.hostname 与目标关联的主机名
dhost,dst,target_ip target.ip 与目标关联的 IP 地址
remoteGeolocation target.location.name 与目标关联的位置的名称
target_port target.port 与目标关联的端口号
OmnisSecurityUrl target.url 与目标关联的网址
end vuln.scan_end_time 漏洞扫描的结束时间
start vuln.scan_start_time 漏洞扫描的开始时间
metadata.vendor_name 供应商名称
device_product metadata.product_name 产品名称
mitreTactic", "mitreTechnique", "srcCount", "dstCount", "srcHostGroupCount", "dstHostGroupCount", "interfaceCount", "violationCount", "dstHostGroup", and "srcHostGroup security_result.detection_fields 从变更日志映射
Policy" and "Classification additional.fields 从变更日志映射

更新日志

查看此解析器的更新日志

需要更多帮助?获得社区成员和 Google SecOps 专业人士的解答。