收集 Netscout OCI 記錄

支援的國家/地區:

本文說明如何使用 Bindplane,將 NETSCOUT nGeniusONE 記錄檔擷取至 Google Security Operations。

NETSCOUT nGeniusONE (Observer Infrastructure) 是網路效能監控和流量分析平台,可提供深入的封包檢查、網路流量即時可視性,以及安全威脅偵測。這個平台支援透過系統記錄轉送安全事件和警示,包括 SIEM 整合的 CEF 格式。

事前準備

請確認您已完成下列事前準備事項:

  • Google SecOps 執行個體
  • Windows Server 2016 以上版本,或搭載 systemd 的 Linux 主機
  • Bindplane 代理程式與 NETSCOUT nGeniusONE 伺服器之間的網路連線
  • 如果透過 Proxy 執行,請確保防火牆通訊埠已根據 Bindplane 代理程式需求開啟
  • 具備管理員權限的 NETSCOUT nGeniusONE 管理控制台特殊存取權

取得 Google SecOps 擷取驗證檔案

  1. 登入 Google SecOps 控制台。
  2. 依序前往「SIEM 設定」>「收集代理程式」
  3. 下載擷取驗證檔案。將檔案安全地儲存在要安裝 Bindplane 的系統上。

取得 Google SecOps 客戶 ID

  1. 登入 Google SecOps 控制台。
  2. 依序前往「SIEM 設定」>「設定檔」
  3. 複製並儲存「機構詳細資料」部分中的客戶 ID

安裝 Bindplane 代理程式

請按照下列操作說明,在 Windows 或 Linux 作業系統上安裝 Bindplane 代理程式。

Windows 安裝

  1. 以管理員身分開啟「命令提示字元」或「PowerShell」
  2. 執行下列指令:

    msiexec /i "https://github.com/observIQ/bindplane-agent/releases/latest/download/observiq-otel-collector.msi" /quiet
    
  3. 等待安裝完成。

  4. 執行下列指令,確認安裝成功:

    sc query observiq-otel-collector
    

服務應顯示為「RUNNING」

Linux 安裝

  1. 開啟具有根層級或 sudo 權限的終端機。
  2. 執行下列指令:

    sudo sh -c "$(curl -fsSlL https://github.com/observiq/bindplane-agent/releases/latest/download/install_unix.sh)" install_unix.sh
    
  3. 等待安裝完成。

  4. 執行下列指令,確認安裝成功:

    sudo systemctl status observiq-otel-collector
    

服務應顯示為有效 (執行中)

其他安裝資源

如需其他安裝選項和疑難排解資訊,請參閱 Bindplane 代理程式安裝指南

設定 Bindplane 代理程式,擷取系統記錄檔並傳送至 Google SecOps

找出設定檔

  • Linux:

    sudo systemctl status observiq-otel-collector
    
  • Windows:

    notepad "C:\Program Files\observIQ OpenTelemetry Collector\config.yaml"
    

編輯設定檔

  • config.yaml 的所有內容替換為下列設定:

    receivers:
        udplog:
            listen_address: "0.0.0.0:514"
    
    exporters:
        chronicle/netscout_oci:
            compression: gzip
            creds_file_path: '/etc/bindplane-agent/ingestion-auth.json'
            customer_id: '<customer_id>'
            endpoint: malachiteingestion-pa.googleapis.com
            log_type: NETSCOUT_OCI
            raw_log_field: body
            ingestion_labels:
                env: production
    
    service:
        pipelines:
            logs/netscout_to_chronicle:
                receivers:
                    - udplog
                exporters:
                    - chronicle/netscout_oci
    

設定參數

替換下列預留位置:

  • 接收器設定:

    • udplog:根據通訊協定的接收器類型:
      • udplog (適用於 UDP 系統記錄檔)
      • tcplog (適用於 TCP Syslog)
    • 0.0.0.0:要接聽的 IP 位址:
      • 0.0.0.0,監聽所有介面 (建議)
      • 在一個介面上接聽的特定 IP 位址
    • 514:要接聽的通訊埠號碼 (例如 51415146514)
  • 匯出工具設定:

    • netscout_oci:匯出工具的說明名稱
    • creds_file_path:擷取驗證檔案的完整路徑:
      • Linux/etc/bindplane-agent/ingestion-auth.json
      • WindowsC:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json
    • <customer_id>:上一步中的客戶 ID
    • endpoint:區域端點網址:
      • 美國malachiteingestion-pa.googleapis.com
      • 歐洲europe-malachiteingestion-pa.googleapis.com
      • 亞洲asia-southeast1-malachiteingestion-pa.googleapis.com
      • 如需完整清單,請參閱「區域端點
    • NETSCOUT_OCI:記錄類型,與 Chronicle 中顯示的完全相同
    • ingestion_labels:YAML 格式的選用標籤 (例如 env: production)
  • 管道設定:

    • netscout_to_chronicle:管道的說明名稱

儲存設定檔

  • 編輯完成後,請儲存檔案:
    • Linux:依序按下 Ctrl+OEnterCtrl+X
    • Windows:依序點選「檔案」>「儲存」

重新啟動 Bindplane 代理程式,以套用變更

如要在 Linux 中重新啟動 Bindplane 代理程式,請執行下列步驟:

  1. 執行下列指令:

    sudo systemctl restart observiq-otel-collector
    
  2. 確認服務正在執行:

    sudo systemctl status observiq-otel-collector
    
  3. 檢查記錄中是否有錯誤:

    sudo journalctl -u observiq-otel-collector -f
    

如要在 Windows 中重新啟動 Bindplane 代理程式,請按照下列步驟操作:

  1. 您可以選擇下列其中一個選項:

    • 以管理員身分開啟命令提示字元或 PowerShell:
    net stop observiq-otel-collector && net start observiq-otel-collector
    
    • 服務控制台:
      1. 按下 Win+R,輸入 services.msc,然後按下 Enter 鍵。
      2. 找出 observIQ OpenTelemetry Collector
      3. 按一下滑鼠右鍵,然後選取「重新啟動」
  2. 確認服務正在執行:

    sc query observiq-otel-collector
    
  3. 檢查記錄中是否有錯誤:

    type "C:\Program Files\observIQ OpenTelemetry Collector\log\collector.log"
    

設定 NETSCOUT nGeniusONE 系統記錄轉送

  1. 以管理員權限登入 nGeniusONE 管理控制台。
  2. 依序前往「設定」>「全域設定」>「通知設定」
  3. 在「Syslog」Syslog部分,設定下列項目:
    • 系統記錄檔伺服器位址:輸入 Bindplane 代理程式主機的 IP 位址 (例如 192.168.1.100)。
    • 系統記錄檔通訊埠:輸入 514 (必須與 Bindplane 代理程式接收器通訊埠相符)。
    • 「通訊協定」:選取「UDP」 (必須與 Bindplane 代理程式接收器類型相符)。
  4. 選取要轉送的事件類型和嚴重性等級。
  5. 按一下「儲存」,套用設定。
  6. 查看 Bindplane 代理程式記錄,確認是否收到系統記錄訊息。

UDM 對應表

記錄欄位 UDM 對應 邏輯
Policy,Classification additional.fields 其他自訂欄位
vuln extensions.vulns.vulnerabilities 安全漏洞清單
遞減 metadata.description 事件說明
event_type metadata.event_type 活動類型
類型 metadata.product_event_type 產品專屬事件類型
device_version metadata.product_version 產品版本
dvchost、dvc、shost、src、src_iporhost principal.asset.hostname 與主體相關聯的資產主機名稱
dvchost、dvc、shost、src、src_iporhost principal.asset.ip 與主體相關聯的資產 IP 位址
dvchost、dvc、shost、src、src_iporhost principal.hostname 與主體相關聯的主機名稱
dvchost、dvc、shost、src、src_iporhost principal.ip 與主體相關聯的 IP 位址
serverPort principal.port 與主體相關聯的通訊埠編號
event_name、Category security_result.category_details 類別的其他詳細資料
iocDescription security_result.description 安全性結果說明
OmnisSecurityHostType、HostGroupCount、HostGroup、IOCSeverity、IOCConfidence、OmnisSecurityHostCount、OmnisSecurityInterfaceCount、OmnisSecurityViolationCount、App、UserIdentity、mitreTactic、mitreTechnique、srcCount、dstCount、srcHostGroupCount、dstHostGroupCount、interfaceCount、violationCount、dstHostGroup、srcHostGroup security_result.detection_fields 用於偵測的欄位
security_rule_name security_result.rule_name 觸發事件的規則名稱
嚴重性 security_result.severity 安全結果的嚴重性等級
應用程式 target.application 與目標相關聯的應用程式
target_host target.asset.hostname 與目標相關聯的資產主機名稱
target_ip target.asset.ip 與目標相關聯的資產 IP 位址
dhost、dst、target_host target.hostname 與目標相關聯的主機名稱
dhost、dst、target_ip target.ip 與目標相關聯的 IP 位址
remoteGeolocation target.location.name 與目標相關聯的位置名稱
target_port target.port 與目標相關聯的通訊埠編號
OmnisSecurityUrl target.url 與目標相關聯的網址
結束 vuln.scan_end_time 安全漏洞掃描的結束時間
開始 vuln.scan_start_time 安全漏洞掃描的開始時間
metadata.vendor_name 供應商名稱
device_product metadata.product_name 產品名稱
mitreTactic", "mitreTechnique", "srcCount", "dstCount", "srcHostGroupCount", "dstHostGroupCount", "interfaceCount", "violationCount", "dstHostGroup", and "srcHostGroup security_result.detection_fields 從變更記錄對應
Policy" and "Classification additional.fields 從變更記錄對應

變更記錄

查看這個剖析器的變更記錄

還有其他問題嗎?向社群成員和 Google SecOps 專業人員尋求答案。