收集 Nokia 路由器記錄

支援的服務:

本文說明如何使用 Bindplane 代理程式,將 Nokia 路由器記錄擷取至 Google Security Operations。

Nokia Service Router 是一種網路路由器,可針對 BGP 事件、介面狀態變更、MKA 工作階段、LLDP 鄰近探索、IS-IS 路由和安全篩選器比對,產生系統記錄訊息。剖析器會使用 Grok 模式從 Syslog 格式的記錄檔中擷取欄位,並將這些欄位對應至統合式資料模型 (UDM)。

事前準備

請確認您符合下列必要條件:

  • Google SecOps 執行個體
  • Windows Server 2016 以上版本,或搭載 systemd 的 Linux 主機
  • Bindplane 代理程式與 Nokia 服務路由器之間的網路連線
  • 如果是在 Proxy 後方執行,請確認防火牆通訊埠已按照 Bindplane 代理程式規定開啟
  • Nokia 路由器的特殊存取權

取得 Bindplane 代理程式的 Google SecOps 憑證

如要向 Google SecOps 驗證 Bindplane 代理程式,請選擇下列其中一種方法:

  • 新部署作業:使用 Chronicle API (選項 1)。
  • 舊版部署作業:繼續使用擷取驗證檔案 (選項 2),直到 Ingestion API 於 2027 年 7 月 20 日停用。
  1. 登入 Google Cloud 控制台,然後選取連結至 Google SecOps 執行個體的 Google Cloud 專案。
  2. 依序前往「IAM & Admin」(IAM 與管理) >「Service Accounts」(服務帳戶)。
  3. 按一下「建立服務帳戶」。
  4. 請提供下列設定詳細資料:
    • 「Service account name」(服務帳戶名稱):輸入帳戶名稱 (例如 bindplane-ingest)。
    • 「服務帳戶說明」:輸入說明 (例如 Bindplane agent log ingestion)。
  5. 點按「Create and continue」(建立並繼續)。
  6. 在「將專案存取權授予這個服務帳戶」部分,按一下「選取角色」,然後選取「Chronicle 編輯者」。
  7. 依序點選「繼續」和「完成」。
  8. 按一下您建立的服務帳戶,然後前往「金鑰」分頁。
  9. 依序點選「新增金鑰」>「建立新的金鑰」。
  10. 選取「JSON」,然後點選「建立」。金鑰檔案會下載到電腦。
  11. 將金鑰檔案儲存為 Bindplane 收集器目錄中的 ingestion-auth.json (Linux 為 /opt/observiq-otel-collector/ingestion-auth.json,Windows 為 C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json),或更新 config.yaml 中的 creds_file_path,使其與儲存檔案的路徑相符。
  12. 依序前往「IAM 與管理」>「設定」,然後複製「專案編號」。設定匯出工具時會用到。

方法 2:下載擷取驗證檔案 (舊版)

  1. 登入 Google SecOps 控制台。
  2. 依序前往「SIEM Settings」 > 「Collection Agents」。
  3. 下載擷取驗證檔案。
  4. 將檔案安全地儲存在要安裝 Bindplane 代理程式的系統上。

取得 Google SecOps 客戶 ID

  1. 登入 Google SecOps 控制台。
  2. 依序前往「SIEM 設定」>「設定檔」。
  3. 複製並儲存「機構詳細資料」部分的客戶 ID。

安裝 Bindplane 代理程式

請按照下列操作說明,在 Windows 或 Linux 作業系統上安裝 Bindplane 代理程式。

Windows 安裝

  1. 以管理員身分開啟命令提示字元或 PowerShell。
  2. 執行下列指令:

    msiexec /i "https://github.com/observIQ/bindplane-agent/releases/latest/download/observiq-otel-collector.msi" /quiet
    
  3. 等待安裝完成。

  4. 執行下列指令,確認安裝成功:

    sc query observiq-otel-collector
    

    服務應顯示為「RUNNING」。

Linux 安裝

  1. 開啟具有 root 或 sudo 權限的終端機。
  2. 執行下列指令:

    sudo sh -c "$(curl -fsSlL https://github.com/observiq/bindplane-agent/releases/latest/download/install_unix.sh)" install_unix.sh
    
  3. 等待安裝完成。

  4. 執行下列指令,確認安裝成功:

    sudo systemctl status observiq-otel-collector
    

    服務應顯示為「active (running)」。

其他安裝資源

如需其他安裝選項和疑難排解資訊,請參閱 Bindplane 代理程式安裝指南。

設定 Bindplane 代理,擷取系統記錄檔並傳送至 Google SecOps

找出設定檔

  • Linux:

    sudo nano /opt/observiq-otel-collector/config.yaml
    
  • Windows:

    notepad "C:\Program Files\observIQ OpenTelemetry Collector\config.yaml"
    

編輯設定檔

  • 將 config.yaml 的全部內容替換為下列設定:

    receivers:
      udplog:
        listen_address: "0.0.0.0:514"
    
    exporters:
      chronicle/nokia_router:
        protocol: https
        # Region of your instance, for example us, europe, asia-southeast1
        location: <LOCATION>
        # Project number of the Google Cloud project linked to the instance
        project: '<PROJECT_NUMBER>'
        compression: gzip
        creds_file_path: '/opt/observiq-otel-collector/ingestion-auth.json'
        customer_id: '<customer_id>'
        endpoint: chronicle.googleapis.com
        log_type: NOKIA_ROUTER
        raw_log_field: body
    
    service:
      pipelines:
        logs/nokia_router_to_chronicle:
          receivers:
            - udplog
          exporters:
            - chronicle/nokia_router
    

設定參數

替換下列預留位置:

  • 接收器設定:

    • listen_address:要接聽的 IP 位址和通訊埠:
      • 0.0.0.0:在所有介面上監聽 (建議)
      • 通訊埠 514 是標準 syslog 通訊埠 (在 Linux 上需要根目錄;非根目錄請使用 1514)
  • 匯出工具設定:

    • creds_file_path:服務帳戶 JSON 金鑰檔案的完整路徑 (選項 1):
      • Linux:/opt/observiq-otel-collector/ingestion-auth.json
      • Windows:C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json
    • customer_id:從 Google SecOps 控制台複製的客戶 ID
    • location:將 <LOCATION> 替換為 Google SecOps 執行個體的區域 (例如 us、europe 或 asia-southeast1)。匯出工具會在這個值前面加上 chronicle.googleapis.com。如需完整清單,請參閱「區域性端點」。
    • project:將 <PROJECT_NUMBER> 替換為「IAM 與管理」>「設定」中的專案編號。
    • endpoint:維持設為 chronicle.googleapis.com。

舊版 Ingestion API 匯出工具

  • 如果您使用選項 2 的擷取驗證檔案,請將 exporters 區塊替換為下列內容。將 creds_file_path 設為擷取驗證檔案的路徑。如果執行個體位於美國境外,請將 malachiteingestion-pa.googleapis.com 替換為區域端點 (例如 europe-malachiteingestion-pa.googleapis.com)。

    exporters:
      chronicle/nokia_router:
        compression: gzip
        creds_file_path: '/opt/observiq-otel-collector/ingestion-auth.json'
        customer_id: '<customer_id>'
        endpoint: malachiteingestion-pa.googleapis.com
        log_type: NOKIA_ROUTER
        raw_log_field: body
    

儲存設定檔

  • 編輯完畢後,請儲存檔案:
    • Linux:依序按下 Ctrl+O、Enter 和 Ctrl+X
    • Windows:依序點選「檔案」>「儲存」

重新啟動 Bindplane 代理程式,套用變更

  • 如要在 Linux 重新啟動 Bindplane 代理程式,請執行下列指令:

    sudo systemctl restart observiq-otel-collector
    
    1. 確認服務正在執行:

      sudo systemctl status observiq-otel-collector
      
    2. 檢查記錄是否有錯誤:

      sudo journalctl -u observiq-otel-collector -f
      
  • 如要在 Windows 中重新啟動 Bindplane 代理程式,請選擇下列其中一個選項:

    • 以管理員身分開啟命令提示字元或 PowerShell:

      net stop observiq-otel-collector && net start observiq-otel-collector
      
    • 服務控制台:

      1. 按下 Win+R 鍵,輸入 services.msc,然後按下 Enter 鍵。
      2. 找出「observIQ OpenTelemetry Collector」。
      3. 按一下滑鼠右鍵,然後選取「重新啟動」。
      4. 確認服務是否正在執行:

        sc query observiq-otel-collector
        
      5. 查看記錄檔是否有錯誤:

        type "C:\Program Files\observIQ OpenTelemetry Collector\log\collector.log"
        

在 Nokia Service Router 上設定系統記錄

  1. 進入設定模式:

    config# log
    
  2. 定義系統記錄目的地:

    config>log# syslog 1
    
  3. 設定 syslog 參數:

    config>log>syslog# address <syslog-server-ip>
    config>log>syslog# port <port-number>
    config>log>syslog# facility local0
    config>log>syslog# level info
    config>log>syslog# log-prefix "Nokia-SR"
    config>log>syslog# description "Syslog to Bindplane"
    
    • 將 <syslog-server-ip> 替換為 Bindplane 代理程式 IP 位址,並將 <port-number> 替換為適當的連接埠 (例如 UDP 的 514)。
  4. 將 syslog 目的地套用至記錄檔:

    config>log# log-id 1
    config>log>log-id# to syslog 1
    
  5. 啟用記錄檔:

    config>log>log-id# no shutdown
    
  6. 儲存設定:

    config>log>log-id# exit
    config>log# save
    

UDM 對應表

記錄欄位 UDM 對應 邏輯
%{SYSLOGTIMESTAMP:date_time} metadata.event_timestamp 從原始記錄擷取並轉換為時間戳記。
%{IP:src_ip} principal.ip 從原始記錄中擷取。
%{HOSTNAME:host_name} principal.hostname 從原始記錄中擷取。
%{INT:sequence_id} metadata.product_log_id 從原始記錄中擷取。
%{DATA:router_name} metadata.product_name 從原始記錄中擷取。
%{DATA:application} target.application 從原始記錄中擷取。
%{WORD:severity} security_result.severity 根據下列邏輯,從原始記錄嚴重性對應:
- CLEARED、INFO -> INFORMATIONAL
- MINOR -> ERROR
- WARNING -> LOW
- MAJOR -> HIGH
- CRITICAL -> CRITICAL
%{DATA:event_name} metadata.product_event_type 從原始記錄中擷取。
%{INT:event_id} additional.fields.value.string_value 從原始記錄檔擷取,並放置在 additional fields 中,索引鍵為 Event Id。
%{GREEDYDATA:message1} 用於根據 event_name 擷取各種欄位。請參閱下方的特定欄位邏輯。
Group %{NOTSPACE:group_id} target.group.product_object_id 如果 event_name 與 BGP 事件相關,則會從 message1 中擷取。
%{WORD} %{IP:dest_ip} target.ip 如果 event_name 與 BGP 事件相關,則會從 message1 中擷取。
%{GREEDYDATA:desc} security_result.description 從 message1 擷取,適用於各種 event_name 情境。
SAP %{DATA:sap_id} additional.fields.value.string_value 從 message1 擷取,當 event_name 為 sapStatusChanged 時,會放置在 additional fields 中,並使用 SAP Id 鍵。
in service %{INT:service_id} additional.fields.value.string_value 當 event_name 為 sapStatusChanged 時,從 message1 擷取並放入 additional fields,鍵為 Service Id。
\\(customer %{INT:customer_id}\\) additional.fields.value.string_value 當 event_name 為 sapStatusChanged 時,從 message1 擷取並放入 additional fields,鍵為 Customer Id。
admin=%{WORD:admin_status} additional.fields.value.string_value 當 event_name 為 sapStatusChanged 時,從 message1 擷取並放入 additional fields,鍵為 Admin Status。
oper=%{WORD:operation_status} additional.fields.value.string_value 當 event_name 為 sapStatusChanged 時,從 message1 擷取並放入 additional fields,鍵為 Operation Status。
flags=%{WORD:flag} additional.fields.value.string_value 當 event_name 為 sapStatusChanged 時,從 message1 擷取並放入 additional fields,鍵為 Flag。
with MI:SCI %{DATA:mi_sci} additional.fields.value.string_value 當 event_name 為 tmnxMkaSessionEstablished 時,從 message1 擷取並放入 additional fields,鍵為 MI:SCI。
on port %{DATA:port_id} additional.fields.value.string_value 當 event_name 為 tmnxMkaSessionEstablished 時,從 message1 擷取並放入 additional fields,鍵為 Port Id。
sub-port %{INT:sub_port_id} additional.fields.value.string_value 當 event_name 為 tmnxMkaSessionEstablished 時,從 message1 擷取並放入 additional fields,鍵為 Sub-port Id。
CA %{INT:ca} additional.fields.value.string_value 從 message1 擷取,當 event_name 為 tmnxMkaSessionEstablished 時,會放置在 additional fields 中,並使用 CA 鍵。
EAPOL-destination %{MAC:dest_mac} target.mac 當 event_name 為 tmnxMkaSessionEstablished 時,系統會從 message1 擷取這項資訊。
local port-id %{DATA:local_port_id} target.resource.attribute.labels.value 從 message1 擷取特定 event_name 值,並使用鍵 local_port_id 放入 target.resource.attribute.labels。
dest-mac-type %{NOTSPACE:mac_type} target.resource.attribute.labels.value 從 message1 擷取特定 event_name 值,並使用鍵 mac_type 放入 target.resource.attribute.labels。
remote system name %{HOSTNAME:dest_host} target.hostname 從特定 event_name 值的 message1 中擷取。
remote chassis-id %{DATA:dest_mac} target.mac 從 message1 擷取特定 event_name 值。
remote port-id %{DATA:port_id} target.resource.attribute.labels.value 從 message1 擷取特定 event_name 值,並使用鍵 port_id 放入 target.resource.attribute.labels。
remote-index %{INT:remote_index} target.resource.attribute.labels.value 從特定 event_name 值的 message1 擷取,並放置在 target.resource.attribute.labels 中,鍵為 remote_index。
remote management address %{IP:dest_ip} target.ip 從特定 event_name 值的 message1 中擷取。
advRtr:%{HOSTNAME:dest_host}%{GREEDYDATA}, ip@:%{IP:dest_ip}/%{INT:dest_port} target.hostname、target.ip、target.port 從 message1 擷取特定 event_name 值。
SID:%{INT:sid} network.session_id 從特定 event_name 值的 message1 中擷取。
level:%{DATA:level} target.resource.attribute.labels.value 從特定 event_name 值的 message1 擷取,並放置在 target.resource.attribute.labels 中,鍵為 level。
mtid:%{INT:mtid} target.resource.attribute.labels.value 從 message1 擷取特定 event_name 值,並使用鍵 mtid 放入 target.resource.attribute.labels。
type:%{WORD:type} target.resource.attribute.labels.value 從特定 event_name 值的 message1 擷取,並放置在 target.resource.attribute.labels 中,鍵為 type。
flags:%{WORD:flag} target.resource.attribute.labels.value 從特定 event_name 值的 message1 擷取,並放置在 target.resource.attribute.labels 中,鍵為 flag。
, algo:%{INT:algo} target.resource.attribute.labels.value 從特定 event_name 值的 message1 擷取,並放置在 target.resource.attribute.labels 中,鍵為 algo。
Description:%{GREEDYDATA:desc}. security_result.description 當 event_name 為 mafEntryMatch 時,系統會從 message1 擷取這項資訊。
SrcIP principal.ip 當 event_name 為 mafEntryMatch 時,從 kv_data 欄位擷取。
SrcIP: %{INT:src_port} principal.port 當 event_name 為 mafEntryMatch 時,從「kv_data」欄位擷取。
DstIP target.ip 當 event_name 為 mafEntryMatch 時,從「kv_data」欄位擷取。
DstIP: %{INT:dest_port} target.port 當 event_name 為 mafEntryMatch 時,從「kv_data」欄位擷取。
Protocol network.ip_protocol 當 event_name 為 mafEntryMatch 時,從「kv_data」欄位擷取。
不適用 metadata.vendor_name 設為 NOKIA_ROUTER。
不適用 metadata.event_type 根據擷取欄位的存在和組合決定:
- src_ip、dest_ip 和 network 存在 -> NETWORK_CONNECTION
- principal 存在 -> STATUS_UPDATE
- 否則 -> GENERIC_EVENT
%{GREEDYDATA:description} metadata.description 當 event_name 為 tmnxMkaSessionEstablished 時,從 message1 擷取。
src_ip event.idm.read_only_udm.intermediary.ip 從變更記錄對應
src_ip event.idm.read_only_udm.intermediary.asset.ip 從變更記錄對應

變更記錄

查看這個剖析器的變更記錄

還有其他問題嗎?向社群成員和 Google SecOps 專業人員尋求解答。