收集 One Identity Identity Manager 記錄

支援的服務:

本文說明如何使用 Bindplane,將 One Identity Identity Manager 記錄檔擷取至 Google Security Operations。

One Identity Identity Manager 是身分識別管理與管理 (IGA) 平台,用於管理混合環境中的使用者身分、存取權和法規遵循。這項服務提供自動佈建、存取要求、認證和政策執行功能,並內建通用 SIEM 轉送器,可匯出事件。

事前準備

請確認您已完成下列事前準備事項:

  • Google SecOps 執行個體
  • Windows Server 2016 以上版本,或搭載 systemd 的 Linux 主機
  • Bindplane 代理程式與 One Identity Identity Manager 伺服器之間的網路連線
  • 如果是在 Proxy 後方執行,請確認防火牆通訊埠已按照 Bindplane 代理程式規定開啟
  • 具備管理員權限,可存取 One Identity Identity Manager 管理控制台
  • 已安裝 Universal SIEM Forwarder 模組的 One Identity Identity Manager 8.x 以上版本

取得 Bindplane 代理程式的 Google SecOps 憑證

如要向 Google SecOps 驗證 Bindplane 代理程式,請選擇下列其中一種方法:

  • 新部署作業:使用 Chronicle API (選項 1)。
  • 舊版部署作業:在 2027 年 7 月 20 日停用 Ingestion API 前,請繼續使用擷取驗證檔案 (選項 2)。
  1. 登入 Google Cloud 控制台,選取連結至 Google SecOps 執行個體的 Google Cloud 專案。
  2. 依序前往「IAM & Admin」(IAM 與管理) >「Service Accounts」(服務帳戶)。
  3. 按一下「建立服務帳戶」。
  4. 請提供下列設定詳細資料:
    • 「Service account name」(服務帳戶名稱):輸入帳戶名稱 (例如 bindplane-ingest)。
    • 服務帳戶說明:輸入說明 (例如 Bindplane agent log ingestion)。
  5. 點按「Create and continue」(建立並繼續)。
  6. 在「將專案存取權授予這個服務帳戶」部分,按一下「選取角色」,然後選取「Chronicle 編輯者」。
  7. 依序點選「繼續」和「完成」。
  8. 按一下您建立的服務帳戶,然後前往「金鑰」分頁標籤。
  9. 依序點選「新增金鑰」>「建立新的金鑰」。
  10. 選取「JSON」,然後點選「建立」。金鑰檔案會下載到電腦。
  11. 將金鑰檔案儲存為 Bindplane 收集器目錄中的 ingestion-auth.json (Linux 上的 /opt/observiq-otel-collector/ingestion-auth.json 或 Windows 上的 C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json),或更新 config.yaml 中的 creds_file_path,使其與儲存路徑相符。
  12. 依序前往「IAM 與管理」>「設定」,然後複製「專案編號」。設定匯出工具時會用到。

方法 2:下載擷取驗證檔案 (舊版)

  1. 登入 Google SecOps 控制台。
  2. 依序前往「SIEM 設定」>「收集代理程式」。
  3. 下載擷取驗證檔案。
  4. 將檔案安全地儲存在要安裝 Bindplane 代理程式的系統中。

取得 Google SecOps 客戶 ID

  1. 登入 Google SecOps 控制台。
  2. 依序前往「SIEM 設定」 > 「設定檔」。
  3. 複製並儲存「機構詳細資料」專區中的「客戶 ID」。

安裝 Bindplane 代理程式

請按照下列操作說明,在 Windows 或 Linux 作業系統上安裝 Bindplane 代理程式。

Windows 安裝

  1. 以管理員身分開啟命令提示字元或 PowerShell。
  2. 執行下列指令:

    msiexec /i "https://github.com/observIQ/bindplane-agent/releases/latest/download/observiq-otel-collector.msi" /quiet
    
  3. 等待安裝完成。

  4. 執行下列指令,確認安裝成功:

    sc query observiq-otel-collector
    

服務應顯示為「RUNNING」。

Linux 安裝

  1. 開啟具有 root 或 sudo 權限的終端機。
  2. 執行下列指令:

    sudo sh -c "$(curl -fsSlL https://github.com/observiq/bindplane-agent/releases/latest/download/install_unix.sh)" install_unix.sh
    
  3. 等待安裝完成。

  4. 執行下列指令,確認安裝成功:

    sudo systemctl status observiq-otel-collector
    

服務應顯示為「active (running)」。

其他安裝資源

如需其他安裝選項和疑難排解資訊,請參閱 Bindplane 代理程式安裝指南。

設定 Bindplane 代理程式,擷取系統記錄並傳送至 Google SecOps

找出設定檔

  • Linux:

    sudo nano /opt/observiq-otel-collector/config.yaml
    
  • Windows:

    notepad "C:\Program Files\observIQ OpenTelemetry Collector\config.yaml"
    

編輯設定檔

  • 將 config.yaml 的全部內容替換為下列設定:

    receivers:
      tcplog:
        listen_address: "0.0.0.0:514"
    
    exporters:
      chronicle/one_identity_idm:
        protocol: https
        # Region of your instance, for example us, europe, asia-southeast1
        location: <LOCATION>
        # Project number of the Google Cloud project linked to the instance
        project: '<PROJECT_NUMBER>'
        compression: gzip
        creds_file_path: '<CREDS_FILE_PATH>'
        customer_id: '<CUSTOMER_ID>'
        endpoint: chronicle.googleapis.com
        log_type: ONE_IDENTITY_IDENTITY_MANAGER
        raw_log_field: body
        ingestion_labels:
          env: production
    
    service:
      pipelines:
        logs/one_identity_idm_to_chronicle:
          receivers:
            - tcplog
          exporters:
            - chronicle/one_identity_idm
    

設定參數

請替換下列預留位置:

  • 接收器設定:

    • tcplog:透過 TCP 接收系統記錄。通用 SIEM 轉送器支援 TCP,可確保傳送可靠性。
    • 0.0.0.0:514:在通訊埠 514 上監聽所有介面。視需要變更通訊埠 (例如非根 Linux 的 1514)。
  • Exporter 設定:

    • <CREDS_FILE_PATH>:服務帳戶 JSON 金鑰檔案的完整路徑 (選項 1):
      • Linux:/opt/observiq-otel-collector/ingestion-auth.json
      • Windows:C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json
    • <CUSTOMER_ID>:在「取得 Google SecOps 客戶 ID」步驟中取得的客戶 ID。
    • location:將 <LOCATION> 替換為 Google SecOps 執行個體的區域 (例如 us、europe 或 asia-southeast1)。匯出工具會以這個值做為 chronicle.googleapis.com 的前置字元。如需完整清單,請參閱「區域性端點」。
    • project:依序前往「IAM 與管理」>「設定」,然後將 <PROJECT_NUMBER> 替換為專案編號。
    • endpoint:請將此值設為 chronicle.googleapis.com。

舊版 Ingestion API 匯出工具

  • 如果您使用方式 2 的擷取驗證檔案,請將 exporters 區塊替換成下列內容。將 creds_file_path 設為擷取驗證檔案的路徑,如果您的執行個體位於美國境外,請將 malachiteingestion-pa.googleapis.com 替換為區域端點 (例如 europe-malachiteingestion-pa.googleapis.com)。

    exporters:
      chronicle/one_identity_idm:
        compression: gzip
        creds_file_path: '<CREDS_FILE_PATH>'
        customer_id: '<CUSTOMER_ID>'
        endpoint: malachiteingestion-pa.googleapis.com
        log_type: ONE_IDENTITY_IDENTITY_MANAGER
        raw_log_field: body
        ingestion_labels:
          env: production
    

儲存設定檔

  • 編輯完畢後,請儲存檔案:
    • Linux:依序按下 Ctrl+O、Enter 和 Ctrl+X
    • Windows:依序點選「檔案」 > 「儲存」

重新啟動 Bindplane 代理程式,套用變更

如要在 Linux 中重新啟動 Bindplane 代理程式,請按照下列步驟操作:

  1. 執行下列指令:

    sudo systemctl restart observiq-otel-collector
    
  2. 確認服務是否正在執行:

    sudo systemctl status observiq-otel-collector
    
  3. 檢查記錄是否有錯誤:

    sudo journalctl -u observiq-otel-collector -f
    

如要在 Windows 重新啟動 Bindplane 代理程式,請按照下列步驟操作:

  1. 您可以選擇下列其中一個選項:

    • 以管理員身分開啟命令提示字元或 PowerShell:
    net stop observiq-otel-collector && net start observiq-otel-collector
    
    • 服務控制台:
      1. 按下 Win+R 鍵,輸入 services.msc,然後按下 Enter 鍵。
      2. 找出「observIQ OpenTelemetry Collector」。
      3. 按一下滑鼠右鍵,然後選取「重新啟動」。
  2. 確認服務正在執行:

    sc query observiq-otel-collector
    
  3. 查看記錄檔是否有錯誤:

    type "C:\Program Files\observIQ OpenTelemetry Collector\log\collector.log"
    

設定 One Identity Identity Manager 系統記錄轉送

One Identity Identity Manager 包含通用 SIEM 轉送器,可透過 syslog 以 JSON、CEF 或 JSON-CIM 格式匯出稽核和身分生命週期事件。

  1. 登入 One Identity Manager 管理控制台 (管理員或設計工具)。
  2. 依序前往「基礎資料」>「一般」>「設定參數」。
  3. 找到 QER\Person\Siem 設定部分。
  4. 將「Enabled」(已啟用) 參數設為 True,即可啟用通用 SIEM 轉送器。
  5. 設定系統記錄目的地:
    • SyslogHost:輸入 Bindplane 代理程式主機的 IP 位址 (例如 192.168.1.100)。
    • SyslogPort:輸入 514 (必須與 Bindplane 代理程式接收器通訊埠相符)。
    • SyslogProtocol:選取「TCP」。
    • SyslogFormat:選取「JSON」 (建議,可確保剖析結果最準確)。
  6. 設定要轉送的事件類型:
    • PersonEvents:設為 True 可轉送身分生命週期事件 (建立、修改、刪除)。
    • EntitlementEvents:設為 True,即可轉送存取權指派和移除事件。
    • PolicyEvents:設為 True,即可轉送違反政策和認證事件。
    • SystemEvents:設為 True,即可轉送佈建和同步處理事件。
  7. 按一下「儲存」,儲存設定。
  8. 重新啟動 One Identity Manager 服務,讓變更生效。
  9. 檢查 Bindplane 代理程式記錄,確認系統是否正在傳送記錄。

UDM 對應表

記錄欄位 UDM 對應 邏輯
ImportCompleted、MembersCount、SchedulerTriggerId、JobThreadCount、JobMessage、JobExitCode、TriggerVetoed、TriggerMisfired、JobException、ErrorCount、IdentityProviderName、AuditLogUri、ApplianceId、AssetName、AssetPartitionName、TaskId、SystemId、SystemName、AssetPartitionId、DurationInMinutes、OfflineWorkflowMode、RequiredDate、WasCheckedOut、ApproverAccessRequestUri、ReviewerAccessRequestUri、_DB_HOST、Enabled、UID_ConfigParm、XOrigin、Ident_AERole、UID_Person additional.fields 從各個欄位合併為鍵/值組合
RequesterAccessRequestUri extensions.auth.auth_details 直接複製值
user_login、user_logout extensions.auth.type 如果 user_login 或 user_logout 為 true,請設為 AUTHTYPE_UNSPECIFIED
主機名稱 intermediary.hostname 設定主機名稱 (如果不是 IP)
主機名稱 intermediary.ip 如果主機名稱是 IP,請設定
時間 metadata.collected_timestamp 從 ISO8601 時間戳記轉換
EventDescription metadata.description 直接複製值
EventTimestamp、MessageDate、XDateUpdated、XDateInserted metadata.event_timestamp 從 UNIX_MS 轉換,優先順序為 XDateInserted > XDateUpdated > MessageDate > EventTimestamp
has_principal、has_target_resource、has_user、user_login、user_logout、has_target_user metadata.event_type 如果具有 principal、target_resource、user 和 user_login,則設為 USER_LOGIN;如果具有 principal、target_resource、user 和 user_logout,則設為 USER_LOGOUT;如果具有 target_user 或 user,則設為 USER_UNCATEGORIZED;如果具有 principal,則設為 STATUS_UPDATE;否則設為 GENERIC_EVENT
EventDisplayName, XUserInserted, UID_ConfigParm, XDateInserted, XOrigin metadata.product_event_type EventDisplayName 的值,如果 XUserInserted 和 UID_ConfigParm 不為空白,則會覆寫為「設定已變更」;如果 XDateInserted 和 XOrigin 不為空白,則會覆寫為「使用者已加入群組」
IdentityProviderId metadata.product_log_id 直接複製值
版本 metadata.product_version 直接複製值
EventUserDomainName principal.administrative_domain 直接複製值
app_name、ApplicationName principal.application ApplicationName 的值 (如果不是空白),否則為 app_name
HostName principal.asset.hostname 直接複製值
AuthClientMachine principal.asset.ip 從 AuthClientMachine 擷取的 IP
AssetId principal.asset_id 串連為「AssetId:%{AssetId}」
HostName principal.hostname 直接複製值
AuthClientMachine principal.ip 從 AuthClientMachine 擷取的 IP
process_id principal.process.pid 直接複製值
AccountDistinguishedName principal.user.attribute.roles 設為名稱為 AccountDistinguishedName 的物件
電子郵件 principal.user.email_addresses 如果符合 ^.+@.+$,則會合併
RequestId, UserGroupName principal.user.product_object_id UserGroupName 的值 (如果不是空白),否則為 RequestId
EventUserDisplayName principal.user.user_display_name 直接複製值
EventUserName、UserGroupId、User、XUserInserted、Assignor principal.user.userid 如果 Assignor 不為空值,則為 Assignor 的值;如果 XUserInserted 不為空值,則為 XUserInserted;如果 User 不為空值,則為 User;如果 UserGroupId 不為空值,則為 UserGroupId;否則為 EventUserName
SuccessInfo security_result.category_details 直接複製值
MessageString security_result.description 直接複製值
UID_DialogJournal、ApplicationIntent、IsLogOff、AuthIdentity、AuthModule security_result.detection_fields 與各個欄位的標籤合併
AccountDomainName target.administrative_domain 直接複製值
AccessRequestType target.application 直接複製值
AssetNetworkAddress target.asset.hostname 直接複製值
AssetPlatformType target.asset.platform_software.platform 如果符合「(?i)Windows」,請設為 WINDOWS
AssetNetworkAddress, AssetId target.asset_id 串連為「AssetNetworkAddress:%{AssetId}」
完整路徑 target.file.full_path 直接複製值
AssetNetworkAddress target.hostname 直接複製值
_DB_NAME、databasename、_DB_DRIVER、_DB_PORT target.resource.attribute.labels 與 _DB_NAME 或 databasename 的 db_name、_DB_DRIVER 的 db_driver、_DB_PORT 的 db_port 合併
EventUserId target.user.product_object_id 直接複製值
AccountName, Receiver target.user.user_display_name 如果接收者不為空值,則為接收者的值,否則為帳戶名稱
AccountId、XUserUpdated、CentralAccount target.user.userid CentralAccount 的值 (如果不是空白),否則為 XUserUpdated (如果不是空白),否則為 AccountId
metadata.product_name 設為「ONE_IDENTITY_IDENTITY_MANAGER」
metadata.vendor_name 設為「ONE_IDENTITY」

變更記錄

查看這個剖析器的變更記錄

還有其他問題嗎?向社群成員和 Google SecOps 專家尋求解答。