收集 Oracle Unified Directory 日志
本文档介绍了如何使用 Bindplane 将 Oracle Unified Directory 日志注入到 Google Security Operations。
Oracle Unified Directory 是一种企业级 LDAP 目录服务,用于身份管理。它提供了一个可伸缩的、基于标准的目录,用于存储和管理身份数据,支持身份验证、授权和目录代理功能。解析器会从 Oracle Unified Directory 日志条目中提取字段,并将这些字段映射到统一数据模型 (UDM)。
准备工作
请确保满足以下前提条件:
- Google SecOps 实例
- Windows Server 2016 或更高版本,或者具有
systemd的 Linux 主机 - Bindplane 代理与 Oracle Unified Directory 服务器之间的网络连接
- 如果通过代理运行,请确保防火墙端口根据 Bindplane 代理要求处于打开状态
- 拥有对 Oracle Unified Directory 服务器的特权访问权限,并具有管理员权限
获取 Bindplane 代理的 Google SecOps 凭据
如需对 Bindplane 代理进行 Google SecOps 身份验证,请选择以下方法之一:
- 新部署:使用 Chronicle API(方法 1)。
- 旧版部署:继续使用注入身份验证文件(方法 2),直到注入 API 于 2027 年 7 月 20 日停用为止。
方法 1:为 Chronicle API 创建服务帐号(推荐)
- 登录 Google Cloud 控制台,然后选择与您的 Google SecOps 实例关联的 Google Cloud 项目。
- 依次前往 IAM 和管理 > 服务账号。
- 点击创建服务账号 。
- 提供以下配置详细信息:
- 服务账号名称:输入账号的名称(例如
bindplane-ingest)。 - 服务账号说明:输入说明(例如
Bindplane agent log ingestion)。
- 服务账号名称:输入账号的名称(例如
- 点击创建并继续 。
- 在向此服务帐号授予对项目的访问权限 部分,点击选择角色 ,然后选择 Chronicle Editor 。
- 点击继续 ,然后点击完成 。
- 点击您创建的服务帐号,然后前往密钥 标签页。
- 依次点击添加密钥 > 创建新密钥。
- 选择 JSON ,然后点击创建 。密钥文件会下载到您的计算机上。
- 将密钥文件另存为 Bindplane 收集器目录中的
ingestion-auth.json(在 Linux 上为/opt/observiq-otel-collector/ingestion-auth.json,在 Windows 上为C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json),或者更新creds_file_path在config.yaml中以与您保存该文件的路径匹配。 - 依次前往 IAM 和管理 > 设置 ,然后复制项目编号 。您需要此编号进行导出器配置。
方法 2:下载注入身份验证文件(旧版)
- 登录 Google SecOps 控制台。
- 依次前往 SIEM 设置 > 收集代理。
- 下载注入身份验证文件 。
- 将该文件安全地保存在将安装 Bindplane 代理的系统上。
获取 Google SecOps 客户 ID
- 登录 Google SecOps 控制台。
- 依次前往 SIEM 设置 > 个人资料。
从组织详细信息 部分复制并保存客户 ID 。
安装 Bindplane 代理
按照以下说明在 Windows 或 Linux 操作系统上安装 Bindplane 代理。
Windows 安装
- 以管理员身份打开命令提示符 或 PowerShell 。
运行以下命令:
msiexec /i "https://github.com/observIQ/bindplane-agent/releases/latest/download/observiq-otel-collector.msi" /quiet等待安装完成。
运行以下命令,验证安装是否成功:
sc query observiq-otel-collector
该服务应显示为正在运行 。
Linux 安装
- 使用 root 或 sudo 权限打开终端。
运行以下命令:
sudo sh -c "$(curl -fsSlL https://github.com/observiq/bindplane-agent/releases/latest/download/install_unix.sh)" install_unix.sh等待安装完成。
运行以下命令,验证安装是否成功:
sudo systemctl status observiq-otel-collector
该服务应显示为活跃 (正在运行) 。
其他安装资源
如需了解其他安装选项和问题排查信息,请参阅 Bindplane 代理安装指南。
配置 Bindplane 代理以注入 syslog 并将其发送到 Google SecOps
找到配置文件
Linux :
sudo nano /opt/observiq-otel-collector/config.yamlWindows :
notepad "C:\Program Files\observIQ OpenTelemetry Collector\config.yaml"
修改配置文件
将
config.yaml的全部内容替换为以下配置:receivers: tcplog: listen_address: "0.0.0.0:514" exporters: chronicle/oracle_oud: protocol: https # Region of your instance, for example us, europe, asia-southeast1 location: <LOCATION> # Project number of the Google Cloud project linked to the instance project: '<PROJECT_NUMBER>' compression: gzip creds_file_path: '/opt/observiq-otel-collector/ingestion-auth.json' customer_id: '<customer_id>' endpoint: chronicle.googleapis.com log_type: ORACLE_OUD raw_log_field: body service: pipelines: logs/oracle_oud: receivers: - tcplog exporters: - chronicle/oracle_oud
配置参数
替换以下占位符:
接收器配置:
tcplog:基于协议的接收器类型:- UDP syslog 的
udplog - TCP syslog 的
tcplog - RFC 3164/5424 syslog 的
syslog
- UDP syslog 的
0.0.0.0:要监听的 IP 地址:0.0.0.0以监听所有接口(推荐)- 要监听一个接口的特定 IP 地址
514:要监听的端口号(例如514、1514、6514)
导出器配置:
<customer_id>:上一步中的客户 IDlocation:将<LOCATION>替换为 Google SecOps 实例的区域(例如us、europe或asia-southeast1)。导出器会使用此值为chronicle.googleapis.com添加前缀。如需查看完整列表,请参阅区域级端点。project:将<PROJECT_NUMBER>替换为 IAM 和管理 > 设置 中的项目编号。endpoint:保持设置为chronicle.googleapis.com。- 根据平台调整
creds_file_path以指向服务帐号 JSON 密钥文件的路径(方法 1):- Linux:
/opt/observiq-otel-collector/ingestion-auth.json - Windows:
C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json
- Linux:
旧版注入 API 导出器
如果您使用方法 2 中的注入身份验证文件,请将
exporters块替换为以下内容。将creds_file_path设置为注入身份验证文件的路径,如果您的实例位于美国境外,请将malachiteingestion-pa.googleapis.com替换为您的 区域级端点(例如europe-malachiteingestion-pa.googleapis.com)。exporters: chronicle/oracle_oud: compression: gzip creds_file_path: '/opt/observiq-otel-collector/ingestion-auth.json' customer_id: '<customer_id>' endpoint: malachiteingestion-pa.googleapis.com log_type: ORACLE_OUD raw_log_field: body
保存配置文件
- 修改后,保存文件:
- Linux:按
Ctrl+O,然后按Enter,再按Ctrl+X - Windows:依次点击文件 > 保存
- Linux:按
重启 Bindplane 代理以应用更改
如需在 Linux 中重启 Bindplane 代理,请执行以下操作:
运行以下命令:
sudo systemctl restart observiq-otel-collector验证服务是否正在运行:
sudo systemctl status observiq-otel-collector检查日志中的错误:
sudo journalctl -u observiq-otel-collector -f
如需在 Windows 中重启 Bindplane 代理,请执行以下操作:
请从下列选项中选择一项:
- 以管理员身份运行命令提示符或 PowerShell:
net stop observiq-otel-collector && net start observiq-otel-collector- 服务控制台:
- 按
Win+R,输入services.msc,然后按 Enter 键。 - 找到 observIQ OpenTelemetry Collector 。
- 右键点击,然后选择重启 。
- 按
验证服务是否正在运行:
sc query observiq-otel-collector检查日志中的错误:
type "C:\Program Files\observIQ OpenTelemetry Collector\log\collector.log"
配置 Oracle Unified Directory syslog 转发
Oracle Unified Directory 会将日志存储在服务器文件系统的本地,通常位于 OUD_INSTANCE/logs/ 目录中。使用系统 syslog 守护程序配置 syslog 转发,以将这些日志发送到 Bindplane 代理。
确定 Oracle Unified Directory 日志目录。常见的日志文件包括
access、errors、replication和audit。配置系统 syslog 守护程序(例如
rsyslog)以监控和转发 OUD 日志文件。创建新的 rsyslog 配置文件:sudo nano /etc/rsyslog.d/oud-forward.conf添加以下内容:
module(load="imfile") input(type="imfile" File="/path/to/oud-instance/logs/access" Tag="oracle-oud" Severity="info" Facility="local0") input(type="imfile" File="/path/to/oud-instance/logs/errors" Tag="oracle-oud" Severity="error" Facility="local0") local0.* @@BINDPLANE_AGENT_IP:514重启 rsyslog 服务:
sudo systemctl restart rsyslog
UDM 映射表
| 日志字段 | UDM 映射 | 逻辑 |
|---|---|---|
| conn,op,msgID,oid,result,etime,filter,attrs,ou,version,type,authFailureID,authFailureReason,name,o | additional.fields | 其他 UDM 字段未涵盖的其他元数据 |
| metadata.event_type | 事件类型(例如 USER_LOGIN、NETWORK_CONNECTION) | |
| operation,operation1 | metadata.product_event_type | 特定于产品的事件类型 |
| protocol | network.application_protocol | 网络连接中使用的应用协议 |
| hostname | principal.hostname | 主要资产的主机名 |
| srcaddr | principal.ip | 主体的 IP 地址 |
| srcport | principal.port | 主体使用的端口号 |
| uid | principal.user.userid | 主体用户的用户 ID |
| operation | security_result.action_details | 安全产品采取的操作的详细信息 |
| reason | security_result.description | 安全结果的说明 |
| msg_data | security_result.summary | 安全结果的摘要 |
| destaddr | target.ip | 目标的 IP 地址 |
| destport | target.port | 目标使用的端口号 |
| metadata.product_name | 生成事件的产品的名称 | |
| metadata.vendor_name | 产品供应商的名称 | |
authFailureID", "filter", "attrs", "changetype", "replace" and "authFailureReason |
additional.fields |
从更改日志映射 |
from |
principal.ip |
从更改日志映射 |
更新日志
需要更多帮助?获得社区成员和 Google SecOps 专业人士的解答。