收集 Oracle Unified Directory 記錄
本文說明如何使用 Bindplane,將 Oracle Unified Directory 記錄擷取至 Google Security Operations。
Oracle Unified Directory 是企業級 LDAP 目錄服務,用於身分管理。這項服務提供可擴充、符合標準的目錄,用於儲存及管理身分資料,並支援驗證、授權和目錄 Proxy 功能。剖析器會從 Oracle Unified Directory 記錄檔項目中擷取欄位,並將這些欄位對應至統合式資料模型 (UDM)。
事前準備
請確認您已完成下列事前準備事項:
- Google SecOps 執行個體
- Windows Server 2016 以上版本,或搭載
systemd的 Linux 主機 - Bindplane 代理程式與 Oracle Unified Directory 伺服器之間的網路連線
- 如果透過 Proxy 執行,請確保防火牆通訊埠已根據 Bindplane 代理程式需求開啟
- 具備管理員權限,可存取 Oracle Unified Directory 目錄伺服器
取得 Bindplane 代理程式的 Google SecOps 憑證
如要向 Google SecOps 驗證 Bindplane 代理程式,請選擇下列其中一種方法:
- 新部署作業:使用 Chronicle API (選項 1)。
- 舊版部署作業:繼續使用擷取驗證檔案 (選項 2),直到 Ingestion API 於 2027 年 7 月 20 日停用。
方法 1:為 Chronicle API 建立服務帳戶 (建議)
- 登入 Google Cloud 控制台,然後選取連結至 Google SecOps 執行個體的 Google Cloud 專案。
- 依序前往「IAM & Admin」(IAM 與管理) >「Service Accounts」(服務帳戶)。
- 按一下「建立服務帳戶」。
- 提供下列設定詳細資料:
- 「Service account name」(服務帳戶名稱):輸入帳戶名稱 (例如
bindplane-ingest)。 - 「服務帳戶說明」:輸入說明 (例如
Bindplane agent log ingestion)。
- 「Service account name」(服務帳戶名稱):輸入帳戶名稱 (例如
- 點按「Create and continue」(建立並繼續)。
- 在「將專案存取權授予這個服務帳戶」部分,按一下「選取角色」,然後選取「Chronicle 編輯者」。
- 依序點選「繼續」和「完成」。
- 按一下您建立的服務帳戶,然後前往「金鑰」分頁。
- 依序點選「新增金鑰」>「建立新的金鑰」。
- 選取「JSON」,然後按一下「建立」。金鑰檔案會下載到電腦。
- 將金鑰檔案儲存為 Bindplane 收集器目錄中的
ingestion-auth.json(Linux 上的/opt/observiq-otel-collector/ingestion-auth.json或 Windows 上的C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json),或更新config.yaml中的creds_file_path,使其與儲存路徑相符。 - 依序前往「IAM 與管理」>「設定」,然後複製「專案編號」。設定匯出工具時會用到。
方法 2:下載擷取驗證檔案 (舊版)
- 登入 Google SecOps 控制台。
- 依序前往「SIEM Settings」 > 「Collection Agents」。
- 下載擷取驗證檔案。
- 將檔案安全地儲存在要安裝 Bindplane 代理程式的系統中。
取得 Google SecOps 客戶 ID
- 登入 Google SecOps 控制台。
- 依序前往「SIEM 設定」>「設定檔」。
複製並儲存「機構詳細資料」專區中的「客戶 ID」。
安裝 Bindplane 代理程式
請按照下列操作說明,在 Windows 或 Linux 作業系統上安裝 Bindplane 代理程式。
Windows 安裝
- 以管理員身分開啟「命令提示字元」或「PowerShell」。
執行下列指令:
msiexec /i "https://github.com/observIQ/bindplane-agent/releases/latest/download/observiq-otel-collector.msi" /quiet等待安裝完成。
執行下列指令,確認安裝成功:
sc query observiq-otel-collector
服務應顯示為「RUNNING」。
安裝 Linux
- 開啟具有 root 或 sudo 權限的終端機。
執行下列指令:
sudo sh -c "$(curl -fsSlL https://github.com/observiq/bindplane-agent/releases/latest/download/install_unix.sh)" install_unix.sh等待安裝完成。
執行下列指令,確認安裝成功:
sudo systemctl status observiq-otel-collector
服務應顯示為「active (running)」。
其他安裝資源
如需其他安裝選項和疑難排解資訊,請參閱 Bindplane 代理程式安裝指南。
設定 Bindplane 代理程式,擷取系統記錄並傳送至 Google SecOps
找出設定檔
Linux:
sudo nano /opt/observiq-otel-collector/config.yamlWindows:
notepad "C:\Program Files\observIQ OpenTelemetry Collector\config.yaml"
編輯設定檔
將
config.yaml的全部內容替換為下列設定:receivers: tcplog: listen_address: "0.0.0.0:514" exporters: chronicle/oracle_oud: protocol: https # Region of your instance, for example us, europe, asia-southeast1 location: <LOCATION> # Project number of the Google Cloud project linked to the instance project: '<PROJECT_NUMBER>' compression: gzip creds_file_path: '/opt/observiq-otel-collector/ingestion-auth.json' customer_id: '<customer_id>' endpoint: chronicle.googleapis.com log_type: ORACLE_OUD raw_log_field: body service: pipelines: logs/oracle_oud: receivers: - tcplog exporters: - chronicle/oracle_oud
設定參數
替換下列預留位置:
接收器設定:
tcplog:依通訊協定區分的接收端類型:- UDP syslog 的
udplog tcplog(適用於 TCP syslog)syslog(適用於 RFC 3164/5424 syslog)
- UDP syslog 的
0.0.0.0:要接聽的 IP 位址:0.0.0.0在所有介面接聽電話 (建議)- 在一個介面上接聽的特定 IP 位址
514:要監聽的通訊埠編號 (例如514、1514、6514)
匯出工具設定:
<customer_id>:先前步驟中的客戶 IDlocation:將<LOCATION>替換為 Google SecOps 執行個體的區域 (例如us、europe或asia-southeast1)。匯出工具會在這個值前面加上chronicle.googleapis.com。如需完整清單,請參閱「區域性端點」。project:依序前往「IAM 與管理」>「設定」,然後將<PROJECT_NUMBER>替換為專案編號。endpoint:請將此值設為chronicle.googleapis.com。- 根據平台,將
creds_file_path調整為服務帳戶 JSON 金鑰檔案的路徑 (選項 1):- Linux:
/opt/observiq-otel-collector/ingestion-auth.json - Windows:
C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json
- Linux:
舊版 Ingestion API 匯出工具
如果您使用選項 2 的擷取驗證檔案,請將
exporters區塊替換為下列內容。將creds_file_path設為擷取驗證檔案的路徑。如果執行個體位於美國境外,請將malachiteingestion-pa.googleapis.com替換為區域端點 (例如europe-malachiteingestion-pa.googleapis.com)。exporters: chronicle/oracle_oud: compression: gzip creds_file_path: '/opt/observiq-otel-collector/ingestion-auth.json' customer_id: '<customer_id>' endpoint: malachiteingestion-pa.googleapis.com log_type: ORACLE_OUD raw_log_field: body
儲存設定檔
- 編輯完畢後,請儲存檔案:
- Linux:依序按下
Ctrl+O、Enter和Ctrl+X - Windows:依序點選「檔案」 > 「儲存」
- Linux:依序按下
重新啟動 Bindplane 代理程式,套用變更
如要在 Linux 中重新啟動 Bindplane 代理程式,請按照下列步驟操作:
執行下列指令:
sudo systemctl restart observiq-otel-collector確認服務正在執行:
sudo systemctl status observiq-otel-collector查看記錄檔是否有錯誤:
sudo journalctl -u observiq-otel-collector -f
如要在 Windows 中重新啟動 Bindplane 代理程式,請按照下列步驟操作:
您可以選擇下列其中一個選項:
- 以管理員身分開啟命令提示字元或 PowerShell:
net stop observiq-otel-collector && net start observiq-otel-collector- 服務控制台:
- 按下
Win+R鍵,輸入services.msc,然後按下 Enter 鍵。 - 找出「observIQ OpenTelemetry Collector」。
- 按一下滑鼠右鍵,然後選取「重新啟動」。
- 按下
確認服務正在執行:
sc query observiq-otel-collector查看記錄檔是否有錯誤:
type "C:\Program Files\observIQ OpenTelemetry Collector\log\collector.log"
設定 Oracle Unified Directory 系統記錄轉送
Oracle Unified Directory 會將記錄檔儲存在伺服器檔案系統的本機,通常位於 OUD_INSTANCE/logs/ 目錄。使用系統 syslog daemon 設定 syslog 轉送功能,將這些記錄傳送至 Bindplane 代理程式。
找出 Oracle Unified Directory 記錄目錄。常見的記錄檔包括
access、errors、replication和audit。設定系統 syslog daemon (例如
rsyslog),監控及轉送 OUD 記錄檔。建立新的 rsyslog 設定檔:sudo nano /etc/rsyslog.d/oud-forward.conf新增下列內容:
module(load="imfile") input(type="imfile" File="/path/to/oud-instance/logs/access" Tag="oracle-oud" Severity="info" Facility="local0") input(type="imfile" File="/path/to/oud-instance/logs/errors" Tag="oracle-oud" Severity="error" Facility="local0") local0.* @@BINDPLANE_AGENT_IP:514重新啟動 rsyslog 服務:
sudo systemctl restart rsyslog
UDM 對應表
| 記錄欄位 | UDM 對應 | 邏輯 |
|---|---|---|
| conn,op,msgID,oid,result,etime,filter,attrs,ou,version,type,authFailureID,authFailureReason,name,o | additional.fields | 其他 UDM 欄位未涵蓋的其他中繼資料 |
| metadata.event_type | 事件類型 (例如 USER_LOGIN、NETWORK_CONNECTION) | |
| operation,operation1 | metadata.product_event_type | 產品專屬事件類型 |
| 通訊協定 | network.application_protocol | 網路連線中使用的應用程式通訊協定 |
| 主機名稱 | principal.hostname | 主體資產的主機名稱 |
| srcaddr | principal.ip | 主體的 IP 位址 |
| srcport | principal.port | 主體使用的通訊埠編號 |
| uid | principal.user.userid | 主要使用者的使用者 ID |
| 作業 | security_result.action_details | 安全性產品採取的動作詳細資料 |
| reason | security_result.description | 安全性結果說明 |
| msg_data | security_result.summary | 安全性結果摘要 |
| destaddr | target.ip | 目標的 IP 位址 |
| destport | target.port | 目標使用的通訊埠編號 |
| metadata.product_name | 產生事件的產品名稱 | |
| metadata.vendor_name | 產品供應商名稱 | |
authFailureID", "filter", "attrs", "changetype", "replace" and "authFailureReason |
additional.fields |
從變更記錄對應 |
from |
principal.ip |
從變更記錄對應 |
變更記錄
還有其他問題嗎?向社群成員和 Google SecOps 專業人員尋求解答。