收集抢占身份验证日志

支持的平台:

本文档介绍了如何使用 Bindplane 代理将 Preempt Auth 日志注入到 Google Security Operations。

Preempt Auth 是一种身份验证事件监控解决方案,可为 Active Directory 环境生成详细的身份验证日志。它可捕获各个端点上的成功和失败登录事件、LDAP 搜索、服务访问和身份验证类型。

准备工作

请确保满足以下前提条件:

  • Google SecOps 实例
  • Windows Server 2016 或更高版本,或者具有 systemd 的 Linux 主机
  • Bindplane 代理与 Preempt 服务器之间的网络连接
  • 如果通过代理运行,请确保防火墙端口已根据 Bindplane 代理要求打开
  • 具有管理员权限的 Preempt Auth(CrowdStrike Identity Protection)特权访问权限

获取 Google SecOps 注入身份验证文件

  1. 登录 Google SecOps 控制台。
  2. 依次前往 SIEM 设置 > 收集代理
  3. 下载注入身份验证文件
  4. 将文件安全地保存在将要安装 Bindplane 的系统上。

获取 Google SecOps 客户 ID

  1. 登录 Google SecOps 控制台。
  2. 依次前往 SIEM 设置 > 配置文件
  3. 复制并保存组织详细信息部分中的客户 ID

安装 Bindplane 代理

按照以下说明在 Windows 或 Linux 操作系统上安装 Bindplane 代理。

Windows 安装

  1. 以管理员身份打开命令提示符PowerShell
  2. 运行以下命令:

    msiexec /i "https://github.com/observIQ/bindplane-agent/releases/latest/download/observiq-otel-collector.msi" /quiet
    
  3. 等待安装完成。

  4. 运行以下命令,验证安装是否成功:

    sc query observiq-otel-collector
    

    该服务应显示为 RUNNING

Linux 安装

  1. 打开具有 root 或 sudo 权限的终端。
  2. 运行以下命令:

    sudo sh -c "$(curl -fsSlL https://github.com/observiq/bindplane-agent/releases/latest/download/install_unix.sh)" install_unix.sh
    
  3. 等待安装完成。

  4. 运行以下命令,验证安装是否成功:

    sudo systemctl status observiq-otel-collector
    

    该服务应显示为有效(正在运行)

其他安装资源

如需了解其他安装选项和问题排查信息,请参阅 Bindplane 代理安装指南

配置 Bindplane 代理以注入 syslog 并将其发送到 Google SecOps

找到配置文件

  • Linux

    sudo nano /opt/observiq-otel-collector/config.yaml
    
  • Windows

    notepad "C:\Program Files\observIQ OpenTelemetry Collector\config.yaml"
    

修改配置文件

  • config.yaml 的全部内容替换为以下配置:

    receivers:
        tcplog:
            listen_address: "0.0.0.0:514"
    
    exporters:
        chronicle/preempt_auth:
            compression: gzip
            creds_file_path: '<CREDS_FILE_PATH>'
            customer_id: '<CUSTOMER_ID>'
            endpoint: <REGION_ENDPOINT>
            log_type: PREEMPT_AUTH
            raw_log_field: body
            ingestion_labels:
                env: production
    
    service:
        pipelines:
            logs/preempt_auth_to_chronicle:
                receivers:
                    - tcplog
                exporters:
                    - chronicle/preempt_auth
    

配置参数

替换以下占位符:

  • 接收器配置

    • tcplog:通过 TCP 接收 syslog。如果您的 Preempt 部署通过 UDP 进行转发,请使用 udplog
    • 0.0.0.0:514:在端口 514 上监听所有接口。如果需要,请更改端口(例如,对于非 root Linux,请使用 1514)。
  • 导出器配置

    • <CREDS_FILE_PATH>:提取身份验证文件的完整路径:
      • Linux/etc/bindplane-agent/ingestion-auth.json
      • WindowsC:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json
    • <CUSTOMER_ID>获取 Google SecOps 客户 ID 步骤中的客户 ID。
    • <REGION_ENDPOINT>:区域端点网址:
      • 美国malachiteingestion-pa.googleapis.com
      • 欧洲europe-malachiteingestion-pa.googleapis.com
      • 亚洲asia-southeast1-malachiteingestion-pa.googleapis.com
      • 如需查看完整列表,请参阅区域级端点

保存配置文件

  • 修改后,保存文件:
    • Linux:依次按 Ctrl+OEnterCtrl+X
    • Windows:依次点击文件 > 保存

重启 Bindplane 代理以应用更改

  • 如需在 Linux 中重启 Bindplane 代理,请运行以下命令:

    sudo systemctl restart observiq-otel-collector
    
    1. 验证服务是否正在运行:

      sudo systemctl status observiq-otel-collector
      
    2. 检查日志是否存在错误:

      sudo journalctl -u observiq-otel-collector -f
      
  • 如需在 Windows 中重启 Bindplane 代理,请选择以下选项之一:

    • 以管理员身份运行命令提示符或 PowerShell:

      net stop observiq-otel-collector && net start observiq-otel-collector
      
    • 服务控制台:

      1. Win+R,输入 services.msc,然后按 Enter 键。
      2. 找到 observIQ OpenTelemetry 收集器
      3. 右键点击并选择重新启动
      4. 验证服务是否正在运行:

        sc query observiq-otel-collector
        
      5. 检查日志是否存在错误:

        type "C:\Program Files\observIQ OpenTelemetry Collector\log\collector.log"
        

配置抢占身份验证 syslog 转发

  1. 登录 Preempt 管理控制台
  2. 前往设置 > SIEM 集成
  3. 为身份验证事件启用 syslog 转发。
  4. 提供以下配置详细信息:
    • 协议:选择 TCP(必须与 Bindplane 代理接收器配置相匹配)。
    • Syslog 服务器地址:输入 Bindplane 代理主机(例如 192.168.1.100)的 IP 地址。
    • 端口:输入 514(必须与 Bindplane 代理接收器端口一致)。
  5. 选择要转发的身份验证事件类型:
    • 身份验证成功事件
    • 身份验证失败事件
    • LDAP 搜索
    • 服务访问事件
  6. 点击保存应用
  7. 通过检查 Bindplane 代理日志,验证日志是否正在发送。

UDM 映射表

日志字段 UDM 映射 逻辑
authenticationType extensions.auth.type 如果 authenticationType 与 SSO_LOGIN 或 LDAP_AUTHENTICATION 匹配,则设置为“SSO”;如果与 DOMAIN_LOGIN 匹配,则设置为“MACHINE”;如果与 NTLM_AUTHENTICATION 匹配,则设置为“AUTHTYPE_UNSPECIFIED”
extensions.auth.mechanism 设置为“MECHANISM_UNSPECIFIED”
inter_ip intermediary.hostname 设置 inter_ip 是否为有效的 IP 地址
inter_ip intermediary.ip 设置 inter_ip 是否为有效的 IP 地址
eventLabel metadata.description 直接复制值
eventType metadata.event_type 如果 eventType 为 SUCCESSFUL_AUTHENTICATION 或 FAILED_AUTHENTICATION,则设置为“USER_LOGIN”;如果 eventType 为 SERVICE_ACCESS 或 LDAP_SEARCH,且 principal_host_set 为 true,则设置为“SERVICE_UNSPECIFIED”
eventType metadata.product_event_type 直接复制值
endpointDisplayName、ipAddress principal.hostname 如果 endpointDisplayName != ipAddress 且 endpointDisplayName != "",则进行设置
ipAddress, inter_ip principal.ip 如果 ipAddress != inter_ip,则为 ipAddress 中的值;否则为 inter_ip 中的值
networkType principal.resource.name 直接复制值
principal.resource.type 设置为“网络类型”
userDisplayName principal.user.email_addresses 设置 userDisplayName 是否与电子邮件正则表达式匹配
userDisplayName principal.user.user_display_name 直接复制值
userEntity.secondaryDisplayName、userDisplayName principal.user.userid 如果 userEntity.secondaryDisplayName 不为空,则返回该值;否则,如果 userEntity.secondaryDisplayName 为空,则返回 userDisplayName 中的值
eventType security_result.action 如果为 SUCCESSFUL_AUTHENTICATION,则设置为“ALLOW”;如果为 FAILED_AUTHENTICATION,则设置为“BLOCK”
eventSeverity security_result.severity_details 直接复制值
authenticationType security_result.summary 直接复制值
targetEntity.primaryDisplayName、targetServiceIdentifier、eventType、targetEntity.type target.application 如果 targetEntity.type == "CLOUD_SERVICE",则为 targetEntity.primaryDisplayName 中的值;否则,如果 targetServiceIdentifier != "" 且之前未设置,则为 targetServiceIdentifier 中的值;否则,如果 eventType == "LDAP_SEARCH" 且之前未设置,则为“LDAP”
targetEntity.primaryDisplayName, targetEntity.type target.hostname 如果 targetEntity.type == "ENDPOINT",则进行设置
targetServiceType target.resource.name 如果 targetServiceType 不等于 "" 且不等于 "UNKNOWN",则进行设置
targetServiceType target.resource.type 如果 targetServiceType 不等于 "" 且不等于 "UNKNOWN",则设置为“服务类型”
targetEntity.primaryDisplayName, targetEntity.type target.user.user_display_name 如果 targetEntity.type == "USER",则进行设置
targetEntity.secondaryDisplayName, targetEntity.type target.user.userid 如果 targetEntity.type == "USER",则进行设置
metadata.product_name 设置为“PREEMPT_AUTH”
metadata.vendor_name 设置为“抢占”

需要更多帮助?获得社区成员和 Google SecOps 专业人士的解答。