收集 Preempt Auth 記錄
本文說明如何使用 Bindplane 代理程式,將 Preempt Auth 記錄檔擷取至 Google Security Operations。
Preempt Auth 是一種驗證事件監控解決方案,可為 Active Directory 環境產生詳細的驗證記錄。這項功能會擷取端點的登入成功和失敗事件、LDAP 搜尋、服務存取和驗證類型。
事前準備
請確認您符合下列必要條件:
- Google SecOps 執行個體
- Windows Server 2016 以上版本,或搭載
systemd的 Linux 主機 - Bindplane 代理程式與 Preempt 伺服器之間的網路連線
- 如果是在 Proxy 後方執行,請確認防火牆通訊埠已按照 Bindplane 代理程式規定開啟
- 具備管理員權限,可特殊存取 Preempt Auth (CrowdStrike Identity Protection)
取得 Bindplane 代理程式的 Google SecOps 憑證
如要向 Google SecOps 驗證 Bindplane 代理程式,請選擇下列其中一種方法:
- 新部署作業:使用 Chronicle API (選項 1)。
- 舊版部署作業:繼續使用擷取驗證檔案 (選項 2),直到 Ingestion API 於 2027 年 7 月 20 日停用。
方法 1:為 Chronicle API 建立服務帳戶 (建議)
- 登入 Google Cloud 控制台,選取連結至 Google SecOps 執行個體的 Google Cloud 專案。
- 依序前往 「IAM & Admin」(IAM 與管理) >「Service Accounts」(服務帳戶)。
- 按一下「建立服務帳戶」。
- 請提供下列設定詳細資料:
- 「Service account name」(服務帳戶名稱):輸入帳戶名稱 (例如
bindplane-ingest)。 - 服務帳戶說明:輸入說明 (例如
Bindplane agent log ingestion)。
- 「Service account name」(服務帳戶名稱):輸入帳戶名稱 (例如
- 點按「Create and continue」(建立並繼續)。
- 在「將專案存取權授予這個服務帳戶」部分,按一下「選取角色」,然後選取「Chronicle 編輯者」。
- 依序點選「繼續」和「完成」。
- 按一下您建立的服務帳戶,然後前往「金鑰」分頁。
- 依序點選「新增金鑰」>「建立新的金鑰」。
- 選取「JSON」,然後點選「建立」。金鑰檔案會下載到電腦。
- 將金鑰檔案儲存為 Bindplane 收集器目錄中的
ingestion-auth.json(Linux 為/opt/observiq-otel-collector/ingestion-auth.json,Windows 為C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json),或更新config.yaml中的creds_file_path,使其與儲存檔案的路徑相符。 - 依序前往「IAM 與管理」>「設定」,然後複製「專案編號」。匯出工具設定時會用到。
方法 2:下載擷取驗證檔案 (舊版)
- 登入 Google SecOps 控制台。
- 依序前往「SIEM Settings」 > 「Collection Agents」。
- 下載擷取驗證檔案。
- 將檔案安全地儲存在要安裝 Bindplane 代理程式的系統上。
取得 Google SecOps 客戶 ID
- 登入 Google SecOps 控制台。
- 依序前往「SIEM 設定」>「設定檔」。
複製並儲存「機構詳細資料」部分的客戶 ID。
安裝 Bindplane 代理程式
請按照下列操作說明,在 Windows 或 Linux 作業系統上安裝 Bindplane 代理程式。
Windows 安裝
- 以管理員身分開啟「命令提示字元」或「PowerShell」。
執行下列指令:
msiexec /i "https://github.com/observIQ/bindplane-agent/releases/latest/download/observiq-otel-collector.msi" /quiet等待安裝完成。
執行下列指令,確認安裝成功:
sc query observiq-otel-collector服務應顯示為「RUNNING」。
Linux 安裝
- 開啟具有 root 或 sudo 權限的終端機。
執行下列指令:
sudo sh -c "$(curl -fsSlL https://github.com/observiq/bindplane-agent/releases/latest/download/install_unix.sh)" install_unix.sh等待安裝完成。
執行下列指令,確認安裝成功:
sudo systemctl status observiq-otel-collector服務應顯示為「active (running)」。
其他安裝資源
如需其他安裝選項和疑難排解資訊,請參閱 Bindplane 代理程式安裝指南。
設定 Bindplane 代理,擷取系統記錄檔並傳送至 Google SecOps
找出設定檔
Linux:
sudo nano /opt/observiq-otel-collector/config.yamlWindows:
notepad "C:\Program Files\observIQ OpenTelemetry Collector\config.yaml"
編輯設定檔
將
config.yaml的全部內容替換為下列設定:receivers: tcplog: listen_address: "0.0.0.0:514" exporters: chronicle/preempt_auth: protocol: https # Region of your instance, for example us, europe, asia-southeast1 location: <LOCATION> # Project number of the Google Cloud project linked to the instance project: '<PROJECT_NUMBER>' compression: gzip creds_file_path: '<CREDS_FILE_PATH>' customer_id: '<CUSTOMER_ID>' endpoint: chronicle.googleapis.com log_type: PREEMPT_AUTH raw_log_field: body ingestion_labels: env: production service: pipelines: logs/preempt_auth_to_chronicle: receivers: - tcplog exporters: - chronicle/preempt_auth
設定參數
替換下列預留位置:
接收器設定:
tcplog:透過 TCP 接收系統記錄。如果 Preempt 部署作業透過 UDP 轉送,請使用udplog。0.0.0.0:514:在通訊埠 514 上監聽所有介面。視需要變更通訊埠 (例如非根 Linux 的1514)。
Exporter 設定:
<CREDS_FILE_PATH>:服務帳戶 JSON 金鑰檔案的完整路徑 (選項 1):- Linux:
/opt/observiq-otel-collector/ingestion-auth.json - Windows:
C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json
- Linux:
<CUSTOMER_ID>:在「取得 Google SecOps 客戶 ID」步驟中取得的客戶 ID。location:將<LOCATION>替換為 Google SecOps 執行個體的區域 (例如us、europe或asia-southeast1)。匯出工具會在這個值前面加上chronicle.googleapis.com。如需完整清單,請參閱「區域性端點」。project:將<PROJECT_NUMBER>替換為「IAM 與管理」>「設定」中的專案編號。endpoint:維持設為chronicle.googleapis.com。
舊版擷取 API 匯出工具
如果您使用選項 2 的擷取驗證檔案,請將
exporters區塊替換為下列內容。將creds_file_path設為擷取驗證檔案的路徑。如果執行個體位於美國境外,請將malachiteingestion-pa.googleapis.com替換為區域端點 (例如europe-malachiteingestion-pa.googleapis.com)。exporters: chronicle/preempt_auth: compression: gzip creds_file_path: '<CREDS_FILE_PATH>' customer_id: '<CUSTOMER_ID>' endpoint: malachiteingestion-pa.googleapis.com log_type: PREEMPT_AUTH raw_log_field: body ingestion_labels: env: production
儲存設定檔
- 編輯完成後,請儲存檔案:
- Linux:依序按下
Ctrl+O、Enter和Ctrl+X - Windows:依序點選「檔案」 > 「儲存」
- Linux:依序按下
重新啟動 Bindplane 代理程式,套用變更
如要在 Linux 重新啟動 Bindplane 代理程式,請執行下列指令:
sudo systemctl restart observiq-otel-collector確認服務是否正在執行:
sudo systemctl status observiq-otel-collector查看記錄檔是否有錯誤:
sudo journalctl -u observiq-otel-collector -f
如要在 Windows 中重新啟動 Bindplane 代理程式,請選擇下列其中一個選項:
以管理員身分開啟命令提示字元或 PowerShell:
net stop observiq-otel-collector && net start observiq-otel-collector服務控制台:
- 按下
Win+R鍵,輸入services.msc,然後按下 Enter 鍵。 - 找出「observIQ OpenTelemetry Collector」。
- 按一下滑鼠右鍵,然後選取「重新啟動」。
確認服務是否正在執行:
sc query observiq-otel-collector檢查記錄是否有錯誤:
type "C:\Program Files\observIQ OpenTelemetry Collector\log\collector.log"
- 按下
設定 Preempt Auth Syslog 轉送
- 登入 Preempt 管理控制台。
- 依序前往「設定」>「SIEM 整合」。
- 啟用驗證事件的系統記錄轉送功能。
- 請提供下列設定詳細資料:
- 「Protocol」(通訊協定):選取「TCP」(必須與 Bindplane 代理程式接收器設定相符)。
- Syslog 伺服器位址:輸入 Bindplane 代理程式主機的 IP 位址 (例如
192.168.1.100)。 - 通訊埠:輸入
514(必須與 Bindplane 代理程式接收器通訊埠相符)。
- 選取要轉送的驗證事件類型:
- 驗證成功的事件
- 驗證失敗事件
- LDAP 搜尋
- 服務存取事件
- 按一下「儲存」或「套用」。
- 檢查 Bindplane 代理程式記錄,確認記錄是否已傳送。
UDM 對應表
| 記錄欄位 | UDM 對應 | 邏輯 |
|---|---|---|
| authenticationType | extensions.auth.type | 如果 authenticationType 符合 SSO_LOGIN 或 LDAP_AUTHENTICATION,請設為「SSO」;如果符合 DOMAIN_LOGIN,請設為「MACHINE」;如果符合 NTLM_AUTHENTICATION,請設為「AUTHTYPE_UNSPECIFIED」 |
| extensions.auth.mechanism | 設為「MECHANISM_UNSPECIFIED」 | |
| inter_ip | intermediary.hostname | 如果 inter_ip 不是有效的 IP 位址,請設定 |
| inter_ip | intermediary.ip | 如果 inter_ip 是有效的 IP 位址,請設定 |
| eventLabel | metadata.description | 直接複製值 |
| eventType | metadata.event_type | 如果 eventType 為 SUCCESSFUL_AUTHENTICATION 或 FAILED_AUTHENTICATION,請設為「USER_LOGIN」;如果為 SERVICE_ACCESS 或 LDAP_SEARCH,且 principal_host_set 為 true,請設為「SERVICE_UNSPECIFIED」 |
| eventType | metadata.product_event_type | 直接複製值 |
| endpointDisplayName, ipAddress | principal.hostname | 如果 endpointDisplayName != ipAddress 且 endpointDisplayName != "",則設定 |
| ipAddress、inter_ip | principal.ip | 如果 ipAddress != inter_ip,則為 ipAddress 的值,否則為 inter_ip 的值 |
| networkType | principal.resource.name | 直接複製值 |
| principal.resource.type | 設為「網路類型」 | |
| userDisplayName | principal.user.email_addresses | 如果 userDisplayName 符合電子郵件規則運算式,則設定 |
| userDisplayName | principal.user.user_display_name | 直接複製值 |
| userEntity.secondaryDisplayName、userDisplayName | principal.user.userid | 如果 userEntity.secondaryDisplayName 不為空白,則使用該值;如果 userEntity.secondaryDisplayName 為空白,則使用 userDisplayName 的值 |
| eventType | security_result.action | 如果驗證成功,請設為「ALLOW」;如果驗證失敗,請設為「BLOCK」 |
| eventSeverity | security_result.severity_details | 直接複製值 |
| authenticationType | security_result.summary | 直接複製值 |
| targetEntity.primaryDisplayName、targetServiceIdentifier、eventType、targetEntity.type | target.application | 如果 targetEntity.type == "CLOUD_SERVICE",則為 targetEntity.primaryDisplayName 的值;否則,如果 targetServiceIdentifier != "" 且先前未設定,則為 targetServiceIdentifier 的值;否則,如果 eventType == "LDAP_SEARCH" 且先前未設定,則為「LDAP」 |
| targetEntity.primaryDisplayName, targetEntity.type | target.hostname | 如果 targetEntity.type == "ENDPOINT",則設定 |
| targetServiceType | target.resource.name | 如果 targetServiceType != "" 且 != "UNKNOWN",則設定 |
| targetServiceType | target.resource.type | 如果 targetServiceType != "" 且 != "UNKNOWN",則設為「服務類型」 |
| targetEntity.primaryDisplayName, targetEntity.type | target.user.user_display_name | 如果 targetEntity.type == "USER",則設定 |
| targetEntity.secondaryDisplayName, targetEntity.type | target.user.userid | 如果 targetEntity.type == "USER",請設定 |
| metadata.product_name | 設為「PREEMPT_AUTH」 | |
| metadata.vendor_name | 設為「搶占」 |
還有其他問題嗎?向社群成員和 Google SecOps 專家尋求解答。