收集 Proofpoint 電子郵件篩選器記錄
本文說明如何使用 Bindplane 代理程式,將 Proofpoint Email Filter 記錄擷取至 Google Security Operations。
Proofpoint Email Protection (PPS) 是一種電子郵件安全防護閘道,可提供垃圾郵件篩選、威脅偵測和電子郵件政策強制執行功能。這項服務支援轉送系統記錄檔和整合 CEF 記錄,可匯出安全性事件和郵件交易記錄。
事前準備
請確認您已完成下列事前準備事項:
- Google SecOps 執行個體
- Windows Server 2016 以上版本,或搭載
systemd的 Linux 主機 - Bindplane 代理程式與 Proofpoint Protection Server (PPS) 之間的網路連線
- 如果透過 Proxy 執行,請確保防火牆通訊埠已根據 Bindplane 代理程式需求開啟
- 具備管理員權限,可存取 Proofpoint Protection Server (PPS) 管理控制台
取得 Google SecOps 擷取驗證檔案
- 登入 Google SecOps 控制台。
- 依序前往「SIEM 設定」>「收集代理程式」。
- 下載擷取驗證檔案。
將檔案安全地儲存在要安裝 Bindplane 的系統上。
取得 Google SecOps 客戶 ID
- 登入 Google SecOps 控制台。
- 依序前往「SIEM 設定」>「設定檔」。
複製並儲存「機構詳細資料」部分中的客戶 ID。
安裝 Bindplane 代理程式
請按照下列操作說明,在 Windows 或 Linux 作業系統上安裝 Bindplane 代理程式。
Windows 安裝
- 以管理員身分開啟「命令提示字元」或「PowerShell」。
執行下列指令:
msiexec /i "https://github.com/observIQ/bindplane-agent/releases/latest/download/observiq-otel-collector.msi" /quiet等待安裝完成。
執行下列指令,確認安裝成功:
sc query observiq-otel-collector服務應顯示為「RUNNING」。
Linux 安裝
- 開啟具有根層級或 sudo 權限的終端機。
執行下列指令:
sudo sh -c "$(curl -fsSlL https://github.com/observiq/bindplane-agent/releases/latest/download/install_unix.sh)" install_unix.sh等待安裝完成。
執行下列指令,確認安裝成功:
sudo systemctl status observiq-otel-collector服務應顯示為有效 (執行中)。
其他安裝資源
如需其他安裝選項和疑難排解資訊,請參閱 Bindplane 代理程式安裝指南。
設定 Bindplane 代理程式,擷取系統記錄檔並傳送至 Google SecOps
找出設定檔
Linux:
sudo nano /opt/observiq-otel-collector/config.yamlWindows:
notepad "C:\Program Files\observIQ OpenTelemetry Collector\config.yaml"
編輯設定檔
將
config.yaml的所有內容替換為下列設定:receivers: tcplog: listen_address: "0.0.0.0:514" exporters: chronicle/proofpoint_mail_filter: compression: gzip creds_file_path: '<CREDS_FILE_PATH>' customer_id: '<CUSTOMER_ID>' endpoint: <REGION_ENDPOINT> log_type: PROOFPOINT_MAIL_FILTER raw_log_field: body ingestion_labels: env: production service: pipelines: logs/proofpoint_mail_to_chronicle: receivers: - tcplog exporters: - chronicle/proofpoint_mail_filter
設定參數
替換下列預留位置:
接收器設定:
tcplog:透過 TCP 接收系統記錄。如果您在 PPS 中設定 UDP 傳輸,請使用udplog。0.0.0.0:514:在通訊埠 514 上監聽所有介面。視需要變更通訊埠 (例如非根目錄 Linux 的1514)。
匯出工具設定:
<CREDS_FILE_PATH>:擷取驗證檔案的完整路徑:- Linux:
/etc/bindplane-agent/ingestion-auth.json - Windows:
C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json
- Linux:
<CUSTOMER_ID>:從「取得 Google Security Operations 客戶 ID」步驟取得的客戶 ID。<REGION_ENDPOINT>:區域端點網址:- 美國:
malachiteingestion-pa.googleapis.com - 歐洲:
europe-malachiteingestion-pa.googleapis.com - 亞洲:
asia-southeast1-malachiteingestion-pa.googleapis.com - 如需完整清單,請參閱「區域端點」。
- 美國:
儲存設定檔
- 編輯完成後,請儲存檔案:
- Linux:依序按下
Ctrl+O、Enter和Ctrl+X - Windows:依序點選「檔案」>「儲存」
- Linux:依序按下
重新啟動 Bindplane 代理程式,以套用變更
如要在 Linux 中重新啟動 Bindplane 代理程式,請執行下列指令:
sudo systemctl restart observiq-otel-collector確認服務正在執行:
sudo systemctl status observiq-otel-collector檢查記錄中是否有錯誤:
sudo journalctl -u observiq-otel-collector -f
如要在 Windows 中重新啟動 Bindplane 代理程式,請選擇下列其中一個選項:
以管理員身分開啟命令提示字元或 PowerShell:
net stop observiq-otel-collector && net start observiq-otel-collector服務控制台:
- 按下
Win+R,輸入services.msc,然後按下 Enter 鍵。 - 找出 observIQ OpenTelemetry Collector。
- 按一下滑鼠右鍵,然後選取「重新啟動」。
確認服務正在執行:
sc query observiq-otel-collector檢查記錄中是否有錯誤:
type "C:\Program Files\observIQ OpenTelemetry Collector\log\collector.log"
- 按下
設定轉送 Proofpoint Email Protection 系統記錄
方法 1:在 Proofpoint PPS 中設定系統記錄轉送
- 登入 Proofpoint Protection Server (PPS) 管理控制台。
- 依序前往「系統」>「記錄和報告」>「記錄設定」。
- 在「Remote Log Settings」(遠端記錄設定) 區段中,設定下列項目:
- 「通訊協定」:選取「系統記錄檔」。
- Syslog:輸入 Bindplane 代理程式主機的 IP 位址 (例如
192.168.1.100)。 - 「Port」(通訊埠):輸入
514(必須與 Bindplane 代理程式接收器通訊埠一致)。 - 傳輸:選取「TCP」 (必須與 Bindplane 代理程式接收器設定相符)。此外,TLS 也支援安全轉寄。
- 在「Local Log Options」(本機記錄選項) 部分,視需要設定記錄詳細程度。
按一下 [儲存變更]。
方法 2:設定 CEF 記錄整合
- 登入 Proofpoint Protection Server (PPS) 管理控制台。
- 依序前往「Configuration」>「Integrations」>「Integrated SIEM」。
- 按一下「SIEM 記錄整合」分頁標籤。
- 選取「啟用匯出為 ArcSight 格式」,啟用 CEF 記錄整合功能。
- 設定系統記錄目的地伺服器:
- 主機:輸入 Bindplane 代理程式主機的 IP 位址 (例如
192.168.1.100)。 - 「Port」(通訊埠):輸入
514(必須與 Bindplane 代理程式接收器通訊埠一致)。
- 主機:輸入 Bindplane 代理程式主機的 IP 位址 (例如
- 按一下 [儲存]。
- 檢查 Bindplane 代理程式記錄,確認是否收到 CEF 格式的記錄。
UDM 對應表
| 記錄欄位 | UDM 對應 | 邏輯 |
|---|---|---|
| 關於 | 事件的其他資訊 | |
| adultscore、attachments、hops、routes、notroutes、eid、querydepth、selector、spamscore、phishscore、mod、status、folder | additional.fields | 無法在 UDM 模型的正式區段中充分呈現的供應商專屬事件資料 |
| 授權 | extensions.auth.type | 使用的驗證類型 |
| 中介 | 事件中涉及的中介裝置相關資訊 | |
| 網域 | intermediary.administrative_domain | 中介機構的行政網域 |
| hops-ip、lip、interm_ip | intermediary.ip | 中介裝置的 IP 位址 |
| metadata.event_type | 事件類型 (例如 USER_LOGIN、NETWORK_CONNECTION) | |
| prod_event_type | metadata.product_event_type | 產品專屬事件類型 |
| 引擎 | metadata.product_version | 產生事件的產品版本 |
| proto、mailer | network.application_protocol | 網路連線中使用的應用程式通訊協定 |
| hfrom、from | network.email.from | 電子郵件寄件者地址 |
| m、msgid、net_mail_id、hdr_mid | network.email.mail_id | 電子郵件訊息的專屬 ID |
| 主旨 | network.email.subject | 電子郵件主旨行 |
| 至 | network.email.to | 電子郵件收件者地址 |
| received_byte | network.received_bytes | 網路連線中接收的位元組數 |
| 秒 | network.session_id | 網路連線工作階段的專屬 ID |
| 密碼 | network.tls.cipher | 使用的 TLS 加密套件 |
| tls_version、version | network.tls.version | 使用的 TLS 版本 |
| 網域 | principal.administrative_domain | 主體的管理網域 |
| proc | principal.application | 與事件相關的應用程式 |
| 裝置、主機 | principal.asset.hostname | 與主體相關聯的資產主機名稱 |
| ip、srcip | principal.asset.ip | 與主體相關聯的資產 IP 位址 |
| guid | principal.asset_id | 資產的專屬 ID |
| 裝置、主機 | principal.hostname | 主體的主機名稱 |
| ip、srcip | principal.ip | 主體的 IP 位址 |
| 國家/地區 | principal.location.country_or_region | 主要負責人所在國家/地區 |
| cmd | principal.process.command_line | 用於啟動程序的指令列 |
| 檔案、名稱 | principal.process.file.full_path | 程序中涉及的檔案完整路徑 |
| sz、size | principal.process.file.size | 檔案大小 (以位元組為單位) |
| pid、process_id | principal.process.pid | 程序 ID |
| action、security_action | security_result.action | 安全性產品採取的動作 |
| 分類器 | security_result.category | 安全性結果的類別 |
| class、internalId | security_result.detection_fields | 用於偵測的欄位 |
| 規則 | security_result.rule_name | 觸發安全性結果的規則名稱 |
| security_desc | security_result.summary | 安全性結果摘要 |
| 主機名稱 | target.asset.hostname | 與目標相關聯的資產主機名稱 |
| 主機名稱 | target.hostname | 目標的主機名稱 |
| metadata.product_name | 產生事件的產品名稱 | |
| metadata.vendor_name | 產品製造商的名稱 | |
AppAccessContext.AADSessionId |
event.idm.read_only_udm.network.session_id |
從變更記錄對應 |
ClientAppName |
event.idm.read_only_udm.target.application |
從變更記錄對應 |
AppAccessContext.CorrelationId |
event.idm.read_only_udm.additional.fields |
從變更記錄對應 |
AppAccessContext.UniqueTokenId |
event.idm.read_only_udm.additional.fields |
從變更記錄對應 |
AppAccessContext.UserObjectId |
event.idm.read_only_udm.principal.user.product_object_id |
從變更記錄對應 |
Id |
event.idm.read_only_udm.target.resource.product_object_id |
從變更記錄對應 |
Operation |
event.idm.read_only_udm.metadata.product_event_type |
從變更記錄對應 |
RecordType |
event.idm.read_only_udm.security_result.detection_fields |
從變更記錄對應 |
UserKey |
event.idm.read_only_udm.principal.user.attribute.labels |
從變更記錄對應 |
UserType |
event.idm.read_only_udm.principal.user.attribute.labels |
從變更記錄對應 |
Version |
event.idm.read_only_udm.additional.fields |
從變更記錄對應 |
Workload |
event.idm.read_only_udm.principal.application |
從變更記錄對應 |
ClientIP |
event.idm.read_only_udm.principal.ip, event.idm.read_only_udm.principal.asset.ip |
從變更記錄對應 |
UserId |
event.idm.read_only_udm.principal.user.email_addresses |
從變更記錄對應 |
AuthenticationType |
event.idm.read_only_udm.extensions.auth.auth_details |
從變更記錄對應 |
BrowserName |
event.idm.read_only_udm.network.http.parsed_user_agent |
從變更記錄對應 |
BrowserVersion |
event.idm.read_only_udm.network.http.parsed_user_agent.browser_version |
從變更記錄對應 |
CorrelationId |
event.idm.read_only_udm.additional.fields |
從變更記錄對應 |
EventSource |
event.idm.read_only_udm.additional.fields |
從變更記錄對應 |
GeoLocation |
event.idm.read_only_udm.principal.location.name |
從變更記錄對應 |
IsManagedDevice |
event.idm.read_only_udm.security_result.detection_fields |
從變更記錄對應 |
ItemType |
event.idm.read_only_udm.additional.fields |
從變更記錄對應 |
ListId |
event.idm.read_only_udm.additional.fields |
從變更記錄對應 |
ListItemUniqueId |
event.idm.read_only_udm.additional.fields |
從變更記錄對應 |
Platform |
event.idm.read_only_udm.additional.fields |
從變更記錄對應 |
Site |
event.idm.read_only_udm.additional.fields |
從變更記錄對應 |
UserAgent |
event.idm.read_only_udm.network.http.user_agent |
從變更記錄對應 |
WebId |
event.idm.read_only_udm.additional.fields |
從變更記錄對應 |
HighPriorityMediaProcessing |
event.idm.read_only_udm.additional.fields |
從變更記錄對應 |
ListBaseType |
event.idm.read_only_udm.additional.fields |
從變更記錄對應 |
ListServerTemplate |
event.idm.read_only_udm.additional.fields |
從變更記錄對應 |
SourceRelativeUrl |
event.idm.read_only_udm.principal.url |
從變更記錄對應 |
net_mail_id" and "hdr_mid |
network.email.mail_id |
從變更記錄對應 |
delay |
about.resource.attribute.labels |
從變更記錄對應 |
relay |
intermediary.administrative_domain |
從變更記錄對應 |
device" from "intermediary.hostname |
principal.hostname |
從變更記錄對應 |
變更記錄
還有其他問題嗎?向社群成員和 Google SecOps 專業人員尋求答案。