收集 Quest 檔案存取稽核記錄
本文說明如何使用 Bindplane 代理程式,將 Quest 檔案存取稽核記錄擷取至 Google Security Operations。
Quest Change Auditor (舊稱 Quest File Access Audit) 是一個檔案伺服器和 Active Directory 稽核平台,可監控及回報 Windows 環境中的檔案存取活動、權限變更和管理動作。Change Auditor 提供內建的 SIEM 整合功能,包括透過事件訂閱轉送系統記錄。
事前準備
請確認您符合下列必要條件:
- Google SecOps 執行個體
- Windows Server 2016 以上版本,或搭載
systemd的 Linux 主機 - Bindplane 代理程式與 Quest Change Auditor 協調器伺服器之間的網路連線
- 如果透過 Proxy 執行,請確保防火牆通訊埠已根據 Bindplane 代理程式需求開啟
- Quest Change Auditor 用戶端或協調器伺服器的特殊權限
取得 Bindplane 代理程式的 Google SecOps 憑證
如要向 Google SecOps 驗證 Bindplane 代理程式,請選擇下列其中一種方法:
- 新部署作業:使用 Chronicle API (選項 1)。
- 舊版部署作業:繼續使用擷取驗證檔案 (選項 2),直到 Ingestion API 於 2027 年 7 月 20 日停用。
方法 1:為 Chronicle API 建立服務帳戶 (建議)
- 登入 Google Cloud 控制台,選取連結至 Google SecOps 執行個體的 Google Cloud 專案。
- 依序前往「IAM & Admin」(IAM 與管理) >「Service Accounts」(服務帳戶)。
- 按一下「建立服務帳戶」。
- 提供下列設定詳細資料:
- 「Service account name」(服務帳戶名稱):輸入帳戶名稱 (例如
bindplane-ingest)。 - 服務帳戶說明:輸入說明 (例如
Bindplane agent log ingestion)。
- 「Service account name」(服務帳戶名稱):輸入帳戶名稱 (例如
- 點按「Create and continue」(建立並繼續)。
- 在「將專案存取權授予這個服務帳戶」部分,按一下「選取角色」,然後選取「Chronicle 編輯者」。
- 依序點選「繼續」和「完成」。
- 按一下您建立的服務帳戶,然後前往「金鑰」分頁標籤。
- 依序點選「新增金鑰」>「建立新的金鑰」。
- 選取「JSON」,然後按一下「建立」。金鑰檔案會下載到電腦。
- 將金鑰檔案儲存為 Bindplane 收集器目錄中的
ingestion-auth.json(Linux 為/opt/observiq-otel-collector/ingestion-auth.json,Windows 為C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json),或更新config.yaml中的creds_file_path,使其與儲存檔案的路徑相符。 - 依序前往「IAM & Admin」(IAM 與管理) >「Settings」(設定),然後複製「Project number」(專案編號)。設定匯出工具時會用到。
方法 2:下載擷取驗證檔案 (舊版)
- 登入 Google SecOps 控制台。
- 依序前往「SIEM Settings」 > 「Collection Agents」。
- 下載擷取驗證檔案。
- 將檔案安全地儲存在要安裝 Bindplane 代理程式的系統上。
取得 Google SecOps 客戶 ID
- 登入 Google SecOps 控制台。
- 依序前往「SIEM 設定」 > 「設定檔」。
複製並儲存「機構詳細資料」部分的客戶 ID。
安裝 Bindplane 代理程式
請按照下列操作說明,在 Windows 或 Linux 作業系統上安裝 Bindplane 代理程式。
Windows 安裝
- 以管理員身分開啟命令提示字元或 PowerShell。
執行下列指令:
msiexec /i "https://github.com/observIQ/bindplane-agent/releases/latest/download/observiq-otel-collector.msi" /quiet等待安裝完成。
執行下列指令,確認安裝成功:
sc query observiq-otel-collector服務應顯示為「RUNNING」。
Linux 安裝
- 開啟具有 root 或 sudo 權限的終端機。
執行下列指令:
sudo sh -c "$(curl -fsSlL https://github.com/observiq/bindplane-agent/releases/latest/download/install_unix.sh)" install_unix.sh等待安裝完成。
執行下列指令,確認安裝成功:
sudo systemctl status observiq-otel-collector服務應顯示為「active (running)」。
其他安裝資源
如需其他安裝選項和疑難排解資訊,請參閱 Bindplane 代理程式安裝指南。
設定 Bindplane 代理,擷取系統記錄檔並傳送至 Google SecOps
找出設定檔
Linux:
sudo nano /opt/observiq-otel-collector/config.yamlWindows:
notepad "C:\Program Files\observIQ OpenTelemetry Collector\config.yaml"
編輯設定檔
將
config.yaml的全部內容替換為下列設定:receivers: udplog: listen_address: "0.0.0.0:514" exporters: chronicle/quest_file_audit: protocol: https # Region of your instance, for example us, europe, asia-southeast1 location: <LOCATION> # Project number of the Google Cloud project linked to the instance project: '<PROJECT_NUMBER>' compression: gzip creds_file_path: '/opt/observiq-otel-collector/ingestion-auth.json' customer_id: '<customer_id>' endpoint: chronicle.googleapis.com log_type: QUEST_FILE_AUDIT raw_log_field: body service: pipelines: logs/quest_file_audit_to_chronicle: receivers: - udplog exporters: - chronicle/quest_file_audit
設定參數
請替換下列預留位置:
接收器設定:
listen_address:要接聽的 IP 位址和通訊埠:0.0.0.0:在所有介面上監聽 (建議)- 通訊埠
514是標準的系統記錄通訊埠 (在 Linux 上需要根層級權限;如果沒有根層級權限,請使用1514)
匯出工具設定:
creds_file_path:服務帳戶 JSON 金鑰檔案的完整路徑 (選項 1):- Linux:
/opt/observiq-otel-collector/ingestion-auth.json - Windows:
C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json
- Linux:
customer_id:從 Google SecOps 控制台複製的客戶 IDlocation:將<LOCATION>替換為 Google SecOps 執行個體的區域 (例如us、europe或asia-southeast1)。匯出工具會以這個值做為chronicle.googleapis.com的前置字元。如需完整清單,請參閱「區域性端點」。project:依序前往「IAM 與管理」>「設定」,然後將<PROJECT_NUMBER>替換為專案編號。endpoint:維持設為chronicle.googleapis.com。
舊版擷取 API 匯出工具
如果您使用方式 2 的擷取驗證檔案,請將
exporters區塊替換成下列內容。將creds_file_path設為擷取驗證檔案的路徑,如果您的執行個體位於美國境外,請將malachiteingestion-pa.googleapis.com替換為區域端點 (例如europe-malachiteingestion-pa.googleapis.com)。exporters: chronicle/quest_file_audit: compression: gzip creds_file_path: '/opt/observiq-otel-collector/ingestion-auth.json' customer_id: '<customer_id>' endpoint: malachiteingestion-pa.googleapis.com log_type: QUEST_FILE_AUDIT raw_log_field: body
儲存設定檔
- 編輯完成後,請儲存檔案:
- Linux:依序按下
Ctrl+O、Enter和Ctrl+X - Windows:依序點選「檔案」 > 「儲存」
- Linux:依序按下
重新啟動 Bindplane 代理程式,套用變更
如要在 Linux 重新啟動 Bindplane 代理程式,請執行下列指令:
sudo systemctl restart observiq-otel-collector確認服務正在執行:
sudo systemctl status observiq-otel-collector查看記錄檔是否有錯誤:
sudo journalctl -u observiq-otel-collector -f
如要在 Windows 中重新啟動 Bindplane 代理程式,請選擇下列其中一個選項:
以管理員身分開啟命令提示字元或 PowerShell:
net stop observiq-otel-collector && net start observiq-otel-collector服務控制台:
- 按下
Win+R,輸入services.msc,然後按下 Enter 鍵。 - 找出「observIQ OpenTelemetry Collector」。
- 按一下滑鼠右鍵,然後選取「重新啟動」。
確認服務正在執行:
sc query observiq-otel-collector檢查記錄是否有錯誤:
type "C:\Program Files\observIQ OpenTelemetry Collector\log\collector.log"
- 按下
設定 Quest Change Auditor 系統記錄轉送
選項 1:使用 Change Auditor 用戶端設定 syslog 轉送
- 開啟 Change Auditor 用戶端應用程式。
- 依序前往「Administration」>「Event Subscriptions」。
- 按一下「New」(新增),然後選取「Syslog」做為訂閱類型。
- 在 Syslog 事件訂閱精靈中,設定下列項目:
- Host:輸入 Bindplane 代理程式主機的 IP 位址。
- 通訊埠:輸入
514。 - 訊息格式:選取「CEF」 (通用事件格式) 或「LEEF」 (記錄事件擴充格式)。
- 子系統:選取要轉送的事件子系統 (例如「檔案系統」)。
- 按一下「完成」即可建立訂閱項目。
方法 2:使用 PowerShell 設定 syslog 轉送
- 在 Change Auditor 協調器伺服器上開啟 PowerShell,然後匯入 Change Auditor 模組。
建立系統記錄事件訂閱項目:
$subsystems = Get-CAEventExportSubsystems | Where-Object { $_.Name -like "*File*" } New-CASyslogEventSubscription -Host "<BINDPLANE_AGENT_IP>" -Port 514 -SyslogFormat "CEF" -Subsystems $subsystems確認訂閱項目已建立:
Get-CASyslogEventSubscriptions
UDM 對應表
| 記錄欄位 | UDM 對應 | 邏輯 |
|---|---|---|
| Keywords, EventType, Task, ThreadID, Channel, Opcode | additional.fields | 事件的其他資訊 |
| EventTime | metadata.event_timestamp | 事件發生的時間戳記 |
| event_type | metadata.event_type | 事件類型 |
| EventReceivedTime | metadata.ingested_timestamp | 事件擷取時間的時間戳記 |
| EventID | metadata.product_event_type | 產品定義的事件類型 |
| RecordNumber | metadata.product_log_id | 產品指派的記錄 ID |
| metadata.product_name | 產生事件的產品名稱 | |
| metadata.vendor_name | 產生事件的供應商名稱 | |
| SourceModuleType | observer.application | 觀察者使用的應用程式 |
| SourceModuleName | observer.resource.attribute.labels | 與觀察者資源相關聯的標籤 |
| 網域 | principal.administrative_domain | 主體的管理網域 |
| SourceName | principal.application | 主體使用的應用程式 |
| 主機名稱 | principal.asset.hostname | 與主體相關聯的資產主機名稱 |
| ip_address | principal.asset.ip | 與主體相關聯的資產 IP 位址 |
| 主機名稱 | principal.hostname | 主體的主機名稱 |
| ip_address | principal.ip | 主體的 IP 位址 |
| ProcessID | principal.process.pid | 程序 ID |
| logonID | principal.user.attribute.labels | 與使用者相關聯的標籤 |
| AccountType | principal.user.attribute.roles | 與使用者相關聯的角色 |
| AccountName | principal.user.userid | 使用者 ID |
| UserID | principal.user.windows_sid | 使用者的 Windows SID |
| 說明 | security_result.description | 安全性結果說明 |
| SeverityValue | security_result.severity | 安全性結果的嚴重性 |
| 嚴重性 | security_result.severity_details | 嚴重性詳細資料 |
| 類別 | security_result.summary | 安全性結果摘要 |
| file_path | target.file.full_path | 目標檔案的完整路徑 |
| file_path | target.process.file.full_path | 與目標程序相關聯的檔案完整路徑 |
變更記錄
還有其他問題嗎?向社群成員和 Google SecOps 專業人員尋求解答。