收集 ReviveSec 記錄
本文說明如何使用 Bindplane 代理程式,將 ReviveSec 記錄擷取至 Google Security Operations。
ReviveSec 是 Revive Security Ltd (以色列) 推出的安全性分析平台,專門監控 Check Point 防火牆健康狀態、主動偵測錯誤及監控端點。這個平台會在 Windows 和 Linux 電腦上部署輕量型代理程式,監控程序、檔案、網路連線、DNS 和 USB 裝置。
事前準備
請確認您符合下列必要條件:
Google SecOps 執行個體
Windows Server 2016 以上版本,或搭載
systemd的 Linux 主機Bindplane 代理程式與 ReviveSec 伺服器之間的網路連線
如果透過 Proxy 執行,請確保防火牆通訊埠已根據 Bindplane 代理程式需求開啟
具備管理員權限的 ReviveSec 入口網站特殊存取權
取得 Bindplane 代理程式的 Google SecOps 憑證
如要向 Google SecOps 驗證 Bindplane 代理程式,請選擇下列其中一種方法:
- 新部署作業:使用 Chronicle API (選項 1)。
- 舊版部署作業:在 2027 年 7 月 20 日停用 Ingestion API 前,請繼續使用擷取驗證檔案 (選項 2)。
方法 1:為 Chronicle API 建立服務帳戶 (建議)
- 登入 Google Cloud 控制台,選取連結至 Google SecOps 執行個體的 Google Cloud 專案。
- 依序前往 「IAM & Admin」(IAM 與管理) >「Service Accounts」(服務帳戶)。
- 按一下「建立服務帳戶」。
- 請提供下列設定詳細資料:
- 服務帳戶名稱:輸入帳戶名稱 (例如
bindplane-ingest)。 - 「服務帳戶說明」:輸入說明 (例如
Bindplane agent log ingestion)。
- 服務帳戶名稱:輸入帳戶名稱 (例如
- 點按「Create and continue」(建立並繼續)。
- 在「將專案存取權授予這個服務帳戶」部分,按一下「選取角色」,然後選取「Chronicle 編輯者」。
- 依序點選「繼續」和「完成」。
- 按一下您建立的服務帳戶,然後前往「金鑰」分頁。
- 依序點選「新增金鑰」>「建立新的金鑰」。
- 選取「JSON」,然後按一下「建立」。金鑰檔案會下載到電腦。
- 將金鑰檔案儲存為 Bindplane 收集器目錄中的
ingestion-auth.json(Linux 上的/opt/observiq-otel-collector/ingestion-auth.json或 Windows 上的C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json),或更新config.yaml中的creds_file_path,使其與儲存路徑相符。 - 依序前往「IAM & Admin」(IAM 與管理) >「Settings」(設定),然後複製「Project number」(專案編號)。匯出工具設定時會用到。
方法 2:下載擷取驗證檔案 (舊版)
- 登入 Google SecOps 控制台。
- 依序前往「SIEM 設定」>「收集代理程式」。
- 下載擷取驗證檔案。
- 將檔案安全地儲存在要安裝 Bindplane 代理程式的系統中。
取得 Google SecOps 客戶 ID
- 登入 Google SecOps 控制台。
- 依序前往「SIEM 設定」 > 「設定檔」。
複製並儲存「機構詳細資料」部分的客戶 ID。
安裝 Bindplane 代理程式
請按照下列操作說明,在 Windows 或 Linux 作業系統上安裝 Bindplane 代理程式。
Windows 安裝
- 以管理員身分開啟「命令提示字元」或「PowerShell」。
執行下列指令:
msiexec /i "https://github.com/observIQ/bindplane-agent/releases/latest/download/observiq-otel-collector.msi" /quiet等待安裝完成。
執行下列指令,確認安裝成功:
sc query observiq-otel-collector服務應顯示為「RUNNING」。
Linux 安裝
- 開啟具有 root 或 sudo 權限的終端機。
執行下列指令:
sudo sh -c "$(curl -fsSlL https://github.com/observiq/bindplane-agent/releases/latest/download/install_unix.sh)" install_unix.sh等待安裝完成。
執行下列指令,確認安裝成功:
sudo systemctl status observiq-otel-collector服務應顯示為「active (running)」。
其他安裝資源
如需其他安裝選項和疑難排解資訊,請參閱 Bindplane 代理程式安裝指南。
設定 Bindplane 代理程式,擷取系統記錄並傳送至 Google SecOps
找出設定檔
Linux:
sudo nano /opt/observiq-otel-collector/config.yamlWindows:
notepad "C:\Program Files\observIQ OpenTelemetry Collector\config.yaml"
編輯設定檔
將
config.yaml的全部內容替換為下列設定:receivers: filelog: include: - /path/to/revivesec/logs/*.json - /path/to/revivesec/logs/*.csv start_at: beginning exporters: chronicle/revivesec: protocol: https # Region of your instance, for example us, europe, asia-southeast1 location: <LOCATION> # Project number of the Google Cloud project linked to the instance project: '<PROJECT_NUMBER>' compression: gzip creds_file_path: '/opt/observiq-otel-collector/ingestion-auth.json' customer_id: '<customer_id>' endpoint: chronicle.googleapis.com log_type: REVIVESEC raw_log_field: body ingestion_labels: env: production service: pipelines: logs/revivesec_to_chronicle: receivers: - filelog exporters: - chronicle/revivesec
設定參數
替換下列預留位置:
接收器設定:
filelog:從磁碟收集記錄檔的接收器類型include:要監控的檔案路徑或 glob 模式清單:- 調整路徑,以符合 ReviveSec 記錄檔位置
- 使用 glob 模式 (例如
*.json、*.csv) 比對多個檔案
start_at:設為beginning,從頭讀取現有記錄檔;或設為end,只讀取新項目
Exporter 設定:
revivesec:匯出工具的說明名稱creds_file_path:服務帳戶 JSON 金鑰檔案的完整路徑 (選項 1):- Linux:
/opt/observiq-otel-collector/ingestion-auth.json - Windows:
C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json
- Linux:
<customer_id>:上一步中的客戶 IDlocation:將<LOCATION>替換為 Google SecOps 執行個體的區域 (例如us、europe或asia-southeast1)。匯出工具會在這個值前面加上chronicle.googleapis.com。如需完整清單,請參閱「區域性端點」。project:依序前往「IAM 與管理」>「設定」,然後將<PROJECT_NUMBER>替換為專案編號。endpoint:維持設為chronicle.googleapis.com。REVIVESEC:記錄類型,與 Chronicle 中顯示的完全相同ingestion_labels:YAML 格式的選用標籤 (例如env: production)
管道設定:
revivesec_to_chronicle::管道的說明名稱
舊版 Ingestion API 匯出工具
如果您使用方式 2 的擷取驗證檔案,請將
exporters區塊替換成下列內容。將creds_file_path設為擷取驗證檔案的路徑。如果執行個體位於美國境外,請將malachiteingestion-pa.googleapis.com替換為區域端點 (例如europe-malachiteingestion-pa.googleapis.com)。exporters: chronicle/revivesec: compression: gzip creds_file_path: '/opt/observiq-otel-collector/ingestion-auth.json' customer_id: '<customer_id>' endpoint: malachiteingestion-pa.googleapis.com log_type: REVIVESEC raw_log_field: body ingestion_labels: env: production
儲存設定檔
- 編輯完成後,請儲存檔案:
- Linux:依序按下
Ctrl+O、Enter和Ctrl+X - Windows:依序點選「檔案」>「儲存」
- Linux:依序按下
重新啟動 Bindplane 代理程式,套用變更
如要在 Linux 中重新啟動 Bindplane 代理程式,請執行下列指令:
sudo systemctl restart observiq-otel-collector確認服務是否正在執行:
sudo systemctl status observiq-otel-collector查看記錄檔是否有錯誤:
sudo journalctl -u observiq-otel-collector -f
如要在 Windows 中重新啟動 Bindplane 代理程式,請選擇下列任一選項:
以管理員身分開啟命令提示字元或 PowerShell:
net stop observiq-otel-collector && net start observiq-otel-collector服務控制台:
- 按下
Win+R鍵,輸入services.msc,然後按下 Enter 鍵。 - 找出「observIQ OpenTelemetry Collector」。
- 按一下滑鼠右鍵,然後選取「重新啟動」。
確認服務正在執行:
sc query observiq-otel-collector查看記錄檔是否有錯誤:
type "C:\Program Files\observIQ OpenTelemetry Collector\log\collector.log"
- 按下
匯出 ReviveSec 記錄以供收集
- 登入 ReviveSec 管理入口網站。
- 前往「數據分析」或「報表」部分。
- 選取所需的報表類型 (健康狀態檢查、法規遵循、端點活動或防火牆分析)。
- 視需要套用日期範圍篩選器。
- 按一下「匯出」,然後選取輸出格式:
- JSON:建議用於 SIEM 擷取。
- CSV:結構化資料的表格格式。
- 將匯出的檔案儲存至 Bindplane 代理程式監控的目錄 (例如
/path/to/revivesec/logs/)。 (選用) 設定排程報表 (每日、每週或每月),自動將資料匯出至受監控的目錄。如要進一步瞭解自動匯出選項和 API 存取權,請洽詢 ReviveSec 支援團隊。
UDM 對應表
| 記錄欄位 | UDM 對應 | 邏輯 |
|---|---|---|
country_label |
additional.fields |
已合併 |
hit_count_label |
additional.fields |
已合併 |
linkInfo_label |
additional.fields |
已合併 |
proxy_label |
additional.fields |
已合併 |
signature_label |
additional.fields |
已合併 |
signature_status_label |
additional.fields |
已合併 |
svc_num_label |
additional.fields |
已合併 |
desc |
metadata.description |
直接對應 |
description |
metadata.description |
直接對應 |
description_gateway |
metadata.description |
直接對應 |
description_signature |
metadata.description |
直接對應 |
has_principal |
metadata.event_type |
已對應:true → NETWORK_CONNECTION、true → STATUS_UPDATE |
has_user |
metadata.event_type |
已對應:true → USER_UNCATEGORIZED |
product_event |
metadata.product_event_type |
直接對應 |
domain |
principal.asset.hostname |
直接對應 |
info_ip |
principal.asset.ip |
已合併 |
ipadd |
principal.asset.ip |
已合併 |
src_ip |
principal.asset.ip |
已合併 |
domain |
principal.hostname |
直接對應 |
info_ip |
principal.ip |
已合併 |
ipadd |
principal.ip |
已合併 |
src_ip |
principal.ip |
已合併 |
country_name |
principal.location.country_or_region |
直接對應 |
port |
principal.port |
直接對應 |
link_url |
principal.url |
直接對應 |
display_name |
principal.user.user_display_name |
直接對應 |
username |
principal.user.userid |
直接對應 |
domain_name |
target.asset.hostname |
直接對應 |
ipadd |
target.asset.ip |
已合併 |
domain_name |
target.hostname |
直接對應 |
ipadd |
target.ip |
已合併 |
| 不適用 | metadata.event_type |
常數:NETWORK_CONNECTION |
| 不適用 | metadata.product_name |
常數:REVIVESEC |
| 不適用 | metadata.vendor_name |
常數:REVIVESEC |
變更記錄
還有其他問題嗎?向社群成員和 Google SecOps 專家尋求解答。