收集 Ribbon Analytics Platform 記錄
本文說明如何使用 Bindplane 代理程式,將 Ribbon Analytics Platform 記錄檔擷取至 Google Security Operations。
Ribbon Analytics Platform 是網路分析和工作階段邊界控制器平台,可監控語音和資料通訊。系統會產生通話詳細記錄、工作階段事件和系統健康狀態資訊的 syslog 訊息。
事前準備
請確認您已完成下列事前準備事項:
- Google SecOps 執行個體
- Windows Server 2016 以上版本,或搭載
systemd的 Linux 主機 - Bindplane 代理程式與 Ribbon Analytics Platform 之間的網路連線
- 如果是在 Proxy 後方執行,請確認防火牆通訊埠已按照 Bindplane 代理程式規定開啟
- Ribbon Analytics Platform 管理介面的特殊存取權
取得 Bindplane 代理程式的 Google SecOps 憑證
如要向 Google SecOps 驗證 Bindplane 代理程式,請選擇下列其中一種方法:
- 新部署作業:使用 Chronicle API (選項 1)。
- 舊版部署作業:在 2027 年 7 月 20 日停用 Ingestion API 前,請繼續使用擷取驗證檔案 (選項 2)。
方法 1:為 Chronicle API 建立服務帳戶 (建議)
- 登入 Google Cloud 控制台,然後選取連結至 Google SecOps 執行個體的 Google Cloud 專案。
- 依序前往 「IAM & Admin」(IAM 與管理) >「Service Accounts」(服務帳戶)。
- 按一下「建立服務帳戶」。
- 提供下列設定詳細資料:
- 服務帳戶名稱:輸入帳戶名稱 (例如
bindplane-ingest)。 - 「服務帳戶說明」:輸入說明 (例如
Bindplane agent log ingestion)。
- 服務帳戶名稱:輸入帳戶名稱 (例如
- 點按「Create and continue」(建立並繼續)。
- 在「將專案存取權授予這個服務帳戶」部分,按一下「選取角色」,然後選取「Chronicle 編輯者」。
- 依序點選「繼續」和「完成」。
- 按一下您建立的服務帳戶,然後前往「金鑰」分頁。
- 依序點選「新增金鑰」>「建立新的金鑰」。
- 選取「JSON」,然後點選「建立」。金鑰檔案會下載到電腦。
- 將金鑰檔案儲存為 Bindplane 收集器目錄中的
ingestion-auth.json(Linux 上的/opt/observiq-otel-collector/ingestion-auth.json或 Windows 上的C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json),或更新config.yaml中的creds_file_path,使其與儲存路徑相符。 - 依序前往「IAM 與管理」>「設定」,然後複製「專案編號」。匯出工具設定時會用到。
方法 2:下載擷取驗證檔案 (舊版)
- 登入 Google SecOps 控制台。
- 依序前往「SIEM Settings」 > 「Collection Agents」。
- 下載擷取驗證檔案。
- 將檔案安全地儲存在要安裝 Bindplane 代理程式的系統上。
取得 Google SecOps 客戶 ID
- 登入 Google SecOps 控制台。
- 依序前往「SIEM 設定」 > 「設定檔」。
複製並儲存「機構詳細資料」專區中的「客戶 ID」。
安裝 Bindplane 代理程式
請按照下列操作說明,在 Windows 或 Linux 作業系統上安裝 Bindplane 代理程式。
Windows 安裝
- 以管理員身分開啟「命令提示字元」或「PowerShell」。
執行下列指令:
msiexec /i "https://github.com/observIQ/bindplane-agent/releases/latest/download/observiq-otel-collector.msi" /quiet等待安裝完成。
執行下列指令,確認安裝成功:
sc query observiq-otel-collector服務應顯示為「RUNNING」。
Linux 安裝
- 開啟具有 root 或 sudo 權限的終端機。
執行下列指令:
sudo sh -c "$(curl -fsSlL https://github.com/observiq/bindplane-agent/releases/latest/download/install_unix.sh)" install_unix.sh等待安裝完成。
執行下列指令,確認安裝成功:
sudo systemctl status observiq-otel-collector服務應顯示為「active (running)」。
其他安裝資源
如需其他安裝選項和疑難排解資訊,請參閱 Bindplane 代理程式安裝指南。
設定 Bindplane 代理,擷取系統記錄檔並傳送至 Google SecOps
找出設定檔
Linux:
sudo nano /opt/observiq-otel-collector/config.yamlWindows:
notepad "C:\Program Files\observIQ OpenTelemetry Collector\config.yaml"
編輯設定檔
將
config.yaml的全部內容替換為下列設定:receivers: udplog: listen_address: "0.0.0.0:514" exporters: chronicle/ribbon_analytics: protocol: https # Region of your instance, for example us, europe, asia-southeast1 location: <LOCATION> # Project number of the Google Cloud project linked to the instance project: '<PROJECT_NUMBER>' compression: gzip creds_file_path: '/opt/observiq-otel-collector/ingestion-auth.json' customer_id: '<customer_id>' endpoint: chronicle.googleapis.com log_type: RIBBON_ANALYTICS_PLATFORM raw_log_field: body service: pipelines: logs/ribbon_analytics_to_chronicle: receivers: - udplog exporters: - chronicle/ribbon_analytics
設定參數
替換下列預留位置:
接收器設定:
listen_address:要監聽的 IP 位址和通訊埠:0.0.0.0在所有介面接聽電話 (建議)- 通訊埠
514是標準 syslog 通訊埠 (在 Linux 上需要根目錄;非根目錄請使用1514)
Exporter 設定:
creds_file_path:服務帳戶 JSON 金鑰檔案的完整路徑 (選項 1):- Linux:
/opt/observiq-otel-collector/ingestion-auth.json - Windows:
C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json
- Linux:
customer_id:從 Google SecOps 控制台複製的客戶 IDlocation:將<LOCATION>替換為 Google SecOps 執行個體的區域 (例如us、europe或asia-southeast1)。匯出工具會在這個值前面加上chronicle.googleapis.com。如需完整清單,請參閱「區域性端點」。project:依序前往「IAM 與管理」>「設定」,然後將<PROJECT_NUMBER>替換為專案編號。endpoint:維持設為chronicle.googleapis.com。
舊版 Ingestion API 匯出工具
如果您使用選項 2 的擷取驗證檔案,請將
exporters區塊替換為下列內容。將creds_file_path設為擷取驗證檔案的路徑,如果您的執行個體位於美國境外,請將malachiteingestion-pa.googleapis.com替換為區域端點 (例如europe-malachiteingestion-pa.googleapis.com)。exporters: chronicle/ribbon_analytics: compression: gzip creds_file_path: '/opt/observiq-otel-collector/ingestion-auth.json' customer_id: '<customer_id>' endpoint: malachiteingestion-pa.googleapis.com log_type: RIBBON_ANALYTICS_PLATFORM raw_log_field: body
儲存設定檔
- 編輯完成後,請儲存檔案:
- Linux:依序按下
Ctrl+O、Enter和Ctrl+X - Windows:依序點選「檔案」 > 「儲存」
- Linux:依序按下
重新啟動 Bindplane 代理程式,套用變更
如要在 Linux 重新啟動 Bindplane 代理程式,請執行下列指令:
sudo systemctl restart observiq-otel-collector確認服務是否正在執行:
sudo systemctl status observiq-otel-collector檢查記錄是否有錯誤:
sudo journalctl -u observiq-otel-collector -f
如要在 Windows 中重新啟動 Bindplane 代理程式,請選擇下列任一選項:
以管理員身分開啟命令提示字元或 PowerShell:
net stop observiq-otel-collector && net start observiq-otel-collector服務控制台:
- 按下
Win+R鍵,輸入services.msc,然後按下 Enter 鍵。 - 找出「observIQ OpenTelemetry Collector」。
- 按一下滑鼠右鍵,然後選取「重新啟動」。
確認服務正在執行:
sc query observiq-otel-collector查看記錄檔是否有錯誤:
type "C:\Program Files\observIQ OpenTelemetry Collector\log\collector.log"
- 按下
設定 Ribbon Analytics Platform 的系統記錄轉送功能
- 登入 Ribbon 管理介面。
- 依序前往「Settings」>「Remote Log Servers」。
- 新增遠端記錄伺服器,並採用下列設定:
- 主機:輸入 Bindplane 代理程式主機的 IP 位址。
- 通訊埠:輸入
514。 - 「通訊協定」:選取「UDP」。
- 按一下 [儲存]。
UDM 對應表
| 記錄欄位 | UDM 對應 | 邏輯 |
|---|---|---|
type_name |
about |
對應:SYSCALL → about |
type_syscall_props.AUID |
about.user.user_display_name |
直接對應 |
type_syscall_props.auid |
about.user.userid |
直接對應 |
additional_delay_data |
additional.fields |
已合併 |
additional_delays_data |
additional.fields |
已合併 |
additional_dns_data |
additional.fields |
已合併 |
additional_field |
additional.fields |
已合併 |
additional_relay_data |
additional.fields |
已合併 |
auth_realm_field |
additional.fields |
已合併 |
log_details_label |
additional.fields |
已合併 |
_mechanism |
extensions.auth.mechanism |
已合併 |
audit_message |
extensions.auth.type |
對應:`type=(SYSCALL/LOGIN/USER_LOGIN/USER_CMD/USER_ACCT/USER_ROLE_CHANGE/USERSTART/USER... |
msg2 |
extensions.auth.type |
對應:login failure → MACHINE |
type_name |
extensions.auth.type |
已對應:USER_LOGIN → MACHINE、`"LOGIN", "USER_START", "USER_AUTH", "CRED_ACQ", "CRED_REF... |
dvc |
intermediary.hostname |
直接對應 |
dvc |
intermediary.ip |
已合併 |
description |
metadata.description |
直接對應 |
error_message |
metadata.description |
直接對應 |
msg2 |
metadata.description |
直接對應 |
event_timestamp |
metadata.event_timestamp |
剖析為 UNIX |
timestamp |
metadata.event_timestamp |
已剖析為 MMM d HH:mm:ss |
event_type |
metadata.event_type |
已對應:GENERIC_EVENT → STATUS_UPDATE |
has_principal |
metadata.event_type |
對應:true → STATUS_UPDATE |
msg2 |
metadata.event_type |
對應:HTTP → NETWORK_HTTP、login failure → USER_LOGIN |
target_user_present |
metadata.event_type |
對應:true → USER_UNCATEGORIZED |
type_name |
metadata.event_type |
對應:SYSCALL → USER_UNCATEGORIZED |
applica |
metadata.product_event_type |
直接對應 |
audit_message |
metadata.product_event_type |
對應值 (共 6 個,例如 pam_krb5.*authentication fails for → PAM_KRB5_AUTH_ERROR、`... |
eventType |
metadata.product_event_type |
直接對應 |
p_event_type |
metadata.product_event_type |
直接對應 |
type |
metadata.product_event_type |
直接對應 |
type_name |
metadata.product_event_type |
直接對應 |
jsonPayload._AUDIT_ID |
metadata.product_log_id |
直接對應 |
product_log_id |
metadata.product_log_id |
直接對應 |
audit_message |
network.application_protocol |
對應:type=(CRYPTO_SESSION/CRYPTO_KEY_USER) → SSH |
auth |
network.application_protocol |
對應:ssh → SSH |
message |
network.application_protocol |
對應:ssh/ssh2 → SSH |
tty |
network.application_protocol |
對應:ssh → SSH |
audit_message |
network.direction |
已對應:type=(CRYPTO_SESSION/CRYPTO_KEY_USER) → OUTBOUND,`type=(CRYPTO_SESSION/CRYPTO_K... |
mailid |
network.email.mail_id |
直接對應 |
to_email |
network.email.to |
已對應:^.+@.+$ → to_email |
response_code |
network.http.response_code |
直接對應 |
audit_message |
network.ip_protocol |
對應:type=(CRYPTO_SESSION/CRYPTO_KEY_USER) → TCP |
bytes_sent |
network.sent_bytes |
直接對應 |
type_crypto_props.ksize |
network.sent_bytes |
已重新命名/對應 |
jsonPayload._AUDIT_SESSION |
network.session_id |
直接對應 |
sessionid |
network.session_id |
直接對應 |
type_anom_props.ses |
network.session_id |
已重新命名/對應 |
type_syscall_props.ses |
network.session_id |
直接對應 |
type_crypto_props.cipher |
network.tls.cipher |
直接對應 |
type_crypto_props.pfs |
network.tls.curve |
直接對應 |
applica |
principal.application |
直接對應 |
jsonPayload._COMM |
principal.application |
直接對應 |
type_anom_props.comm |
principal.application |
直接對應 |
type_syscall_props.comm |
principal.application |
直接對應 |
type_syscall_props.terminal |
principal.application |
直接對應 |
%{rhost} |
principal.asset.hostname |
已合併 |
rhost |
principal.asset.hostname |
當 kvdata != `` 時對應 |
princi_ip |
principal.asset.ip |
已合併 |
rhost |
principal.asset.ip |
已合併 |
srcIp |
principal.asset.ip |
已對應:`^(?:(25[0-5]/2[0-4][0-9]/1[0-9]{2}/[1-9]?[0-9]).){3}(25[0-5]/2[0-4][0-9]/1[0-9]{2}... |
%{rhost} |
principal.hostname |
已合併 |
jsonPayload._HOSTNAME |
principal.hostname |
直接對應 |
principal_hostname |
principal.hostname |
直接對應 |
rhost |
principal.hostname |
當 kvdata != `` 時對應 |
audit_message |
principal.ip |
對應:`type=(SYSCALL/LOGIN/USER_LOGIN/USER_CMD/USER_ACCT/USER_ROLE_CHANGE/USERSTART/USER... |
prin_ip |
principal.ip |
已合併 |
princi_ip |
principal.ip |
已合併 |
rhost |
principal.ip |
已合併 |
srcIp |
principal.ip |
已對應:`^(?:(25[0-5]/2[0-4][0-9]/1[0-9]{2}/[1-9]?[0-9]).){3}(25[0-5]/2[0-4][0-9]/1[0-9]{2}... |
type_crypto_props.laddr |
principal.ip |
已合併 |
srcPort |
principal.port |
已重新命名/對應 |
type_crypto_props.lport |
principal.port |
已重新命名/對應 |
auth |
principal.process.command_line |
直接對應 |
proctitle_value |
principal.process.command_line |
直接對應 |
type_syscall_props.cmd |
principal.process.command_line |
直接對應 |
event.idm.read_only_udm.target.process.file.full_path |
principal.process.file.full_path |
直接對應 |
proctitle_value |
principal.process.file.full_path |
直接對應 |
audit_message |
principal.process.file.names |
對應:`type=(SYSCALL/LOGIN/USER_LOGIN/USER_CMD/USER_ACCT/USER_ROLE_CHANGE/USERSTART/USER... |
filename |
principal.process.file.names |
已合併 |
jsonPayload._PPID |
principal.process.parent_process.pid |
直接對應 |
type_syscall_props.ppid |
principal.process.parent_process.pid |
直接對應 |
jsonPayload._PID |
principal.process.pid |
直接對應 |
pi |
principal.process.pid |
直接對應 |
process_pid |
principal.process.pid |
直接對應 |
type_crypto_props.spid |
principal.process.pid |
直接對應 |
type_syscall_props.pid |
principal.process.pid |
直接對應 |
email |
principal.user.email_addresses |
已對應:^.+@.+$ → email |
user_name |
principal.user.email_addresses |
對應:^.+@.+$ → user_name |
type_syscall_props.UID |
principal.user.user_display_name |
直接對應 |
type_syscall_props.acct |
principal.user.user_display_name |
直接對應 |
jsonPayload._AUDIT_FIELD_SUID |
principal.user.userid |
直接對應 |
principal_user_userid |
principal.user.userid |
直接對應 |
ruser |
principal.user.userid |
直接對應 |
type_crypto_props.suid |
principal.user.userid |
直接對應 |
user_name |
principal.user.userid |
直接對應 |
usr |
principal.user.userid |
直接對應 |
a0_label |
security_result.about.labels |
已合併 |
a1_label |
security_result.about.labels |
已合併 |
a2_label |
security_result.about.labels |
已合併 |
a3_label |
security_result.about.labels |
已合併 |
audit_message |
security_result.about.labels |
對應值 (共 7 個,例如 `type=(SYSCALL/LOGIN/USER_LOGIN/USER_CMD/USER_ACCT/USER_ROLE_CH... |
exit_label |
security_result.about.labels |
已合併 |
syscall_label |
security_result.about.labels |
已合併 |
tty_label |
security_result.about.labels |
已合併 |
jsonPayload._AUDIT_FIELD_ARCH |
security_result.about.platform_version |
直接對應 |
type_syscall_props.arch |
security_result.about.platform_version |
直接對應 |
type_syscall_props.key |
security_result.about.registry.registry_key |
直接對應 |
product_log_id |
security_result.about.registry.registry_value_data |
直接對應 |
action |
security_result.action |
已合併 |
action_data |
security_result.action |
對應項目:`"authentication failure", "Authentication failure", "Failed password", "Connection ... |
audit_message |
security_result.action |
對應:`type=(SYSCALL/LOGIN/USER_LOGIN/USER_CMD/USER_ACCT/USER_ROLE_CHANGE/USERSTART/USER... |
security_action |
security_result.action |
已合併 |
action_data |
security_result.action_details |
直接對應 |
auth |
security_result.action_details |
對應:sshd → FAILURE |
status |
security_result.action_details |
直接對應 |
type_crypto_props.res |
security_result.action_details |
已重新命名/對應 |
type_syscall_props.res |
security_result.action_details |
直接對應 |
a0_label |
security_result.detection_fields |
已合併 |
a1_label |
security_result.detection_fields |
已合併 |
a2_label |
security_result.detection_fields |
已合併 |
a3_label |
security_result.detection_fields |
已合併 |
audit_message |
security_result.detection_fields |
對應:`type=(SYSCALL/LOGIN/USER_LOGIN/USER_CMD/USER_ACCT/USER_ROLE_CHANGE/USERSTART/USER... |
auid_field |
security_result.detection_fields |
已合併 |
auth |
security_result.detection_fields |
對應:sshd → authentication_protocol_field、sshd → authentication_mechanism_field... |
authentication_mechanism_field |
security_result.detection_fields |
已合併 |
authentication_protocol_field |
security_result.detection_fields |
已合併 |
bootid_label |
security_result.detection_fields |
已合併 |
connection_state_field |
security_result.detection_fields |
已合併 |
cwd_field |
security_result.detection_fields |
已合併 |
exit_label |
security_result.detection_fields |
已合併 |
jsonPayload._AUDIT_TYPE_NAME |
security_result.rule_id |
直接對應 |
type_name |
security_result.rule_id |
直接對應 |
msg_desc |
security_result.summary |
直接對應 |
secsummary |
security_result.summary |
直接對應 |
type_anom_props.reason |
security_result.summary |
直接對應 |
type_syscall_props.op |
security_result.summary |
直接對應 |
type_syscall_props.res |
security_result.summary |
直接對應 |
type_syscall_props.success |
security_result.summary |
直接對應 |
type_path1_props.name |
src.file.full_path |
已重新命名/對應 |
type_crypto_props.terminal |
target.application |
已重新命名/對應 |
target_hostname |
target.asset.hostname |
直接對應 |
type_crypto_props.hostname |
target.asset.hostname |
直接對應 |
dst_ip |
target.asset.ip |
已合併 |
resource.labels.project_id |
target.cloud.project.name |
直接對應 |
filepath |
target.file.full_path |
直接對應 |
jsonPayload._AUDIT_FIELD_FILE |
target.file.full_path |
直接對應 |
target_file_full_path |
target.file.full_path |
直接對應 |
jsonPayload._AUDIT_FIELD_HASH |
target.file.sha256 |
直接對應 |
target_hostname |
target.hostname |
直接對應 |
type_crypto_props.hostname |
target.hostname |
直接對應 |
audit_message |
target.ip |
對應:type=(CRYPTO_SESSION/CRYPTO_KEY_USER) → tar_ip |
dst_ip |
target.ip |
已合併 |
tar_ip |
target.ip |
已合併 |
resource.labels.location |
target.location.name |
直接對應 |
dst_port |
target.port |
直接對應 |
target_port |
target.port |
直接對應 |
type_crypto_props.rport |
target.port |
已重新命名/對應 |
args |
target.process.command_line |
已重新命名/對應 |
cmnd |
target.process.command_line |
直接對應 |
command_line |
target.process.command_line |
直接對應 |
cwd |
target.process.file.full_path |
直接對應 |
jsonPayload._EXE |
target.process.file.full_path |
直接對應 |
proctitle_value |
target.process.file.full_path |
直接對應 |
type_anom_props.exe |
target.process.file.full_path |
已重新命名/對應 |
type_crypto_props.exe |
target.process.file.full_path |
已重新命名/對應 |
type_syscall_props.exe |
target.process.file.full_path |
直接對應 |
type_anom_props.pid |
target.process.pid |
已重新命名/對應 |
type_crypto_props.pid |
target.process.pid |
已重新命名/對應 |
resource.labels.cluster_name |
target.resource.name |
直接對應 |
audit_message |
target.resource.type |
對應:`type=(SYSCALL/LOGIN/USER_LOGIN/USER_CMD/USER_ACCT/USER_ROLE_CHANGE/USERSTART/USER... |
type_name |
target.resource.type |
已對應:"USER_ACCT", "USER_ROLE_CHANGE","USER_MGMT" → SETTING |
target_email |
target.user.email_addresses |
已對應:^.+@.+$ → target_email |
type_syscall_props.ID |
target.user.user_display_name |
直接對應 |
type_syscall_props.acct |
target.user.user_display_name |
直接對應 |
event.idm.read_only_udm.principal.user.userid |
target.user.userid |
已重新命名/對應 |
jsonPayload._UID |
target.user.userid |
直接對應 |
type_crypto_props.uid |
target.user.userid |
直接對應 |
type_syscall_props.acct |
target.user.userid |
直接對應 |
type_syscall_props.id |
target.user.userid |
直接對應 |
type_syscall_props.uid |
target.user.userid |
直接對應 |
user_name |
target.user.userid |
直接對應 |
username |
target.user.userid |
直接對應 |
| 不適用 | extensions.auth.type |
常數:AUTHTYPE_UNSPECIFIED |
| 不適用 | metadata.event_type |
常數:STATUS_UPDATE |
| 不適用 | metadata.product_event_type |
常數:PAM_KRB5_AUTH_ERROR |
| 不適用 | metadata.product_name |
常數:AuditD |
| 不適用 | metadata.vendor_name |
常數:Linux |
| 不適用 | network.application_protocol |
常數:SSH |
| 不適用 | network.direction |
常數:OUTBOUND |
| 不適用 | network.ip_protocol |
常數:TCP |
| 不適用 | principal.platform |
常數:LINUX |
| 不適用 | principal.user.userid |
常數:event.idm.read_only_udm.target.user.userid |
| 不適用 | security_result.action_details |
常數:FAILURE |
| 不適用 | target.resource.type |
常數:SETTING |
變更記錄
還有其他問題嗎?向社群成員和 Google SecOps 專業人員尋求解答。