收集 SailPoint IdentityIQ 日志

支持:

本文档介绍了如何使用 Bindplane 代理将 SailPoint IdentityIQ 日志注入到 Google Security Operations。

SailPoint IdentityIQ 是一个身份治理平台,用于访问权限认证、预配和合规性管理。它通过 Log4j 配置支持系统日志级日志记录,从而允许将审核事件和应用日志转发到远程系统日志收集器。

准备工作

请确保满足以下前提条件:

  • Google SecOps 实例
  • Windows Server 2016 或更高版本,或者具有 systemd 的 Linux 主机
  • Bindplane 代理与 SailPoint IdentityIQ 应用服务器之间的网络连接
  • 如果在代理后面运行,请确保按照 Bindplane 代理要求打开防火墙端口
  • 具有管理员权限的 SailPoint IdentityIQ 应用服务器的特权访问权限

获取 Bindplane 代理的 Google SecOps 凭证

如需向 Google SecOps 验证 Bindplane 代理,请选择以下方法之一:

  • 新部署:使用 Chronicle API(选项 1)。
  • 旧版部署:继续使用提取身份验证文件(方法 2),直到提取 API 于 2027 年 7 月 20 日停用。
  1. 登录 Google Cloud 控制台,然后选择与您的 Google SecOps 实例关联的 Google Cloud 项目。
  2. 前往 IAM 和管理 > 服务账号。
  3. 点击创建服务账号。
  4. 提供以下配置详细信息:
    • 服务账号名称:输入账号的名称(例如 bindplane-ingest)。
    • 服务账号说明:输入说明(例如 Bindplane agent log ingestion)。
  5. 点击创建并继续。
  6. 在向此服务账号授予对项目的访问权限部分,点击选择角色,然后选择 Chronicle Editor。
  7. 点击继续,然后点击完成。
  8. 点击您创建的服务账号,然后前往密钥标签页。
  9. 依次点击添加密钥 > 创建新密钥。
  10. 选择 JSON,然后点击创建。密钥文件会下载到您的计算机上。
  11. 将密钥文件另存为 Bindplane 收集器目录(Linux 上的 /opt/observiq-otel-collector/ingestion-auth.json 或 Windows 上的 C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json)中的 ingestion-auth.json,或更新 config.yaml 中的 creds_file_path 以匹配您保存该文件的路径。
  12. 前往 IAM 和管理 > 设置,然后复制项目编号。您在配置导出器时需要用到该名称。

方法 2:下载数据注入身份验证文件(旧版)

  1. 登录 Google SecOps 控制台。
  2. 依次前往 SIEM 设置 > 收集代理。
  3. 下载数据注入身份验证文件。
  4. 将文件安全地保存在将要安装 Bindplane 代理的系统上。

获取 Google SecOps 客户 ID

  1. 登录 Google SecOps 控制台。
  2. 前往 SIEM 设置 > 个人资料。
  3. 复制并保存组织详细信息部分中的客户 ID。

安装 Bindplane 代理

根据以下说明,在 Windows 或 Linux 操作系统上安装 Bindplane 代理。

Windows 安装

  1. 以管理员身份打开命令提示符或 PowerShell。
  2. 运行以下命令:

    msiexec /i "https://github.com/observIQ/bindplane-agent/releases/latest/download/observiq-otel-collector.msi" /quiet
    
  3. 等待安装完成。

  4. 运行以下命令,验证安装是否成功:

    sc query observiq-otel-collector
    

    该服务应显示为正在运行。

Linux 安装

  1. 打开具有 root 或 sudo 权限的终端。
  2. 运行以下命令:

    sudo sh -c "$(curl -fsSlL https://github.com/observiq/bindplane-agent/releases/latest/download/install_unix.sh)" install_unix.sh
    
  3. 等待安装完成。

  4. 运行以下命令,验证安装是否成功:

    sudo systemctl status observiq-otel-collector
    

    该服务应显示为 active (running)。

其他安装资源

如需了解其他安装选项和问题排查,请参阅 Bindplane 代理安装指南。

配置 Bindplane 代理以注入 syslog 并发送到 Google SecOps

找到配置文件

  • Linux:

    sudo nano /opt/observiq-otel-collector/config.yaml
    
  • Windows:

    notepad "C:\Program Files\observIQ OpenTelemetry Collector\config.yaml"
    

修改配置文件

  • 将 config.yaml 的全部内容替换为以下配置:

    receivers:
      udplog:
        listen_address: "0.0.0.0:514"
    
    exporters:
      chronicle/sailpoint_iiq:
        protocol: https
        # Region of your instance, for example us, europe, asia-southeast1
        location: <LOCATION>
        # Project number of the Google Cloud project linked to the instance
        project: '<PROJECT_NUMBER>'
        compression: gzip
        creds_file_path: '/opt/observiq-otel-collector/ingestion-auth.json'
        customer_id: '<customer_id>'
        endpoint: chronicle.googleapis.com
        log_type: SAILPOINT_IIQ
        raw_log_field: body
    
    service:
      pipelines:
        logs/sailpoint_iiq_to_chronicle:
          receivers:
            - udplog
          exporters:
            - chronicle/sailpoint_iiq
    

配置参数

替换以下占位符:

  • 接收器配置:

    • listen_address:要监听的 IP 地址和端口:
      • 0.0.0.0 在所有接口上监听(推荐)
      • 端口 514 是标准 syslog 端口(在 Linux 上需要 root 权限;对于非 root 用户,请使用 1514)
  • 导出器配置:

    • creds_file_path:服务账号 JSON 密钥文件的完整路径(选项 1):
      • Linux:/opt/observiq-otel-collector/ingestion-auth.json
      • Windows:C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json
    • customer_id:从 Google SecOps 控制台复制的客户 ID
    • location:将 <LOCATION> 替换为 Google SecOps 实例所在的区域(例如 us、europe 或 asia-southeast1)。导出工具会在此值前面加上 chronicle.googleapis.com。如需查看完整列表,请参阅区域级端点。
    • project:将 <PROJECT_NUMBER> 替换为“IAM 和管理”>“设置”中的项目编号。
    • endpoint:保持设置为 chronicle.googleapis.com。

旧版提取 API 导出工具

  • 如果您使用选项 2 中的数据注入身份验证文件,请将 exporters 代码块替换为以下内容。将 creds_file_path 设置为数据注入身份验证文件的路径,如果您的实例位于美国境外,请将 malachiteingestion-pa.googleapis.com 替换为您的区域端点(例如 europe-malachiteingestion-pa.googleapis.com)。

    exporters:
      chronicle/sailpoint_iiq:
        compression: gzip
        creds_file_path: '/opt/observiq-otel-collector/ingestion-auth.json'
        customer_id: '<customer_id>'
        endpoint: malachiteingestion-pa.googleapis.com
        log_type: SAILPOINT_IIQ
        raw_log_field: body
    

保存配置文件

  • 修改后,保存文件:
    • Linux:依次按 Ctrl+O、Enter 和 Ctrl+X
    • Windows:依次点击文件 > 保存

重启 Bindplane 代理以应用更改

  • 如需在 Linux 中重启 Bindplane 代理,请运行以下命令:

    sudo systemctl restart observiq-otel-collector
    
    1. 验证服务是否正在运行:

      sudo systemctl status observiq-otel-collector
      
    2. 检查日志中是否存在错误:

      sudo journalctl -u observiq-otel-collector -f
      
  • 如需在 Windows 中重启 Bindplane 代理,请选择以下选项之一:

    • 以管理员身份运行命令提示符或 PowerShell:

      net stop observiq-otel-collector && net start observiq-otel-collector
      
    • 服务控制台:

      1. 按 Win+R,输入 services.msc,然后按 Enter 键。
      2. 找到 observIQ OpenTelemetry 收集器。
      3. 右键点击并选择重启。
      4. 验证服务是否正在运行:

        sc query observiq-otel-collector
        
      5. 检查日志中的错误:

        type "C:\Program Files\observIQ OpenTelemetry Collector\log\collector.log"
        

配置 SailPoint IdentityIQ syslog 转发

SailPoint IdentityIQ 使用 Log4j 进行日志记录。配置 syslog appender 以将日志转发到 Bindplane 代理。

  1. 以管理员身份登录 SailPoint IdentityIQ 服务器。
  2. 找到 Log4j 配置文件:
    • IdentityIQ 7.x 及更低版本: <TOMCAT_HOME>/webapps/identityiq/WEB-INF/classes/log4j.properties
    • IdentityIQ 8.0 及更高版本: <TOMCAT_HOME>/webapps/identityiq/WEB-INF/classes/log4j2.properties
  3. 在配置文件中添加或更新 syslog 附加器。对于 Log4j 1.x (log4j.properties):

    log4j.appender.SYSLOG=org.apache.log4j.net.SyslogAppender
    log4j.appender.SYSLOG.syslogHost=<BINDPLANE_AGENT_IP>
    log4j.appender.SYSLOG.port=514
    log4j.appender.SYSLOG.facility=LOCAL0
    log4j.appender.SYSLOG.layout=org.apache.log4j.PatternLayout
    log4j.appender.SYSLOG.layout.ConversionPattern=%d{ISO8601} %-5p %c - %m%n
    
  4. 对于 Log4j 2.x (log4j2.properties),请添加 Syslog 附加器:

    appender.syslog.type = Syslog
    appender.syslog.name = SYSLOG
    appender.syslog.host = <BINDPLANE_AGENT_IP>
    appender.syslog.port = 514
    appender.syslog.protocol = UDP
    appender.syslog.facility = LOCAL0
    appender.syslog.format = RFC 5424
    
  5. 将 syslog 附加器添加到根日志记录器:

    • Log4j 1.x:log4j.rootLogger=INFO, file, SYSLOG
    • Log4j 2.x:rootLogger.appenderRef.syslog.ref = SYSLOG
  6. 保存配置文件并重启 IdentityIQ 应用服务器(例如 Apache Tomcat),以使更改生效。

UDM 映射表

日志字段 UDM 映射 逻辑
api_module about.labels 已合并
data_label additional.fields 已合并
ou1_label additional.fields 已合并
ou2_label additional.fields 已合并
ou3_label additional.fields 已合并
ou4_label additional.fields 已合并
ou5_label additional.fields 已合并
ou6_label additional.fields 已合并
ou7_label additional.fields 已合并
temp_value_label additional.fields 已合并
type_label additional.fields 已合并
type_label1 additional.fields 已合并
type_temp_label additional.fields 已合并
value_label additional.fields 已合并
has_principal extensions.auth.type 已映射:true → AUTHTYPE_UNSPECIFIED
desc metadata.description 直接映射
description metadata.description 直接映射
left_message_data_doctype metadata.description 已重命名/已映射
left_message_systemd metadata.description 已重命名/已映射
created metadata.event_timestamp 已解析为 UNIX_MS
event_type metadata.event_type 直接映射
product_event_type metadata.product_event_type 直接映射
id metadata.product_log_id 直接映射
application principal.application 直接映射
client_host principal.asset.hostname 直接映射
host principal.asset.hostname 直接映射
client_ip principal.asset.ip 已合并
client_host principal.hostname 直接映射
displayName principal.hostname 直接映射
host principal.hostname 直接映射
identity principal.hostname 直接映射
log_origin principal.hostname 直接映射
client_ip principal.ip 已合并
ref principal.url 直接映射
display principal.user.user_display_name 直接映射
lauer principal.user.userid 直接映射
launcher principal.user.userid 直接映射
source principal.user.userid 直接映射
username principal.user.userid 直接映射
action security_result.action_details 直接映射
field_ security_result.detection_fields 已合并
event_level security_result.severity 映射值(总共 5 个,例如 (?i)Low → LOW、(?i)Informational → INFORMATIONAL、`(?i)…
server target.asset.hostname 直接映射
server_host target.asset.hostname 直接映射
server target.hostname 直接映射
server_host target.hostname 直接映射
不适用 extensions.auth.type 常量:AUTHTYPE_UNSPECIFIED
不适用 metadata.event_type 常量:SERVICE_START
不适用 metadata.product_name 常量:IAM
不适用 metadata.vendor_name 常量:SAILPOINT
不适用 security_result.severity 常量:LOW
不适用 target.application 常量:SailPointIIQ Web Application
created event.idm.read_only_udm.metadata.event_timestamp 从更新日志映射
lauer event.idm.read_only_udm.principal.user.userid 从更新日志映射
launcher event.idm.read_only_udm.principal.user.userid 从更新日志映射
source event.idm.read_only_udm.principal.user.userid 从更新日志映射
username event.idm.read_only_udm.principal.user.userid 从更新日志映射
host event.idm.read_only_udm.principal.hostname和event.idm.read_only_udm.principal.asset.hostname之间 从更新日志映射
client_host event.idm.read_only_udm.principal.hostname和event.idm.read_only_udm.principal.asset.hostname之间 从更新日志映射
server_host event.idm.read_only_udm.target.hostname和event.idm.read_only_udm.target.asset.hostname之间 从更新日志映射
server event.idm.read_only_udm.target.hostname和event.idm.read_only_udm.target.asset.hostname之间 从更新日志映射
client_host event.idm.read_only_udm.principal.ip和event.idm.read_only_udm.principal.asset.ip之间 从更新日志映射
action event.idm.read_only_udm.security_result.action_details 从更新日志映射
type event.idm.read_only_udm.security_result.detection_fields 从更新日志映射
completion_status event.idm.read_only_udm.security_result.detection_fields 从更新日志映射
name event.idm.read_only_udm.security_result.detection_fields 从更新日志映射
owner event.idm.read_only_udm.security_result.detection_fields 从更新日志映射
assigned_scope event.idm.read_only_udm.security_result.detection_fields 从更新日志映射
assigned_scope_path event.idm.read_only_udm.security_result.detection_fields 从更新日志映射
stack event.idm.read_only_udm.security_result.detection_fields 从更新日志映射
launched event.idm.read_only_udm.security_result.detection_fields 从更新日志映射
progress event.idm.read_only_udm.security_result.detection_fields 从更新日志映射
percent_complete event.idm.read_only_udm.security_result.detection_fields 从更新日志映射
expiration event.idm.read_only_udm.security_result.detection_fields 从更新日志映射
verified event.idm.read_only_udm.security_result.detection_fields 从更新日志映射
definition event.idm.read_only_udm.security_result.detection_fields 从更新日志映射
schedule event.idm.read_only_udm.security_result.detection_fields 从更新日志映射
pending_signoffs event.idm.read_only_udm.security_result.detection_fields 从更新日志映射
signoff event.idm.read_only_udm.security_result.detection_fields 从更新日志映射
report event.idm.read_only_udm.security_result.detection_fields 从更新日志映射
target_class event.idm.read_only_udm.security_result.detection_fields 从更新日志映射
target_id event.idm.read_only_udm.security_result.detection_fields 从更新日志映射
target_name event.idm.read_only_udm.security_result.detection_fields 从更新日志映射
task_terminated event.idm.read_only_udm.security_result.detection_fields 从更新日志映射
partitioned event.idm.read_only_udm.security_result.detection_fields 从更新日志映射
live event.idm.read_only_udm.security_result.detection_fields 从更新日志映射
run_length event.idm.read_only_udm.security_result.detection_fields 从更新日志映射
run_length_average event.idm.read_only_udm.security_result.detection_fields 从更新日志映射
run_length_deviation event.idm.read_only_udm.security_result.detection_fields 从更新日志映射
interface event.idm.read_only_udm.security_result.detection_fields 从更新日志映射
account_name event.idm.read_only_udm.security_result.detection_fields 从更新日志映射
instance event.idm.read_only_udm.security_result.detection_fields 从更新日志映射
attribute_name event.idm.read_only_udm.security_result.detection_fields 从更新日志映射
attribute_value event.idm.read_only_udm.security_result.detection_fields 从更新日志映射
tracking_id event.idm.read_only_udm.security_result.detection_fields 从更新日志映射
string1 event.idm.read_only_udm.security_result.detection_fields 从更新日志映射
string2 event.idm.read_only_udm.security_result.detection_fields 从更新日志映射
string3 event.idm.read_only_udm.security_result.detection_fields 从更新日志映射
string4 event.idm.read_only_udm.security_result.detection_fields 从更新日志映射
quick_key event.idm.read_only_udm.security_result.detection_fields 从更新日志映射
classname event.idm.read_only_udm.security_result.detection_fields 从更新日志映射
line_number event.idm.read_only_udm.security_result.detection_fields 从更新日志映射
thread event.idm.read_only_udm.security_result.detection_fields 从更新日志映射
stacktrace event.idm.read_only_udm.security_result.detection_fields 从更新日志映射
message_data event.idm.read_only_udm.security_result.detection_fields 从更新日志映射
target_data event.idm.read_only_udm.security_result.detection_fields 从更新日志映射
modified event.idm.read_only_udm.security_result.detection_fields 从更新日志映射
completed event.idm.read_only_udm.security_result.detection_fields 从更新日志映射
data_value event.idm.read_only_udm.security_result.detection_fields 从更新日志映射
attributes event.idm.read_only_udm.additional.fields 从更新日志映射

更新日志

查看相应解析器的更新日志

需要更多帮助?获得社区成员和 Google SecOps 专业人士的解答。