收集 SailPoint IdentityIQ 記錄
本文說明如何使用 Bindplane 代理程式,將 SailPoint IdentityIQ 記錄擷取至 Google Security Operations。
SailPoint IdentityIQ 是一個身分管理平台,可進行存取權認證、佈建及法規遵循管理。它透過 Log4j 設定支援系統記錄層級的記錄功能,可將稽核事件和應用程式記錄轉送至遠端系統記錄收集器。
事前準備
請確認您已完成下列事前準備事項:
- Google SecOps 執行個體
- Windows Server 2016 以上版本,或搭載
systemd的 Linux 主機 - Bindplane 代理程式與 SailPoint IdentityIQ 應用程式伺服器之間的網路連線
- 如果透過 Proxy 執行,請確保防火牆通訊埠已根據 Bindplane 代理程式需求開啟
- 具備管理員權限的 SailPoint IdentityIQ 應用程式伺服器特殊存取權
取得 Google SecOps 擷取驗證檔案
- 登入 Google SecOps 控制台。
- 依序前往「SIEM 設定」>「收集代理程式」。
- 下載擷取驗證檔案。
將檔案安全地儲存在要安裝 Bindplane 的系統上。
取得 Google SecOps 客戶 ID
- 登入 Google SecOps 控制台。
- 依序前往「SIEM 設定」>「設定檔」。
複製並儲存「機構詳細資料」部分中的客戶 ID。
安裝 Bindplane 代理程式
請按照下列操作說明,在 Windows 或 Linux 作業系統上安裝 Bindplane 代理程式。
Windows 安裝
- 以管理員身分開啟「命令提示字元」或「PowerShell」。
執行下列指令:
msiexec /i "https://github.com/observIQ/bindplane-agent/releases/latest/download/observiq-otel-collector.msi" /quiet等待安裝完成。
執行下列指令,確認安裝成功:
sc query observiq-otel-collector服務應顯示為「RUNNING」。
Linux 安裝
- 開啟具有根層級或 sudo 權限的終端機。
執行下列指令:
sudo sh -c "$(curl -fsSlL https://github.com/observiq/bindplane-agent/releases/latest/download/install_unix.sh)" install_unix.sh等待安裝完成。
執行下列指令,確認安裝成功:
sudo systemctl status observiq-otel-collector服務應顯示為有效 (執行中)。
其他安裝資源
如需其他安裝選項和疑難排解資訊,請參閱 Bindplane 代理程式安裝指南。
設定 Bindplane 代理程式,擷取系統記錄檔並傳送至 Google SecOps
找出設定檔
Linux:
sudo nano /opt/observiq-otel-collector/config.yamlWindows:
notepad "C:\Program Files\observIQ OpenTelemetry Collector\config.yaml"
編輯設定檔
將
config.yaml的所有內容替換為下列設定:receivers: udplog: listen_address: "0.0.0.0:514" exporters: chronicle/sailpoint_iiq: compression: gzip creds_file_path: '/etc/bindplane-agent/ingestion-auth.json' customer_id: '<customer_id>' endpoint: malachiteingestion-pa.googleapis.com log_type: SAILPOINT_IIQ raw_log_field: body service: pipelines: logs/sailpoint_iiq_to_chronicle: receivers: - udplog exporters: - chronicle/sailpoint_iiq
設定參數
替換下列預留位置:
接收器設定:
listen_address:要接聽的 IP 位址和通訊埠:0.0.0.0,監聽所有介面 (建議)- 通訊埠
514是標準的系統記錄通訊埠 (在 Linux 上需要根層級權限;非根層級權限請使用1514)
匯出工具設定:
creds_file_path:擷取驗證檔案的完整路徑:- Linux:
/etc/bindplane-agent/ingestion-auth.json - Windows:
C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json
- Linux:
customer_id:從 Google SecOps 控制台複製的客戶 IDendpoint:區域端點網址:- 美國:
malachiteingestion-pa.googleapis.com - 歐洲:
europe-malachiteingestion-pa.googleapis.com - 亞洲:
asia-southeast1-malachiteingestion-pa.googleapis.com - 如需完整清單,請參閱「區域端點」
- 美國:
儲存設定檔
- 編輯完成後,請儲存檔案:
- Linux:依序按下
Ctrl+O、Enter和Ctrl+X - Windows:依序點選「檔案」>「儲存」
- Linux:依序按下
重新啟動 Bindplane 代理程式,以套用變更
如要在 Linux 中重新啟動 Bindplane 代理程式,請執行下列指令:
sudo systemctl restart observiq-otel-collector確認服務正在執行:
sudo systemctl status observiq-otel-collector檢查記錄中是否有錯誤:
sudo journalctl -u observiq-otel-collector -f
如要在 Windows 中重新啟動 Bindplane 代理程式,請選擇下列其中一個選項:
以管理員身分開啟命令提示字元或 PowerShell:
net stop observiq-otel-collector && net start observiq-otel-collector服務控制台:
- 按下
Win+R,輸入services.msc,然後按下 Enter 鍵。 - 找出 observIQ OpenTelemetry Collector。
- 按一下滑鼠右鍵,然後選取「重新啟動」。
確認服務正在執行:
sc query observiq-otel-collector檢查記錄中是否有錯誤:
type "C:\Program Files\observIQ OpenTelemetry Collector\log\collector.log"
- 按下
設定 SailPoint IdentityIQ 系統記錄檔轉送
SailPoint IdentityIQ 使用 Log4j 記錄。設定系統記錄檔附加程式,將記錄轉送至 Bindplane 代理程式。
- 以管理員身分登入 SailPoint IdentityIQ 伺服器。
- 找出 Log4j 設定檔:
- IdentityIQ 7.x 和更早版本:
<TOMCAT_HOME>/webapps/identityiq/WEB-INF/classes/log4j.properties - IdentityIQ 8.0 以上版本:
<TOMCAT_HOME>/webapps/identityiq/WEB-INF/classes/log4j2.properties
- IdentityIQ 7.x 和更早版本:
在設定檔中新增或更新系統記錄附加程式。適用於 Log4j 1.x (
log4j.properties):log4j.appender.SYSLOG=org.apache.log4j.net.SyslogAppender log4j.appender.SYSLOG.syslogHost=<BINDPLANE_AGENT_IP> log4j.appender.SYSLOG.port=514 log4j.appender.SYSLOG.facility=LOCAL0 log4j.appender.SYSLOG.layout=org.apache.log4j.PatternLayout log4j.appender.SYSLOG.layout.ConversionPattern=%d{ISO8601} %-5p %c - %m%n如果是 Log4j 2.x (
log4j2.properties),請新增系統記錄檔附加程式:appender.syslog.type = Syslog appender.syslog.name = SYSLOG appender.syslog.host = <BINDPLANE_AGENT_IP> appender.syslog.port = 514 appender.syslog.protocol = UDP appender.syslog.facility = LOCAL0 appender.syslog.format = RFC 5424將 syslog appender 新增至根記錄器:
- Log4j 1.x:
log4j.rootLogger=INFO, file, SYSLOG - Log4j 2.x:
rootLogger.appenderRef.syslog.ref = SYSLOG
- Log4j 1.x:
儲存設定檔,然後重新啟動 IdentityIQ 應用程式伺服器 (例如 Apache Tomcat),變更才會生效。
UDM 對應表
| 記錄欄位 | UDM 對應 | 邏輯 |
|---|---|---|
api_module |
about.labels |
已合併 |
data_label |
additional.fields |
已合併 |
ou1_label |
additional.fields |
已合併 |
ou2_label |
additional.fields |
已合併 |
ou3_label |
additional.fields |
已合併 |
ou4_label |
additional.fields |
已合併 |
ou5_label |
additional.fields |
已合併 |
ou6_label |
additional.fields |
已合併 |
ou7_label |
additional.fields |
已合併 |
temp_value_label |
additional.fields |
已合併 |
type_label |
additional.fields |
已合併 |
type_label1 |
additional.fields |
已合併 |
type_temp_label |
additional.fields |
已合併 |
value_label |
additional.fields |
已合併 |
has_principal |
extensions.auth.type |
已對應:true → AUTHTYPE_UNSPECIFIED |
desc |
metadata.description |
直接對應 |
description |
metadata.description |
直接對應 |
left_message_data_doctype |
metadata.description |
已重新命名/對應 |
left_message_systemd |
metadata.description |
已重新命名/對應 |
created |
metadata.event_timestamp |
已剖析為 UNIX_MS |
event_type |
metadata.event_type |
直接對應 |
product_event_type |
metadata.product_event_type |
直接對應 |
id |
metadata.product_log_id |
直接對應 |
application |
principal.application |
直接對應 |
client_host |
principal.asset.hostname |
直接對應 |
host |
principal.asset.hostname |
直接對應 |
client_ip |
principal.asset.ip |
已合併 |
client_host |
principal.hostname |
直接對應 |
displayName |
principal.hostname |
直接對應 |
host |
principal.hostname |
直接對應 |
identity |
principal.hostname |
直接對應 |
log_origin |
principal.hostname |
直接對應 |
client_ip |
principal.ip |
已合併 |
ref |
principal.url |
直接對應 |
display |
principal.user.user_display_name |
直接對應 |
lauer |
principal.user.userid |
直接對應 |
launcher |
principal.user.userid |
直接對應 |
source |
principal.user.userid |
直接對應 |
username |
principal.user.userid |
直接對應 |
action |
security_result.action_details |
直接對應 |
field_ |
security_result.detection_fields |
已合併 |
event_level |
security_result.severity |
對應值 (共 5 個,例如 (?i)Low → LOW、(?i)Informational → INFORMATIONAL、`(?i)... |
server |
target.asset.hostname |
直接對應 |
server_host |
target.asset.hostname |
直接對應 |
server |
target.hostname |
直接對應 |
server_host |
target.hostname |
直接對應 |
| 不適用 | extensions.auth.type |
常數:AUTHTYPE_UNSPECIFIED |
| 不適用 | metadata.event_type |
常數:SERVICE_START |
| 不適用 | metadata.product_name |
常數:IAM |
| 不適用 | metadata.vendor_name |
常數:SAILPOINT |
| 不適用 | security_result.severity |
常數:LOW |
| 不適用 | target.application |
常數:SailPointIIQ Web Application |
created |
event.idm.read_only_udm.metadata.event_timestamp |
從變更記錄對應 |
lauer |
event.idm.read_only_udm.principal.user.userid |
從變更記錄對應 |
launcher |
event.idm.read_only_udm.principal.user.userid |
從變更記錄對應 |
source |
event.idm.read_only_udm.principal.user.userid |
從變更記錄對應 |
username |
event.idm.read_only_udm.principal.user.userid |
從變更記錄對應 |
host |
event.idm.read_only_udm.principal.hostname 和 event.idm.read_only_udm.principal.asset.hostname |
從變更記錄對應 |
client_host |
event.idm.read_only_udm.principal.hostname 和 event.idm.read_only_udm.principal.asset.hostname |
從變更記錄對應 |
server_host |
event.idm.read_only_udm.target.hostname 和 event.idm.read_only_udm.target.asset.hostname |
從變更記錄對應 |
server |
event.idm.read_only_udm.target.hostname 和 event.idm.read_only_udm.target.asset.hostname |
從變更記錄對應 |
client_host |
event.idm.read_only_udm.principal.ip 和 event.idm.read_only_udm.principal.asset.ip |
從變更記錄對應 |
action |
event.idm.read_only_udm.security_result.action_details |
從變更記錄對應 |
type |
event.idm.read_only_udm.security_result.detection_fields |
從變更記錄對應 |
completion_status |
event.idm.read_only_udm.security_result.detection_fields |
從變更記錄對應 |
name |
event.idm.read_only_udm.security_result.detection_fields |
從變更記錄對應 |
owner |
event.idm.read_only_udm.security_result.detection_fields |
從變更記錄對應 |
assigned_scope |
event.idm.read_only_udm.security_result.detection_fields |
從變更記錄對應 |
assigned_scope_path |
event.idm.read_only_udm.security_result.detection_fields |
從變更記錄對應 |
stack |
event.idm.read_only_udm.security_result.detection_fields |
從變更記錄對應 |
launched |
event.idm.read_only_udm.security_result.detection_fields |
從變更記錄對應 |
progress |
event.idm.read_only_udm.security_result.detection_fields |
從變更記錄對應 |
percent_complete |
event.idm.read_only_udm.security_result.detection_fields |
從變更記錄對應 |
expiration |
event.idm.read_only_udm.security_result.detection_fields |
從變更記錄對應 |
verified |
event.idm.read_only_udm.security_result.detection_fields |
從變更記錄對應 |
definition |
event.idm.read_only_udm.security_result.detection_fields |
從變更記錄對應 |
schedule |
event.idm.read_only_udm.security_result.detection_fields |
從變更記錄對應 |
pending_signoffs |
event.idm.read_only_udm.security_result.detection_fields |
從變更記錄對應 |
signoff |
event.idm.read_only_udm.security_result.detection_fields |
從變更記錄對應 |
report |
event.idm.read_only_udm.security_result.detection_fields |
從變更記錄對應 |
target_class |
event.idm.read_only_udm.security_result.detection_fields |
從變更記錄對應 |
target_id |
event.idm.read_only_udm.security_result.detection_fields |
從變更記錄對應 |
target_name |
event.idm.read_only_udm.security_result.detection_fields |
從變更記錄對應 |
task_terminated |
event.idm.read_only_udm.security_result.detection_fields |
從變更記錄對應 |
partitioned |
event.idm.read_only_udm.security_result.detection_fields |
從變更記錄對應 |
live |
event.idm.read_only_udm.security_result.detection_fields |
從變更記錄對應 |
run_length |
event.idm.read_only_udm.security_result.detection_fields |
從變更記錄對應 |
run_length_average |
event.idm.read_only_udm.security_result.detection_fields |
從變更記錄對應 |
run_length_deviation |
event.idm.read_only_udm.security_result.detection_fields |
從變更記錄對應 |
interface |
event.idm.read_only_udm.security_result.detection_fields |
從變更記錄對應 |
account_name |
event.idm.read_only_udm.security_result.detection_fields |
從變更記錄對應 |
instance |
event.idm.read_only_udm.security_result.detection_fields |
從變更記錄對應 |
attribute_name |
event.idm.read_only_udm.security_result.detection_fields |
從變更記錄對應 |
attribute_value |
event.idm.read_only_udm.security_result.detection_fields |
從變更記錄對應 |
tracking_id |
event.idm.read_only_udm.security_result.detection_fields |
從變更記錄對應 |
string1 |
event.idm.read_only_udm.security_result.detection_fields |
從變更記錄對應 |
string2 |
event.idm.read_only_udm.security_result.detection_fields |
從變更記錄對應 |
string3 |
event.idm.read_only_udm.security_result.detection_fields |
從變更記錄對應 |
string4 |
event.idm.read_only_udm.security_result.detection_fields |
從變更記錄對應 |
quick_key |
event.idm.read_only_udm.security_result.detection_fields |
從變更記錄對應 |
classname |
event.idm.read_only_udm.security_result.detection_fields |
從變更記錄對應 |
line_number |
event.idm.read_only_udm.security_result.detection_fields |
從變更記錄對應 |
thread |
event.idm.read_only_udm.security_result.detection_fields |
從變更記錄對應 |
stacktrace |
event.idm.read_only_udm.security_result.detection_fields |
從變更記錄對應 |
message_data |
event.idm.read_only_udm.security_result.detection_fields |
從變更記錄對應 |
target_data |
event.idm.read_only_udm.security_result.detection_fields |
從變更記錄對應 |
modified |
event.idm.read_only_udm.security_result.detection_fields |
從變更記錄對應 |
completed |
event.idm.read_only_udm.security_result.detection_fields |
從變更記錄對應 |
data_value |
event.idm.read_only_udm.security_result.detection_fields |
從變更記錄對應 |
attributes |
event.idm.read_only_udm.additional.fields |
從變更記錄對應 |
變更記錄
還有其他問題嗎?向社群成員和 Google SecOps 專業人員尋求答案。