收集 Snort IDS 記錄
本文說明如何使用 Bindplane 代理程式,將 Snort IDS 記錄擷取至 Google Security Operations。
Snort 是開放原始碼的入侵偵測與防範系統,可產生系統記錄訊息,用於網路入侵快訊、通訊協定分析事件和流量異常。剖析器會使用 grok 模式從 syslog 格式和 JSON 格式的記錄檔中擷取欄位,並將這些欄位對應至統合式資料模型 (UDM)。
事前準備
請確認您已完成下列事前準備事項:
- Google SecOps 執行個體
- Windows Server 2016 以上版本,或搭載
systemd的 Linux 主機 - Bindplane 代理程式與 Snort 裝置之間的網路連線
- 如果是在 Proxy 後方執行,請確認防火牆通訊埠已按照 Bindplane 代理程式規定開啟
- Snort 裝置的終端機存取權
取得 Bindplane 代理程式的 Google SecOps 憑證
如要向 Google SecOps 驗證 Bindplane 代理程式,請選擇下列其中一種方法:
- 新部署作業:使用 Chronicle API (選項 1)。
- 舊版部署作業:在 2027 年 7 月 20 日停用 Ingestion API 前,請繼續使用擷取驗證檔案 (選項 2)。
方法 1:為 Chronicle API 建立服務帳戶 (建議)
- 登入 Google Cloud 控制台,然後選取連結至 Google SecOps 執行個體的 Google Cloud 專案。
- 依序前往 「IAM & Admin」(IAM 與管理) >「Service Accounts」(服務帳戶)。
- 按一下「建立服務帳戶」。
- 提供下列設定詳細資料:
- 「Service account name」(服務帳戶名稱):輸入帳戶名稱 (例如
bindplane-ingest)。 - 「服務帳戶說明」:輸入說明 (例如
Bindplane agent log ingestion)。
- 「Service account name」(服務帳戶名稱):輸入帳戶名稱 (例如
- 點按「Create and continue」(建立並繼續)。
- 在「將專案存取權授予這個服務帳戶」部分,按一下「選取角色」,然後選取「Chronicle 編輯者」。
- 依序點選「繼續」和「完成」。
- 按一下您建立的服務帳戶,然後前往「金鑰」分頁。
- 依序點選「新增金鑰」>「建立新的金鑰」。
- 選取「JSON」,然後按一下「建立」。金鑰檔案會下載到電腦。
- 將金鑰檔案儲存為 Bindplane 收集器目錄中的
ingestion-auth.json(Linux 為/opt/observiq-otel-collector/ingestion-auth.json,Windows 為C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json),或更新config.yaml中的creds_file_path,使其與儲存檔案的路徑相符。 - 依序前往「IAM & Admin」(IAM 與管理) >「Settings」(設定),然後複製「Project number」(專案編號)。匯出工具設定時會用到。
方法 2:下載擷取驗證檔案 (舊版)
- 登入 Google SecOps 控制台。
- 依序前往「SIEM Settings」 > 「Collection Agents」。
- 下載擷取驗證檔案。
- 將檔案安全地儲存在要安裝 Bindplane 代理程式的系統上。
取得 Google SecOps 客戶 ID
- 登入 Google SecOps 控制台。
- 依序前往「SIEM 設定」>「設定檔」。
複製並儲存「機構詳細資料」部分的客戶 ID。
安裝 Bindplane 代理程式
請按照下列操作說明,在 Windows 或 Linux 作業系統上安裝 Bindplane 代理程式。
Windows 安裝
- 以管理員身分開啟命令提示字元或 PowerShell。
執行下列指令:
msiexec /i "https://github.com/observIQ/bindplane-agent/releases/latest/download/observiq-otel-collector.msi" /quiet等待安裝完成。
執行下列指令,確認安裝成功:
sc query observiq-otel-collector服務應顯示為「RUNNING」。
安裝 Linux
- 開啟具有 root 或 sudo 權限的終端機。
執行下列指令:
sudo sh -c "$(curl -fsSlL https://github.com/observiq/bindplane-agent/releases/latest/download/install_unix.sh)" install_unix.sh等待安裝完成。
執行下列指令,確認安裝成功:
sudo systemctl status observiq-otel-collector服務應顯示為「active (running)」。
其他安裝資源
如需其他安裝選項和疑難排解資訊,請參閱 Bindplane 代理程式安裝指南。
設定 Bindplane 代理程式,擷取系統記錄並傳送至 Google SecOps
找出設定檔
Linux:
sudo nano /opt/observiq-otel-collector/config.yamlWindows:
notepad "C:\Program Files\observIQ OpenTelemetry Collector\config.yaml"
編輯設定檔
將
config.yaml的全部內容替換為下列設定:receivers: udplog: listen_address: "0.0.0.0:514" exporters: chronicle/snort_ids: protocol: https # Region of your instance, for example us, europe, asia-southeast1 location: <LOCATION> # Project number of the Google Cloud project linked to the instance project: '<PROJECT_NUMBER>' compression: gzip creds_file_path: '/opt/observiq-otel-collector/ingestion-auth.json' customer_id: '<customer_id>' endpoint: chronicle.googleapis.com log_type: SNORT_IDS raw_log_field: body service: pipelines: logs/snort_ids_to_chronicle: receivers: - udplog exporters: - chronicle/snort_ids
設定參數
請替換下列預留位置:
接收器設定:
listen_address:要接聽的 IP 位址和通訊埠:0.0.0.0:在所有介面上監聽 (建議)- 通訊埠
514是標準 syslog 通訊埠 (在 Linux 上需要根目錄;非根目錄請使用1514)
匯出工具設定:
creds_file_path:服務帳戶 JSON 金鑰檔案的完整路徑 (選項 1):- Linux:
/opt/observiq-otel-collector/ingestion-auth.json - Windows:
C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json
- Linux:
customer_id:從 Google SecOps 控制台複製的客戶 IDlocation:將<LOCATION>替換為 Google SecOps 執行個體的區域 (例如us、europe或asia-southeast1)。匯出工具會以這個值做為chronicle.googleapis.com的前置字元。如需完整清單,請參閱「區域性端點」。project:將<PROJECT_NUMBER>替換為「IAM 與管理」>「設定」中的專案編號。endpoint:維持設為chronicle.googleapis.com。
舊版擷取 API 匯出工具
如果您使用選項 2 的擷取驗證檔案,請將
exporters區塊替換為下列內容。將creds_file_path設為擷取驗證檔案的路徑,如果您的執行個體位於美國境外,請將malachiteingestion-pa.googleapis.com替換為區域端點 (例如europe-malachiteingestion-pa.googleapis.com)。exporters: chronicle/snort_ids: compression: gzip creds_file_path: '/opt/observiq-otel-collector/ingestion-auth.json' customer_id: '<customer_id>' endpoint: malachiteingestion-pa.googleapis.com log_type: SNORT_IDS raw_log_field: body
儲存設定檔
- 編輯完畢後,請儲存檔案:
- Linux:依序按下
Ctrl+O、Enter和Ctrl+X - Windows:依序點選「檔案」 > 「儲存」
- Linux:依序按下
重新啟動 Bindplane 代理程式,套用變更
如要在 Linux 中重新啟動 Bindplane 代理程式,請執行下列指令:
sudo systemctl restart observiq-otel-collector確認服務正在執行:
sudo systemctl status observiq-otel-collector查看記錄檔是否有錯誤:
sudo journalctl -u observiq-otel-collector -f
如要在 Windows 中重新啟動 Bindplane 代理程式,請選擇下列其中一個選項:
以管理員身分開啟命令提示字元或 PowerShell:
net stop observiq-otel-collector && net start observiq-otel-collector服務控制台:
- 按下
Win+R鍵,輸入services.msc,然後按下 Enter 鍵。 - 找出「observIQ OpenTelemetry Collector」。
- 按一下滑鼠右鍵,然後選取「重新啟動」。
確認服務正在執行:
sc query observiq-otel-collector查看記錄檔是否有錯誤:
type "C:\Program Files\observIQ OpenTelemetry Collector\log\collector.log"
- 按下
在 Snort v2.x 上設定系統記錄匯出功能
- 使用終端機登入 Snort 裝置。
- 編輯下列檔案:
/etc/snort/snort.conf。 - 前往
6) Configure output plugins。 新增下列項目:
# syslog output alert_syslog: host=<BINDPLANE_IP>:<PORT_NUMBER>, LOG_AUTH LOG_ALERT- 將
<BINDPLANE_IP>替換為 Bindplane 代理程式 IP 位址,並將<PORT_NUMBER>替換為通訊埠編號。
- 將
儲存檔案。
啟動 snort 服務。
停止 rsyslog 服務。
編輯下列檔案:
/etc/rsyslogd.conf:# remote host is: name/ip:port *.* @@<BINDPLANE_IP>:<PORT_NUMBER>- 將
<BINDPLANE_IP>替換為 Bindplane 代理程式 IP 位址,並將<PORT_NUMBER>替換為連接埠號碼。
- 將
啟動 rsyslog 服務。
在 Snort v3.1.53 設定系統記錄匯出功能
- 使用終端機登入 Snort 裝置。
- 停止 rsyslog 和 snort 服務。
- 前往 Snort 安裝目錄:
/usr/local/etc/snort/。 - 編輯 Snort 設定檔:
snort.lua。 在「Configure outputs」(設定輸出) 選項中,附加下列程式碼:
alert_syslog = { facility = 'local3', level = 'info', }儲存 Snort 設定檔。
前往 rsyslog 服務預設設定檔目錄:
/etc/rsyslog.d。建立新檔案:
3-snort.conf。如要透過 TCP 或 UDP 傳送記錄,請新增下列設定:
local3.* @@<BINDPLANE_IP>:<PORT_NUMBER>- 將
<BINDPLANE_IP>替換為 Bindplane 代理程式 IP 位址,並將<PORT_NUMBER>替換為通訊埠編號。
- 將
儲存檔案。
啟動 rsyslog,然後啟動 snort 服務。
UDM 對應表
| 記錄欄位 | UDM 對應 | 邏輯 |
|---|---|---|
| agent.hostname | observer.hostname | 值取自原始記錄中的 agent.hostname 欄位。 |
| agent.id | observer.asset_id | 取自原始記錄中 agent.id 欄位的值,並與 agent.type 串連,如下所示:agent.type:agent.id。 |
| agent.type | observer.application | 值取自原始記錄中的 agent.type 欄位。 |
| agent.version | observer.platform_version | 取自原始記錄中的 agent.version 欄位值。 |
| alert.category | security_result.category_details | 值取自原始記錄中的 alert.category 欄位。 |
| alert.rev | security_result.rule_version | 值取自原始記錄中的 alert.rev 欄位。 |
| alert.rule | security_result.summary | 值取自原始記錄中的 alert.rule 欄位,並移除雙引號。 |
| alert.severity | security_result.severity | 如果 alert.severity 大於或等於 4,請設為 LOW。如果 alert.severity 為 2 或 3,請設為 MEDIUM。如果 alert.severity 為 1,請設為 HIGH。否則,請設為 UNKNOWN_SEVERITY。 |
| alert.signature | security_result.rule_name | 值取自原始記錄中的 alert.signature 欄位。 |
| alert.signature_id | security_result.rule_id | 值取自原始記錄中的 alert.signature_id 欄位。 |
| app_proto | network.application_protocol | 如果 app_proto 是 dns、smb 或 http,請轉換為大寫並使用該值。否則,請設為 UNKNOWN_APPLICATION_PROTOCOL。 |
| category | security_result.category | 如果 category 為 trojan-activity,請設為 NETWORK_MALICIOUS。如果 category 為 policy-violation,請設為 POLICY_VIOLATION。否則請設為 UNKNOWN_CATEGORY。 |
| classtype | security_result.rule_type | 如果原始記錄中的 classtype 欄位不為空白或 unknown,則會從該欄位擷取值。 |
| community_id | network.community_id | 值取自原始記錄中的 community_id 欄位。 |
| date_log | 如果 time 欄位空白,則用於設定事件時間戳記。 |
|
| 遞減 | metadata.description | 值取自原始記錄中的 desc 欄位。 |
| dest_ip | target.ip | 取自原始記錄中的 dest_ip 欄位值。 |
| dest_port | target.port | 從原始記錄的 dest_port 欄位擷取值,並轉換為整數。 |
| dstport | target.port | 從原始記錄的 dstport 欄位擷取值,並轉換為整數。 |
| file.filename | security_result.about.file.full_path | 如果原始記錄中的 file.filename 欄位並非空白或 /,則會從該欄位擷取值。 |
| file.size | security_result.about.file.size | 從原始記錄的 file.size 欄位取得值,並轉換為不帶正負號的整數。 |
| host.name | principal.hostname | 值取自原始記錄中的 host.name 欄位。 |
| 主機名稱 | principal.hostname | 值取自原始記錄中的 hostname 欄位。 |
| inter_host | intermediary.hostname | 取自原始記錄中的 inter_host 欄位值。 |
| log.file.path | principal.process.file.full_path | 值取自原始記錄中的 log.file.path 欄位。 |
| metadata.version | metadata.product_version | 取自原始記錄中的 metadata.version 欄位值。 |
| proto | network.ip_protocol | 取自原始記錄中的 proto 欄位值。如果是數字,系統會使用對照表將其轉換為對應的 IP 通訊協定名稱。 |
| rule_name | security_result.rule_name | 取自原始記錄中的 rule_name 欄位值。 |
| signature_id | security_result.rule_id | 取自原始記錄中的 signature_id 欄位值。 |
| signature_rev | security_result.rule_version | 取自原始記錄中的 signature_rev 欄位值。 |
| src_ip | principal.ip | 值取自原始記錄中的 src_ip 欄位。 |
| src_port | principal.port | 從原始記錄的 src_port 欄位取得值,並轉換為整數。 |
| srcport | principal.port | 從原始記錄的 srcport 欄位取得值,並轉換為整數。 |
| 時間 | 用於設定事件時間戳記。 | |
| metadata.event_type | 一律設為 SCAN_NETWORK。 |
|
| metadata.log_type | 硬式編碼為 SNORT_IDS。 |
|
| metadata.product_name | 硬式編碼為 SNORT_IDS。 |
|
| metadata.vendor_name | 硬式編碼為 SNORT。 |
|
| security_result.action | 如果 alert.action 為 allowed,請設為 ALLOW,否則設為 UNKNOWN_ACTION。 |
變更記錄
還有其他問題嗎?向社群成員和 Google SecOps 專業人員尋求解答。