收集 Sophos Central 日志

支持的平台:

本文档介绍了如何使用 Bindplane 收集 Sophos Central 日志。解析器会将 JSON 日志转换为统一数据模型 (UDM)。它会从嵌套的 JSON 结构中提取字段,将其映射到 UDM 字段,并根据 type 字段执行事件分类,从而针对不同的 Sophos Central 事件类型丰富数据,添加具体详情和操作。

准备工作

请确保满足以下前提条件:

  • Google SecOps 实例。
  • 您使用的是 Windows 2016 或更高版本,或者使用带有 systemd 的 Linux 主机。
  • 您有另一台能够持续运行 Python 的 Windows 或 Linux 计算机。
  • 如果通过代理运行,请确保防火墙端口已根据 Bindplane 代理要求打开。
  • 对 Sophos Central 管理控制台的特权访问权限。

获取 Google SecOps 注入身份验证文件

  1. 登录 Google SecOps 控制台
  2. 依次前往 SIEM 设置 > 收集代理
  3. 下载数据注入身份验证文件
    • 将文件安全地保存在将要安装 Bindplane 的系统上。

获取 Google SecOps 客户 ID

  1. 登录 Google SecOps 控制台
  2. 依次前往 SIEM 设置 > 配置文件
  3. 复制并保存组织详细信息部分中的客户 ID

安装 Bindplane 代理

按照以下说明在 Windows 或 Linux 操作系统上安装 Bindplane 代理。

Windows 安装

  1. 以管理员身份打开命令提示符PowerShell
  2. 运行以下命令:

    msiexec /i "[https://github.com/observIQ/bindplane-agent/releases/latest/download/observiq-otel-collector.msi](https://github.com/observIQ/bindplane-agent/releases/latest/download/observiq-otel-collector.msi)" /quiet
    

Linux 安装

  1. 打开具有 root 或 sudo 权限的终端。
  2. 运行以下命令:

    sudo sh -c "$(curl -fsSlL [https://github.com/observiq/bindplane-agent/releases/latest/download/install_unix.sh](https://github.com/observiq/bindplane-agent/releases/latest/download/install_unix.sh))" install_unix.sh
    

其他安装资源

如需了解其他安装选项,请参阅此安装指南

配置 Bindplane 代理以注入 Syslog 并将其发送到 Google SecOps

  1. 访问配置文件:

    • 找到 config.yaml 文件。通常,该文件位于 Linux 上的 /opt/observiq-otel-collector/ 目录中或 Windows 上的安装目录中。
    • 使用文本编辑器(例如 nanovi 或记事本)打开该文件。
  2. 按如下方式修改 config.yaml 文件:

    receivers:
    udplog:
       # Replace the port and IP address as required
       listen_address: "0.0.0.0:514"
    
    exporters:
    chronicle/chronicle_w_labels:
       compression: gzip
       # Adjust the path to the credentials file you downloaded in Step 1
       creds_file_path: '/path/to/ingestion-authentication-file.json'
       # Replace with your actual customer ID from Step 2
       customer_id: '<customer_id>'
       endpoint: malachiteingestion-pa.googleapis.com
       # Add optional ingestion labels for better organization
       log_type: 'SOPHOS_CENTRAL'
       raw_log_field: body
       ingestion_labels:
    
    service:
    pipelines:
       logs/source0__chronicle_w_labels-0:
          receivers:
          - udplog
          exporters:
          - chronicle/chronicle_w_labels
    
  3. 根据基础架构的需要替换端口和 IP 地址。

  4. <customer_id> 替换为实际的客户 ID

  5. /path/to/ingestion-authentication-file.json 更新为在第 1 步中保存身份验证文件的文件路径。

重启 Bindplane 代理以应用更改

  1. 如需在 Linux 中重启 Bindplane 代理,请运行以下命令:

    /opt/observiq-otel-collector/config.yaml
    
  2. 如需在 Windows 中重启 Bindplane 代理,您可以使用服务控制台,也可以输入以下命令:

    net stop BindPlaneAgent && net start BindPlaneAgent
    

配置 Sophos Central API 访问权限

  1. 登录 Sophos Central Admin
  2. 依次选择全局设置 > API 令牌管理
  3. 点击添加令牌以创建新令牌。
  4. 输入令牌名称,然后点击保存。系统会显示所提供令牌的 API 令牌摘要
  5. API 令牌摘要部分,点击复制以复制 API 访问网址和标头。

在其他机器上安装 Python

  1. 打开网络浏览器,然后前往 Python 网站
  2. 点击适用于您的操作系统(Windows 或 Mac)的 Download Python
  3. 安装 Python:

    • 在 Windows 上:
      1. 运行安装程序。
      2. 勾选显示 Add Python to PATH 的复选框。
      3. 点击立即安装
    • 在 Mac 上:
      1. Python 可能已安装;如果未安装,您可以使用终端安装最新版本。
      2. 打开终端,然后输入以下命令进行验证:
    python --version
    

下载 Sophos 集成脚本

  1. 前往 Sophos Central SIEM Integration Repository 的 GitHub 页面。
  2. 依次点击绿色的代码按钮 > 下载 ZIP
  3. 提取 ZIP 文件。

设置脚本配置

  1. 使用文本编辑器找到并打开 config.ini 文件。
  2. 修改配置文件:
    • API 令牌:输入之前从 Sophos Central 复制的 API 密钥。
    • Syslog 服务器详细信息:输入 syslog 服务器的详细信息。
    • Host:输入 Bindplane IP 地址。
    • 端口:输入 Bindplane 端口号。
    • 协议:输入 UDP(您也可以根据自己的设置使用 TCPTLS)。
  3. 保存文件。

运行脚本

  1. 前往脚本文件夹。
    • 在 Windows 上:
      1. Windows 键,然后输入 cmd
      2. 点击命令提示符
      3. 前往相应文件夹: cmd cd C:\Users\YourName\Downloads\Sophos-Central-SIEM-Integration
    • 在 macOS 上:
      1. 依次前往应用 > 实用程序
      2. 打开终端
      3. 前往相应文件夹: bash cd /Users/YourName/Downloads/Sophos-Central-SIEM-Integration
  2. 运行脚本:

    • 输入以下命令以启动脚本:
    python siem.py
    

自动运行脚本以实现持续运行

在 Windows 上(使用任务计划程序)

  1. 在“开始”菜单中输入“任务计划程序”,打开任务计划程序
  2. 点击创建任务
  3. 常规标签页中:
    • 为任务命名(例如 Sophos Central Log Export)。
  4. 触发器标签页中:
    • 点击新建,并将任务设置为每天启动时运行。
  5. 操作标签页中:
    • 点击新建,然后选择启动程序
    • 浏览 python.exe 可执行文件(通常位于 C:\PythonXX\python.exe)。
    • 添加实参字段中,输入脚本的路径(例如 C:\Users\YourName\Downloads\Sophos-Central-SIEM-Integration\siem.py)。
  6. 点击确定以保存任务。

在 Mac 上(使用 Cron 作业)

  1. 打开终端
  2. 输入 crontab -e 并按 Enter 键。
  3. 在文件末尾添加新行:

    * * * * * /usr/bin/python /Users/YourName/Downloads/Sophos-Central-SIEM-Integration/siem.py
    
  4. 保存并退出编辑器。

UDM 映射表

日志字段 UDM 映射 逻辑
created_at_label additional.fields 已合并
datastream_label additional.fields 已合并
security_result.description metadata.description 已重命名/已映射
end metadata.event_timestamp 解析为 RFC 3339
when metadata.event_timestamp 解析为 RFC 3339
has_principal metadata.event_type 已映射:trueFILE_OPENtrueNETWORK_CONNECTIONtrueSCAN_UNCATEGORIZED
type metadata.event_type 映射值(共 14 个,例如 Event::Endpoint::DataLossPreventionAutomaticallyAllowed → `F...
type metadata.product_event_type 直接映射
type network.direction 已映射:Event::Endpoint::WebControlViolationOUTBOUND,`Event::Endpoint::WindowsFirewa...
type network.ip_protocol 已映射:Event::Endpoint::WebControlViolationTCP
dhost principal.asset.hostname 直接映射
location principal.asset.hostname 直接映射
data.source_info.ip principal.asset.ip 已合并
source_info.ip principal.asset.ip 已合并
dhost principal.hostname 直接映射
location principal.hostname 直接映射
data.source_info.ip principal.ip 已合并
source_info.ip principal.ip 已合并
type principal.user.attribute.labels 已映射:Event::Endpoint::DataLossPreventionAutomaticallyAllowedusername_label
username_label principal.user.attribute.labels 已合并
Username principal.user.user_display_name 直接映射
source principal.user.user_display_name 直接映射
source principal.user.userid 直接映射
suser principal.user.userid 直接映射
user_id principal.user.userid 直接映射
endpoint_type_label security_result.about.labels 已合并
sec_action security_result.action 已合并
type security_result.action 映射:Event::Endpoint::DataLossPreventionAutomaticallyAllowedsec_action,`Event::En...
group security_result.category_details 已合并
name security_result.description 直接映射
type security_result.description 已映射:Event::Endpoint::(UpdateRebootRequired/ServiceNotRunning/NonCompliant/OutOfDate) →...
duid_label security_result.detection_fields 已合并
id_label security_result.detection_fields 已合并
rule security_result.rule_name 直接映射
rules security_result.rule_name 直接映射
severity security_result.severity 映射:lowLOWmediumMEDIUMhighHIGH
security_result.description security_result.summary 已重命名/已映射
app target.application 直接映射
application target.application 直接映射
dhost target.asset.hostname 直接映射
endpoint_id target.asset_id 直接映射
f_path target.file.full_path 直接映射
f_size target.file.size 已重命名/已映射
dhost target.hostname 直接映射
application target.process.file.full_path 直接映射
core_remedy_items.items.0.descriptor target.process.file.full_path 直接映射
data.core_remedy_items.items.0.descriptor target.process.file.full_path 直接映射
file_path_1 target.process.file.full_path 直接映射
customer_id target.resource.id 直接映射
p_device target.resource.name 直接映射
scan_name target.resource.name 直接映射
type target.resource.name 已映射:Event::Endpoint::SavDisabledReal time protection,`Event::Endpoint::Registere...
type target.resource.type 映射的值(总共 5 个,例如 Event::Endpoint::SavDisabledSETTING,`Event::Endpoint::R...
url target.url 直接映射
principal.user.userid target.user.userid 直接映射
suser target.user.userid 直接映射
不适用 metadata.event_type 常量:GENERIC_EVENT
不适用 metadata.product_name 常量:Sophos Central
不适用 metadata.vendor_name 常量:Sophos
不适用 network.direction 常量:OUTBOUND
不适用 network.ip_protocol 常量:TCP
不适用 security_result.description 常量:security_result.summary
不适用 security_result.severity 常量:LOW
不适用 target.resource.name 常量:Real time protection
不适用 target.resource.type 常量:SETTING

更新日志

查看相应解析器的更改日志

需要更多帮助?获得社区成员和 Google SecOps 专业人士的解答。