收集 Sophos Central 記錄
本文說明如何使用 Bindplane 收集 Sophos Central 記錄。剖析器會將 JSON 記錄轉換為統合資料模型 (UDM)。這個剖析器會從巢狀 JSON 結構中擷取欄位,並對應至 UDM 欄位,然後根據類型欄位分類事件,並針對不同的 Sophos Central 事件類型,在資料中加入特定詳細資料和動作。
事前準備
請確認您符合下列必要條件:
- Google SecOps 執行個體。
- 您使用的是 Windows 2016 以上版本,或搭載 systemd 的 Linux 主機。
- 您有額外的 Windows 或 Linux 機器,能夠持續執行 Python。
- 如果透過 Proxy 執行,請確認防火牆通訊埠已根據 Bindplane 代理程式需求開啟。
- Sophos Central 管理控制台的特殊存取權。
取得 Bindplane 代理程式的 Google SecOps 憑證
如要向 Google SecOps 驗證 Bindplane 代理程式,請選擇下列其中一種方法:
- 新部署作業:使用 Chronicle API (選項 1)。
- 舊版部署作業:繼續使用擷取驗證檔案 (選項 2),直到 Ingestion API 於 2027 年 7 月 20 日停用。
方法 1:為 Chronicle API 建立服務帳戶 (建議)
- 登入 Google Cloud 控制台,然後選取連結至 Google SecOps 執行個體的 Google Cloud 專案。
- 依序前往 「IAM & Admin」(IAM 與管理) >「Service Accounts」(服務帳戶)。
- 按一下「建立服務帳戶」。
- 提供下列設定詳細資料:
- 「Service account name」(服務帳戶名稱):輸入帳戶名稱 (例如
bindplane-ingest)。 - 服務帳戶說明:輸入說明 (例如
Bindplane agent log ingestion)。
- 「Service account name」(服務帳戶名稱):輸入帳戶名稱 (例如
- 點按「Create and continue」(建立並繼續)。
- 在「將專案存取權授予這個服務帳戶」部分,按一下「選取角色」,然後選取「Chronicle 編輯者」。
- 依序點選「繼續」和「完成」。
- 按一下您建立的服務帳戶,然後前往「金鑰」分頁。
- 依序點選「新增金鑰」>「建立新的金鑰」。
- 選取「JSON」,然後點選「建立」。金鑰檔案會下載到電腦。
- 將金鑰檔案儲存為 Bindplane 收集器目錄中的
ingestion-auth.json(Linux 為/opt/observiq-otel-collector/ingestion-auth.json,Windows 為C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json),或更新config.yaml中的creds_file_path,使其與儲存檔案的路徑相符。 - 依序前往「IAM 與管理」>「設定」,然後複製「專案編號」。設定匯出工具時會用到。
方法 2:下載擷取驗證檔案 (舊版)
- 登入 Google SecOps 控制台。
- 依序前往「SIEM Settings」 > 「Collection Agents」。
- 下載擷取驗證檔案。
- 將檔案安全地儲存在要安裝 Bindplane 代理程式的系統上。
取得 Google SecOps 客戶 ID
- 登入 Google SecOps 控制台。
- 依序前往「SIEM Settings」(SIEM 設定) >「Profile」(設定檔)。
- 複製並儲存「機構詳細資料」部分的客戶 ID。
安裝 Bindplane 代理程式
請按照下列操作說明,在 Windows 或 Linux 作業系統上安裝 Bindplane 代理程式。
Windows 安裝
- 以管理員身分開啟「命令提示字元」或「PowerShell」。
執行下列指令:
msiexec /i "[https://github.com/observIQ/bindplane-agent/releases/latest/download/observiq-otel-collector.msi](https://github.com/observIQ/bindplane-agent/releases/latest/download/observiq-otel-collector.msi)" /quiet
Linux 安裝
- 開啟具有 root 或 sudo 權限的終端機。
執行下列指令:
sudo sh -c "$(curl -fsSlL [https://github.com/observiq/bindplane-agent/releases/latest/download/install_unix.sh](https://github.com/observiq/bindplane-agent/releases/latest/download/install_unix.sh))" install_unix.sh
其他安裝資源
如需其他安裝選項,請參閱這份安裝指南。
設定 Bindplane 代理程式,擷取系統記錄並傳送至 Google SecOps
存取設定檔:
- 找出
config.yaml檔案。通常位於 Linux 的/opt/observiq-otel-collector/目錄,或 Windows 的安裝目錄。 - 使用文字編輯器 (例如
nano、vi或記事本) 開啟檔案。
- 找出
按照下列方式編輯
config.yaml檔案:receivers: udplog: # Replace the port and IP address as required listen_address: "0.0.0.0:514" exporters: chronicle/chronicle_w_labels: protocol: https # Region of your instance, for example us, europe, asia-southeast1 location: <LOCATION> # Project number of the Google Cloud project linked to the instance project: '<PROJECT_NUMBER>' compression: gzip # Adjust the path to the credentials file you downloaded in Step 1 creds_file_path: '/path/to/ingestion-authentication-file.json' # Replace with your actual customer ID from Step 2 customer_id: '<customer_id>' endpoint: chronicle.googleapis.com # Add optional ingestion labels for better organization log_type: 'SOPHOS_CENTRAL' raw_log_field: body ingestion_labels: service: pipelines: logs/source0__chronicle_w_labels-0: receivers: - udplog exporters: - chronicle/chronicle_w_labels請根據基礎架構需求,替換通訊埠和 IP 位址。
將
<LOCATION>替換為 Google SecOps 執行個體的區域 (例如us、europe或asia-southeast1)。匯出工具會以這個值做為chronicle.googleapis.com的前置字元。將
<PROJECT_NUMBER>替換為「IAM 與管理」>「設定」中的專案編號。將
<customer_id>替換為實際的客戶 ID。將
/path/to/ingestion-authentication-file.json更新為步驟 1 中儲存服務帳戶金鑰檔案 (選項 1) 的檔案路徑。
舊版 Ingestion API 匯出工具
如果您使用選項 2 的擷取驗證檔案,請將
exporters區塊替換為下列內容。將creds_file_path設為擷取驗證檔案的路徑。如果執行個體位於美國境外,請將malachiteingestion-pa.googleapis.com替換為區域端點 (例如europe-malachiteingestion-pa.googleapis.com)。exporters: chronicle/chronicle_w_labels: compression: gzip # Adjust the path to the credentials file you downloaded in Step 1 creds_file_path: '/path/to/ingestion-authentication-file.json' # Replace with your actual customer ID from Step 2 customer_id: '<customer_id>' endpoint: malachiteingestion-pa.googleapis.com # Add optional ingestion labels for better organization log_type: 'SOPHOS_CENTRAL' raw_log_field: body ingestion_labels:
重新啟動 Bindplane 代理程式,套用變更
如要在 Linux 中重新啟動 Bindplane 代理程式,請執行下列指令:
/opt/observiq-otel-collector/config.yaml如要在 Windows 重新啟動 Bindplane 代理程式,可以使用「服務」控制台,或輸入下列指令:
net stop BindPlaneAgent && net start BindPlaneAgent
設定 Sophos Central API 存取權
- 登入 Sophos Central Admin。
- 依序選取「通用設定」>「API 權杖管理」。
- 按一下「Add Token」,建立新的權杖。
- 輸入權杖名稱,然後按一下「儲存」。系統會顯示所提供權杖的「API Token Summary」。
- 在「API Token Summary」部分,按一下「Copy」,複製 API 存取網址和標頭。
在其他電腦上安裝 Python
- 開啟網路瀏覽器,然後前往 Python 網站。
- 按一下適用於作業系統 (Windows 或 Mac) 的「Download Python」。
安裝 Python:
- Windows 系統:
- 執行安裝程式。
- 勾選「Add Python to PATH」方塊。
- 按一下「立即安裝」。
- Mac:
- Python 可能已安裝,如果沒有,可以使用終端機安裝最新版本。
- 開啟終端機,然後輸入下列指令進行驗證:
python --version- Windows 系統:
下載 Sophos 整合指令碼
- 前往 Sophos Central SIEM Integration Repository 的 GitHub 頁面。
- 依序點選綠色的「Code」按鈕 >「Download ZIP」。
- 解壓縮 ZIP 檔案。
設定指令碼
- 使用文字編輯器找出並開啟
config.ini檔案。 - 編輯設定檔:
- API 權杖:輸入先前從 Sophos Central 複製的 API 金鑰。
- Syslog Server Details: 輸入 Syslog 伺服器的詳細資料。
- 主機:輸入 Bindplane IP 位址。
- 通訊埠:輸入 Bindplane 通訊埠編號。
- 通訊協定:輸入 UDP (您也可以視設定使用 TCP 或 TLS)。
- 儲存檔案。
執行指令碼
- 前往指令碼資料夾。
- Windows 系統:
- 按下 Windows 鍵,然後輸入
cmd。 - 按一下「命令提示字元」。
- 前往資料夾:
cmd cd C:\Users\YourName\Downloads\Sophos-Central-SIEM-Integration
- 按下 Windows 鍵,然後輸入
- macOS:
- 依序前往「應用程式」>「工具程式」。
- 開啟 [Terminal]。
- 前往資料夾:
bash cd /Users/YourName/Downloads/Sophos-Central-SIEM-Integration
- Windows 系統:
執行指令碼:
- 輸入下列指令來啟動指令碼:
python siem.py
自動執行指令碼,持續放送
在 Windows 上 (使用工作排程器)
- 在「開始」選單中輸入「工作排程器」,開啟工作排程器。
- 按一下「建立工作」。
- 在「一般」分頁中:
- 為工作命名 (例如
Sophos Central Log Export)。
- 為工作命名 (例如
- 在「Triggers」(觸發條件) 分頁中:
- 按一下「新增」,然後將工作設為「每日」或「啟動時」執行。
- 在「動作」分頁中:
- 按一下「新增」,然後選取「開始計畫」。
- 瀏覽
python.exe可執行檔 (通常位於C:\PythonXX\python.exe)。 - 在「Add arguments」(新增引數) 欄位中,輸入腳本路徑 (例如
C:\Users\YourName\Downloads\Sophos-Central-SIEM-Integration\siem.py)。
- 按一下「OK」儲存工作。
Mac (使用 Cron 工作)
- 開啟「終端機」。
- 輸入
crontab -e,然後按下 Enter 鍵。 在檔案結尾新增一行:
* * * * * /usr/bin/python /Users/YourName/Downloads/Sophos-Central-SIEM-Integration/siem.py儲存並結束編輯器。
UDM 對應表
| 記錄欄位 | UDM 對應 | 邏輯 |
|---|---|---|
created_at_label |
additional.fields |
已合併 |
datastream_label |
additional.fields |
已合併 |
security_result.description |
metadata.description |
已重新命名/對應 |
end |
metadata.event_timestamp |
已剖析為 RFC 3339 |
when |
metadata.event_timestamp |
已剖析為 RFC 3339 |
has_principal |
metadata.event_type |
對應:true → FILE_OPEN、true → NETWORK_CONNECTION、true → SCAN_UNCATEGORIZED |
type |
metadata.event_type |
對應值 (共 14 個,例如 Event::Endpoint::DataLossPreventionAutomaticallyAllowed → `F... |
type |
metadata.product_event_type |
直接對應 |
type |
network.direction |
已對應:Event::Endpoint::WebControlViolation → OUTBOUND、`Event::Endpoint::WindowsFirewa... |
type |
network.ip_protocol |
已對應:Event::Endpoint::WebControlViolation → TCP |
dhost |
principal.asset.hostname |
直接對應 |
location |
principal.asset.hostname |
直接對應 |
data.source_info.ip |
principal.asset.ip |
已合併 |
source_info.ip |
principal.asset.ip |
已合併 |
dhost |
principal.hostname |
直接對應 |
location |
principal.hostname |
直接對應 |
data.source_info.ip |
principal.ip |
已合併 |
source_info.ip |
principal.ip |
已合併 |
type |
principal.user.attribute.labels |
已對應:Event::Endpoint::DataLossPreventionAutomaticallyAllowed → username_label |
username_label |
principal.user.attribute.labels |
已合併 |
Username |
principal.user.user_display_name |
直接對應 |
source |
principal.user.user_display_name |
直接對應 |
source |
principal.user.userid |
直接對應 |
suser |
principal.user.userid |
直接對應 |
user_id |
principal.user.userid |
直接對應 |
endpoint_type_label |
security_result.about.labels |
已合併 |
sec_action |
security_result.action |
已合併 |
type |
security_result.action |
對應:Event::Endpoint::DataLossPreventionAutomaticallyAllowed → sec_action,`Event::En... |
group |
security_result.category_details |
已合併 |
name |
security_result.description |
直接對應 |
type |
security_result.description |
已對應:Event::Endpoint::(UpdateRebootRequired/ServiceNotRunning/NonCompliant/OutOfDate) →... |
duid_label |
security_result.detection_fields |
已合併 |
id_label |
security_result.detection_fields |
已合併 |
rule |
security_result.rule_name |
直接對應 |
rules |
security_result.rule_name |
直接對應 |
severity |
security_result.severity |
對應:low → LOW、medium → MEDIUM、high → HIGH |
security_result.description |
security_result.summary |
已重新命名/對應 |
app |
target.application |
直接對應 |
application |
target.application |
直接對應 |
dhost |
target.asset.hostname |
直接對應 |
endpoint_id |
target.asset_id |
直接對應 |
f_path |
target.file.full_path |
直接對應 |
f_size |
target.file.size |
已重新命名/對應 |
dhost |
target.hostname |
直接對應 |
application |
target.process.file.full_path |
直接對應 |
core_remedy_items.items.0.descriptor |
target.process.file.full_path |
直接對應 |
data.core_remedy_items.items.0.descriptor |
target.process.file.full_path |
直接對應 |
file_path_1 |
target.process.file.full_path |
直接對應 |
customer_id |
target.resource.id |
直接對應 |
p_device |
target.resource.name |
直接對應 |
scan_name |
target.resource.name |
直接對應 |
type |
target.resource.name |
對應:Event::Endpoint::SavDisabled → Real time protection,`Event::Endpoint::Registere... |
type |
target.resource.type |
對應值 (共 5 個,例如 Event::Endpoint::SavDisabled → SETTING、`Event::Endpoint::R... |
url |
target.url |
直接對應 |
principal.user.userid |
target.user.userid |
直接對應 |
suser |
target.user.userid |
直接對應 |
| 不適用 | metadata.event_type |
常數:GENERIC_EVENT |
| 不適用 | metadata.product_name |
常數:Sophos Central |
| 不適用 | metadata.vendor_name |
常數:Sophos |
| 不適用 | network.direction |
常數:OUTBOUND |
| 不適用 | network.ip_protocol |
常數:TCP |
| 不適用 | security_result.description |
常數:security_result.summary |
| 不適用 | security_result.severity |
常數:LOW |
| 不適用 | target.resource.name |
常數:Real time protection |
| 不適用 | target.resource.type |
常數:SETTING |
變更記錄
還有其他問題嗎?向社群成員和 Google SecOps 專家尋求解答。