收集 Symantec DLP 日志

支持:

本文档介绍了如何使用 Bindplane 代理将 Symantec DLP 日志注入到 Google Security Operations。

Symantec 数据泄露防护 (DLP) 是一种数据保护解决方案,可针对违规行为、数据发现事件、端点监控事件和网络监控提醒生成 syslog 消息。解析器会从以管道符分隔且采用 CEF 格式的 syslog 日志中提取字段,并将其映射到统一数据模型 (UDM)。

准备工作

请确保满足以下前提条件:

  • Google SecOps 实例
  • Windows Server 2016 或更高版本,或者具有 systemd 的 Linux 主机
  • Bindplane 代理与 Symantec DLP 服务器之间的网络连接
  • 如果通过代理运行,请确保防火墙端口根据 Bindplane 代理要求处于开放状态
  • 对 Symantec Server 管理控制台的管理员权限

获取 Bindplane 代理的 Google SecOps 凭证

如需向 Google SecOps 验证 Bindplane 代理的身份,请选择以下方法之一:

  • 新部署:使用 Chronicle API(选项 1)。
  • 旧版部署:继续使用提取身份验证文件(方法 2),直到提取 API 于 2027 年 7 月 20 日停用。
  1. 登录 Google Cloud 控制台,然后选择与您的 Google SecOps 实例关联的 Google Cloud 项目。
  2. 前往 IAM 和管理 > 服务账号。
  3. 点击创建服务账号。
  4. 提供以下配置详细信息:
    • 服务账号名称:输入账号的名称(例如 bindplane-ingest)。
    • 服务账号说明:输入说明(例如 Bindplane agent log ingestion)。
  5. 点击创建并继续。
  6. 在向此服务账号授予对项目的访问权限部分,点击选择角色,然后选择 Chronicle Editor。
  7. 点击继续,然后点击完成。
  8. 点击您创建的服务账号,然后前往密钥标签页。
  9. 依次点击添加密钥> 创建新密钥。
  10. 选择 JSON,然后点击创建。密钥文件会下载到您的计算机上。
  11. 将密钥文件另存为 Bindplane 收集器目录(Linux 上的 /opt/observiq-otel-collector/ingestion-auth.json 或 Windows 上的 C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json)中的 ingestion-auth.json,或更新 config.yaml 中的 creds_file_path 以匹配您保存该文件的路径。
  12. 前往 IAM 和管理 > 设置,然后复制项目编号。您在配置导出器时需要用到该名称。

方法 2:下载数据注入身份验证文件(旧版)

  1. 登录 Google SecOps 控制台。
  2. 依次前往 SIEM 设置 > 收集代理。
  3. 下载数据注入身份验证文件。
  4. 将文件安全地保存在将安装 Bindplane 代理的系统上。

获取 Google SecOps 客户 ID

  1. 登录 Google SecOps 控制台。
  2. 依次前往 SIEM 设置 > 配置文件。
  3. 从组织详细信息部分复制并保存客户 ID。

安装 Bindplane 代理

根据以下说明,在 Windows 或 Linux 操作系统上安装 Bindplane 代理。

Windows 安装

  1. 以管理员身份打开命令提示符或 PowerShell。
  2. 运行以下命令:

    msiexec /i "https://github.com/observIQ/bindplane-agent/releases/latest/download/observiq-otel-collector.msi" /quiet
    
  3. 等待安装完成。

  4. 运行以下命令,验证安装是否成功:

    sc query observiq-otel-collector
    

    该服务应显示为正在运行。

Linux 安装

  1. 打开具有 root 或 sudo 权限的终端。
  2. 运行以下命令:

    sudo sh -c "$(curl -fsSlL https://github.com/observiq/bindplane-agent/releases/latest/download/install_unix.sh)" install_unix.sh
    
  3. 等待安装完成。

  4. 运行以下命令,验证安装是否成功:

    sudo systemctl status observiq-otel-collector
    

    该服务应显示为有效(正在运行)。

其他安装资源

如需了解其他安装选项和问题排查,请参阅 Bindplane 代理安装指南。

配置 Bindplane 代理以注入 syslog 并将其发送到 Google SecOps

找到配置文件

  • Linux:

    sudo nano /opt/observiq-otel-collector/config.yaml
    
  • Windows:

    notepad "C:\Program Files\observIQ OpenTelemetry Collector\config.yaml"
    

修改配置文件

  • 将 config.yaml 的全部内容替换为以下配置:

    receivers:
      udplog:
        listen_address: "0.0.0.0:514"
    
    exporters:
      chronicle/symantec_dlp:
        protocol: https
        # Region of your instance, for example us, europe, asia-southeast1
        location: <LOCATION>
        # Project number of the Google Cloud project linked to the instance
        project: '<PROJECT_NUMBER>'
        compression: gzip
        creds_file_path: '/opt/observiq-otel-collector/ingestion-auth.json'
        customer_id: '<customer_id>'
        endpoint: chronicle.googleapis.com
        log_type: SYMANTEC_DLP
        raw_log_field: body
    
    service:
      pipelines:
        logs/symantec_dlp_to_chronicle:
          receivers:
            - udplog
          exporters:
            - chronicle/symantec_dlp
    

配置参数

替换以下占位符:

  • 接收器配置:

    • listen_address:要监听的 IP 地址和端口:
      • 0.0.0.0 在所有接口上监听(推荐)
      • 端口 514 是标准 syslog 端口(在 Linux 上需要 root 权限;对于非 root 用户,请使用 1514)
  • 导出器配置:

    • creds_file_path:服务账号 JSON 密钥文件的完整路径(选项 1):
      • Linux:/opt/observiq-otel-collector/ingestion-auth.json
      • Windows:C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json
    • customer_id:从 Google SecOps 控制台复制的客户 ID
    • location:将 <LOCATION> 替换为 Google SecOps 实例所在的区域(例如 us、europe 或 asia-southeast1)。导出工具会在此值前面加上 chronicle.googleapis.com。如需查看完整列表,请参阅区域级端点。
    • project:将 <PROJECT_NUMBER> 替换为“IAM 和管理”>“设置”中的项目编号。
    • endpoint:保持设置为 chronicle.googleapis.com。

旧版提取 API 导出工具

  • 如果您使用选项 2 中的数据注入身份验证文件,请将 exporters 代码块替换为以下内容。将 creds_file_path 设置为数据注入身份验证文件的路径,如果您的实例位于美国境外,请将 malachiteingestion-pa.googleapis.com 替换为您的区域端点(例如 europe-malachiteingestion-pa.googleapis.com)。

    exporters:
      chronicle/symantec_dlp:
        compression: gzip
        creds_file_path: '/opt/observiq-otel-collector/ingestion-auth.json'
        customer_id: '<customer_id>'
        endpoint: malachiteingestion-pa.googleapis.com
        log_type: SYMANTEC_DLP
        raw_log_field: body
    

保存配置文件

  • 修改后,保存文件:
    • Linux:依次按 Ctrl+O、Enter 和 Ctrl+X
    • Windows:依次点击文件 > 保存

重启 Bindplane 代理以应用更改

  • 如需在 Linux 中重启 Bindplane 代理,请运行以下命令:

    sudo systemctl restart observiq-otel-collector
    
    1. 验证服务是否正在运行:

      sudo systemctl status observiq-otel-collector
      
    2. 检查日志中的错误:

      sudo journalctl -u observiq-otel-collector -f
      
  • 如需在 Windows 中重启 Bindplane 代理,请选择以下选项之一:

    • 以管理员身份运行命令提示符或 PowerShell:

      net stop observiq-otel-collector && net start observiq-otel-collector
      
    • 服务控制台:

      1. 按 Win+R,输入 services.msc,然后按 Enter 键。
      2. 找到 observIQ OpenTelemetry 收集器。
      3. 右键点击,然后选择重新启动。
      4. 验证服务是否正在运行:

        sc query observiq-otel-collector
        
      5. 检查日志中是否存在错误:

        type "C:\Program Files\observIQ OpenTelemetry Collector\log\collector.log"
        

配置 Symantec DLP

  1. 登录 Symantec Server 管理控制台。
  2. 依次选择管理 > 政策 > 响应规则。
  3. 选择配置回答规则,然后输入规则名称。
  4. 提供以下详细信息:

    • 操作:选择记录到 syslog 服务器。
    • 主机:输入 Bindplane IP 地址。
    • 端口:输入 Bindplane 端口号。
    • 消息:输入以下 syslog 消息模板:
    |symcdlpsys|APPLICATION_NAME|$APPLICATION_NAME$|APPLICATION_USER|$APPLICATION_USER$|ATTACHMENT_FILENAME|$ATTACHMENT_FILENAME$|BLOCKED|$BLOCKED$|DATAOWNER_NAME|$DATAOWNER_NAME$|DATAOWNER_EMAIL|$DATAOWNER_EMAIL$|...
    
    • 调试:选择级别 4。
  5. 点击应用。

UDM 映射表

日志字段 UDM 映射 逻辑
act security_result.action 如果 act 为 Passed,则设置为 ALLOW。如果 act 为 Modified,则设置为 ALLOW_WITH_MODIFICATION。如果 act 为 Blocked,则设置为 BLOCK。否则,请将其设置为 UNKNOWN_ACTION。
application_name target.application 直接映射。
asset_ip principal.ip、principal.asset.ip 直接映射。
asset_name principal.hostname、principal.asset.hostname 直接映射。
attachment_name security_result.about.file.full_path 直接映射。
已屏蔽 security_result.action_details 直接映射。
calling_station_id principal.mac、principal.asset.mac 如果 calling_station_id 是 MAC 地址,则在将 - 替换为 : 并转换为小写后,直接进行映射。
called_station_id target.mac, target.asset.mac 如果 called_station_id 是 MAC 地址,则提取 : 之前的 MAC 地址部分,并在将 - 替换为 : 并转换为小写后直接进行映射。
category1 security_result.detection_fields 创建键为 category1 且值为 category1 的标签。
category2 security_result.detection_fields 使用键 category2 和 category2 中的值创建标签。
category3 security_result.detection_fields 创建键为 category3 且值来自 category3 的标签。
client_friendly_name target.user.userid 直接映射。
dataowner_mail principal.user.email_addresses 如果该值是有效的邮箱,则直接映射。
说明 metadata.description 直接映射。
dest_location target.location.country_or_region 如果不是 RED,则直接映射。
deviceId target.asset_id 映射为 ID:%{deviceId}。
device_version metadata.product_version 直接映射。
dhost network.http.referral_url 直接映射。
dlp_type security_result.detection_fields 创建键为 dlp_type 且值来自 dlp_type 的标签。
DLP_EP_Incident_ID security_result.threat_id、security_result.detection_fields 直接映射到 threat_id。此外,还需创建一个键为 Incident ID、值为 DLP_EP_Incident_ID 的标签。
网域 principal.administrative_domain 直接映射。
dst target.ip、target.asset.ip 如果它是有效的 IP 地址,则直接映射。
endpoint_machine target.ip、target.asset.ip 如果它是有效的 IP 地址,则直接映射。
endpoint_user_department target.user.department 直接映射。
endpoint_user_email target.user.email_addresses 直接映射。
endpoint_user_manager target.user.managers 使用 endpoint_user_manager 中的 user_display_name 创建一个管理器对象。
endpoint_user_name target.user.user_display_name 直接映射。
endpoint_user_title target.user.title 直接映射。
event_description metadata.description 直接映射。
event_id metadata.product_log_id 直接映射。
event_source target.application 直接映射。
event_timestamp metadata.event_timestamp 直接映射。
file_name security_result.about.file.full_path 直接映射。
filename target.file.full_path, src.file.full_path 直接映射到 target.file.full_path。如果 has_principal 为 true,则还需映射到 src.file.full_path,并将 event_type 设置为 FILE_COPY。
主机 src.hostname、principal.hostname、principal.asset.hostname 如果 cef_data 包含 CEF,则映射到所有三个字段。否则,请映射到 principal.hostname 和 principal.asset.hostname。
incident_id security_result.threat_id、security_result.detection_fields 直接映射到 threat_id。此外,请创建一个标签,其键为 Incident ID,值为 incident_id。
位置 principal.resource.attribute.labels 创建一个标签,其键为 Location,值为 location。
match_count security_result.detection_fields 使用键 Match Count 和 match_count 中的值创建标签。
monitor_name additional.fields 使用键 Monitor Name 和 monitor_name 中的值创建标签。
nas_id target.hostname、target.asset.hostname 直接映射。
occurred_on principal.labels, additional.fields 为 principal.labels 和 additional.fields 创建一个标签,其键为 Occurred On,值来自 occurred_on。
policy_name sec_result.detection_fields 创建键为 policy_name 且值为 policy_name 的标签。
policy_rule security_result.rule_name 直接映射。
policy_severity security_result.severity 转换为大写后映射到 severity。如果 policy_severity 为 INFO,请将其映射为 INFORMATIONAL。如果 policy_severity 不是 HIGH、MEDIUM、LOW 或 INFORMATIONAL 中的一个,请将 severity 设置为 UNKNOWN_SEVERITY。
policy_violated security_result.summary 直接映射。
协议 network.application_protocol, target.application, sec_result.description 如果 Protocol 不是 FTP 或 Endpoint,请在使用 parse_app_protocol.include 文件解析后将其映射到 network.application_protocol。如果 Protocol 为 FTP,请将其映射到 target.application。如果 Protocol 为 Endpoint,则将 sec_result.description 设置为 Protocol=%{Protocol}。
收件人 target.user.email_addresses, about.user.email_addresses 对于 recipient 中的每个电子邮件地址,将其同时映射到 target.user.email_addresses 和 about.user.email_addresses。
收件人 network.http.referral_url, target.resource.attribute.labels 直接映射到 network.http.referral_url。此外,请创建一个标签,其键为 recipients,值来自 recipients。
reported_on additional.fields 创建键为 Reported On 且值来自 reported_on 的标签。
规则 security_result.detection_fields 创建键为 Rules 且值来自 rules 的标签。
发件人 network.email.from, target.resource.attribute.labels 如果 sender 是有效的邮箱,请将其映射到 network.email.from。此外,请创建一个标签,其键为 sender,值来自 sender。
服务器 target.application 直接映射。
严重级别 security_result.severity 如需了解映射逻辑,请参阅 policy_severity。
src principal.ip、principal.asset.ip 如果它是有效的 IP 地址,则直接映射。
状态 principal.labels, additional.fields 为 principal.labels 和 additional.fields 创建一个标签,其键为 Status,值来自 status。
subject target.resource.attribute.labels, network.email.subject 创建一个标签,其键为 subject,值来自 subject。此外,将 subject 映射到 network.email.subject。
target_type target.resource.attribute.labels 创建键为 Target Type 且值来自 target_type 的标签。
时间戳 metadata.event_timestamp 使用 date 过滤器解析后直接映射。
网址 target.url 直接映射。
用户 target.user.userid 直接映射。
user_id principal.user.userid 直接映射。
用户名 principal.user.userid 直接映射。
不适用 metadata.product_name 设置为 SYMANTEC_DLP。
不适用 metadata.vendor_name 设置为 SYMANTEC。
不适用 metadata.event_type 如果 event_type 不为空,则直接映射。否则,如果 host 不为空且 has_principal 为 true,则设置为 SCAN_NETWORK。否则,请将其设置为 GENERIC_EVENT。
不适用 metadata.product_event_type 如果 policy_violated 包含 -NM- 或 data 包含 DLP NM,则设置为 Network Monitor。如果 policy_violated 包含 -EP- 或 data 包含 DLP EP,则设置为 Endpoint。
不适用 metadata.log_type 设置为 SYMANTEC_DLP。
subject event.idm.read_only_udm.network.email.subject 从更新日志映射
end event.idm.read_only_udm.metadata.event_timestamp 从更新日志映射
cnt event.idm.read_only_udm.network.session_duration.seconds 从更新日志映射
resolution event.idm.read_only_udm.security_result.detection_fields 从更新日志映射
dhost event.idm.read_only_udm.target.user.email_addresses 从更新日志映射
ATTACHMENT_FILENAME principal.file.full_path 从更新日志映射
DATAOWNER_NAME principal.user.userid 从更新日志映射
ENDPOINT_USERNAME principal.user.userid 从更新日志映射
reported_on" and "monitor_name additional.fields 从更新日志映射
incident_id" and "DLP_EP_Incident_ID security_result.detection_fields 从更新日志映射
application principal.application 从更新日志映射
Occurred on principal.labels 从更新日志映射

更新日志

查看相应解析器的更新日志

需要更多帮助?获得社区成员和 Google SecOps 专业人士的解答。