收集 Symantec DLP 記錄

支援:

本文說明如何使用 Bindplane 代理程式,將 Symantec DLP 記錄擷取至 Google Security Operations。

Symantec Data Loss Prevention (DLP) 是一項資料保護解決方案,可針對違反政策、資料探索事件、端點監控事件和網路監控警示,產生 syslog 訊息。剖析器會從以管道分隔和 CEF 格式的 syslog 記錄中擷取欄位,並對應至統合式資料模型 (UDM)。

事前準備

請確認您已完成下列事前準備事項:

  • Google SecOps 執行個體
  • Windows Server 2016 以上版本,或搭載 systemd 的 Linux 主機
  • Bindplane 代理程式與 Symantec DLP 伺服器之間的網路連線
  • 如果透過 Proxy 執行,請確保防火牆通訊埠已根據 Bindplane 代理程式需求開啟
  • Symantec Server 管理控制台的管理員權限

取得 Bindplane 代理程式的 Google SecOps 憑證

如要向 Google SecOps 驗證 Bindplane 代理程式,請選擇下列其中一種方法:

  • 新部署作業:使用 Chronicle API (選項 1)。
  • 舊版部署作業:繼續使用擷取驗證檔案 (選項 2),直到 Ingestion API 於 2027 年 7 月 20 日停用。
  1. 登入 Google Cloud 控制台,選取連結至 Google SecOps 執行個體的 Google Cloud 專案。
  2. 依序前往「IAM & Admin」(IAM 與管理) >「Service Accounts」(服務帳戶)。
  3. 按一下「建立服務帳戶」。
  4. 提供下列設定詳細資料:
    • 服務帳戶名稱:輸入帳戶名稱 (例如 bindplane-ingest)。
    • 「服務帳戶說明」:輸入說明 (例如 Bindplane agent log ingestion)。
  5. 點按「Create and continue」(建立並繼續)。
  6. 在「將專案存取權授予這個服務帳戶」部分,按一下「選取角色」,然後選取「Chronicle 編輯者」。
  7. 依序點選「繼續」和「完成」。
  8. 按一下您建立的服務帳戶,然後前往「金鑰」分頁。
  9. 依序點選「新增金鑰」>「建立新的金鑰」。
  10. 選取「JSON」,然後按一下「建立」。金鑰檔案會下載到電腦。
  11. 將金鑰檔案儲存為 Bindplane 收集器目錄中的 ingestion-auth.json (Linux 上的 /opt/observiq-otel-collector/ingestion-auth.json 或 Windows 上的 C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json),或更新 config.yaml 中的 creds_file_path,使其與儲存路徑相符。
  12. 依序前往「IAM & Admin」(IAM 與管理) >「Settings」(設定),然後複製「Project number」(專案編號)。設定匯出工具時會用到。

方法 2:下載擷取驗證檔案 (舊版)

  1. 登入 Google SecOps 控制台。
  2. 依序前往「SIEM Settings」 > 「Collection Agents」。
  3. 下載擷取驗證檔案。
  4. 將檔案安全地儲存在要安裝 Bindplane 代理程式的系統上。

取得 Google SecOps 客戶 ID

  1. 登入 Google SecOps 控制台。
  2. 依序前往「SIEM 設定」>「設定檔」。
  3. 複製並儲存「機構詳細資料」專區中的「客戶 ID」。

安裝 Bindplane 代理程式

請按照下列操作說明,在 Windows 或 Linux 作業系統上安裝 Bindplane 代理程式。

Windows 安裝

  1. 以管理員身分開啟命令提示字元或 PowerShell。
  2. 執行下列指令:

    msiexec /i "https://github.com/observIQ/bindplane-agent/releases/latest/download/observiq-otel-collector.msi" /quiet
    
  3. 等待安裝完成。

  4. 執行下列指令,確認安裝成功:

    sc query observiq-otel-collector
    

    服務應顯示為「RUNNING」。

Linux 安裝

  1. 開啟具有 root 或 sudo 權限的終端機。
  2. 執行下列指令:

    sudo sh -c "$(curl -fsSlL https://github.com/observiq/bindplane-agent/releases/latest/download/install_unix.sh)" install_unix.sh
    
  3. 等待安裝完成。

  4. 執行下列指令,確認安裝成功:

    sudo systemctl status observiq-otel-collector
    

    服務應顯示為「active (running)」。

其他安裝資源

如需其他安裝選項和疑難排解資訊,請參閱 Bindplane 代理程式安裝指南。

設定 Bindplane 代理,擷取系統記錄檔並傳送至 Google SecOps

找出設定檔

  • Linux:

    sudo nano /opt/observiq-otel-collector/config.yaml
    
  • Windows:

    notepad "C:\Program Files\observIQ OpenTelemetry Collector\config.yaml"
    

編輯設定檔

  • 將 config.yaml 的全部內容替換為下列設定:

    receivers:
      udplog:
        listen_address: "0.0.0.0:514"
    
    exporters:
      chronicle/symantec_dlp:
        protocol: https
        # Region of your instance, for example us, europe, asia-southeast1
        location: <LOCATION>
        # Project number of the Google Cloud project linked to the instance
        project: '<PROJECT_NUMBER>'
        compression: gzip
        creds_file_path: '/opt/observiq-otel-collector/ingestion-auth.json'
        customer_id: '<customer_id>'
        endpoint: chronicle.googleapis.com
        log_type: SYMANTEC_DLP
        raw_log_field: body
    
    service:
      pipelines:
        logs/symantec_dlp_to_chronicle:
          receivers:
            - udplog
          exporters:
            - chronicle/symantec_dlp
    

設定參數

替換下列預留位置:

  • 接收器設定:

    • listen_address:要監聽的 IP 位址和通訊埠:
      • 0.0.0.0 在所有介面接聽電話 (建議)
      • 通訊埠 514 是標準的系統記錄通訊埠 (在 Linux 上需要根層級權限;如果沒有根層級權限,請使用 1514)
  • 匯出工具設定:

    • creds_file_path:服務帳戶 JSON 金鑰檔案的完整路徑 (選項 1):
      • Linux:/opt/observiq-otel-collector/ingestion-auth.json
      • Windows:C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json
    • customer_id:從 Google SecOps 控制台複製的客戶 ID
    • location:將 <LOCATION> 替換為 Google SecOps 執行個體的區域 (例如 us、europe 或 asia-southeast1)。匯出工具會在這個值前面加上 chronicle.googleapis.com。如需完整清單,請參閱「區域性端點」。
    • project:將 <PROJECT_NUMBER> 替換為「IAM 與管理」>「設定」中的專案編號。
    • endpoint:請將此值設為 chronicle.googleapis.com。

舊版擷取 API 匯出工具

  • 如果您使用方式 2 的擷取驗證檔案,請將 exporters 區塊替換成下列內容。將 creds_file_path 設為擷取驗證檔案的路徑,如果您的執行個體位於美國境外,請將 malachiteingestion-pa.googleapis.com 替換為區域端點 (例如 europe-malachiteingestion-pa.googleapis.com)。

    exporters:
      chronicle/symantec_dlp:
        compression: gzip
        creds_file_path: '/opt/observiq-otel-collector/ingestion-auth.json'
        customer_id: '<customer_id>'
        endpoint: malachiteingestion-pa.googleapis.com
        log_type: SYMANTEC_DLP
        raw_log_field: body
    

儲存設定檔

  • 編輯完畢後,請儲存檔案:
    • Linux:依序按下 Ctrl+O、Enter 和 Ctrl+X
    • Windows:依序點選「檔案」>「儲存」

重新啟動 Bindplane 代理程式,套用變更

  • 如要在 Linux 重新啟動 Bindplane 代理程式,請執行下列指令:

    sudo systemctl restart observiq-otel-collector
    
    1. 確認服務正在執行:

      sudo systemctl status observiq-otel-collector
      
    2. 檢查記錄是否有錯誤:

      sudo journalctl -u observiq-otel-collector -f
      
  • 如要在 Windows 中重新啟動 Bindplane 代理程式,請選擇下列任一選項:

    • 以管理員身分開啟命令提示字元或 PowerShell:

      net stop observiq-otel-collector && net start observiq-otel-collector
      
    • 服務控制台:

      1. 按下 Win+R,輸入 services.msc,然後按下 Enter 鍵。
      2. 找出「observIQ OpenTelemetry Collector」。
      3. 按一下滑鼠右鍵,然後選取「重新啟動」。
      4. 確認服務正在執行:

        sc query observiq-otel-collector
        
      5. 檢查記錄是否有錯誤:

        type "C:\Program Files\observIQ OpenTelemetry Collector\log\collector.log"
        

設定 Symantec DLP

  1. 登入 Symantec Server 管理控制台。
  2. 依序選取「管理」>「政策」>「回覆規則」。
  3. 選取「Configure response rule」(設定回應規則),然後輸入規則名稱。
  4. 請提供下列詳細資料:

    • 動作:選取「記錄到系統記錄伺服器」。
    • 「Host」(主機):輸入 Bindplane IP 位址。
    • 「通訊埠」:輸入 Bindplane 通訊埠編號。
    • 訊息:輸入下列系統記錄訊息範本:
    |symcdlpsys|APPLICATION_NAME|$APPLICATION_NAME$|APPLICATION_USER|$APPLICATION_USER$|ATTACHMENT_FILENAME|$ATTACHMENT_FILENAME$|BLOCKED|$BLOCKED$|DATAOWNER_NAME|$DATAOWNER_NAME$|DATAOWNER_EMAIL|$DATAOWNER_EMAIL$|...
    
    • 偵錯:選取「Level 4」。
  5. 按一下「套用」。

UDM 對應表

記錄欄位 UDM 對應 邏輯
act security_result.action 如果 act 為 Passed,請設為 ALLOW。如果 act 為 Modified,請設為 ALLOW_WITH_MODIFICATION。如果 act 為 Blocked,請設為 BLOCK。否則,請設為 UNKNOWN_ACTION。
application_name target.application 直接對應。
asset_ip principal.ip、principal.asset.ip 直接對應。
asset_name principal.hostname、principal.asset.hostname 直接對應。
attachment_name security_result.about.file.full_path 直接對應。
已封鎖 security_result.action_details 直接對應。
calling_station_id principal.mac、principal.asset.mac 如果 calling_station_id 是 MAC 位址,請在將 - 替換為 : 並轉換為小寫後,直接對應。
called_station_id target.mac, target.asset.mac 如果 called_station_id 是 MAC 位址,請擷取 : 前方的 MAC 位址部分,並在將 - 替換為 : 並轉換為小寫後直接對應。
category1 security_result.detection_fields 使用 category1 中的鍵 category1 和值建立標籤。
category2 security_result.detection_fields 使用 category2 中的鍵 category2 和值建立標籤。
category3 security_result.detection_fields 使用 category3 中的鍵 category3 和值建立標籤。
client_friendly_name target.user.userid 直接對應。
dataowner_mail principal.user.email_addresses 如果電子郵件地址有效,則直接對應。
說明 metadata.description 直接對應。
dest_location target.location.country_or_region 如果不是 RED,則直接對應。
deviceId target.asset_id 對應為 ID:%{deviceId}。
device_version metadata.product_version 直接對應。
dhost network.http.referral_url 直接對應。
dlp_type security_result.detection_fields 建立標籤,鍵為 dlp_type,值則來自 dlp_type。
DLP_EP_Incident_ID security_result.threat_id、security_result.detection_fields 直接對應至 threat_id。此外,請建立標籤,並將鍵設為 Incident ID,值設為 DLP_EP_Incident_ID。
網域 principal.administrative_domain 直接對應。
dst target.ip、target.asset.ip 如果 IP 位址有效,則直接對應。
endpoint_machine target.ip、target.asset.ip 如果 IP 位址有效,則直接對應。
endpoint_user_department target.user.department 直接對應。
endpoint_user_email target.user.email_addresses 直接對應。
endpoint_user_manager target.user.managers 使用 endpoint_user_manager 的 user_display_name 建立管理員物件。
endpoint_user_name target.user.user_display_name 直接對應。
endpoint_user_title target.user.title 直接對應。
event_description metadata.description 直接對應。
event_id metadata.product_log_id 直接對應。
event_source target.application 直接對應。
event_timestamp metadata.event_timestamp 直接對應。
file_name security_result.about.file.full_path 直接對應。
filename target.file.full_path、src.file.full_path 直接對應至 target.file.full_path。如果 has_principal 為 true,也請對應至 src.file.full_path,並將 event_type 設為 FILE_COPY。
主機 src.hostname、principal.hostname、principal.asset.hostname 如果 cef_data 包含 CEF,請對應至這三個欄位。否則,請對應至 principal.hostname 和 principal.asset.hostname。
incident_id security_result.threat_id、security_result.detection_fields 直接對應至 threat_id。此外,請使用 Incident ID 鍵和 incident_id 中的值建立標籤。
位置 principal.resource.attribute.labels 使用 Location 鍵和 location 中的值建立標籤。
match_count security_result.detection_fields 建立標籤,鍵為 Match Count,值則來自 match_count。
monitor_name additional.fields 建立標籤,鍵為 Monitor Name,值則來自 monitor_name。
nas_id target.hostname、target.asset.hostname 直接對應。
occurred_on principal.labels、additional.fields 為 principal.labels 和 additional.fields 建立標籤,並使用 Occurred On 做為鍵,以及 occurred_on 中的值。
policy_name sec_result.detection_fields 使用 policy_name 中的鍵 policy_name 和值建立標籤。
policy_rule security_result.rule_name 直接對應。
policy_severity security_result.severity 轉換為大寫後,對應至 severity。如果 policy_severity 為 INFO,請將其對應為 INFORMATIONAL。如果 policy_severity 不是 HIGH、MEDIUM、LOW 或 INFORMATIONAL,請將 severity 設為 UNKNOWN_SEVERITY。
policy_violated security_result.summary 直接對應。
通訊協定 network.application_protocol、target.application、sec_result.description 如果 Protocol 不是 FTP 或 Endpoint,請使用 parse_app_protocol.include 檔案剖析,然後對應至 network.application_protocol。如果 Protocol 為 FTP,請將其對應至 target.application。如果 Protocol 是 Endpoint,請將 sec_result.description 設為 Protocol=%{Protocol}。
收件者 target.user.email_addresses, about.user.email_addresses 將 recipient 中的每個電子郵件地址對應至 target.user.email_addresses 和 about.user.email_addresses。
收件者 network.http.referral_url、target.resource.attribute.labels 直接對應至 network.http.referral_url。此外,請建立標籤,鍵為 recipients,值則來自 recipients。
reported_on additional.fields 建立標籤,鍵為 Reported On,值則來自 reported_on。
規則 security_result.detection_fields 建立標籤,鍵為 Rules,值則來自 rules。
sender network.email.from, target.resource.attribute.labels 如果 sender 是有效的電子郵件地址,請對應至 network.email.from。此外,請建立標籤,鍵為 sender,值則來自 sender。
伺服器 target.application 直接對應。
嚴重性 security_result.severity 如要瞭解對應邏輯,請參閱 policy_severity。
src principal.ip、principal.asset.ip 如果 IP 位址有效,則直接對應。
狀態 principal.labels、additional.fields 為 principal.labels 和 additional.fields 建立標籤,並使用 Status 做為鍵,以及 status 中的值。
主旨 target.resource.attribute.labels, network.email.subject 使用 subject 中的鍵 subject 和值建立標籤。此外,請將 subject 對應至 network.email.subject。
target_type target.resource.attribute.labels 建立標籤,鍵為 Target Type,值則來自 target_type。
時間戳記 metadata.event_timestamp 使用 date 篩選器剖析後直接對應。
網址 target.url 直接對應。
使用者 target.user.userid 直接對應。
user_id principal.user.userid 直接對應。
使用者名稱 principal.user.userid 直接對應。
不適用 metadata.product_name 設為 SYMANTEC_DLP。
不適用 metadata.vendor_name 設為 SYMANTEC。
不適用 metadata.event_type 如果 event_type 不是空白,請直接對應。否則,如果 host 不為空白且 has_principal 為 true,請設為 SCAN_NETWORK。否則,請設為 GENERIC_EVENT。
不適用 metadata.product_event_type 如果 policy_violated 包含 -NM- 或 data 包含 DLP NM,請設為 Network Monitor。如果 policy_violated 包含 -EP-,或 data 包含 DLP EP,請設為 Endpoint。
不適用 metadata.log_type 設為 SYMANTEC_DLP。
subject event.idm.read_only_udm.network.email.subject 從變更記錄對應
end event.idm.read_only_udm.metadata.event_timestamp 從變更記錄對應
cnt event.idm.read_only_udm.network.session_duration.seconds 從變更記錄對應
resolution event.idm.read_only_udm.security_result.detection_fields 從變更記錄對應
dhost event.idm.read_only_udm.target.user.email_addresses 從變更記錄對應
ATTACHMENT_FILENAME principal.file.full_path 從變更記錄對應
DATAOWNER_NAME principal.user.userid 從變更記錄對應
ENDPOINT_USERNAME principal.user.userid 從變更記錄對應
reported_on" and "monitor_name additional.fields 從變更記錄對應
incident_id" and "DLP_EP_Incident_ID security_result.detection_fields 從變更記錄對應
application principal.application 從變更記錄對應
Occurred on principal.labels 從變更記錄對應

變更記錄

查看這個剖析器的變更記錄

還有其他問題嗎?向社群成員和 Google SecOps 專業人員尋求解答。