收集 Symantec Messaging Gateway 記錄
本文說明如何使用 Bindplane,將 Symantec Messaging Gateway 記錄檔擷取至 Google Security Operations。
Symantec Messaging Gateway 是一種電子郵件安全防護閘道,可為企業電子郵件提供防垃圾郵件、防惡意軟體和內容篩選功能。支援原生 syslog 轉送功能,可轉送電子郵件處理事件、政策違規處置和系統健康狀態記錄。
事前準備
請確認您已完成下列事前準備事項:
- Google SecOps 執行個體
- Windows Server 2016 以上版本,或搭載
systemd的 Linux 主機 - Bindplane 代理程式與 Symantec Messaging Gateway 設備之間的網路連線
- 如果透過 Proxy 執行,請確保防火牆通訊埠已根據 Bindplane 代理程式需求開啟
- Symantec Messaging Gateway 管理控制台的特殊權限存取權
取得 Bindplane 代理程式的 Google SecOps 憑證
如要向 Google SecOps 驗證 Bindplane 代理程式,請選擇下列其中一種方法:
- 新部署作業:使用 Chronicle API (選項 1)。
- 舊版部署作業:在 2027 年 7 月 20 日停用 Ingestion API 前,請繼續使用擷取驗證檔案 (選項 2)。
方法 1:為 Chronicle API 建立服務帳戶 (建議)
- 登入 Google Cloud 控制台,選取連結至 Google SecOps 執行個體的 Google Cloud 專案。
- 依序前往「IAM & Admin」(IAM 與管理) >「Service Accounts」(服務帳戶)。
- 按一下「建立服務帳戶」。
- 提供下列設定詳細資料:
- 服務帳戶名稱:輸入帳戶名稱 (例如
bindplane-ingest)。 - 服務帳戶說明:輸入說明 (例如
Bindplane agent log ingestion)。
- 服務帳戶名稱:輸入帳戶名稱 (例如
- 點按「Create and continue」(建立並繼續)。
- 在「將專案存取權授予這個服務帳戶」部分,按一下「選取角色」,然後選取「Chronicle 編輯者」。
- 依序點選「繼續」和「完成」。
- 按一下您建立的服務帳戶,然後前往「金鑰」分頁。
- 依序點選「新增金鑰」>「建立新的金鑰」。
- 選取「JSON」,然後按一下「建立」。金鑰檔案會下載到電腦。
- 將金鑰檔案儲存為 Bindplane 收集器目錄中的
ingestion-auth.json(Linux 為/opt/observiq-otel-collector/ingestion-auth.json,Windows 為C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json),或更新config.yaml中的creds_file_path,使其與儲存檔案的路徑相符。 - 依序前往「IAM & Admin」(IAM 與管理) >「Settings」(設定),然後複製「Project number」(專案編號)。設定匯出工具時會用到。
方法 2:下載擷取驗證檔案 (舊版)
- 登入 Google SecOps 控制台。
- 依序前往「SIEM Settings」 > 「Collection Agents」。
- 下載擷取驗證檔案。
- 將檔案安全地儲存在要安裝 Bindplane 代理程式的系統上。
取得 Google SecOps 客戶 ID
- 登入 Google SecOps 控制台。
- 依序前往「SIEM 設定」>「設定檔」。
複製並儲存「機構詳細資料」專區中的「客戶 ID」。
安裝 Bindplane 代理程式
請按照下列操作說明,在 Windows 或 Linux 作業系統上安裝 Bindplane 代理程式。
Windows 安裝
- 以管理員身分開啟命令提示字元或 PowerShell。
執行下列指令:
msiexec /i "https://github.com/observIQ/bindplane-agent/releases/latest/download/observiq-otel-collector.msi" /quiet等待安裝完成。
執行下列指令,確認安裝成功:
sc query observiq-otel-collector
服務應顯示為「RUNNING」。
Linux 安裝
- 開啟具有 root 或 sudo 權限的終端機。
執行下列指令:
sudo sh -c "$(curl -fsSlL https://github.com/observiq/bindplane-agent/releases/latest/download/install_unix.sh)" install_unix.sh等待安裝完成。
執行下列指令,確認安裝成功:
sudo systemctl status observiq-otel-collector
服務應顯示為「active (running)」。
其他安裝資源
如需其他安裝選項和疑難排解資訊,請參閱 Bindplane 代理程式安裝指南。
設定 Bindplane 代理程式,擷取系統記錄並傳送至 Google SecOps
找出設定檔
Linux:
sudo nano /opt/observiq-otel-collector/config.yamlWindows:
notepad "C:\Program Files\observIQ OpenTelemetry Collector\config.yaml"
編輯設定檔
將
config.yaml的全部內容替換為下列設定:receivers: udplog: listen_address: "0.0.0.0:514" exporters: chronicle/symantec_mail: protocol: https # Region of your instance, for example us, europe, asia-southeast1 location: <LOCATION> # Project number of the Google Cloud project linked to the instance project: '<PROJECT_NUMBER>' compression: gzip creds_file_path: '/opt/observiq-otel-collector/ingestion-auth.json' customer_id: '<customer_id>' endpoint: chronicle.googleapis.com log_type: SYMANTEC_MAIL raw_log_field: body service: pipelines: logs/symantec_mail_to_chronicle: receivers: - udplog exporters: - chronicle/symantec_mail
設定參數
替換下列預留位置:
接收器設定:
listen_address:要接聽的 IP 位址和通訊埠:0.0.0.0:在所有介面上監聽 (建議)- 通訊埠
514是標準的系統記錄通訊埠 (在 Linux 上需要根層級權限;如果沒有根層級權限,請使用1514)
Exporter 設定:
creds_file_path:服務帳戶 JSON 金鑰檔案的完整路徑 (選項 1):- Linux:
/opt/observiq-otel-collector/ingestion-auth.json - Windows:
C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json
- Linux:
customer_id:從 Google SecOps 控制台複製的客戶 IDlocation:將<LOCATION>替換為 Google SecOps 執行個體的區域 (例如us、europe或asia-southeast1)。匯出工具會在這個值前面加上chronicle.googleapis.com。如需完整清單,請參閱「區域性端點」。project:將<PROJECT_NUMBER>替換為「IAM 與管理」>「設定」中的專案編號。endpoint:維持設為chronicle.googleapis.com。
舊版 Ingestion API 匯出工具
如果您使用方式 2 的擷取驗證檔案,請將
exporters區塊替換成下列內容。將creds_file_path設為擷取驗證檔案的路徑。如果執行個體位於美國境外,請將malachiteingestion-pa.googleapis.com替換為區域端點 (例如europe-malachiteingestion-pa.googleapis.com)。exporters: chronicle/symantec_mail: compression: gzip creds_file_path: '/opt/observiq-otel-collector/ingestion-auth.json' customer_id: '<customer_id>' endpoint: malachiteingestion-pa.googleapis.com log_type: SYMANTEC_MAIL raw_log_field: body
儲存設定檔
- 編輯完畢後,請儲存檔案:
- Linux:依序按下
Ctrl+O、Enter和Ctrl+X - Windows:依序點選「檔案」 > 「儲存」
- Linux:依序按下
重新啟動 Bindplane 代理程式,套用變更
如要在 Linux 中重新啟動 Bindplane 代理程式,請執行下列指令:
執行下列指令:
sudo systemctl restart observiq-otel-collector確認服務正在執行:
sudo systemctl status observiq-otel-collector檢查記錄是否有錯誤:
sudo journalctl -u observiq-otel-collector -f
如要在 Windows 重新啟動 Bindplane 代理程式,請按照下列步驟操作:
您可以選擇下列其中一個選項:
- 以管理員身分開啟命令提示字元或 PowerShell:
net stop observiq-otel-collector && net start observiq-otel-collector- 服務控制台:
- 按下
Win+R,輸入services.msc,然後按下 Enter 鍵。 - 找出「observIQ OpenTelemetry Collector」。
- 按一下滑鼠右鍵,然後選取「重新啟動」。
- 按下
確認服務正在執行:
sc query observiq-otel-collector查看記錄檔是否有錯誤:
type "C:\Program Files\observIQ OpenTelemetry Collector\log\collector.log"
設定 Symantec Messaging Gateway 系統記錄轉送
- 登入 Symantec Messaging Gateway 管理控制台。
- 依序前往「Administration」 > 「Settings」 > 「Logs」。
- 按一下「Remote」分頁標籤。
- 啟用「Syslogs」。
- 設定遠端系統記錄伺服器:
- 主機:輸入 Bindplane 代理程式主機的 IP 位址。
- 「Port」(通訊埠):輸入
514。
- 按一下 [儲存]。
UDM 對應表
| 記錄欄位 | UDM 對應 | 邏輯 |
|---|---|---|
| file.fileNameOrURL | about.file.full_path | 直接複製 FILE_INCLUDED 的值 |
| file.md5 | about.file.md5 | 直接複製 FILE_INCLUDED 的值 |
| file.fileType | about.file.mime_type | 直接複製 FILE_INCLUDED 的值 |
| file.sha256 | about.file.sha256 | 直接複製 FILE_INCLUDED 的值 |
| file.fileSize | about.file.size | 已轉換為 FILE_INCLUDED 的 uinteger |
| file.urlCategories、file.urlRiskScore | about.labels | 已合併 LINK_INCLUDED 的標籤 |
| file.fileNameOrURL | about.url | 直接複製 LINK_INCLUDED 的值 |
| emailInfo.longMsgRef, emailInfo.messageId, emailInfo.isOutbound, emailInfo.HELOString, emailInfo.authResults.raw_header, emailInfo.authResults.dkim, emailInfo.authResults.dkim_signing_domain, emailInfo.authResults.spf, emailInfo.authResults.dmarc, emailInfo.authResults.dmarc_policy, emailInfo.authResults.dmarc_override_action, emailInfo.tlsInfo.tlsAdvertised, emailInfo.tlsInfo.tlsUsed, emailInfo.tlsInfo.tlsKeyLength, emailInfo.tlsInfo.tlsFallbackReason, emailInfo.tlsInfo.tlsForwardSecrecy, emailInfo.tlsInfo.tlsNegotiationFailed, emailInfo.messageSize, emailInfo.avQuarantinePenId, emailInfo.rawHeaderFrom, emailInfo.headerReplyTo, emailInfo.newDomainAge, emailInfo.timeInCynicSandboxMs, incidents | additional.fields | 合併為標籤 |
| emailInfo.mailProcessingStartTime, @timestamp | metadata.event_timestamp | 從 mailProcessingStartTime 轉換 (如有),否則從 @timestamp 轉換 |
| metadata.event_type | 如果 email_from_present 和 email_to_present 均為 true,則設為「EMAIL_TRANSACTION」;如果 has_principal 和 has_target 均為 true,則設為「NETWORK_CONNECTION」;如果 has_user 為 true,則設為「USER_UNCATEGORIZED」;如果 has_principal 為 true,則設為「STATUS_UPDATE」;否則設為「GENERIC_EVENT」 | |
| emailInfo.xMsgRef | metadata.product_log_id | 直接複製值 |
| emailInfo.headerFrom | network.email.from | 如果符合電子郵件模式,系統會直接複製值 |
| emailInfo.subject | network.email.subject | 直接複製值 |
| emailInfo.envTo, emailInfo.headerTo | network.email.to | 如果符合電子郵件模式,則從 envTo 和 headerTo 合併 |
| emailInfo.tlsInfo.tlsCipher | network.tls.cipher | 直接複製值 |
| emailInfo.senderMailserver | network.tls.client.server_name | 直接複製值 |
| emailInfo.tlsInfo.tlsPolicy | network.tls.version | 直接複製值 |
| emailInfo.tlsInfo.tlsProtocol | network.tls.version_protocol | 直接複製值 |
| emailInfo.senderMailserver | principal.hostname | 直接複製值 |
| emailInfo.senderIp | principal.ip | 直接複製值 |
| emailInfo.country | principal.location.country_or_region | 直接複製值 |
| emailInfo.envFrom | principal.user.email_addresses | 直接複製值 |
| metadata.product_name | 設為「SYMANTEC_MAIL」 | |
| metadata.vendor_name | 設為「SYMANTEC_MAIL」 | |
hostname |
event.idm.read_only_udm.principal.hostname 和 event.idm.read_only_udm.principal.asset.hostname |
從變更記錄對應 |
process |
event.idm.read_only_udm.principal.process.file.names |
從變更記錄對應 |
pid |
event.idm.read_only_udm.principal.process.pid |
從變更記錄對應 |
tag |
event.idm.read_only_udm.metadata.product_event_type |
從變更記錄對應 |
loglevel |
event.idm.read_only_udm.security_result.severity |
從變更記錄對應 |
log_id |
event.idm.read_only_udm.metadata.product_log_id |
從變更記錄對應 |
internal_id |
event.idm.read_only_udm.additional.fields |
從變更記錄對應 |
ruleset |
event.idm.read_only_udm.additional.fields |
從變更記錄對應 |
ttl |
event.idm.read_only_udm.additional.fields |
從變更記錄對應 |
source |
event.idm.read_only_udm.additional.fields |
從變更記錄對應 |
allow_redirect |
event.idm.read_only_udm.additional.fields |
從變更記錄對應 |
transaction_id |
event.idm.read_only_udm.additional.fields |
從變更記錄對應 |
component |
event.idm.read_only_udm.additional.fields |
從變更記錄對應 |
msg_code |
event.idm.read_only_udm.additional.fields |
從變更記錄對應 |
url |
event.idm.read_only_udm.target.url |
從變更記錄對應 |
status |
event.idm.read_only_udm.network.http.response_code |
從變更記錄對應 |
description |
event.idm.read_only_udm.security_result.description |
從變更記錄對應 |
priority |
event.idm.read_only_udm.metadata.ingestion_labels |
從變更記錄對應 |
timestamp |
event.idm.read_only_udm.metadata.event_timestamp |
從變更記錄對應 |
emailInfo.longMsgRef", "emailInfo.messageId", "emailInfo.isOutbound", "emailInfo.HELOString", "emailInfo.authResults.raw_header", "emailInfo.authResults.dkim", "emailInfo.authResults.dkim_signing_domain", "emailInfo.authResults.spf", "emailInfo.authResults.dmarc", "emailInfo.authResults.dmarc_policy", "emailInfo.authResults.dmarc_override_action", "emailInfo.tlsInfo.tlsAdvertised", "emailInfo.tlsInfo.tlsUsed", "emailInfo.tlsInfo.tlsKeyLength", "emailInfo.tlsInfo.tlsFallbackReason", "emailInfo.tlsInfo.tlsForwardSecrecy", "emailInfo.tlsInfo.tlsNegotiationFailed", "emailInfo.messageSize", "emailInfo.avQuarantinePenId", "emailInfo.rawHeaderFrom", "emailInfo.headerReplyTo", "emailInfo.newDomainAge", "emailInfo.timeInCynicSandboxMs", and "incidents |
additional.fields |
從變更記錄對應 |
變更記錄
還有其他問題嗎?向社群成員和 Google SecOps 專家尋求解答。