收集 Symantec Security Analytics 記錄
本文說明如何使用 Bindplane,將 Symantec Security Analytics 記錄檔擷取至 Google Security Operations。
Symantec Security Analytics (前身為 Blue Coat) 是網路鑑識和封包擷取平台,可為內部部署作業提供深入的封包檢查、完整的網路可視性,以及威脅分析。
事前準備
請確認您已完成下列事前準備事項:
- Google SecOps 執行個體
- Windows Server 2016 以上版本,或搭載
systemd的 Linux 主機 - Bindplane 代理程式與 Symantec Security Analytics 設備之間的網路連線
- 如果透過 Proxy 執行,請確保防火牆通訊埠已根據 Bindplane 代理程式需求開啟
- 具備管理員權限,可存取 Symantec Security Analytics 設備
取得 Google SecOps 擷取驗證檔案
- 登入 Google SecOps 控制台。
- 依序前往「SIEM 設定」>「收集代理程式」。
下載擷取驗證檔案。將檔案安全地儲存在要安裝 Bindplane 的系統上。
取得 Google SecOps 客戶 ID
- 登入 Google SecOps 控制台。
- 依序前往「SIEM 設定」>「設定檔」。
複製並儲存「機構詳細資料」部分中的客戶 ID。
安裝 Bindplane 代理程式
請按照下列操作說明,在 Windows 或 Linux 作業系統上安裝 Bindplane 代理程式。
Windows 安裝
- 以管理員身分開啟「命令提示字元」或「PowerShell」。
執行下列指令:
msiexec /i "https://github.com/observIQ/bindplane-agent/releases/latest/download/observiq-otel-collector.msi" /quiet等待安裝完成。
執行下列指令,確認安裝成功:
sc query observiq-otel-collector
服務應顯示為「RUNNING」。
Linux 安裝
- 開啟具有根層級或 sudo 權限的終端機。
執行下列指令:
sudo sh -c "$(curl -fsSlL https://github.com/observiq/bindplane-agent/releases/latest/download/install_unix.sh)" install_unix.sh等待安裝完成。
執行下列指令,確認安裝成功:
sudo systemctl status observiq-otel-collector
服務應顯示為有效 (執行中)。
其他安裝資源
如需其他安裝選項和疑難排解資訊,請參閱 Bindplane 代理程式安裝指南。
設定 Bindplane 代理程式,擷取系統記錄檔並傳送至 Google SecOps
找出設定檔
Linux:
sudo nano /etc/bindplane-agent/config.yamlWindows:
notepad "C:\Program Files\observIQ OpenTelemetry Collector\config.yaml"
編輯設定檔
將
config.yaml的所有內容替換為下列設定:receivers: udplog: listen_address: "0.0.0.0:514" exporters: chronicle/symantec_sa: compression: gzip creds_file_path: '/etc/bindplane-agent/ingestion-auth.json' customer_id: '<customer_id>' endpoint: malachiteingestion-pa.googleapis.com log_type: SYMANTEC_SA raw_log_field: body service: pipelines: logs/symantec_sa_to_chronicle: receivers: - udplog exporters: - chronicle/symantec_sa
設定參數
替換下列預留位置:
接收器設定:
listen_address:要接聽的 IP 位址和通訊埠:0.0.0.0,監聽所有介面 (建議)- 通訊埠
514是標準的系統記錄通訊埠 (在 Linux 上需要根層級權限;非根層級權限請使用1514)
匯出工具設定:
creds_file_path:擷取驗證檔案的完整路徑:- Linux:
/etc/bindplane-agent/ingestion-auth.json - Windows:
C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json
- Linux:
customer_id:從 Google SecOps 控制台複製的客戶 IDendpoint:區域端點網址:- 美國:
malachiteingestion-pa.googleapis.com - 歐洲:
europe-malachiteingestion-pa.googleapis.com - 亞洲:
asia-southeast1-malachiteingestion-pa.googleapis.com - 如需完整清單,請參閱「區域端點」
- 美國:
儲存設定檔
- 編輯完成後,請儲存檔案:
- Linux:依序按下
Ctrl+O、Enter和Ctrl+X - Windows:依序點選「檔案」>「儲存」
- Linux:依序按下
重新啟動 Bindplane 代理程式,以套用變更
如要在 Linux 中重新啟動 Bindplane 代理程式,請執行下列步驟:
執行下列指令:
sudo systemctl restart observiq-otel-collector確認服務正在執行:
sudo systemctl status observiq-otel-collector檢查記錄中是否有錯誤:
sudo journalctl -u observiq-otel-collector -f
如要在 Windows 中重新啟動 Bindplane 代理程式,請按照下列步驟操作:
您可以選擇下列其中一個選項:
- 以管理員身分開啟命令提示字元或 PowerShell:
net stop observiq-otel-collector && net start observiq-otel-collector- 服務控制台:
- 按下
Win+R,輸入services.msc,然後按下 Enter 鍵。 - 找出 observIQ OpenTelemetry Collector。
- 按一下滑鼠右鍵,然後選取「重新啟動」。
- 按下
確認服務正在執行:
sc query observiq-otel-collector檢查記錄中是否有錯誤:
type "C:\Program Files\observIQ OpenTelemetry Collector\log\collector.log"
設定 Symantec Security Analytics 系統記錄轉送
- 登入 Symantec Security Analytics 設備網頁介面。
- 依序前往「System」>「Alerting」>「Syslog」。
- 按一下「新增」,建立新的系統記錄目的地。
- 請提供下列設定詳細資料:
- 系統記錄伺服器:輸入 Bindplane 代理程式主機的 IP 位址。
- 「Port」(通訊埠):輸入
514。 - 「通訊協定」:選取「UDP」。
- 設施:選取「Local0」或偏好的設施。
- 選取要轉送的記錄類別 (安全性快訊、系統事件、網路事件)。
- 按一下「儲存」,套用設定。
- 檢查 Bindplane 代理程式記錄,確認記錄是否已傳送。
UDM 對應表
| 記錄欄位 | UDM 對應 | 邏輯 |
|---|---|---|
| additional.fields | 已從 m_label、c_label、start_time_label 合併 | |
| action_name | security_result.action_details | 直接複製值 |
| category | target.resource.type | 直接複製值 |
| cs4 | security_result.description | 直接複製值 |
| cs5 | security_result.summary | 直接複製值 |
| dmac | target.mac | 直接複製值 |
| dpt | target.port | 已轉換為整數 |
| dst | target.ip | 使用 grok 模式擷取為 dst_ip |
| dst | target.asset.ip | 使用 grok 模式擷取為 dst_ip |
| elapsed_time | security_result.detection_fields | 已從 elapsed_time_label 合併 |
| 結束 | 從 Epoch 毫秒轉換為時間戳記 (不適用於 UDM 對應) | |
| event_id | security_result.rule_id | 直接複製值 |
| event_name | metadata.product_event_type | 直接複製值 |
| evt | metadata.product_event_type | 直接複製值 |
| 主機 | intermediary.hostname | 直接複製值 |
| 主機 | intermediary.asset.hostname | 直接複製值 |
| id | target.resource.id | 直接複製值 |
| ip | principal.ip | 使用 grok 模式擷取為 ip_address1 |
| ip | principal.asset.ip | 使用 grok 模式擷取為 ip_address1 |
| ip_address | principal.ip | 使用 grok 模式擷取為 ip_address2 |
| ip_address | principal.asset.ip | 使用 grok 模式擷取為 ip_address2 |
| logmsg | metadata.description | 直接複製值 |
| m | additional.fields | 已從 m_label 合併 |
| mac_address | principal.mac | 直接複製值 |
| 模型 | target.resource.name | 直接複製值 |
| msgs | metadata.description | 直接複製值 |
| 路徑 | target.file.full_path | 直接複製值 |
| query_id | target.resource.attribute.labels | 從 query_id_label 合併 |
| remote_ip | target.ip | 使用 grok 模式擷取為 r_ipaddress |
| remote_ip | target.asset.ip | 使用 grok 模式擷取為 r_ipaddress |
| sequenceId | metadata.product_log_id | 直接複製值 |
| 嚴重性 | security_result.severity_details | 直接複製值 |
| 嚴重性 | security_result.severity | 如果值介於 ["0","1","2","3"],則設為 LOW;如果值介於 ["4","5","6"],則設為 MEDIUM;如果值介於 ["7","8"],則設為 HIGH;如果值介於 ["9","10"],則設為 CRITICAL;否則設為 UNKNOWN_SEVERITY |
| smac | principal.mac | 直接複製值 |
| sn | principal.mac | 直接複製值 |
| spt | principal.port | 已轉換為整數 |
| src | principal.ip | 使用 grok 模式擷取為 src_ip |
| src | principal.asset.ip | 使用 grok 模式擷取為 src_ip |
| 開始 | additional.fields | 已從 start_time_label 合併 |
| ts | metadata.collected_timestamp | 使用日期比對格式轉換 |
| 使用者 | principal.user.userid | 直接複製值 |
| 版本 | metadata.product_version | 直接複製值 |
| metadata.event_type | 如果 has_principal 和 has_target 為 true,則設為 NETWORK_CONNECTION;如果 has_principal 為 true 且 has_target 為 false,則設為 STATUS_UPDATE;如果 has_principal_user 為 true,則設為 USER_UNCATEGORIZED;否則設為 GENERIC_EVENT | |
| metadata.product_name | 設為「Security Analytics Platform」 | |
| metadata.vendor_name | 設為「Symantec Corporation」 | |
host |
event.idm.read_only_udm.intermediary.hostname 和 event.idm.read_only_udm.intermediary.asset.hostname |
從變更記錄對應 |
event_name |
event.idm.read_only_udm.metadata.product_event_type |
從變更記錄對應 |
end |
event.idm.read_only_udm.metadata.event_timestamp |
從變更記錄對應 |
ts |
event.idm.read_only_udm.metadata.collected_timestamp |
從變更記錄對應 |
host |
principal.hostname |
從變更記錄對應 |
logmsg |
metadata description |
從變更記錄對應 |
m" and "c |
additional.fields |
從變更記錄對應 |
變更記錄
還有其他問題嗎?向社群成員和 Google SecOps 專業人員尋求答案。