收集 Symantec VIP Authentication Hub 記錄

支援:

本文說明如何使用 Bindplane 代理程式,將 Symantec VIP Authentication Hub 記錄檔擷取至 Google Security Operations。

Symantec VIP Authentication Hub 是雲端式身分和驗證平台,可針對驗證事件、使用者同步、API 存取、OAuth 流程和 LDAP 目錄作業產生系統記錄訊息。剖析器會從 JSON 格式的記錄中擷取欄位,並對應至統合式資料模型 (UDM)。

事前準備

請確認您已完成下列事前準備事項:

  • Google SecOps 執行個體
  • Windows Server 2016 以上版本,或搭載 systemd 的 Linux 主機
  • Bindplane 代理程式與 Symantec VIP Authentication Hub 之間的網路連線
  • 如果是在 Proxy 後方執行,請確認防火牆通訊埠已按照 Bindplane 代理程式規定開啟
  • Symantec VIP Gateway 網頁 UI 的管理員權限

取得 Bindplane 代理程式的 Google SecOps 憑證

如要向 Google SecOps 驗證 Bindplane 代理程式,請選擇下列其中一種方法:

  • 新部署作業:使用 Chronicle API (選項 1)。
  • 舊版部署作業:在 2027 年 7 月 20 日停用 Ingestion API 前,請繼續使用擷取驗證檔案 (選項 2)。
  1. 登入 Google Cloud 控制台,選取連結至 Google SecOps 執行個體的 Google Cloud 專案。
  2. 依序前往 「IAM & Admin」(IAM 與管理) >「Service Accounts」(服務帳戶)。
  3. 按一下「建立服務帳戶」。
  4. 請提供下列設定詳細資料:
    • 服務帳戶名稱:輸入帳戶名稱 (例如 bindplane-ingest)。
    • 服務帳戶說明:輸入說明 (例如 Bindplane agent log ingestion)。
  5. 點按「Create and continue」(建立並繼續)。
  6. 在「將專案存取權授予這個服務帳戶」部分,按一下「選取角色」,然後選取「Chronicle 編輯者」。
  7. 依序點選「繼續」和「完成」。
  8. 按一下您建立的服務帳戶,然後前往「金鑰」分頁標籤。
  9. 依序點選「新增金鑰」>「建立新的金鑰」。
  10. 選取「JSON」,然後點選「建立」。金鑰檔案會下載到電腦。
  11. 將金鑰檔案儲存為 Bindplane 收集器目錄中的 ingestion-auth.json (Linux 上的 /opt/observiq-otel-collector/ingestion-auth.json 或 Windows 上的 C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json),或更新 config.yaml 中的 creds_file_path,使其與儲存路徑相符。
  12. 依序前往「IAM & Admin」(IAM 與管理) >「Settings」(設定),然後複製「Project number」(專案編號)。匯出工具設定時會用到。

方法 2:下載擷取驗證檔案 (舊版)

  1. 登入 Google SecOps 控制台。
  2. 依序前往「SIEM Settings」 > 「Collection Agents」。
  3. 下載擷取驗證檔案。
  4. 將檔案安全地儲存在要安裝 Bindplane 代理程式的系統中。

取得 Google SecOps 客戶 ID

  1. 登入 Google SecOps 控制台。
  2. 依序前往「SIEM 設定」>「設定檔」。
  3. 複製並儲存「機構詳細資料」部分的客戶 ID。

安裝 Bindplane 代理程式

請按照下列操作說明,在 Windows 或 Linux 作業系統上安裝 Bindplane 代理程式。

Windows 安裝

  1. 以管理員身分開啟「命令提示字元」或「PowerShell」。
  2. 執行下列指令:

    msiexec /i "https://github.com/observIQ/bindplane-agent/releases/latest/download/observiq-otel-collector.msi" /quiet
    
  3. 等待安裝完成。

  4. 執行下列指令,確認安裝成功:

    sc query observiq-otel-collector
    

    服務應顯示為「RUNNING」。

Linux 安裝

  1. 開啟具有 root 或 sudo 權限的終端機。
  2. 執行下列指令:

    sudo sh -c "$(curl -fsSlL https://github.com/observiq/bindplane-agent/releases/latest/download/install_unix.sh)" install_unix.sh
    
  3. 等待安裝完成。

  4. 執行下列指令,確認安裝成功:

    sudo systemctl status observiq-otel-collector
    

    服務應顯示為「active (running)」。

其他安裝資源

如需其他安裝選項和疑難排解資訊,請參閱 Bindplane 代理程式安裝指南。

設定 Bindplane 代理,擷取系統記錄檔並傳送至 Google SecOps

找出設定檔

  • Linux:

    sudo nano /opt/observiq-otel-collector/config.yaml
    
  • Windows:

    notepad "C:\Program Files\observIQ OpenTelemetry Collector\config.yaml"
    

編輯設定檔

  • 將 config.yaml 的全部內容替換為下列設定:

    receivers:
      udplog:
        listen_address: "0.0.0.0:514"
    
    exporters:
      chronicle/symantec_vip_authhub:
        protocol: https
        # Region of your instance, for example us, europe, asia-southeast1
        location: <LOCATION>
        # Project number of the Google Cloud project linked to the instance
        project: '<PROJECT_NUMBER>'
        compression: gzip
        creds_file_path: '/opt/observiq-otel-collector/ingestion-auth.json'
        customer_id: '<customer_id>'
        endpoint: chronicle.googleapis.com
        log_type: SYMANTEC_VIP_AUTHHUB
        raw_log_field: body
    
    service:
      pipelines:
        logs/symantec_vip_authhub_to_chronicle:
          receivers:
            - udplog
          exporters:
            - chronicle/symantec_vip_authhub
    

設定參數

替換下列預留位置:

  • 接收器設定:

    • listen_address:要接聽的 IP 位址和通訊埠:
      • 0.0.0.0 在所有介面接聽電話 (建議)
      • 通訊埠 514 是標準 syslog 通訊埠 (在 Linux 上需要根目錄;非根目錄請使用 1514)
  • Exporter 設定:

    • creds_file_path:服務帳戶 JSON 金鑰檔案的完整路徑 (選項 1):
      • Linux:/opt/observiq-otel-collector/ingestion-auth.json
      • Windows:C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json
    • customer_id:從 Google SecOps 控制台複製的客戶 ID
    • location:將 <LOCATION> 替換為 Google SecOps 執行個體的區域 (例如 us、europe 或 asia-southeast1)。匯出工具會在這個值前面加上 chronicle.googleapis.com。如需完整清單,請參閱「區域性端點」。
    • project:依序前往「IAM 與管理」>「設定」,然後將 <PROJECT_NUMBER> 替換為專案編號。
    • endpoint:維持設為 chronicle.googleapis.com。

舊版擷取 API 匯出工具

  • 如果您使用選項 2 的擷取驗證檔案,請將 exporters 區塊替換為下列內容。將 creds_file_path 設為擷取驗證檔案的路徑,如果您的執行個體位於美國境外,請將 malachiteingestion-pa.googleapis.com 替換為區域端點 (例如 europe-malachiteingestion-pa.googleapis.com)。

    exporters:
      chronicle/symantec_vip_authhub:
        compression: gzip
        creds_file_path: '/opt/observiq-otel-collector/ingestion-auth.json'
        customer_id: '<customer_id>'
        endpoint: malachiteingestion-pa.googleapis.com
        log_type: SYMANTEC_VIP_AUTHHUB
        raw_log_field: body
    

儲存設定檔

  • 編輯完畢後,請儲存檔案:
    • Linux:依序按下 Ctrl+O、Enter 和 Ctrl+X
    • Windows:依序點選「檔案」 > 「儲存」

重新啟動 Bindplane 代理程式,套用變更

  • 如要在 Linux 重新啟動 Bindplane 代理程式,請執行下列指令:

    sudo systemctl restart observiq-otel-collector
    
    1. 確認服務是否正在執行:

      sudo systemctl status observiq-otel-collector
      
    2. 檢查記錄是否有錯誤:

      sudo journalctl -u observiq-otel-collector -f
      
  • 如要在 Windows 中重新啟動 Bindplane 代理程式,請選擇下列其中一個選項:

    • 以管理員身分開啟命令提示字元或 PowerShell:

      net stop observiq-otel-collector && net start observiq-otel-collector
      
    • 服務控制台:

      1. 按下 Win+R 鍵,輸入 services.msc,然後按下 Enter 鍵。
      2. 找出「observIQ OpenTelemetry Collector」。
      3. 按一下滑鼠右鍵,然後選取「重新啟動」。
      4. 確認服務正在執行:

        sc query observiq-otel-collector
        
      5. 查看記錄檔是否有錯誤:

        type "C:\Program Files\observIQ OpenTelemetry Collector\log\collector.log"
        

在 Symantec VIP Authentication Hub 中設定系統記錄

  1. 登入 Symantec VIP Gateway 網頁版 UI。
  2. 依序前往「記錄」>「系統記錄設定」。
  3. 如果是首次設定系統記錄,請在系統提示時選取「是」。如果已設定,請按一下「編輯」。
  4. 提供下列設定詳細資料:
    • 系統記錄設施:選取「LOG_LOCAL0」。
    • Syslog Host:輸入 Bindplane 代理程式 IP 位址。
    • 「Syslog Port」(Syslog 通訊埠):輸入 Bindplane 代理程式通訊埠編號 (例如 514,用於 UDP)。
  5. 按一下 [儲存]。
  6. 依序前往「Identity providers」>「Self Service Portal Configuration」。
  7. 編輯下列設定詳細資料:
    • 記錄層級:選取「資訊」。
    • 啟用系統記錄:選取「是」。
  8. 按一下「提交」。
  9. 依序前往「Identity providers」>「VIP Manager Authentication Configuration」。
  10. 編輯下列設定詳細資料:
    • 記錄層級:選取「資訊」。
    • 啟用系統記錄:選取「是」。
  11. 按一下「提交」。
  12. 依序前往 「User Store」 > 「LDAP Directory Synchronization」。
  13. 編輯下列設定詳細資料:
    • 記錄層級:選取「資訊」。
    • 啟用 Syslog:選取「是」。
  14. 按一下「提交」。

UDM 對應表

記錄欄位 UDM 對應 邏輯
/auth/v1/authenticate security_result.detection_fields[].value 該值取自原始記錄中的 /auth/v1/authenticate 欄位,並指派給含有 api 鍵的 security_result.detection_fields 物件。
__isAuditIdLcmIdStore additional.fields[].value.string_value 系統會從原始記錄的 __isAuditIdLcmIdStore 欄位擷取值,並指派給含有 __isAuditIdLcmIdStore 鍵的 additional.fields 物件。
accessTokenScopes security_result.detection_fields[].value 系統會從原始記錄的 accessTokenScopes 欄位擷取值,並指派給鍵為 accessTokenScopes 的 security_result.detection_fields 物件。
accessTokenTid security_result.detection_fields[].value 系統會從原始記錄的 accessTokenTid 欄位擷取值,並指派給鍵為 accessTokenTid 的 security_result.detection_fields 物件。
api security_result.detection_fields[].value 該值取自原始記錄中的 api 欄位,並指派給含有 api 鍵的 security_result.detection_fields 物件。
appId additional.fields[].value.string_value 系統會從原始記錄的 appId 欄位擷取值,並指派給含有 appId 鍵的 additional.fields 物件。
appName principal.application 這個值取自原始記錄中的 appName 欄位。
azpName additional.fields[].value.string_value 系統會從原始記錄的 azpName 欄位擷取值,並指派給含有 azpName 鍵的 additional.fields 物件。
bytes_sent network.sent_bytes 這個值取自原始記錄中的 bytes_sent 欄位。
client principal.asset.ip、principal.ip 系統會使用 grok 模式從原始記錄的 client 欄位擷取 IP 位址,並新增至 principal.ip 和 principal.asset.ip 欄位。
clientId additional.fields[].value.string_value、principal.user.userid 系統會從原始記錄的 clientId 欄位擷取值,並指派給含有 clientId 鍵的 additional.fields 物件。如果 clientId 欄位不是空白,系統也會使用該欄位填入 principal.user.userid 欄位。
clientIp principal.asset.ip、principal.ip 系統會從原始記錄的 clientIp 欄位中取得值,並新增至 principal.ip 和 principal.asset.ip 欄位。
clientTid additional.fields[].value.string_value 系統會從原始記錄的 clientTid 欄位擷取值,並指派給含有 clientTid 鍵的 additional.fields 物件。
clientTxnId additional.fields[].value.string_value 系統會從原始記錄的 clientTxnId 欄位擷取值,並指派給含有 clientTxnId 鍵的 additional.fields 物件。
contentType additional.fields[].value.string_value 系統會從原始記錄的 contentType 欄位擷取值,並指派給含有 contentType 鍵的 additional.fields 物件。
countryISO principal.location.country_or_region 這個值取自原始記錄中的 countryISO 欄位。
eventId metadata.product_event_type 這個值取自原始記錄中的 eventId 欄位。
flowStateId additional.fields[].value.string_value 系統會從原始記錄的 flowStateId 欄位擷取值,並指派給含有 flowStateId 鍵的 additional.fields 物件。
geo.city_name principal.location.city 這個值取自原始記錄中的 geo.city_name 欄位。
geo.country_name principal.location.country_or_region 這個值取自原始記錄中的 geo.country_name 欄位。
geo.location.lat principal.location.region_coordinates.latitude 系統會從原始記錄的 geo.location.lat 欄位擷取值,轉換為浮點數,並重新命名為 principal.location.region_coordinates.latitude。
geo.location.lon principal.location.region_coordinates.longitude 系統會從原始記錄的 geo.location.lon 欄位擷取值,轉換為浮點數,並重新命名為 principal.location.region_coordinates.longitude。
guid metadata.product_log_id 這個值取自原始記錄中的 guid 欄位。
host principal.asset.hostname、principal.hostname 系統會從原始記錄的 host 欄位擷取值,移除所有引號,然後新增至 principal.hostname 和 principal.asset.hostname 欄位。
httpMethod network.http.method 這個值取自原始記錄中的 httpMethod 欄位。
httpReferrer network.http.referral_url 這個值取自原始記錄中的 httpReferrer 欄位。
identitySourceId additional.fields[].value.string_value 系統會從原始記錄的 identitySourceId 欄位擷取值,並指派給含有 identitySourceId 鍵的 additional.fields 物件。
internal-user-sync-ext-resourceGuid target.user.userid 這個值取自原始記錄中的 internal-user-sync-ext-resourceGuid 欄位。
internal-user-sync-ext-resourceName target.user.email_addresses 系統會從原始記錄的 internal-user-sync-ext-resourceName 欄位擷取值,並新增至 target.user.email_addresses 欄位。
issuerUrl target.url 這個值取自原始記錄中的 issuerUrl 欄位。
kubernetes.annotations.cni.projectcalico.org_containerID target.resource.product_object_id 這個值取自原始記錄中的 kubernetes.annotations.cni.projectcalico.org_containerID 欄位。
kubernetes.annotations.cni.projectcalico.org_podIP target.resource.attribute.labels[].value 系統會從原始記錄的 kubernetes.annotations.cni.projectcalico.org_podIP 欄位擷取值,並指派給鍵為 podIP 的 target.resource.attribute.labels 物件。
kubernetes.annotations.cni.projectcalico.org_podIPs target.resource.attribute.labels[].value 系統會從原始記錄的 kubernetes.annotations.cni.projectcalico.org_podIPs 欄位擷取值,並指派給鍵為 podIPs 的 target.resource.attribute.labels 物件。
kubernetes.container_hash target.resource.attribute.labels[].value 該值取自原始記錄中的 kubernetes.container_hash 欄位,並指派給含有 container_hash 鍵的 target.resource.attribute.labels 物件。
kubernetes.container_image target.resource.attribute.labels[].value 系統會從原始記錄的 kubernetes.container_image 欄位擷取值,並指派給鍵為 container_image 的 target.resource.attribute.labels 物件。
kubernetes.container_name target.resource.attribute.labels[].value 該值取自原始記錄中的 kubernetes.container_name 欄位,並指派給含有 container_name 鍵的 target.resource.attribute.labels 物件。
kubernetes.docker_id target.resource.attribute.labels[].value 系統會從原始記錄的 kubernetes.docker_id 欄位擷取值,並指派給鍵為 docker_id 的 target.resource.attribute.labels 物件。
kubernetes.host principal.asset.hostname、principal.hostname 系統會從原始記錄的 kubernetes.host 欄位中取得值,並新增至 principal.hostname 和 principal.asset.hostname 欄位。
kubernetes.labels.app 這個欄位未對應至 UDM 中的 IDM 物件。
kubernetes.labels.app.kubernetes.io/component target.resource.attribute.labels[].value 該值取自原始記錄中的 kubernetes.labels.app.kubernetes.io/component 欄位,並指派給含有 io_component 鍵的 target.resource.attribute.labels 物件。
kubernetes.labels.app.kubernetes.io/instance target.resource.attribute.labels[].value 系統會從原始記錄的 kubernetes.labels.app.kubernetes.io/instance 欄位擷取值,並指派給鍵為 io_instance 的 target.resource.attribute.labels 物件。
kubernetes.labels.app.kubernetes.io/managed-by target.resource.attribute.labels[].value 該值取自原始記錄中的 kubernetes.labels.app.kubernetes.io/managed-by 欄位,並指派給含有 io_managed-by 鍵的 target.resource.attribute.labels 物件。
kubernetes.labels.app.kubernetes.io/name target.resource.attribute.labels[].value 該值取自原始記錄中的 kubernetes.labels.app.kubernetes.io/name 欄位,並指派給含有 io_name 鍵的 target.resource.attribute.labels 物件。
kubernetes.labels.app.kubernetes.io/part-of target.resource.attribute.labels[].value 該值取自原始記錄中的 kubernetes.labels.app.kubernetes.io/part-of 欄位,並指派給含有 io_part-of 鍵的 target.resource.attribute.labels 物件。
kubernetes.labels.app.kubernetes.io/version target.resource.attribute.labels[].value 該值取自原始記錄中的 kubernetes.labels.app.kubernetes.io/version 欄位,並指派給含有 io_version 鍵的 target.resource.attribute.labels 物件。
kubernetes.labels.helm.sh/chart target.resource.attribute.labels[].value 系統會從原始記錄的 kubernetes.labels.helm.sh/chart 欄位擷取值,並指派給鍵為 helm_sh_chart 的 target.resource.attribute.labels 物件。
kubernetes.labels.helmChartName target.resource.attribute.labels[].value 系統會從原始記錄的 kubernetes.labels.helmChartName 欄位擷取值,並指派給鍵為 helmChartName 的 target.resource.attribute.labels 物件。
kubernetes.labels.imageTag target.resource.attribute.labels[].value 系統會從原始記錄的 kubernetes.labels.imageTag 欄位擷取值,並指派給鍵為 imageTag 的 target.resource.attribute.labels 物件。
kubernetes.labels.pod-template-hash target.resource.attribute.labels[].value 該值取自原始記錄中的 kubernetes.labels.pod-template-hash 欄位,並指派給含有 pod-template-hash 鍵的 target.resource.attribute.labels 物件。
kubernetes.namespace_name target.resource.attribute.labels[].value 系統會從原始記錄的 kubernetes.namespace_name 欄位擷取值,並指派給鍵為 namespace_name 的 target.resource.attribute.labels 物件。
kubernetes.pod_id target.resource.attribute.labels[].value 系統會從原始記錄的 kubernetes.pod_id 欄位擷取值,並指派給鍵為 pod_id 的 target.resource.attribute.labels 物件。
kubernetes.pod_name target.resource.attribute.labels[].value 該值取自原始記錄中的 kubernetes.pod_name 欄位,並指派給含有 pod_name 鍵的 target.resource.attribute.labels 物件。
level security_result.severity 如果原始記錄中的 level 欄位與 notice 或 info 相符 (不區分大小寫),security_result.severity 欄位會設為 INFORMATIONAL。
log security_result.description、level、kv_data 系統會使用 grok 模式,從原始記錄的 log 欄位中擷取 level 和 kv_data 欄位。security_result.description 欄位會填入整個 log 欄位。
logtag additional.fields[].value.string_value 系統會從原始記錄的 logtag 欄位擷取值,並指派給含有 logtag 鍵的 additional.fields 物件。
method network.http.method 這個值取自原始記錄中的 method 欄位。
msg metadata.event_type、security_result.description 系統會從原始記錄的 msg 欄位擷取值,並填入 security_result.description 欄位。metadata.event_type 欄位會根據 msg 欄位的內容決定: * 如果 msg 包含 Internal user created or updated,則為 USER_CREATION。* 如果 msg 包含 Authorization Initiated Succesfully、Authentication Initiated Successfully 或 Authentication Successful,則為 USER_LOGIN。* 如果 msg 包含 Token Generated 或 token verified,則為 USER_RESOURCE_ACCESS。* 如果 has_principal 和 has_target 皆為 true,則為 NETWORK_CONNECTION。* 如果 has_principal 為 true,則為 STATUS_UPDATE。* 其他情況則為 GENERIC_EVENT。
path principal.file.full_path 這個值取自原始記錄中的 path 欄位。
principalId additional.fields[].value.string_value、principal.user.userid 系統會從原始記錄的 principalId 欄位擷取值,並指派給含有 principalId 鍵的 additional.fields 物件。如果 principalId 欄位不是 clientId 且不為空白,系統也會用來填入 principal.user.userid 欄位。
principalType additional.fields[].value.string_value 該值取自原始記錄中的 principalType 欄位,並指派給含有 principalType 鍵的 additional.fields 物件。
protocol network.application_protocol 如果原始記錄中的 protocol 欄位與 HTTP 相符 (不區分大小寫),network.application_protocol 欄位會設為 HTTP。
referrer network.http.referral_url 系統會從原始記錄的 referrer 欄位中取得值,去除所有引號,然後指派給 network.http.referral_url 欄位。
relVersion metadata.product_version 這個值取自原始記錄中的 relVersion 欄位。
remoteAddr additional.fields[].value.string_value 系統會從原始記錄的 remoteAddr 欄位擷取值,並指派給含有 remoteAddr 鍵的 additional.fields 物件。
requestId additional.fields[].value.string_value 該值取自原始記錄中的 requestId 欄位,並指派給含有 requestId 鍵的 additional.fields 物件。
requestTime additional.fields[].value.string_value 系統會從原始記錄的 requestTime 欄位擷取值,並指派給含有 requestTime 鍵的 additional.fields 物件。
responseCode network.http.response_code 系統會使用 grok 模式從原始記錄的 responseCode 欄位擷取數值,並轉換為整數,然後指派給 network.http.response_code 欄位。
request method、path、protocol 系統會先移除所有引號,再使用 grok 模式從原始記錄的 request 欄位擷取 method、path 和 protocol 欄位。
server target.asset.hostname、target.hostname 系統會從原始記錄的 server 欄位擷取值,並新增至 target.hostname 和 target.asset.hostname 欄位。
service additional.fields[].value.string_value 系統會從原始記錄的 service 欄位擷取值,並指派給含有 service 鍵的 additional.fields 物件。
status network.http.response_code 系統會從原始記錄的 status 欄位中取得值,並轉換為整數,然後指派給 network.http.response_code 欄位。
stream additional.fields[].value.string_value 該值取自原始記錄中的 stream 欄位,並指派給含有 stream 鍵的 additional.fields 物件。
sub additional.fields[].value.string_value 該值取自原始記錄中的 sub 欄位,並指派給含有 sub 鍵的 additional.fields 物件。
subType additional.fields[].value.string_value 該值取自原始記錄中的 subType 欄位,並指派給含有 subType 鍵的 additional.fields 物件。
tid additional.fields[].value.string_value 該值取自原始記錄中的 tid 欄位,並指派給含有 tid 鍵的 additional.fields 物件。
timestamp metadata.event_timestamp 這個值取自原始記錄中的 timestamp 欄位,並剖析為 ISO8601 時間戳記。
tname additional.fields[].value.string_value 系統會從原始記錄的 tname 欄位擷取值,並指派給含有 tname 鍵的 additional.fields 物件。
txnId additional.fields[].value.string_value 系統會從原始記錄的 txnId 欄位擷取值,並指派給含有 txnId 鍵的 additional.fields 物件。
type additional.fields[].value.string_value 該值取自原始記錄中的 type 欄位,並指派給含有 type 鍵的 additional.fields 物件。
userAgent network.http.parsed_user_agent、network.http.user_agent 系統會從原始記錄的 userAgent 欄位取得值,並指派給 network.http.user_agent 和 network.http.parsed_user_agent 欄位。接著,network.http.parsed_user_agent 欄位會轉換為剖析的使用者代理程式物件。
userDN additional.fields[].value.string_value 系統會從原始記錄的 userDN 欄位擷取值,並指派給含有 userDN 鍵的 additional.fields 物件。
userGuid additional.fields[].value.string_value 該值取自原始記錄中的 userGuid 欄位,並指派給含有 userGuid 鍵的 additional.fields 物件。
userIdpGuid additional.fields[].value.string_value 該值取自原始記錄中的 userIdpGuid 欄位,並指派給含有 userIdpGuid 鍵的 additional.fields 物件。
userIP principal.asset.ip、principal.ip、target.asset.ip、target.ip、intermediary.ip 系統會使用 grok 模式,從原始記錄的 userIP 欄位擷取 IP 位址。第一個 IP 位址會新增至 principal.ip 和 principal.asset.ip 欄位。第二個 IP 位址會新增至 target.ip 和 target.asset.ip 欄位。第三個 IP 位址會新增至 intermediary.ip 欄位。
userLoginId target.user.email_addresses 如果原始記錄中的 userLoginId 欄位不為空白,且符合電子郵件地址模式,系統就會將該欄位新增至 target.user.email_addresses 欄位。
userLoginIdAttributeMappingName target.user.user_display_name 這個值取自原始記錄中的 userLoginIdAttributeMappingName 欄位。
userRiskLevel additional.fields[].value.string_value 該值取自原始記錄中的 userRiskLevel 欄位,並指派給含有 userRiskLevel 鍵的 additional.fields 物件。
userRiskScore additional.fields[].value.string_value 該值取自原始記錄中的 userRiskScore 欄位,並指派給含有 userRiskScore 鍵的 additional.fields 物件。
userIp principal.asset.ip、principal.ip 系統會從原始記錄的 userIp 欄位擷取值,並新增至 principal.ip 和 principal.asset.ip 欄位。
userUniversalId additional.fields[].value.string_value 系統會從原始記錄的 userUniversalId 欄位擷取值,並指派給含有 userUniversalId 鍵的 additional.fields 物件。
vhost additional.fields[].value.string_value 系統會從原始記錄的 vhost 欄位擷取值,並指派給含有 vhost 鍵的 additional.fields 物件。
不適用 extensions.auth.type 如果 metadata.event_type 欄位為 USER_LOGIN,值會設為 SSO。
不適用 metadata.log_type 值會設為 SYMANTEC_VIP_AUTHHUB。
azserver-idp-response-verify-cert-ext-idpId", "__THIS_RESOURCE_ID" and "admin-identityprovider-create-ext-resourceGuid principal.user.attribute.cloud.project.id 從變更記錄對應
thread additional.fields 從變更記錄對應
remoteUser additional.fields 從變更記錄對應
kubernetes.labels.app.kubernetes.io_component target.resource.attribute.labels 從變更記錄對應
kubernetes.labels.app.kubernetes.io_instance target.resource.attribute.labels 從變更記錄對應
kubernetes.labels.app.kubernetes.io_name target.resource.attribute.labels 從變更記錄對應
kubernetes.labels.app.kubernetes.io_managed-by target.resource.attribute.labels 從變更記錄對應
kubernetes.labels.app.kubernetes.io_part-of target.resource.attribute.labels 從變更記錄對應
kubernetes.labels.app.kubernetes.io_version target.resource.attribute.labels 從變更記錄對應
kubernetes.labels.helm.sh_chart target.resource.attribute.labels 從變更記錄對應
reqLength additional.fields 從變更記錄對應

變更記錄

查看這個剖析器的變更記錄

還有其他問題嗎?向社群成員和 Google SecOps 專家尋求解答。