收集 Symantec Web Isolation 日志

支持:

本文档介绍了如何使用 Bindplane 代理将 Symantec Web Isolation 日志注入到 Google Security Operations。

Symantec Web Isolation 是一个浏览器隔离平台,可为网页浏览会话、网址访问事件、文件下载活动、政策执行和设备管理事件生成 syslog 消息。解析器会从 JSON 格式的日志中提取字段,并将其映射到统一数据模型 (UDM)。

准备工作

请确保满足以下前提条件:

  • Google SecOps 实例
  • Windows Server 2016 或更高版本,或者具有 systemd 的 Linux 主机
  • Bindplane 代理与 Symantec Web Isolation 平台之间的网络连接
  • 如果在代理后面运行,请确保按照 Bindplane 代理要求打开防火墙端口
  • 对 Symantec Web Isolation 网页界面的管理员权限

获取 Bindplane 代理的 Google SecOps 凭据

如需向 Google SecOps 验证 Bindplane 代理,请选择以下方法之一:

  • 新部署:使用 Chronicle API(选项 1)。
  • 旧版部署:继续使用提取身份验证文件(方法 2),直到提取 API 于 2027 年 7 月 20 日停用。
  1. 登录 Google Cloud 控制台,然后选择与您的 Google SecOps 实例关联的 Google Cloud 项目。
  2. 前往 IAM 和管理 > 服务账号。
  3. 点击创建服务账号。
  4. 提供以下配置详细信息:
    • 服务账号名称:输入账号的名称(例如 bindplane-ingest)。
    • 服务账号说明:输入说明(例如 Bindplane agent log ingestion)。
  5. 点击创建并继续。
  6. 在向此服务账号授予对项目的访问权限部分,点击选择角色,然后选择 Chronicle Editor。
  7. 点击继续,然后点击完成。
  8. 点击您创建的服务账号,然后前往密钥标签页。
  9. 依次点击添加密钥 > 创建新密钥。
  10. 选择 JSON,然后点击创建。密钥文件会下载到您的计算机上。
  11. 将密钥文件另存为 Bindplane 收集器目录(Linux 上的 /opt/observiq-otel-collector/ingestion-auth.json 或 Windows 上的 C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json)中的 ingestion-auth.json,或更新 config.yaml 中的 creds_file_path 以匹配您保存该文件的路径。
  12. 前往 IAM 和管理 > 设置,然后复制项目编号。您在配置导出器时需要用到该名称。

方法 2:下载数据注入身份验证文件(旧版)

  1. 登录 Google SecOps 控制台。
  2. 依次前往 SIEM 设置 > 收集代理。
  3. 下载数据注入身份验证文件。
  4. 将文件安全地保存在将安装 Bindplane 代理的系统上。

获取 Google SecOps 客户 ID

  1. 登录 Google SecOps 控制台。
  2. 依次前往 SIEM 设置 > 配置文件。
  3. 复制并保存组织详细信息部分中的客户 ID。

安装 Bindplane 代理

根据以下说明,在 Windows 或 Linux 操作系统上安装 Bindplane 代理。

Windows 安装

  1. 以管理员身份打开命令提示符或 PowerShell。
  2. 运行以下命令:

    msiexec /i "https://github.com/observIQ/bindplane-agent/releases/latest/download/observiq-otel-collector.msi" /quiet
    
  3. 等待安装完成。

  4. 运行以下命令,验证安装是否成功:

    sc query observiq-otel-collector
    

    该服务应显示为 RUNNING。

Linux 安装

  1. 打开具有 root 或 sudo 权限的终端。
  2. 运行以下命令:

    sudo sh -c "$(curl -fsSlL https://github.com/observiq/bindplane-agent/releases/latest/download/install_unix.sh)" install_unix.sh
    
  3. 等待安装完成。

  4. 运行以下命令,验证安装是否成功:

    sudo systemctl status observiq-otel-collector
    

    该服务应显示为 active (running)。

其他安装资源

如需了解其他安装选项和问题排查,请参阅 Bindplane 代理安装指南。

配置 Bindplane 代理以注入 syslog 并将其发送到 Google SecOps

找到配置文件

  • Linux:

    sudo nano /opt/observiq-otel-collector/config.yaml
    
  • Windows:

    notepad "C:\Program Files\observIQ OpenTelemetry Collector\config.yaml"
    

修改配置文件

  • 将 config.yaml 的全部内容替换为以下配置:

    receivers:
      udplog:
        listen_address: "0.0.0.0:514"
    
    exporters:
      chronicle/symantec_web_isolation:
        protocol: https
        # Region of your instance, for example us, europe, asia-southeast1
        location: <LOCATION>
        # Project number of the Google Cloud project linked to the instance
        project: '<PROJECT_NUMBER>'
        compression: gzip
        creds_file_path: '/opt/observiq-otel-collector/ingestion-auth.json'
        customer_id: '<customer_id>'
        endpoint: chronicle.googleapis.com
        log_type: SYMANTEC_WEB_ISOLATION
        raw_log_field: body
    
    service:
      pipelines:
        logs/symantec_web_isolation_to_chronicle:
          receivers:
            - udplog
          exporters:
            - chronicle/symantec_web_isolation
    

配置参数

替换以下占位符:

  • 接收器配置:

    • listen_address:要监听的 IP 地址和端口:
      • 0.0.0.0 在所有接口上监听(推荐)
      • 端口 514 是标准 syslog 端口(在 Linux 上需要 root 权限;对于非 root 用户,请使用 1514)
  • 导出器配置:

    • creds_file_path:服务账号 JSON 密钥文件的完整路径(选项 1):
      • Linux:/opt/observiq-otel-collector/ingestion-auth.json
      • Windows:C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json
    • customer_id:从 Google SecOps 控制台复制的客户 ID
    • location:将 <LOCATION> 替换为 Google SecOps 实例的区域(例如 us、europe 或 asia-southeast1)。导出器会使用此值作为 chronicle.googleapis.com 的前缀。如需查看完整列表,请参阅区域级端点。
    • project:将 <PROJECT_NUMBER> 替换为 IAM 和管理 > 设置中的项目编号。
    • endpoint:保持设置为 chronicle.googleapis.com。

旧版提取 API

  • 如果您使用选项 2 中的数据注入身份验证文件,请将 exporters 代码块替换为以下内容。将 creds_file_path 设置为数据注入身份验证文件的路径,如果您的实例位于美国境外,请将 malachiteingestion-pa.googleapis.com 替换为您的区域端点(例如 europe-malachiteingestion-pa.googleapis.com)。

    exporters:
      chronicle/symantec_web_isolation:
        compression: gzip
        creds_file_path: '/opt/observiq-otel-collector/ingestion-auth.json'
        customer_id: '<customer_id>'
        endpoint: malachiteingestion-pa.googleapis.com
        log_type: SYMANTEC_WEB_ISOLATION
        raw_log_field: body
    

保存配置文件

  • 修改后,保存文件:
    • Linux:依次按 Ctrl+O、Enter 和 Ctrl+X
    • Windows:依次点击文件 > 保存

重启 Bindplane 代理以应用更改

  • 如需在 Linux 中重启 Bindplane 代理,请运行以下命令:

    sudo systemctl restart observiq-otel-collector
    
    1. 验证服务是否正在运行:

      sudo systemctl status observiq-otel-collector
      
    2. 检查日志中的错误:

      sudo journalctl -u observiq-otel-collector -f
      
  • 如需在 Windows 中重启 Bindplane 代理,请选择以下选项之一:

    • 以管理员身份运行命令提示符或 PowerShell:

      net stop observiq-otel-collector && net start observiq-otel-collector
      
    • “服务”控制台:

      1. 按 Win+R,输入 services.msc,然后按 Enter 键。
      2. 找到 observIQ OpenTelemetry 收集器。
      3. 右键点击并选择重启。
      4. 验证服务是否正在运行:

        sc query observiq-otel-collector
        
      5. 检查日志中的错误:

        type "C:\Program Files\observIQ OpenTelemetry Collector\log\collector.log"
        

在 Symantec Web Isolation 平台中配置 syslog

  1. 登录 Symantec Web Isolation 网页界面。
  2. 依次前往系统配置>外部日志服务器>新建外部日志服务器>Syslog 服务器。
  3. 提供以下配置详细信息:
    • 状态:选中复选框以启用。
    • 主机:输入 Bindplane 代理 IP 地址。
    • 端口:输入 Bindplane 代理端口号(例如,UDP 为 514)。
    • 协议:选择 UDP。
    • Appname:输入用于标识 Web 隔离平台的标记。
    • 设备:与 Web 隔离日志相关的 Syslog 设备名称。
  4. 点击创建。
  5. 依次前往报告>日志转发。
  6. 点击修改。
  7. 提供以下配置详细信息:
    • 活动日志:选择新添加的 Bindplane 服务器。
    • 管理审核日志:选择新添加的 Bindplane 服务器。
    • 网关审核日志:选择新添加的 Bindplane 服务器。
  8. 点击更新。

UDM 映射表

日志字段 UDM 映射 逻辑
action security_result.summary 与 action_reason 串联以形成摘要。
action_reason security_result.summary 与 action 串联以形成摘要。
content_action security_result.action_details 直接映射。
createdAt metadata.event_timestamp 已使用 UNIX_MS 格式转换为时间戳。
creationDate metadata.event_timestamp 使用 UNIX_MS 格式转换为时间戳。
data.level security_result.severity 根据值映射到 INFORMATIONAL、LOW 或 HIGH。
data.properties.environment.str intermediary.location.name 直接映射。
data.properties.hostname.str intermediary.hostname 直接映射。
destination_ip target.ip 直接映射。
destination_ip_country_name target.location.country_or_region 直接映射。
device.current_risk_warnings security_result.category_details 直接映射。
device.identifier target.asset.product_object_id 直接映射。
device.model hardware.model 直接映射。
device.os_version target.asset.platform_software.platform_version 直接映射。
device.serial_number hardware.serial_number 直接映射。
device.udid target.asset.asset_id 在映射前带有“UDID:”前缀。
device.user.email target.user.email_addresses 直接映射。
device.user.id target.user.userid 直接映射。
device.user.name target.user.user_display_name 直接映射。
device.user.organization.id target.user.groupid 直接映射。
device.user.organization.name target.user.group_identifiers 直接映射。
event metadata.product_event_type 直接映射。
event_type metadata.event_type 根据日志数据设置为“GENERIC_EVENT”或“NETWORK_HTTP”。
file_name target.file.names 直接映射。
file_type about.labels,about.resource.attribute.labels 添加为键为“file_type”的标签。
id metadata.product_log_id 直接映射。
isolation_session_id network.parent_session_id 直接映射。
level security_result.severity 根据值映射到 INFORMATIONAL、LOW 或 HIGH。
original_source_ip principal.ip 直接映射。
policy_version security_result.rule_version 直接映射。
properties.environment intermediary.location.name 直接映射。
properties.hostname intermediary.hostname 直接映射。
referer_url network.http.referral_url 直接映射。
request_method network.http.method 直接映射。
resource_response_headers.x-nauthilus-traceid network.community_id 直接映射。
response_status_code network.http.response_code 直接映射。
rule_id security_result.rule_id 直接映射。
rule_name_at_log_time security_result.rule_name 直接映射。
rule_type security_result.rule_type 直接映射。
service principal.application 直接映射。
session_id network.session_id 直接映射。
severity security_result.severity 根据值映射到 LOW、MEDIUM 或 HIGH。
source_ip principal.ip 直接映射。
source_ip_country_name principal.location.country_or_region 直接映射。
source_port principal.port 直接映射。
sub_type security_result.summary 直接映射。
target.asset.type target.asset.type 如果 device.model 包含“ipad”或“iphone”,则设置为“MOBILE”。
target.asset.platform_software.platform target.asset.platform_software.platform 如果 device.model 包含“ipad”或“iphone”,则设置为“MAC”。
timestamp metadata.event_timestamp 使用 yyyy-MM-dd HH:mm:ss.SSS Z 格式解析。
total_bytes network.received_bytes 如果大于 0,则直接映射。
traceId metadata.product_log_id 直接映射。
type metadata.product_event_type 直接映射。
url target.url 直接映射。
url_host principal.hostname 直接映射。
user_download_usage_bytes network.received_bytes 直接映射。
user_total_usage_bytes about.labels,about.resource.attribute.labels 添加为键为“user_total_usage_bytes”的标签。
user_upload_usage_bytes network.sent_bytes 直接映射。
username principal.user.user_display_name 直接映射。
vendor_name metadata.vendor_name 设置为“Broadcom Inc.”。
product_name metadata.product_name 设置为“Symantec Web Isolation”。
log_type metadata.log_type 设置为“SYMANTEC_WEB_ISOLATION”。
sandbox about.labels,about.resource.attribute.labels 添加为标签,键为“Sandbox”,值从网址中提取。
utub about.labels,about.resource.attribute.labels 添加为键为“user_total_usage_bytes”的标签。
userid target.user.userid 从网址中提取。

更新日志

查看此解析器的更新日志

需要更多帮助?获得社区成员和 Google SecOps 专业人士的解答。