收集 Symantec Web Isolation 記錄

支援:

本文說明如何使用 Bindplane 代理程式,將 Symantec Web Isolation 記錄擷取至 Google Security Operations。

Symantec Web Isolation 是瀏覽器隔離平台,可針對網頁瀏覽工作階段、網址存取事件、檔案下載活動、政策違規處置和裝置管理事件,產生系統記錄訊息。剖析器會從 JSON 格式的記錄檔中擷取欄位,並對應至統合式資料模型 (UDM)。

事前準備

請確認您已完成下列事前準備事項:

  • Google SecOps 執行個體
  • Windows Server 2016 以上版本,或搭載 systemd 的 Linux 主機
  • Bindplane 代理程式與 Symantec Web Isolation 平台之間的網路連線
  • 如果透過 Proxy 執行,請確保防火牆通訊埠已根據 Bindplane 代理程式需求開啟
  • Symantec Web Isolation 網頁版使用者介面的管理員權限

取得 Bindplane 代理程式的 Google SecOps 憑證

如要向 Google SecOps 驗證 Bindplane 代理程式,請選擇下列其中一種方法:

  • 新部署作業:使用 Chronicle API (選項 1)。
  • 舊版部署作業:在 2027 年 7 月 20 日停用 Ingestion API 前,請繼續使用擷取驗證檔案 (選項 2)。
  1. 登入 Google Cloud 控制台,選取連結至 Google SecOps 執行個體的 Google Cloud 專案。
  2. 依序前往「IAM & Admin」(IAM 與管理) >「Service Accounts」(服務帳戶)。
  3. 按一下「建立服務帳戶」。
  4. 請提供下列設定詳細資料:
    • 「Service account name」(服務帳戶名稱):輸入帳戶名稱 (例如 bindplane-ingest)。
    • 「服務帳戶說明」:輸入說明 (例如 Bindplane agent log ingestion)。
  5. 點按「Create and continue」(建立並繼續)。
  6. 在「將專案存取權授予這個服務帳戶」部分,按一下「選取角色」,然後選取「Chronicle 編輯者」。
  7. 依序點選「繼續」和「完成」。
  8. 按一下您建立的服務帳戶,然後前往「金鑰」分頁標籤。
  9. 依序點選「新增金鑰」>「建立新的金鑰」。
  10. 選取「JSON」,然後點選「建立」。金鑰檔案會下載到電腦。
  11. 將金鑰檔案儲存為 Bindplane 收集器目錄中的 ingestion-auth.json (Linux 上的 /opt/observiq-otel-collector/ingestion-auth.json 或 Windows 上的 C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json),或更新 config.yaml 中的 creds_file_path,使其與儲存路徑相符。
  12. 依序前往「IAM & Admin」(IAM 與管理) >「Settings」(設定),然後複製「Project number」(專案編號)。匯出工具設定時會用到。

方法 2:下載擷取驗證檔案 (舊版)

  1. 登入 Google SecOps 控制台。
  2. 依序前往「SIEM Settings」 > 「Collection Agents」。
  3. 下載擷取驗證檔案。
  4. 將檔案安全地儲存在要安裝 Bindplane 代理程式的系統中。

取得 Google SecOps 客戶 ID

  1. 登入 Google SecOps 控制台。
  2. 依序前往「SIEM 設定」>「設定檔」。
  3. 複製並儲存「機構詳細資料」部分的客戶 ID。

安裝 Bindplane 代理程式

請按照下列操作說明,在 Windows 或 Linux 作業系統上安裝 Bindplane 代理程式。

Windows 安裝

  1. 以管理員身分開啟「命令提示字元」或「PowerShell」。
  2. 執行下列指令:

    msiexec /i "https://github.com/observIQ/bindplane-agent/releases/latest/download/observiq-otel-collector.msi" /quiet
    
  3. 等待安裝完成。

  4. 執行下列指令,確認安裝成功:

    sc query observiq-otel-collector
    

    服務應顯示為「RUNNING」。

Linux 安裝

  1. 開啟具有 root 或 sudo 權限的終端機。
  2. 執行下列指令:

    sudo sh -c "$(curl -fsSlL https://github.com/observiq/bindplane-agent/releases/latest/download/install_unix.sh)" install_unix.sh
    
  3. 等待安裝完成。

  4. 執行下列指令,確認安裝成功:

    sudo systemctl status observiq-otel-collector
    

    服務應顯示為「active (running)」。

其他安裝資源

如需其他安裝選項和疑難排解資訊,請參閱 Bindplane 代理程式安裝指南。

設定 Bindplane 代理程式,擷取系統記錄並傳送至 Google SecOps

找出設定檔

  • Linux:

    sudo nano /opt/observiq-otel-collector/config.yaml
    
  • Windows:

    notepad "C:\Program Files\observIQ OpenTelemetry Collector\config.yaml"
    

編輯設定檔

  • 將 config.yaml 的全部內容替換為下列設定:

    receivers:
      udplog:
        listen_address: "0.0.0.0:514"
    
    exporters:
      chronicle/symantec_web_isolation:
        protocol: https
        # Region of your instance, for example us, europe, asia-southeast1
        location: <LOCATION>
        # Project number of the Google Cloud project linked to the instance
        project: '<PROJECT_NUMBER>'
        compression: gzip
        creds_file_path: '/opt/observiq-otel-collector/ingestion-auth.json'
        customer_id: '<customer_id>'
        endpoint: chronicle.googleapis.com
        log_type: SYMANTEC_WEB_ISOLATION
        raw_log_field: body
    
    service:
      pipelines:
        logs/symantec_web_isolation_to_chronicle:
          receivers:
            - udplog
          exporters:
            - chronicle/symantec_web_isolation
    

設定參數

請替換下列預留位置:

  • 接收器設定:

    • listen_address:要接聽的 IP 位址和通訊埠:
      • 0.0.0.0:在所有介面上監聽 (建議)
      • 通訊埠 514 是標準 syslog 通訊埠 (在 Linux 上需要根目錄;非根目錄請使用 1514)
  • Exporter 設定:

    • creds_file_path:服務帳戶 JSON 金鑰檔案的完整路徑 (選項 1):
      • Linux:/opt/observiq-otel-collector/ingestion-auth.json
      • Windows:C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json
    • customer_id:從 Google SecOps 控制台複製的客戶 ID
    • location:將 <LOCATION> 替換為 Google SecOps 執行個體的區域 (例如 us、europe 或 asia-southeast1)。匯出工具會以這個值做為 chronicle.googleapis.com 的前置字元。如需完整清單,請參閱「區域性端點」。
    • project:依序前往「IAM 與管理」>「設定」,然後將 <PROJECT_NUMBER> 替換為專案編號。
    • endpoint:請將此值設為 chronicle.googleapis.com。

舊版 Ingestion API 匯出工具

  • 如果您使用選項 2 的擷取驗證檔案,請將 exporters 區塊替換為下列內容。將 creds_file_path 設為擷取驗證檔案的路徑。如果執行個體位於美國境外,請將 malachiteingestion-pa.googleapis.com 替換為區域端點 (例如 europe-malachiteingestion-pa.googleapis.com)。

    exporters:
      chronicle/symantec_web_isolation:
        compression: gzip
        creds_file_path: '/opt/observiq-otel-collector/ingestion-auth.json'
        customer_id: '<customer_id>'
        endpoint: malachiteingestion-pa.googleapis.com
        log_type: SYMANTEC_WEB_ISOLATION
        raw_log_field: body
    

儲存設定檔

  • 編輯完畢後,請儲存檔案:
    • Linux:依序按下 Ctrl+O、Enter 和 Ctrl+X
    • Windows:依序點選「檔案」 > 「儲存」

重新啟動 Bindplane 代理程式,套用變更

  • 如要在 Linux 重新啟動 Bindplane 代理程式,請執行下列指令:

    sudo systemctl restart observiq-otel-collector
    
    1. 確認服務是否正在執行:

      sudo systemctl status observiq-otel-collector
      
    2. 檢查記錄是否有錯誤:

      sudo journalctl -u observiq-otel-collector -f
      
  • 如要在 Windows 中重新啟動 Bindplane 代理程式,請選擇下列其中一個選項:

    • 以管理員身分開啟命令提示字元或 PowerShell:

      net stop observiq-otel-collector && net start observiq-otel-collector
      
    • 服務控制台:

      1. 按下 Win+R 鍵,輸入 services.msc,然後按下 Enter 鍵。
      2. 找出「observIQ OpenTelemetry Collector」。
      3. 按一下滑鼠右鍵,然後選取「重新啟動」。
      4. 確認服務正在執行:

        sc query observiq-otel-collector
        
      5. 查看記錄檔是否有錯誤:

        type "C:\Program Files\observIQ OpenTelemetry Collector\log\collector.log"
        

在 Symantec Web Isolation 平台中設定系統記錄

  1. 登入 Symantec Web Isolation 網頁版 UI。
  2. 依序前往「System Configuration」 >「External Log Server」 >「New External Log Server」 >「Syslog Server」。
  3. 提供下列設定詳細資料:
    • 狀態:勾選核取方塊,設為「啟用」。
    • Host:輸入 Bindplane 代理程式 IP 位址。
    • 「通訊埠」:輸入 Bindplane 代理程式通訊埠編號 (例如 UDP 的 514)。
    • 「通訊協定」:選取「UDP」。
    • Appname:輸入標記,用於識別 Web Isolation 平台。
    • Facility:與 Web Isolation 記錄相關的 Syslog 設施名稱。
  4. 點選「建立」。
  5. 依序前往「報表」>「記錄轉送」。
  6. 按一下 [編輯]。
  7. 請提供下列設定詳細資料:
    • 活動記錄:選取新加入的 Bindplane 伺服器。
    • 管理稽核記錄:選取新加入的 Bindplane 伺服器。
    • 閘道稽核記錄:選取新加入的 Bindplane 伺服器。
  8. 按一下「Update」。

UDM 對應表

記錄欄位 UDM 對應 邏輯
action security_result.summary 與 action_reason 串連,形成摘要。
action_reason security_result.summary 與 action 串連,形成摘要。
content_action security_result.action_details 直接對應。
createdAt metadata.event_timestamp 以 UNIX_MS 格式轉換為時間戳記。
creationDate metadata.event_timestamp 使用 UNIX_MS 格式轉換為時間戳記。
data.level security_result.severity 根據值對應至 INFORMATIONAL、LOW 或 HIGH。
data.properties.environment.str intermediary.location.name 直接對應。
data.properties.hostname.str intermediary.hostname 直接對應。
destination_ip target.ip 直接對應。
destination_ip_country_name target.location.country_or_region 直接對應。
device.current_risk_warnings security_result.category_details 直接對應。
device.identifier target.asset.product_object_id 直接對應。
device.model hardware.model 直接對應。
device.os_version target.asset.platform_software.platform_version 直接對應。
device.serial_number hardware.serial_number 直接對應。
device.udid target.asset.asset_id 對應前加上「UDID:」前置字元。
device.user.email target.user.email_addresses 直接對應。
device.user.id target.user.userid 直接對應。
device.user.name target.user.user_display_name 直接對應。
device.user.organization.id target.user.groupid 直接對應。
device.user.organization.name target.user.group_identifiers 直接對應。
event metadata.product_event_type 直接對應。
event_type metadata.event_type 根據記錄資料,設為「GENERIC_EVENT」或「NETWORK_HTTP」。
file_name target.file.names 直接對應。
file_type about.labels、about.resource.attribute.labels 以「file_type」鍵新增為標籤。
id metadata.product_log_id 直接對應。
isolation_session_id network.parent_session_id 直接對應。
level security_result.severity 根據值對應至 INFORMATIONAL、LOW 或 HIGH。
original_source_ip principal.ip 直接對應。
policy_version security_result.rule_version 直接對應。
properties.environment intermediary.location.name 直接對應。
properties.hostname intermediary.hostname 直接對應。
referer_url network.http.referral_url 直接對應。
request_method network.http.method 直接對應。
resource_response_headers.x-nauthilus-traceid network.community_id 直接對應。
response_status_code network.http.response_code 直接對應。
rule_id security_result.rule_id 直接對應。
rule_name_at_log_time security_result.rule_name 直接對應。
rule_type security_result.rule_type 直接對應。
service principal.application 直接對應。
session_id network.session_id 直接對應。
severity security_result.severity 根據值對應至 LOW、MEDIUM 或 HIGH。
source_ip principal.ip 直接對應。
source_ip_country_name principal.location.country_or_region 直接對應。
source_port principal.port 直接對應。
sub_type security_result.summary 直接對應。
target.asset.type target.asset.type 如果 device.model 包含「ipad」或「iphone」,請設為「MOBILE」。
target.asset.platform_software.platform target.asset.platform_software.platform 如果 device.model 包含「ipad」或「iphone」,請設為「MAC」。
timestamp metadata.event_timestamp 以 yyyy-MM-dd HH:mm:ss.SSS Z 格式剖析。
total_bytes network.received_bytes 如果大於 0,則直接對應。
traceId metadata.product_log_id 直接對應。
type metadata.product_event_type 直接對應。
url target.url 直接對應。
url_host principal.hostname 直接對應。
user_download_usage_bytes network.received_bytes 直接對應。
user_total_usage_bytes about.labels、about.resource.attribute.labels 以「user_total_usage_bytes」鍵新增為標籤。
user_upload_usage_bytes network.sent_bytes 直接對應。
username principal.user.user_display_name 直接對應。
vendor_name metadata.vendor_name 設為「Broadcom Inc.」。
product_name metadata.product_name 設為「Symantec Web Isolation」。
log_type metadata.log_type 設為「SYMANTEC_WEB_ISOLATION」。
sandbox about.labels、about.resource.attribute.labels 新增為標籤,鍵為「Sandbox」,值則從網址擷取。
utub about.labels、about.resource.attribute.labels 以「user_total_usage_bytes」鍵新增為標籤。
userid target.user.userid 從網址擷取。

變更記錄

查看這個剖析器的變更記錄

還有其他問題嗎?向社群成員和 Google SecOps 專家尋求解答。