收集 Teradata 数据库日志

支持:

本文档介绍了如何使用 Bindplane 将 Teradata 数据库日志注入 Google Security Operations。

Teradata Database 是一种企业数据仓库平台,可生成查询、访问、安全审核和系统事件日志。它可为大规模本地部署提供高性能分析和数据管理。

准备工作

请确保满足以下前提条件:

  • Google SecOps 实例
  • Windows Server 2016 或更高版本,或者具有 systemd 的 Linux 主机
  • Bindplane 代理与 Teradata 数据库服务器之间的网络连接
  • 如果在代理后面运行,请确保按照 Bindplane 代理要求打开防火墙端口
  • 对 Teradata 数据库系统的特权访问权限(具有管理员权限)

获取 Bindplane 代理的 Google SecOps 凭证

如需向 Google SecOps 验证 Bindplane 代理,请选择以下方法之一:

  • 新部署:使用 Chronicle API(选项 1)。
  • 旧版部署:继续使用提取身份验证文件(方法 2),直到提取 API 于 2027 年 7 月 20 日停用。
  1. 登录 Google Cloud 控制台,然后选择与您的 Google SecOps 实例关联的 Google Cloud 项目。
  2. 前往 IAM 和管理 > 服务账号。
  3. 点击创建服务账号。
  4. 提供以下配置详细信息:
    • 服务账号名称:输入账号的名称(例如 bindplane-ingest)。
    • 服务账号说明:输入说明(例如 Bindplane agent log ingestion)。
  5. 点击创建并继续。
  6. 在向此服务账号授予对项目的访问权限部分,点击选择角色,然后选择 Chronicle Editor。
  7. 点击继续,然后点击完成。
  8. 点击您创建的服务账号,然后前往密钥标签页。
  9. 依次点击添加密钥 > 创建新密钥。
  10. 选择 JSON,然后点击创建。密钥文件会下载到您的计算机上。
  11. 将密钥文件另存为 Bindplane 收集器目录(Linux 上的 /opt/observiq-otel-collector/ingestion-auth.json 或 Windows 上的 C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json)中的 ingestion-auth.json,或更新 config.yaml 中的 creds_file_path 以匹配您保存该文件的路径。
  12. 前往 IAM 和管理 > 设置,然后复制项目编号。您在配置导出器时需要用到该名称。

方法 2:下载数据注入身份验证文件(旧版)

  1. 登录 Google SecOps 控制台。
  2. 依次前往 SIEM 设置 > 收集代理。
  3. 下载数据注入身份验证文件。
  4. 将文件安全地保存在将要安装 Bindplane 代理的系统上。

获取 Google SecOps 客户 ID

  1. 登录 Google SecOps 控制台。
  2. 依次前往 SIEM 设置 > 配置文件。
  3. 复制并保存组织详细信息部分中的客户 ID。

安装 Bindplane 代理

根据以下说明,在 Windows 或 Linux 操作系统上安装 Bindplane 代理。

Windows 安装

  1. 以管理员身份打开命令提示符或 PowerShell。
  2. 运行以下命令:

    msiexec /i "https://github.com/observIQ/bindplane-agent/releases/latest/download/observiq-otel-collector.msi" /quiet
    
  3. 等待安装完成。

  4. 运行以下命令,验证安装是否成功:

    sc query observiq-otel-collector
    

该服务应显示为正在运行。

Linux 安装

  1. 打开具有 root 或 sudo 权限的终端。
  2. 运行以下命令:

    sudo sh -c "$(curl -fsSlL https://github.com/observiq/bindplane-agent/releases/latest/download/install_unix.sh)" install_unix.sh
    
  3. 等待安装完成。

  4. 运行以下命令,验证安装是否成功:

    sudo systemctl status observiq-otel-collector
    

该服务应显示为 active (running)。

其他安装资源

如需了解其他安装选项和问题排查信息,请参阅 Bindplane 代理安装指南。

配置 Bindplane 代理以注入 syslog 并发送到 Google SecOps

找到配置文件

  • Linux:

    sudo nano /opt/observiq-otel-collector/config.yaml
    
  • Windows:

    notepad "C:\Program Files\observIQ OpenTelemetry Collector\config.yaml"
    

修改配置文件

  • 将 config.yaml 的全部内容替换为以下配置:

    receivers:
      tcplog:
        listen_address: "0.0.0.0:514"
    
    exporters:
      chronicle/teradata_db:
        protocol: https
        # Region of your instance, for example us, europe, asia-southeast1
        location: <LOCATION>
        # Project number of the Google Cloud project linked to the instance
        project: '<PROJECT_NUMBER>'
        compression: gzip
        creds_file_path: '/opt/observiq-otel-collector/ingestion-auth.json'
        customer_id: '<customer_id>'
        endpoint: chronicle.googleapis.com
        log_type: TERADATA_DB
        raw_log_field: body
    
    service:
      pipelines:
        logs/teradata_db_to_chronicle:
          receivers:
            - tcplog
          exporters:
            - chronicle/teradata_db
    

配置参数

替换以下占位符:

  • 接收器配置:

    • listen_address:要监听的 IP 地址和端口:
      • 0.0.0.0 在所有接口上监听(推荐)
      • 端口 514 是标准 syslog 端口(在 Linux 上需要 root 权限;对于非 root 用户,请使用 1514)
  • 导出器配置:

    • creds_file_path:服务账号 JSON 密钥文件的完整路径(选项 1):
      • Linux:/opt/observiq-otel-collector/ingestion-auth.json
      • Windows:C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json
    • customer_id:从 Google SecOps 控制台复制的客户 ID
    • location:将 <LOCATION> 替换为 Google SecOps 实例所在的区域(例如 us、europe 或 asia-southeast1)。导出工具会在此值前面加上 chronicle.googleapis.com。如需查看完整列表,请参阅区域级端点。
    • project:将 <PROJECT_NUMBER> 替换为 IAM 和管理 > 设置中的项目编号。
    • endpoint:保持设置为 chronicle.googleapis.com。

旧版提取 API

  • 如果您使用选项 2 中的提取身份验证文件,请将 exporters 代码块替换为以下内容。将 creds_file_path 设置为数据注入身份验证文件的路径,如果您的实例位于美国境外,请将 malachiteingestion-pa.googleapis.com 替换为您的区域端点(例如 europe-malachiteingestion-pa.googleapis.com)。

    exporters:
      chronicle/teradata_db:
        compression: gzip
        creds_file_path: '/opt/observiq-otel-collector/ingestion-auth.json'
        customer_id: '<customer_id>'
        endpoint: malachiteingestion-pa.googleapis.com
        log_type: TERADATA_DB
        raw_log_field: body
    

保存配置文件

  • 修改后,保存文件:
    • Linux:依次按 Ctrl+O、Enter 和 Ctrl+X
    • Windows:依次点击文件 > 保存

重启 Bindplane 代理以应用更改

如需在 Linux 中重启 Bindplane 代理,请运行以下命令:

  1. 运行以下命令:

    sudo systemctl restart observiq-otel-collector
    
  2. 验证服务是否正在运行:

    sudo systemctl status observiq-otel-collector
    
  3. 检查日志中的错误:

    sudo journalctl -u observiq-otel-collector -f
    

如需在 Windows 中重启 Bindplane 代理,请执行以下操作:

  1. 请从下列选项中选择一项:

    • 以管理员身份运行命令提示符或 PowerShell:
    net stop observiq-otel-collector && net start observiq-otel-collector
    
    • “服务”控制台:
      1. 按 Win+R,输入 services.msc,然后按 Enter 键。
      2. 找到 observIQ OpenTelemetry 收集器。
      3. 右键点击,然后选择重新启动。
  2. 验证服务是否正在运行:

    sc query observiq-otel-collector
    
  3. 检查日志中的错误:

    type "C:\Program Files\observIQ OpenTelemetry Collector\log\collector.log"
    

配置 Teradata 数据库 syslog 转发

  1. 以管理员身份登录 Teradata 数据库服务器。
  2. 使用 Teradata 数据库网关日志记录功能配置 syslog 转发。修改 rsyslog 配置文件:

    sudo nano /etc/rsyslog.d/teradata.conf
    
  3. 添加以下行,以将 Teradata 日志转发到 Bindplane 代理:

    # Forward Teradata Database logs to Bindplane agent
    if $programname == 'teradata' then @@<bindplane-ip>:514
    
    • 将 <bindplane-ip> 替换为 Bindplane 代理主机的 IP 地址。
  4. 重启 rsyslog 服务:

    sudo systemctl restart rsyslog
    
  5. 通过检查 Bindplane 代理日志,验证日志是否正在发送。

UDM 映射表

日志字段 UDM 映射 逻辑
additional.fields 从各种标签合并而来,例如 collect_timestamp_label、logon_date_time_label、logon_source_label、protocol_label、remote_hostname_label、logon_details_label、port_label、connection_id_label、cid_label、jdbc_driver_info_label、request_mode_label、statement_group_label、statement_type_label
app_id target.asset.product_object_id 直接复制值
client_addr principal.asset.hostname、principal.asset.ip、principal.hostname、principal.ip 值已直接复制到所有
client_id target.asset.asset_id 串联为 CLIENT_ID:%{client_id}
collect_timestamp metadata.collected_timestamp 已使用日期匹配功能进行转换,格式为 RFC 3339、UNIX_MS、UNIX、ISO8601、yyyy-MM-dd HH:mm:ss
default_database target.resource.name, target.resource.resource_type 值直接复制到 name;resource_type 设置为 DATABASE
error_code network.http.response_code, additional.fields 已转换为 response_code 的整数;已复制到 error_code_label 并合并到 additional.fields 中
error_text security_result.summary 直接复制值
host_name principal.asset.hostname、principal.hostname 值已直接复制到这两处
logon_date_time metadata.event_timestamp 已使用日期匹配功能转换为 ISO8601、yyyy-MM-dd HH:mm:ss 格式
logon_source target.resource.parent 直接复制值
logon_source additional.fields 使用 grok 提取了 logonSource,然后在 logon_source_label 中将其设置为 %{logonSource}LSS,并合并到 additional.fields 中
logon_source additional.fields 使用 grok 提取了 protocol、remote_hostname、port、logon_details、connection_id、cid、jdbc_driver_info,然后将其设置在合并到 additional.fields 的相应标签中
proc_id target.resource.id 直接复制的值
profile_name target.resource.attribute.labels 在 profile_name_label 中设置,已合并到 attribute.labels
query_text target.process.command_line 直接复制的值
request_mode target.resource.resource_subtype, additional.fields 直接复制到 resource_subtype 的值;在合并到 additional.fields 中的 request_mode_label 中设置
session_id network.session_id 直接复制值
statement_group principal.user.groupid, additional.fields 值直接复制到 groupid;在合并到 additional.fields 中的 statement_group_label 中设置
statement_type security_result.about.labels, additional.fields 在 statementtype_value_label 中设置,并合并到 about.labels 中;在 statement_type_label 中设置,并合并到 additional.fields 中
ts metadata.event_timestamp 使用日期匹配功能进行转换,支持的格式包括 MMM d HH:mm:ss、MMM dd HH:mm:ss、SYSLOGTIMESTAMP、RFC 3339、UNIX、ISO8601、UNIX_MS
tt_granularity target.resource.product_object_id 直接复制值
user_id principal.user.userid 直接复制的值
user_name principal.user.user_display_name 直接复制的值
metadata.event_type 如果 has_principal、has_principal_user、has_target_resource 为 true,则设置为 USER_RESOURCE_ACCESS;如果 has_principal 为 true,则设置为 STATUS_UPDATE;否则设置为 GENERIC_EVENT
metadata.product_name 设置为“TERADATA_DB”
metadata.vendor_name 设置为“TERADATA”
profile_name event.idm.read_only_udm.target.resource.attribute.labels 从更新日志映射
proc_id event.idm.read_only_udm.target.resource.id 从更新日志映射
user_id event.idm.read_only_udm.principal.user.userid 从更新日志映射
collect_timestamp event.idm.read_only_udm.metadata.collected_timestamp 从更新日志映射
logon_date_time event.idm.read_only_udm.metadata.event_timestamp 从更新日志映射
user_name event.idm.read_only_udm.principal.user.user_display_name 从更新日志映射
logon_source event.idm.read_only_udm.target.resource.parent 从更新日志映射
app_id event.idm.read_only_udm.target.asset.product_object_id 从更新日志映射
client_id event.idm.read_only_udm.target.asset.asset_id 从更新日志映射
error_code event.idm.read_only_udm.network.http.response_code 从更新日志映射
statement_type event.idm.read_only_udm.security_result.about.labels 从更新日志映射
statement_group event.idm.read_only_udm.principal.user.groupid 从更新日志映射
request_mode event.idm.read_only_udm.target.resource.resource_subtype 从更新日志映射
tt_granularity event.idm.read_only_udm.target.resource.product_object_id 从更新日志映射
protocol event.idm.read_only_udm.additional.fields 从更新日志映射
remote_hostname event.idm.read_only_udm.additional.fields 从更新日志映射
logon_details event.idm.read_only_udm.additional.fields 从更新日志映射
connection_id event.idm.read_only_udm.additional.fields 从更新日志映射
port event.idm.read_only_udm.additional.fields 从更新日志映射
cid event.idm.read_only_udm.additional.fields 从更新日志映射
jdbc_driver_info event.idm.read_only_udm.additional.fields 从更新日志映射
app_id principal.application 从更新日志映射
collect_timestamp event.idm.read_only_udm.additional.fields 从更新日志映射
error_code security_result.detection_fields 从更新日志映射
logon_date_time event.idm.read_only_udm.additional.fields 从更新日志映射
logon_source event.idm.read_only_udm.additional.fields 从更新日志映射
proc_id principal.process.pid 从更新日志映射
request_mode event.idm.read_only_udm.additional.fields 从更新日志映射
statement_group event.idm.read_only_udm.additional.fields 从更新日志映射
statement_type event.idm.read_only_udm.additional.fields 从更新日志映射
user_id target.user.userid 从更新日志映射
user_name target.user.user_display_name 从更新日志映射

更新日志

查看相应解析器的更新日志

需要更多帮助?获得社区成员和 Google SecOps 专业人士的解答。