收集 Teradata 資料庫記錄
本文說明如何使用 Bindplane,將 Teradata 資料庫記錄擷取至 Google Security Operations。
Teradata Database 是企業資料倉儲平台,可產生查詢、存取、安全性稽核和系統事件記錄。可為大規模地端部署提供高效能數據分析和資料管理功能。
事前準備
請確認您符合下列必要條件:
- Google SecOps 執行個體
- Windows Server 2016 以上版本,或搭載
systemd的 Linux 主機 - Bindplane 代理程式與 Teradata 資料庫伺服器之間的網路連線
- 如果是在 Proxy 後方執行,請確認防火牆通訊埠已按照 Bindplane 代理程式規定開啟
- 具備管理員權限的 Teradata 資料庫系統特殊存取權
取得 Bindplane 代理程式的 Google SecOps 憑證
如要向 Google SecOps 驗證 Bindplane 代理程式,請選擇下列其中一種方法:
- 新部署作業:使用 Chronicle API (選項 1)。
- 舊版部署作業:在 2027 年 7 月 20 日停用 Ingestion API 前,請繼續使用擷取驗證檔案 (選項 2)。
方法 1:為 Chronicle API 建立服務帳戶 (建議)
- 登入 Google Cloud 控制台,選取連結至 Google SecOps 執行個體的 Google Cloud 專案。
- 依序前往 「IAM & Admin」(IAM 與管理) >「Service Accounts」(服務帳戶)。
- 按一下「建立服務帳戶」。
- 提供下列設定詳細資料:
- 「Service account name」(服務帳戶名稱):輸入帳戶名稱 (例如
bindplane-ingest)。 - 服務帳戶說明:輸入說明 (例如
Bindplane agent log ingestion)。
- 「Service account name」(服務帳戶名稱):輸入帳戶名稱 (例如
- 點按「Create and continue」(建立並繼續)。
- 在「將專案存取權授予這個服務帳戶」部分,按一下「選取角色」,然後選取「Chronicle 編輯者」。
- 依序點選「繼續」和「完成」。
- 按一下您建立的服務帳戶,然後前往「金鑰」分頁標籤。
- 依序點選「新增金鑰」>「建立新的金鑰」。
- 選取「JSON」,然後按一下「建立」。金鑰檔案會下載到您的電腦。
- 將金鑰檔案儲存為 Bindplane 收集器目錄中的
ingestion-auth.json(Linux 上的/opt/observiq-otel-collector/ingestion-auth.json或 Windows 上的C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json),或更新config.yaml中的creds_file_path,使其與儲存路徑相符。 - 依序前往「IAM 與管理」>「設定」,然後複製「專案編號」。設定匯出工具時會用到。
方法 2:下載擷取驗證檔案 (舊版)
- 登入 Google SecOps 控制台。
- 依序前往「SIEM Settings」 > 「Collection Agents」。
- 下載擷取驗證檔案。
- 將檔案安全地儲存在要安裝 Bindplane 代理程式的系統中。
取得 Google SecOps 客戶 ID
- 登入 Google SecOps 控制台。
- 依序前往「SIEM 設定」>「設定檔」。
複製並儲存「機構詳細資料」部分的客戶 ID。
安裝 Bindplane 代理程式
請按照下列操作說明,在 Windows 或 Linux 作業系統上安裝 Bindplane 代理程式。
Windows 安裝
- 以管理員身分開啟「命令提示字元」或「PowerShell」。
執行下列指令:
msiexec /i "https://github.com/observIQ/bindplane-agent/releases/latest/download/observiq-otel-collector.msi" /quiet等待安裝完成。
執行下列指令,確認安裝成功:
sc query observiq-otel-collector
服務應顯示為「RUNNING」。
Linux 安裝
- 開啟具有 root 或 sudo 權限的終端機。
執行下列指令:
sudo sh -c "$(curl -fsSlL https://github.com/observiq/bindplane-agent/releases/latest/download/install_unix.sh)" install_unix.sh等待安裝完成。
執行下列指令,確認安裝成功:
sudo systemctl status observiq-otel-collector
服務應顯示為「active (running)」。
其他安裝資源
如需其他安裝選項和疑難排解資訊,請參閱 Bindplane 代理程式安裝指南。
設定 Bindplane 代理程式,擷取系統記錄檔並傳送至 Google SecOps
找出設定檔
Linux:
sudo nano /opt/observiq-otel-collector/config.yamlWindows:
notepad "C:\Program Files\observIQ OpenTelemetry Collector\config.yaml"
編輯設定檔
將
config.yaml的全部內容替換為下列設定:receivers: tcplog: listen_address: "0.0.0.0:514" exporters: chronicle/teradata_db: protocol: https # Region of your instance, for example us, europe, asia-southeast1 location: <LOCATION> # Project number of the Google Cloud project linked to the instance project: '<PROJECT_NUMBER>' compression: gzip creds_file_path: '/opt/observiq-otel-collector/ingestion-auth.json' customer_id: '<customer_id>' endpoint: chronicle.googleapis.com log_type: TERADATA_DB raw_log_field: body service: pipelines: logs/teradata_db_to_chronicle: receivers: - tcplog exporters: - chronicle/teradata_db
設定參數
請替換下列預留位置:
接收器設定:
listen_address:要監聽的 IP 位址和通訊埠:0.0.0.0在所有介面接聽電話 (建議)- 通訊埠
514是標準 syslog 通訊埠 (在 Linux 上需要根目錄;非根目錄請使用1514)
匯出工具設定:
creds_file_path:服務帳戶 JSON 金鑰檔案的完整路徑 (選項 1):- Linux:
/opt/observiq-otel-collector/ingestion-auth.json - Windows:
C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json
- Linux:
customer_id:從 Google SecOps 控制台複製的客戶 IDlocation:將<LOCATION>替換為 Google SecOps 執行個體的區域 (例如us、europe或asia-southeast1)。匯出工具會以這個值做為chronicle.googleapis.com的前置字元。如需完整清單,請參閱「區域性端點」。project:將<PROJECT_NUMBER>替換為「IAM 與管理」>「設定」中的專案編號。endpoint:維持設為chronicle.googleapis.com。
舊版擷取 API 匯出工具
如果您使用選項 2 的擷取驗證檔案,請將
exporters區塊替換為下列內容。將creds_file_path設為擷取驗證檔案的路徑,如果您的執行個體位於美國境外,請將malachiteingestion-pa.googleapis.com替換為區域端點 (例如europe-malachiteingestion-pa.googleapis.com)。exporters: chronicle/teradata_db: compression: gzip creds_file_path: '/opt/observiq-otel-collector/ingestion-auth.json' customer_id: '<customer_id>' endpoint: malachiteingestion-pa.googleapis.com log_type: TERADATA_DB raw_log_field: body
儲存設定檔
- 編輯完成後,請儲存檔案:
- Linux:依序按下
Ctrl+O、Enter和Ctrl+X - Windows:依序點選「檔案」 > 「儲存」
- Linux:依序按下
重新啟動 Bindplane 代理程式,套用變更
如要在 Linux 中重新啟動 Bindplane 代理程式,請按照下列步驟操作:
執行下列指令:
sudo systemctl restart observiq-otel-collector確認服務是否正在執行:
sudo systemctl status observiq-otel-collector查看記錄檔是否有錯誤:
sudo journalctl -u observiq-otel-collector -f
如要在 Windows 重新啟動 Bindplane 代理程式,請按照下列步驟操作:
您可以選擇下列其中一個選項:
- 以管理員身分開啟命令提示字元或 PowerShell:
net stop observiq-otel-collector && net start observiq-otel-collector- 服務控制台:
- 按下
Win+R,輸入services.msc,然後按下 Enter 鍵。 - 找出「observIQ OpenTelemetry Collector」。
- 按一下滑鼠右鍵,然後選取「重新啟動」。
- 按下
確認服務是否正在執行:
sc query observiq-otel-collector查看記錄檔是否有錯誤:
type "C:\Program Files\observIQ OpenTelemetry Collector\log\collector.log"
設定 Teradata 資料庫系統記錄檔轉送
- 以管理員身分登入 Teradata 資料庫伺服器。
使用 Teradata Database Gateway 記錄功能設定系統記錄轉送。編輯 rsyslog 設定檔:
sudo nano /etc/rsyslog.d/teradata.conf新增下列程式碼,將 Teradata 記錄轉送至 Bindplane 代理程式:
# Forward Teradata Database logs to Bindplane agent if $programname == 'teradata' then @@<bindplane-ip>:514- 將
<bindplane-ip>替換為 Bindplane 代理程式主機的 IP 位址。
- 將
重新啟動 rsyslog 服務:
sudo systemctl restart rsyslog檢查 Bindplane 代理程式記錄,確認系統是否正在傳送記錄。
UDM 對應表
| 記錄欄位 | UDM 對應 | 邏輯 |
|---|---|---|
| additional.fields | 合併自多個標籤,例如 collect_timestamp_label、logon_date_time_label、logon_source_label、protocol_label、remote_hostname_label、logon_details_label、port_label、connection_id_label、cid_label、jdbc_driver_info_label、request_mode_label、statement_group_label、statement_type_label | |
| app_id | target.asset.product_object_id | 直接複製值 |
| client_addr | principal.asset.hostname、principal.asset.ip、principal.hostname、principal.ip | 直接將值複製到所有項目 |
| client_id | target.asset.asset_id | 串連為 CLIENT_ID:%{client_id} |
| collect_timestamp | metadata.collected_timestamp | 使用日期比對轉換,格式為 RFC 3339、UNIX_MS、UNIX、ISO8601、yyyy-MM-dd HH:mm:ss |
| default_database | target.resource.name, target.resource.resource_type | 值直接複製到名稱;resource_type 設為 DATABASE |
| error_code | network.http.response_code、additional.fields | 轉換為 response_code 的整數;複製到 error_code_label 並合併至 additional.fields |
| error_text | security_result.summary | 直接複製值 |
| host_name | principal.asset.hostname、principal.hostname | 值會直接複製到兩者 |
| logon_date_time | metadata.event_timestamp | 使用日期比對功能轉換,格式為 ISO8601、yyyy-MM-dd HH:mm:ss |
| logon_source | target.resource.parent | 直接複製值 |
| logon_source | additional.fields | 使用 grok 擷取 logonSource,然後在 logon_source_label 中設為 %{logonSource}LSS,並合併至 additional.fields |
| logon_source | additional.fields | 使用 grok 擷取通訊協定、remote_hostname、通訊埠、logon_details、connection_id、cid、jdbc_driver_info,然後在合併至 additional.fields 的相應標籤中設定 |
| proc_id | target.resource.id | 直接複製值 |
| profile_name | target.resource.attribute.labels | profile_name_label 中的設定已合併至 attribute.labels |
| query_text | target.process.command_line | 直接複製值 |
| request_mode | target.resource.resource_subtype, additional.fields | 值直接複製到 resource_subtype;在 request_mode_label 中設定,合併到 additional.fields |
| session_id | network.session_id | 直接複製值 |
| statement_group | principal.user.groupid、additional.fields | 值直接複製到 groupid;在合併到 additional.fields 的 statement_group_label 中設定 |
| statement_type | security_result.about.labels、additional.fields | 在併入 about.labels 的 statementtype_value_label 中設定;在併入 additional.fields 的 statement_type_label 中設定 |
| ts | metadata.event_timestamp | 使用日期比對功能轉換,格式為 MMM d HH:mm:ss、MMM dd HH:mm:ss、SYSLOGTIMESTAMP、RFC 3339、UNIX、ISO8601、UNIX_MS |
| tt_granularity | target.resource.product_object_id | 直接複製值 |
| user_id | principal.user.userid | 直接複製值 |
| user_name | principal.user.user_display_name | 直接複製值 |
| metadata.event_type | 如果 has_principal、has_principal_user、has_target_resource 為 true,則設為 USER_RESOURCE_ACCESS;如果 has_principal 為 true,則設為 STATUS_UPDATE;否則設為 GENERIC_EVENT | |
| metadata.product_name | 設為「TERADATA_DB」 | |
| metadata.vendor_name | 設為「TERADATA」 | |
profile_name |
event.idm.read_only_udm.target.resource.attribute.labels |
從變更記錄對應 |
proc_id |
event.idm.read_only_udm.target.resource.id |
從變更記錄對應 |
user_id |
event.idm.read_only_udm.principal.user.userid |
從變更記錄對應 |
collect_timestamp |
event.idm.read_only_udm.metadata.collected_timestamp |
從變更記錄對應 |
logon_date_time |
event.idm.read_only_udm.metadata.event_timestamp |
從變更記錄對應 |
user_name |
event.idm.read_only_udm.principal.user.user_display_name |
從變更記錄對應 |
logon_source |
event.idm.read_only_udm.target.resource.parent |
從變更記錄對應 |
app_id |
event.idm.read_only_udm.target.asset.product_object_id |
從變更記錄對應 |
client_id |
event.idm.read_only_udm.target.asset.asset_id |
從變更記錄對應 |
error_code |
event.idm.read_only_udm.network.http.response_code |
從變更記錄對應 |
statement_type |
event.idm.read_only_udm.security_result.about.labels |
從變更記錄對應 |
statement_group |
event.idm.read_only_udm.principal.user.groupid |
從變更記錄對應 |
request_mode |
event.idm.read_only_udm.target.resource.resource_subtype |
從變更記錄對應 |
tt_granularity |
event.idm.read_only_udm.target.resource.product_object_id |
從變更記錄對應 |
protocol |
event.idm.read_only_udm.additional.fields |
從變更記錄對應 |
remote_hostname |
event.idm.read_only_udm.additional.fields |
從變更記錄對應 |
logon_details |
event.idm.read_only_udm.additional.fields |
從變更記錄對應 |
connection_id |
event.idm.read_only_udm.additional.fields |
從變更記錄對應 |
port |
event.idm.read_only_udm.additional.fields |
從變更記錄對應 |
cid |
event.idm.read_only_udm.additional.fields |
從變更記錄對應 |
jdbc_driver_info |
event.idm.read_only_udm.additional.fields |
從變更記錄對應 |
app_id |
principal.application |
從變更記錄對應 |
collect_timestamp |
event.idm.read_only_udm.additional.fields |
從變更記錄對應 |
error_code |
security_result.detection_fields |
從變更記錄對應 |
logon_date_time |
event.idm.read_only_udm.additional.fields |
從變更記錄對應 |
logon_source |
event.idm.read_only_udm.additional.fields |
從變更記錄對應 |
proc_id |
principal.process.pid |
從變更記錄對應 |
request_mode |
event.idm.read_only_udm.additional.fields |
從變更記錄對應 |
statement_group |
event.idm.read_only_udm.additional.fields |
從變更記錄對應 |
statement_type |
event.idm.read_only_udm.additional.fields |
從變更記錄對應 |
user_id |
target.user.userid |
從變更記錄對應 |
user_name |
target.user.user_display_name |
從變更記錄對應 |
變更記錄
還有其他問題嗎?向社群成員和 Google SecOps 專家尋求解答。