收集 Tintri 記錄

支援的國家/地區:

本文說明如何使用 Bindplane 代理程式,將 Tintri 記錄擷取至 Google Security Operations。

Tintri 是可感知 VM 的智慧型儲存空間平台,可產生效能、容量和系統事件記錄檔,並為內部部署資料中心的虛擬化環境提供最佳化的儲存空間管理。

事前準備

請確認您已完成下列事前準備事項:

  • Google SecOps 執行個體
  • Windows Server 2016 以上版本,或搭載 systemd 的 Linux 主機
  • Bindplane 代理程式與 Tintri VMstore 設備之間的網路連線
  • 如果透過 Proxy 執行,請確保防火牆通訊埠已根據 Bindplane 代理程式需求開啟
  • 具備管理員權限,可存取 Tintri VMstore 或 Tintri Global Center 的特權

取得 Google SecOps 擷取驗證檔案

  1. 登入 Google SecOps 控制台。
  2. 依序前往「SIEM 設定」>「收集代理程式」
  3. 下載擷取驗證檔案,並將檔案安全地儲存在要安裝 Bindplane 的系統中。

取得 Google SecOps 客戶 ID

  1. 登入 Google SecOps 控制台。
  2. 依序前往「SIEM 設定」>「設定檔」
  3. 複製並儲存「機構詳細資料」部分中的客戶 ID

安裝 Bindplane 代理程式

請按照下列操作說明,在 Windows 或 Linux 作業系統上安裝 Bindplane 代理程式。

Windows 安裝

  1. 以管理員身分開啟「命令提示字元」或「PowerShell」
  2. 執行下列指令:

    msiexec /i "https://github.com/observIQ/bindplane-agent/releases/latest/download/observiq-otel-collector.msi" /quiet
    
  3. 等待安裝完成。

  4. 執行下列指令,確認安裝成功:

    sc query observiq-otel-collector
    

    服務應顯示為「RUNNING」

Linux 安裝

  1. 開啟具有根層級或 sudo 權限的終端機。
  2. 執行下列指令:

    sudo sh -c "$(curl -fsSlL https://github.com/observiq/bindplane-agent/releases/latest/download/install_unix.sh)" install_unix.sh
    
  3. 等待安裝完成。

  4. 執行下列指令,確認安裝成功:

    sudo systemctl status observiq-otel-collector
    

    服務應顯示為有效 (執行中)

其他安裝資源

如需其他安裝選項和疑難排解資訊,請參閱 Bindplane 代理程式安裝指南

設定 Bindplane 代理程式,擷取系統記錄檔並傳送至 Google SecOps

找出設定檔

  • Linux:

    sudo nano /etc/bindplane-agent/config.yaml
    
  • Windows:

    notepad "C:\Program Files\observIQ OpenTelemetry Collector\config.yaml"
    

編輯設定檔

  • config.yaml 的所有內容替換為下列設定:

    receivers:
        udplog:
            listen_address: "0.0.0.0:514"
    
    exporters:
        chronicle/tintri:
            compression: gzip
            creds_file_path: '/etc/bindplane-agent/ingestion-auth.json'
            customer_id: '<customer_id>'
            endpoint: malachiteingestion-pa.googleapis.com
            log_type: TINTRI
            raw_log_field: body
    
    service:
        pipelines:
            logs/tintri_to_chronicle:
                receivers:
                    - udplog
                exporters:
                    - chronicle/tintri
    

設定參數

替換下列預留位置:

  • 接收器設定:

    • listen_address:要接聽的 IP 位址和通訊埠:
      • 0.0.0.0,監聽所有介面 (建議)
      • 通訊埠 514 是標準的系統記錄通訊埠 (在 Linux 上需要根層級權限;非根層級權限請使用 1514)
  • 匯出工具設定:

    • creds_file_path:擷取驗證檔案的完整路徑:
      • Linux/etc/bindplane-agent/ingestion-auth.json
      • WindowsC:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json
    • customer_id:從 Google SecOps 控制台複製的客戶 ID
    • endpoint:區域端點網址:
      • 美國malachiteingestion-pa.googleapis.com
      • 歐洲europe-malachiteingestion-pa.googleapis.com
      • 亞洲asia-southeast1-malachiteingestion-pa.googleapis.com
      • 如需完整清單,請參閱「區域端點

儲存設定檔

  • 編輯完成後,請儲存檔案:

    • Linux:依序按下 Ctrl+OEnterCtrl+X
    • Windows:依序點選「檔案」>「儲存」

重新啟動 Bindplane 代理程式,以套用變更

  • 如要在 Linux 中重新啟動 Bindplane 代理程式,請執行下列指令:

    sudo systemctl restart observiq-otel-collector
    
    1. 確認服務正在執行:

      sudo systemctl status observiq-otel-collector
      
    2. 檢查記錄中是否有錯誤:

      sudo journalctl -u observiq-otel-collector -f
      
  • 如要在 Windows 中重新啟動 Bindplane 代理程式,請選擇下列其中一個選項:

    • 以管理員身分開啟命令提示字元或 PowerShell:

      net stop observiq-otel-collector && net start observiq-otel-collector
      
    • 服務控制台:

      1. 按下 Win+R,輸入 services.msc,然後按下 Enter 鍵。
      2. 找出 observIQ OpenTelemetry Collector
      3. 按一下滑鼠右鍵,然後選取「重新啟動」
      4. 確認服務正在執行:

        sc query observiq-otel-collector
        
      5. 檢查記錄中是否有錯誤:

        type "C:\Program Files\observIQ OpenTelemetry Collector\log\collector.log"
        

設定 Tintri 系統記錄檔轉送

  1. 登入 Tintri VMstore 管理控制台。
  2. 依序前往「設定」>「通知」>「系統記錄」
  3. 按一下「新增」,建立新的系統記錄伺服器項目。
  4. 請提供下列設定詳細資料:
    • 伺服器:輸入 Bindplane 代理程式主機的 IP 位址。
    • 「Port」(通訊埠):輸入 514
    • 「通訊協定」:選取「UDP」
  5. 按一下「儲存」或「套用」,儲存設定。
  6. 檢查 Bindplane 代理程式記錄,確認記錄是否已傳送。

UDM 對應表

記錄欄位 UDM 對應 邏輯
說明 extensions.auth.type 如果說明符合「logged in|login」或「logged out|logout」,請設為「MACHINE」
event_timestamp metadata.event_timestamp 使用日期比對「MMM dd HH:mm:ss 」轉換為時間戳記
hostname、user_id、request_path、description metadata.event_type 如果主機名稱不為空白,且 (user_id 不為空白或 request_path 不為空白),且說明符合「logged in|login」,則設為「USER_LOGIN」;如果主機名稱不為空白,且 (user_id 不為空白或 request_path 不為空白),且說明符合「logged out|logout」,則設為「USER_LOGOUT」;如果主機名稱不為空白,且 (user_id 不為空白或 request_path 不為空白),則設為「USER_UNCATEGORIZED」;如果主機名稱不為空白,則設為「STATUS_UPDATE」;否則設為「GENERIC_EVENT」
user_event metadata.product_event_type 直接複製值
log_id metadata.product_log_id 直接複製值
http_method network.http.method 直接複製值
主機名稱 principal.asset.hostname 直接複製值
client_ip principal.asset.ip 從 client_ip 合併
主機名稱 principal.hostname 直接複製值
client_ip principal.ip 從 client_ip 合併
id principal.process.pid 已轉換為字串
記錄器 principal.resource.attribute.labels 合併為標籤,鍵為「logger」,值來自記錄器
說明 security_result.description 直接複製值
component、thread、client_type security_result.detection_fields 合併為標籤,並以「component」、「thread」、「client_type」做為鍵,以及各欄位的值
log_level security_result.severity 如果 log_level 符合 (?i)(DEBUG|INFO|AUDIT|NOTICE),則設為「INFORMATIONAL」;如果符合 (?i)ERROR,則設為「ERROR」;如果符合 (?i)(WARNING|WARN),則設為「MEDIUM」
狀態 security_result.summary 直接複製值
request_path target.url 直接複製值
user_id target.user.userid 直接複製值
metadata.product_name 設為「Tintri」
metadata.vendor_name 設為「Tintri」

變更記錄

查看這個剖析器的變更記錄

還有其他問題嗎?向社群成員和 Google SecOps 專業人員尋求答案。