收集 Trend Micro Apex Central 記錄
本文說明如何使用 Bindplane 代理程式,將 Trend Micro Apex Central 記錄檔擷取至 Google Security Operations。
Trend Micro Apex Central 是趨勢科技產品的集中式安全管理控制台,可提供端點、伺服器和網路層的威脅偵測、政策管理和安全性事件記錄。並透過 syslog 以 CEF 格式輸出記錄。
事前準備
請確認您已完成下列事前準備事項:
- Google SecOps 執行個體
- Windows Server 2016 以上版本,或搭載
systemd的 Linux 主機 - Bindplane 代理程式與 Trend Micro Apex Central 伺服器之間的網路連線
- 如果是在 Proxy 後方執行,請確認防火牆通訊埠已按照 Bindplane 代理程式規定開啟
- 具備管理員權限,可存取 Trend Micro Apex Central
取得 Bindplane 代理程式的 Google SecOps 憑證
如要向 Google SecOps 驗證 Bindplane 代理程式,請選擇下列其中一種方法:
- 新部署作業:使用 Chronicle API (選項 1)。
- 舊版部署作業:在 2027 年 7 月 20 日停用 Ingestion API 前,請繼續使用擷取驗證檔案 (選項 2)。
方法 1:為 Chronicle API 建立服務帳戶 (建議)
- 登入 Google Cloud 控制台,然後選取連結至 Google SecOps 執行個體的 Google Cloud 專案。
- 依序前往 「IAM & Admin」(IAM 與管理) >「Service Accounts」(服務帳戶)。
- 按一下「建立服務帳戶」。
- 請提供下列設定詳細資料:
- 服務帳戶名稱:輸入帳戶名稱 (例如
bindplane-ingest)。 - 「服務帳戶說明」:輸入說明 (例如
Bindplane agent log ingestion)。
- 服務帳戶名稱:輸入帳戶名稱 (例如
- 點按「Create and continue」(建立並繼續)。
- 在「將專案存取權授予這個服務帳戶」部分,按一下「選取角色」,然後選取「Chronicle 編輯者」。
- 依序點選「繼續」和「完成」。
- 按一下您建立的服務帳戶,然後前往「金鑰」分頁。
- 依序點選「新增金鑰」>「建立新的金鑰」。
- 選取「JSON」,然後點選「建立」。金鑰檔案會下載到電腦。
- 將金鑰檔案儲存為 Bindplane 收集器目錄中的
ingestion-auth.json(Linux 上的/opt/observiq-otel-collector/ingestion-auth.json或 Windows 上的C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json),或更新config.yaml中的creds_file_path,使其與儲存路徑相符。 - 依序前往「IAM 與管理」>「設定」,然後複製「專案編號」。設定匯出工具時會用到。
方法 2:下載擷取驗證檔案 (舊版)
- 登入 Google SecOps 控制台。
- 依序前往「SIEM 設定」>「收集代理程式」。
- 下載擷取驗證檔案。
- 將檔案安全地儲存在要安裝 Bindplane 代理程式的系統上。
取得 Google SecOps 客戶 ID
- 登入 Google SecOps 控制台。
- 依序前往「SIEM 設定」 > 「設定檔」。
複製並儲存「機構詳細資料」部分的客戶 ID。
安裝 Bindplane 代理程式
請按照下列操作說明,在 Windows 或 Linux 作業系統上安裝 Bindplane 代理程式。
Windows 安裝
- 以管理員身分開啟命令提示字元或 PowerShell。
執行下列指令:
msiexec /i "https://github.com/observIQ/bindplane-agent/releases/latest/download/observiq-otel-collector.msi" /quiet等待安裝完成。
執行下列指令,確認安裝成功:
sc query observiq-otel-collector服務應顯示為「RUNNING」。
Linux 安裝
- 開啟具有根層級或 sudo 權限的終端機。
執行下列指令:
sudo sh -c "$(curl -fsSlL https://github.com/observiq/bindplane-agent/releases/latest/download/install_unix.sh)" install_unix.sh等待安裝完成。
執行下列指令,確認安裝成功:
sudo systemctl status observiq-otel-collector服務應顯示為「active (running)」。
其他安裝資源
如需其他安裝選項和疑難排解資訊,請參閱 Bindplane 代理程式安裝指南。
設定 Bindplane 代理程式,擷取系統記錄檔並傳送至 Google SecOps
找出設定檔
Linux:
sudo nano /opt/observiq-otel-collector/config.yamlWindows:
notepad "C:\Program Files\observIQ OpenTelemetry Collector\config.yaml"
編輯設定檔
將
config.yaml的全部內容替換為下列設定:receivers: tcplog: listen_address: "0.0.0.0:514" exporters: chronicle/trendmicro_apex_central: protocol: https # Region of your instance, for example us, europe, asia-southeast1 location: <LOCATION> # Project number of the Google Cloud project linked to the instance project: '<PROJECT_NUMBER>' compression: gzip creds_file_path: '/opt/observiq-otel-collector/ingestion-auth.json' customer_id: '<customer_id>' endpoint: chronicle.googleapis.com log_type: TRENDMICRO_APEX_CENTRAL raw_log_field: body service: pipelines: logs/trendmicro_apex_central_to_chronicle: receivers: - tcplog exporters: - chronicle/trendmicro_apex_central
設定參數
替換下列預留位置:
接收器設定:
listen_address:要接聽的 IP 位址和通訊埠:0.0.0.0:在所有介面上監聽 (建議)- 通訊埠
514是標準的系統記錄通訊埠 (在 Linux 上需要根層級權限;如果沒有根層級權限,請使用1514)
匯出工具設定:
creds_file_path:服務帳戶 JSON 金鑰檔案的完整路徑 (選項 1):- Linux:
/opt/observiq-otel-collector/ingestion-auth.json - Windows:
C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json
- Linux:
customer_id:從 Google SecOps 控制台複製的客戶 IDlocation:將<LOCATION>替換為 Google SecOps 執行個體的區域 (例如us、europe或asia-southeast1)。匯出工具會以這個值做為chronicle.googleapis.com的前置字元。如需完整清單,請參閱「區域性端點」。project:依序前往「IAM 與管理」>「設定」,然後將<PROJECT_NUMBER>替換為專案編號。endpoint:維持設為chronicle.googleapis.com。
舊版 Ingestion API 匯出工具
如果您使用方式 2 的擷取驗證檔案,請將
exporters區塊替換成下列內容。將creds_file_path設為擷取驗證檔案的路徑。如果執行個體位於美國境外,請將malachiteingestion-pa.googleapis.com替換為區域端點 (例如europe-malachiteingestion-pa.googleapis.com)。exporters: chronicle/trendmicro_apex_central: compression: gzip creds_file_path: '/opt/observiq-otel-collector/ingestion-auth.json' customer_id: '<customer_id>' endpoint: malachiteingestion-pa.googleapis.com log_type: TRENDMICRO_APEX_CENTRAL raw_log_field: body
儲存設定檔
- 編輯完成後,請儲存檔案:
- Linux:依序按下
Ctrl+O、Enter和Ctrl+X - Windows:依序點選「檔案」 > 「儲存」
- Linux:依序按下
重新啟動 Bindplane 代理程式,套用變更
如要在 Linux 重新啟動 Bindplane 代理程式,請執行下列指令:
sudo systemctl restart observiq-otel-collector確認服務是否正在執行:
sudo systemctl status observiq-otel-collector查看記錄檔是否有錯誤:
sudo journalctl -u observiq-otel-collector -f
如要在 Windows 中重新啟動 Bindplane 代理程式,請選擇下列其中一個選項:
以管理員身分開啟命令提示字元或 PowerShell:
net stop observiq-otel-collector && net start observiq-otel-collector服務控制台:
- 按下
Win+R,輸入services.msc,然後按下 Enter 鍵。 - 找出「observIQ OpenTelemetry Collector」。
- 按一下滑鼠右鍵,然後選取「重新啟動」。
確認服務正在執行:
sc query observiq-otel-collector查看記錄檔是否有錯誤:
type "C:\Program Files\observIQ OpenTelemetry Collector\log\collector.log"
- 按下
設定 Trend Micro Apex Central 系統記錄轉送
- 登入 Apex Central 管理控制台。
- 依序前往「Administration」(管理) >「Settings」(設定) >「Syslog Settings」(系統記錄設定)。
- 勾選「Enable Syslog Forwarding」(啟用 Syslog 轉送) 核取方塊,啟用 Syslog 轉送功能。
- 提供下列設定詳細資料:
- 伺服器位址:輸入 Bindplane 代理程式主機的 IP 位址。
- 「Port」(通訊埠):輸入
514。 - 通訊協定:選取「TCP」。
- 格式:選取「CEF」 (通用事件格式)。
- 選取要轉送的記錄類型:
- 偵測記錄
- 違反政策事件
- 安全性事件
- 系統事件
- 按一下「儲存」,套用設定。
- 檢查 Bindplane 代理程式記錄,確認記錄是否已傳送。
UDM 對應表
| 記錄欄位 | UDM 對應 | 邏輯 |
|---|---|---|
| var_eventFormatVersion, var_severity, dntdom_label, additional_cs6, additional_product_version, additional_cat, additional_msg, additional_dvchost, var_cs1_label, var_cs1, var_cs2, var_cs5, var_deviceExternalId, var_c6a3, var_cn1_label, var_cn1, var_cn2, var_cs4_label, var_cs4, var_c6a2, var_cn3, var_cnt, var_TMCMLogTarget, var_deviceDirection | additional.fields | 其他供應商專屬事件資料 |
| rt | metadata.event_timestamp | 事件發生時間的時間戳記 |
| event_name | metadata.event_type | 事件類型 (例如 USER_LOGIN、NETWORK_CONNECTION) |
| event_id | metadata.product_event_type | 產品事件類型 |
| devicePayloadId | metadata.product_log_id | 產品記錄項目的專屬 ID |
| cs3、product_version | metadata.product_version | 產品版本 |
| vendor | metadata.vendor_name | 供應商/公司名稱 |
| product_name | metadata.product_name | 產品名稱 |
| 應用程式 | network.application_protocol | 應用程式通訊協定 |
| deviceDirection | network.direction | 網路流量方向 |
| proto | network.ip_protocol | IP 通訊協定 |
| domain、dntdom | principal.administrative_domain | 主體的管理網域 |
| dhost | principal.asset.hostname | 資產的主機名稱 |
| TMCMLogDetectedIP、princ_ip | principal.asset.ip | 資產的 IP 位址 |
| platform | principal.asset.platform | 資產的平台 |
| patch_level | principal.asset.platform_patch_level | 平台的修補程式等級 |
| 版本 | principal.asset.platform_version | 平台版本 |
| dvchost、dhost | principal.hostname | 來源主機名稱 |
| TMCMLogDetectedIP、princ_ip | principal.ip | 主體的 IP 位址 |
| smac | principal.mac | 主體的 MAC 位址 |
| spt | principal.port | 主體通訊埠 |
| deviceProcessName | principal.process.file.full_path | 程序檔案的完整路徑 |
| duser | principal.user.userid | 主體的使用者 ID |
| security_result | security_result | 安全性結果 |
| act | security_result.action | 安全性產品採取的動作 |
| act, cs5 | security_result.action_details | 採取的行動詳細資料 |
| cs4 | security_result.category_details | 類別詳細資料 |
| cs1、cn2 | security_result.description | 安全性結果說明 |
| var_cn2_label | security_result.detection_fields | 與偵測相關的欄位 |
| cn1 | security_result.rule_id | 規則 ID |
| cs1 | security_result.rule_name | 規則名稱 |
| cn3、嚴重性、cn4、cn2 | security_result.severity | 安全性結果的嚴重性 |
| event_name | security_result.threat_name | 威脅名稱 |
| cnt | security_result.verdict_info | 判決結果相關資訊 |
| shost | src.hostname | 來源主機名稱 |
| src, host_ip | src.ip | 來源 IP 位址 |
| suser | src.user.userid | 來源的使用者 ID |
| deviceNtDomain | target.administrative_domain | 目標的管理網域 |
| c6a3 | target.asset.ip | 資產的 IP 位址 |
| filePath、sproc | target.file.full_path | 檔案的完整路徑 |
| fname | target.file.names | 檔案名稱 |
| fileHash | target.file.sha1 | 檔案的 SHA1 雜湊 |
| c6a3 | target.ip | 目標的 IP 位址 |
| dmac | target.mac | 目標的 MAC 位址 |
| dpt | target.port | 目標通訊埠 |
| cs3、sproc | target.process.file.full_path | 程序檔案的完整路徑 |
| 要求 | target.url | 目標網址 |
| duser | target.user.userid | 目標的使用者 ID |
cs3 |
event.idm.read_only_udm.additional.fields |
從變更記錄對應 |
Product_Version |
event.idm.read_only_udm.additional.fields |
從變更記錄對應 |
var_cn2_label.value |
N/A |
從變更記錄對應 |
var_cn2_label.value |
Unknown |
從變更記錄對應 |
var_cn2_label.value |
Clean |
從變更記錄對應 |
var_cn2_label.value |
Delete |
從變更記錄對應 |
var_cn2_label.value |
Move |
從變更記錄對應 |
var_cn2_label.value |
Rename |
從變更記錄對應 |
var_cn2_label.value |
Pass/Log |
從變更記錄對應 |
var_cn2_label.value |
Strip |
從變更記錄對應 |
var_cn2_label.value |
Drop |
從變更記錄對應 |
var_cn2_label.value |
Quarantine |
從變更記錄對應 |
cnt |
security_result.verdict_info.malicious_count |
從變更記錄對應 |
metadata.event_type |
STATUS_UPDATE |
從變更記錄對應 |
變更記錄
還有其他問題嗎?向社群成員和 Google SecOps 專業人員尋求解答。