收集 Trend Micro Email Security 記錄
本文說明如何使用 Bindplane,將 Trend Micro Email Security 記錄檔擷取至 Google Security Operations。Trend Micro Email Security 是以雲端為基礎的電子郵件閘道,可保護機構免受垃圾郵件、惡意軟體、網路釣魚、勒索軟體和進階目標性攻擊侵擾,防護範圍涵蓋使用者信箱。這項功能可針對電子郵件傳入和傳出流量提供網址篩選、附件沙箱和資料遺失防護功能。
事前準備
請確認您符合下列必要條件:
- Google SecOps 執行個體。
- 搭載 systemd 的 Windows 2016 以上版本或 Linux 主機。
- 如果透過 Proxy 執行,請確保防火牆通訊埠已根據 Bindplane 代理程式需求開啟。
- Trend Micro Email Security 管理控制台的特殊權限存取權。
取得 Bindplane 代理程式的 Google SecOps 憑證
如要向 Google SecOps 驗證 Bindplane 代理程式,請選擇下列其中一種方法:
- 新部署作業:使用 Chronicle API (選項 1)。
- 舊版部署作業:繼續使用擷取驗證檔案 (選項 2),直到 Ingestion API 於 2027 年 7 月 20 日停用。
方法 1:為 Chronicle API 建立服務帳戶 (建議)
- 登入 Google Cloud 控制台,然後選取連結至 Google SecOps 執行個體的 Google Cloud 專案。
- 依序前往「IAM & Admin」(IAM 與管理) >「Service Accounts」(服務帳戶)。
- 按一下「建立服務帳戶」。
- 請提供下列設定詳細資料:
- 「Service account name」(服務帳戶名稱):輸入帳戶名稱 (例如
bindplane-ingest)。 - 服務帳戶說明:輸入說明 (例如
Bindplane agent log ingestion)。
- 「Service account name」(服務帳戶名稱):輸入帳戶名稱 (例如
- 點按「Create and continue」(建立並繼續)。
- 在「將專案存取權授予這個服務帳戶」部分,按一下「選取角色」,然後選取「Chronicle 編輯者」。
- 依序點選「繼續」和「完成」。
- 按一下您建立的服務帳戶,然後前往「金鑰」分頁標籤。
- 依序點選「新增金鑰」>「建立新的金鑰」。
- 選取「JSON」,然後點選「建立」。金鑰檔案會下載到電腦。
- 將金鑰檔案儲存為 Bindplane 收集器目錄中的
ingestion-auth.json(Linux 上的/opt/observiq-otel-collector/ingestion-auth.json或 Windows 上的C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json),或更新config.yaml中的creds_file_path,使其與儲存路徑相符。 - 依序前往「IAM & Admin」(IAM 與管理) >「Settings」(設定),然後複製「Project number」(專案編號)。設定匯出工具時會用到。
方法 2:下載擷取驗證檔案 (舊版)
- 登入 Google SecOps 控制台。
- 依序前往「SIEM 設定」>「收集代理程式」。
- 下載擷取驗證檔案。
- 將檔案安全地儲存在要安裝 Bindplane 代理程式的系統上。
取得 Google SecOps 客戶 ID
- 登入 Google SecOps 控制台。
- 依序前往「SIEM 設定」>「設定檔」。
- 複製並儲存「機構詳細資料」部分的客戶 ID。
安裝 Bindplane 代理程式
請按照下列操作說明,在 Windows 或 Linux 作業系統上安裝 Bindplane 代理程式。
Windows 安裝
- 以管理員身分開啟命令提示字元或 PowerShell。
執行下列指令:
msiexec /i "[https://github.com/observIQ/bindplane-agent/releases/latest/download/observiq-otel-collector.msi](https://github.com/observIQ/bindplane-agent/releases/latest/download/observiq-otel-collector.msi)" /quiet
Linux 安裝
- 開啟具有根層級或 sudo 權限的終端機。
執行下列指令:
sudo sh -c "$(curl -fsSlL [https://github.com/observiq/bindplane-agent/releases/latest/download/install_unix.sh](https://github.com/observiq/bindplane-agent/releases/latest/download/install_unix.sh))" install_unix.sh
其他安裝資源
如需其他安裝選項,請參閱這份安裝指南。
設定 Bindplane 代理程式,擷取系統記錄並傳送至 Google SecOps
存取設定檔:
- 找出
config.yaml檔案。通常位於 Linux 的/opt/observiq-otel-collector/目錄,或 Windows 的安裝目錄。 - 使用文字編輯器 (例如
nano、vi或記事本) 開啟檔案。
- 找出
按照下列方式編輯
config.yaml檔案:receivers: tcplog: # Replace the port and IP address as required listen_address: "0.0.0.0:514" exporters: chronicle/chronicle_w_labels: protocol: https # Region of your instance, for example us, europe, asia-southeast1 location: <LOCATION> # Project number of the Google Cloud project linked to the instance project: '<PROJECT_NUMBER>' compression: gzip # Adjust the path to the credentials file you downloaded in Step 1 creds_file_path: '/path/to/ingestion-authentication-file.json' # Replace with your actual customer ID from Step 2 customer_id: YOUR_CUSTOMER_ID endpoint: chronicle.googleapis.com # Add optional ingestion labels for better organization log_type: 'TRENDMICRO_EMAIL_SECURITY' raw_log_field: body ingestion_labels: service: pipelines: logs/source0__chronicle_w_labels-0: receivers: - tcplog exporters: - chronicle/chronicle_w_labels
- 請根據基礎架構需求,替換通訊埠和 IP 位址。
- 將
<LOCATION>替換為 Google SecOps 執行個體的區域 (例如us、europe或asia-southeast1)。匯出工具會在這個值前面加上chronicle.googleapis.com。 - 將
<PROJECT_NUMBER>替換為「IAM 與管理」>「設定」中的專案編號。 - 將
YOUR_CUSTOMER_ID替換為實際的客戶 ID。 - 將
/path/to/ingestion-authentication-file.json更新為步驟 1 中儲存服務帳戶金鑰檔案 (選項 1) 的檔案路徑。
舊版 Ingestion API 匯出工具
如果您使用方式 2 的擷取驗證檔案,請將
exporters區塊替換成下列內容。將creds_file_path設為擷取驗證檔案的路徑,如果您的執行個體位於美國境外,請將malachiteingestion-pa.googleapis.com替換為區域端點 (例如europe-malachiteingestion-pa.googleapis.com)。exporters: chronicle/chronicle_w_labels: compression: gzip # Adjust the path to the credentials file you downloaded in Step 1 creds_file_path: '/path/to/ingestion-authentication-file.json' # Replace with your actual customer ID from Step 2 customer_id: YOUR_CUSTOMER_ID endpoint: malachiteingestion-pa.googleapis.com # Add optional ingestion labels for better organization log_type: 'TRENDMICRO_EMAIL_SECURITY' raw_log_field: body ingestion_labels:
重新啟動 Bindplane 代理程式,套用變更
如要在 Linux 中重新啟動 Bindplane 代理程式,請執行下列指令:
sudo systemctl restart observiq-otel-collector如要在 Windows 重新啟動 Bindplane 代理程式,可以使用「服務」控制台,或輸入下列指令:
net stop observiq-otel-collector && net start observiq-otel-collector
設定 Trend Micro Email Security syslog 轉送
如要設定 Trend Micro Email Security,透過 syslog 將記錄轉送至 Bindplane 代理程式,請按照下列步驟操作:
- 登入 Trend Micro Email Security 管理控制台。
- 依序前往「Administration」>「Syslog Settings」。
按一下「Add」,建立新的 Syslog 伺服器設定檔。
提供下列設定詳細資料:
- 伺服器位址:輸入 Bindplane 代理程式主機的 IP 位址 (例如
192.168.1.100)。 - Port:輸入
514(或 Bindplane 代理程式中設定的通訊埠)。 - 通訊協定:選取「TCP」。
- 格式:選取「CEF」 (通用事件格式)。
- 伺服器位址:輸入 Bindplane 代理程式主機的 IP 位址 (例如
在「Log Types」(記錄類型) 區段中,選取要轉送的記錄類別:
- 政策事件:電子郵件篩選政策動作。
- 垃圾訊息偵測:垃圾郵件和灰郵事件。
- 惡意軟體偵測:病毒和惡意軟體偵測事件。
- 勒索軟體偵測 - 勒索軟體偵測事件。
- 網址分析:網址點擊和點擊時防護事件。
- 進階威脅防護:沙箱分析事件。
- 資料遺失防護:違反資料遺失防護政策的事件。
- 內容篩選 - 內容篩選規則事件。
按一下 [儲存]。
點選「Test Connection」,確認記錄檔已傳送至 Bindplane 代理程式。
檢查 Bindplane 代理程式記錄,確認記錄是否已送達。
詳情請參閱 Trend Micro Email Security 說明文件。
UDM 對應表
| 記錄欄位 | UDM 對應 | 邏輯 |
|---|---|---|
additional_cn1 |
additional.fields |
已合併 |
additional_cs1 |
additional.fields |
已合併 |
additional_cs2 |
additional.fields |
已合併 |
additional_cs3 |
additional.fields |
已合併 |
additional_cs4 |
additional.fields |
已合併 |
additional_cs5 |
additional.fields |
已合併 |
additional_cs6 |
additional.fields |
已合併 |
message |
extensions.auth.type |
已對應:login → AUTHTYPE_UNSPECIFIED |
msg |
metadata.description |
直接對應 |
rt |
metadata.event_timestamp |
已剖析為 ISO8601 |
cs1 |
metadata.event_type |
對應:phishing → SCAN_UNCATEGORIZED |
message |
metadata.event_type |
對應:CEF:0 → GENERIC_EVENT,login → USER_LOGIN |
cs1 |
metadata.product_event_type |
直接對應 |
network_direction |
network.direction |
對應:INCOMING → INBOUND、OUTGOING → OUTBOUND |
cs2 |
principal.hostname |
直接對應 |
principal_ip |
principal.hostname |
直接對應 |
principal_ip |
principal.ip |
已合併 |
message |
principal.user.userid |
已對應:login → target.user.userid |
suser |
principal.user.userid |
直接對應 |
act |
security_result.action |
對應:ALLOW → act、DENY → security_result_action、QUARANTINE → act |
security_result_action |
security_result.action |
已合併 |
act |
security_result.action_details |
直接對應 |
cs5 |
security_result.rule_name |
直接對應 |
severity |
security_result.severity |
對應:"0", "1", "2", "3", "LOW" → LOW、`"4", "5", "6", "MEDIUM", "SUBSTANTIAL", "INFO"... |
cs6 |
target.url |
直接對應 |
duser |
target.user.email_addresses |
已對應:; → emailId |
emailId |
target.user.email_addresses |
已合併 |
duser |
target.user.userid |
直接對應 |
principal.user.userid |
target.user.userid |
已重新命名/對應 |
| 不適用 | extensions.auth.type |
常數:AUTHTYPE_UNSPECIFIED |
| 不適用 | metadata.event_type |
常數:GENERIC_EVENT |
| 不適用 | network.direction |
常數:INBOUND |
| 不適用 | principal.user.userid |
常數:target.user.userid |
| 不適用 | security_result.severity |
常數:LOW |
變更記錄
還有其他問題嗎?向社群成員和 Google SecOps 專業人員尋求解答。