收集 Trend Micro Vision One 检测日志
支持的平台:
Google SecOps
SIEM
本文档介绍了如何使用 AWS S3 将 Trend Micro Vision One Detections 日志注入到 Google Security Operations。解析器会将 Trend Micro Vision One Detections 日志从 JSON 格式转换为统一数据模型 (UDM)。
准备工作
请确保满足以下前提条件:
- Google SecOps 实例
- 对 Trend Micro Vision One 的特权访问权限
在 Trend Micro Vision One 上配置日志记录
- 登录 Trend Micro Vision One 控制台。
- 依次前往工作流和 Automation> 第三方集成。
- 点击 Google Security Operations SIEM。
- 在访问密钥下,点击生成密钥。
- 复制并保存访问密钥 ID 和私有访问密钥。
- 在数据转移下,启用检测数据旁边的切换开关。
- 系统会生成 S3 URI,并开始将数据发送到相应的 S3 存储桶。
- 复制并保存 S3 网址,以供日后使用。
设置 Feed
如需配置 Feed,请按以下步骤操作:
- 依次前往 SIEM 设置 > Feed。
- 点击添加新 Feed。
- 在下一页上,点击配置单个 Feed。
- 在 Feed 名称字段中,输入 Feed 的名称(例如
Trend Micro Vision One Detections Logs)。 - 选择 Amazon S3 V2 作为来源类型。
- 选择 Trend Micro Vision One 检测结果作为日志类型。
- 点击下一步。
为以下输入参数指定值:
- S3 URI:存储桶 URI(格式应为:
s3://log-bucket-name/)。 请替换以下内容:log-bucket-name:相应存储桶的名称。
- 源删除选项:选择永不删除文件。S3 存储桶中的数据在被清除之前会保留 7 天。
- 文件存在时间上限:包含在过去指定天数内修改的文件。默认值为 180 天。
- 访问密钥 ID:有权访问 S3 存储桶的用户访问密钥。
- 私有访问密钥:有权访问 S3 存储桶的用户私有密钥。
- S3 URI:存储桶 URI(格式应为:
点击下一步。
在最终确定界面中查看新的 Feed 配置,然后点击提交。
UDM 映射表
| 日志字段 | UDM 映射 | 逻辑 |
|---|---|---|
about1 |
about |
已合并 |
about2 |
about |
已合并 |
about3 |
about |
已合并 |
about4 |
about |
已合并 |
attachmentFileHashMd5 |
about.file.md5 |
直接映射 |
attachmentFileType |
about.file.mime_type |
直接映射 |
fileName |
about.file.names |
已合并 |
attachmentFileHash |
about.file.sha1 |
直接映射 |
attachmentFileHashSha1 |
about.file.sha1 |
直接映射 |
attachmentFileHashSha256 |
about.file.sha256 |
直接映射 |
process_cmd |
about.process.command_line |
直接映射 |
actResult_label_1 |
additional.fields |
已合并 |
aggregatedCount_label |
additional.fields |
已合并 |
aptCampaigns_label |
additional.fields |
已合并 |
attachmentFileTlshes_label |
additional.fields |
已合并 |
blocking_label |
additional.fields |
已合并 |
eventID_label |
additional.fields |
已合并 |
eventSubId_label |
additional.fields |
已合并 |
field1 |
additional.fields |
已合并 |
groupIdCorrValues_label |
additional.fields |
已合并 |
highlightedRequest_label |
additional.fields |
已合并 |
integrity_level_label |
additional.fields |
已合并 |
level_label |
additional.fields |
已合并 |
mailMsgDirection_label |
additional.fields |
已合并 |
process_hash_id_label |
additional.fields |
已合并 |
process_launch_time_label |
additional.fields |
已合并 |
process_name_label |
additional.fields |
已合并 |
process_signer_label |
additional.fields |
已合并 |
process_signer_valid_label |
additional.fields |
已合并 |
process_sub_true_type_label |
additional.fields |
已合并 |
process_true_type_label |
additional.fields |
已合并 |
rating_label |
additional.fields |
已合并 |
requests_label |
additional.fields |
已合并 |
description |
metadata.description |
直接映射 |
eventTime |
metadata.event_timestamp |
解析为 UNIX_MS |
logReceivedTime |
metadata.event_timestamp |
解析为 UNIX_MS |
objectLastModifyTime |
metadata.event_timestamp |
解析为 TIMESTAMP |
has_principal |
metadata.event_type |
已映射:true → USER_UNCATEGORIZED |
has_principal_mid |
metadata.event_type |
已映射:true → NETWORK_CONNECTION、true → STATUS_UPDATE |
eventName |
metadata.product_event_type |
直接映射 |
eventType |
metadata.product_event_type |
直接映射 |
msgUuid |
metadata.product_log_id |
直接映射 |
uuid |
metadata.product_log_id |
直接映射 |
pname |
metadata.product_name |
直接映射 |
pver |
metadata.product_version |
直接映射 |
app |
network.application_protocol |
直接映射 |
direction |
network.direction |
已映射:OUTGOING → OUTBOUND |
suser.0 |
network.email.from |
直接映射 |
msgId |
network.email.mail_id |
直接映射 |
highlightMailMsgSubject |
network.email.subject |
已合并 |
mailMsgSubject |
network.email.subject |
已合并 |
tmpUser |
network.email.to |
已合并 |
requestMethod |
network.http.method |
直接映射 |
httpReferer |
network.http.referral_url |
直接映射 |
mailSmtpFromAddresses.0 |
network.smtp.mail_from |
直接映射 |
addr |
network.smtp.rcpt_to |
已合并 |
computerDomain |
principal.administrative_domain |
直接映射 |
deviceGUID |
principal.asset.asset_id |
直接映射 |
endpointGUID |
principal.asset.asset_id |
直接映射 |
mDeviceGUID |
principal.asset.asset_id |
直接映射 |
peerEndpointGUID |
principal.asset.asset_id |
直接映射 |
hardware |
principal.asset.hardware |
已合并 |
dvchost |
principal.asset.hostname |
直接映射 |
endpointHostName |
principal.asset.hostname |
直接映射 |
tmpIp |
principal.asset.ip |
已合并 |
deviceMacAddress |
principal.asset.mac |
已合并 |
endpointMacAddress |
principal.asset.mac |
已合并 |
domainName |
principal.asset.network_domain |
直接映射 |
vul |
principal.asset.vulnerabilities |
已合并 |
domainName |
principal.domain.name |
直接映射 |
hostName |
principal.domain.name |
直接映射 |
userDomain |
principal.domain.name |
直接映射 |
groupId |
principal.group.product_object_id |
直接映射 |
dvchost |
principal.hostname |
直接映射 |
endpointHostName |
principal.hostname |
直接映射 |
peerHost |
principal.hostname |
直接映射 |
peerIpAddr |
principal.ip |
已合并 |
srcIp |
principal.ip |
已合并 |
tmpIp |
principal.ip |
已合并 |
deviceMacAddress |
principal.mac |
已合并 |
endpointMacAddress |
principal.mac |
已合并 |
processCmd |
principal.process.command_line |
直接映射 |
processFilePath |
principal.process.file.full_path |
直接映射 |
processImagePath |
principal.process.file.full_path |
直接映射 |
processFileHashMd5 |
principal.process.file.md5 |
直接映射 |
processName |
principal.process.file.names |
已合并 |
processFileHashSha1 |
principal.process.file.sha1 |
直接映射 |
processFileHashSha256 |
principal.process.file.sha256 |
直接映射 |
parentCmd |
principal.process.parent_process.command_line |
直接映射 |
parentFilePath |
principal.process.parent_process.file.full_path |
直接映射 |
parentFileHashMd5 |
principal.process.parent_process.file.md5 |
直接映射 |
parentName |
principal.process.parent_process.file.names |
已合并 |
parentFileHashSha1 |
principal.process.parent_process.file.sha1 |
直接映射 |
parentFileHashSha256 |
principal.process.parent_process.file.sha256 |
直接映射 |
parentPid |
principal.process.parent_process.pid |
直接映射 |
processPid |
principal.process.pid |
直接映射 |
suser_label |
principal.resource.attribute.labels |
已合并 |
uuid_label |
principal.resource.attribute.labels |
已合并 |
userDepartment |
principal.user.department |
已合并 |
tmpUser1 |
principal.user.email_addresses |
已合并 |
logonUsers.0 |
principal.user.userid |
直接映射 |
objectUser |
principal.user.userid |
直接映射 |
principalName |
principal.user.userid |
直接映射 |
suid |
principal.user.userid |
直接映射 |
mailbox |
security_result.about.email |
直接映射 |
security_result_action |
security_result.action |
已合并 |
act.0 |
security_result.action_details |
直接映射 |
tactics |
security_result.attack_details.tactics |
已合并 |
techniques |
security_result.attack_details.techniques |
已合并 |
category |
security_result.category_details |
已合并 |
index |
security_result.category_details |
已合并 |
tag |
security_result.category_details |
已合并 |
actResult_label |
security_result.detection_fields |
已合并 |
cccaDetectionSource_label |
security_result.detection_fields |
已合并 |
cccaRiskLevel_label |
security_result.detection_fields |
已合并 |
field1 |
security_result.detection_fields |
已合并 |
key |
security_result.detection_fields |
已映射:`"engineOperation","engType","detectionAggressivenessLevel","patVer","channel","thre... |
mailbox_label |
security_result.detection_fields |
已合并 |
matchedFilter_id_label |
security_result.detection_fields |
已合并 |
matchedFilter_name_label |
security_result.detection_fields |
已合并 |
matchedRules_id_label |
security_result.detection_fields |
已合并 |
matchedRules_name_label |
security_result.detection_fields |
已合并 |
matchedRules_threatType_label |
security_result.detection_fields |
已合并 |
riskType_label |
security_result.detection_fields |
已合并 |
subRuleId_label |
security_result.detection_fields |
已合并 |
score |
security_result.risk_score |
已重命名/已映射 |
matchedRule.id |
security_result.rule_id |
直接映射 |
ruleId |
security_result.rule_id |
直接映射 |
matchedRule.name |
security_result.rule_name |
直接映射 |
ruleName |
security_result.rule_name |
直接映射 |
ruleType |
security_result.rule_type |
直接映射 |
ruleVer |
security_result.rule_version |
直接映射 |
filterRiskLevel |
security_result.severity_details |
直接映射 |
malName |
security_result.threat_name |
直接映射 |
matchedRule.threatType |
security_result.threat_name |
直接映射 |
mergethreatNames |
security_result.threat_name |
直接映射 |
threatName |
security_result.threat_name |
直接映射 |
source |
src |
已重命名/已映射 |
interestedHost |
target.asset.hostname |
直接映射 |
malDst |
target.asset.hostname |
直接映射 |
tmpIp |
target.asset.ip |
已合并 |
requestBase |
target.domain.name |
直接映射 |
objectFilePath |
target.file.full_path |
直接映射 |
objectFileHashMd5 |
target.file.md5 |
直接映射 |
objectFileName |
target.file.names |
已合并 |
objectFileHashSha1 |
target.file.sha1 |
直接映射 |
objectFileHashSha256 |
target.file.sha256 |
直接映射 |
dstGroup |
target.group.group_display_name |
直接映射 |
dhost |
target.hostname |
直接映射 |
interestedHost |
target.hostname |
直接映射 |
malDst |
target.hostname |
直接映射 |
dstIp |
target.ip |
已合并 |
objectIp |
target.ip |
已合并 |
tmpIp |
target.ip |
已合并 |
dmac |
target.mac |
已合并 |
dOSName |
target.platform_version |
直接映射 |
objectCmd |
target.process.command_line |
直接映射 |
objectTargetProcess |
target.process.file.full_path |
直接映射 |
objectPid |
target.process.pid |
直接映射 |
objectRegistryKeyHandle |
target.registry.registry_key |
直接映射 |
objectRegistryData |
target.registry.registry_value_data |
直接映射 |
objectRegistryValue |
target.registry.registry_value_name |
直接映射 |
tmpUser_label |
target.resource.attribute.labels |
已合并 |
request |
target.url |
直接映射 |
objectUser |
target.user.userid |
直接映射 |
samUser |
target.user.userid |
直接映射 |
| 不适用 | about.file.size |
常量:attachmentFileSize |
| 不适用 | metadata.event_type |
常量:GENERIC_EVENT |
| 不适用 | metadata.product_name |
常量:TREND VISION ONE DETECTIONS |
| 不适用 | metadata.vendor_name |
常量:TREND VISION ONE DETECTIONS |
| 不适用 | network.direction |
常量:OUTBOUND |
| 不适用 | network.http.response_code |
常量:respCode |
| 不适用 | principal.process.integrity_level_rid |
常量:integrityLevel |
| 不适用 | principal.process.parent_process.integrity_level_rid |
常量:parentIntegrityLevel |
| 不适用 | target.port |
常量:dpt |
更新日志
需要更多帮助?获得社区成员和 Google SecOps 专业人士的解答。