收集 uberAgent 日志
本文档介绍了如何使用 Bindplane 代理将 uberAgent 日志注入到 Google Security Operations。
uberAgent 是一款适用于 Windows 和 macOS 的端点安全分析和用户体验监控平台。它会收集遥测数据,包括受监控端点上的进程事件、登录事件、网络连接和应用使用情况。
准备工作
请确保满足以下前提条件:
- Google SecOps 实例
- Windows Server 2016 或更高版本,或者具有
systemd的 Linux 主机 - Bindplane 代理与 uberAgent 端点之间的网络连接
- 如果在代理后面运行,请确保防火墙端口已根据 Bindplane 代理要求打开
- 对 uberAgent 管理控制台或安装了 uberAgent 的端点的特权访问权限
获取 Google SecOps 注入身份验证文件
- 登录 Google SecOps 控制台。
- 依次前往 SIEM 设置 > 收集代理。
下载注入身份验证文件。将该文件安全地保存在将要安装 Bindplane 的系统上。
获取 Google SecOps 客户 ID
- 登录 Google SecOps 控制台。
- 依次前往 SIEM 设置 > 配置文件。
复制并保存组织详细信息部分中的客户 ID。
安装 Bindplane 代理
按照以下说明在 Windows 或 Linux 操作系统上安装 Bindplane 代理。
Windows 安装
- 以管理员身份打开命令提示符或 PowerShell。
运行以下命令:
msiexec /i "https://github.com/observIQ/bindplane-agent/releases/latest/download/observiq-otel-collector.msi" /quiet等待安装完成。
运行以下命令,验证安装是否成功:
sc query observiq-otel-collector该服务应显示为 正在运行。
Linux 安装
- 打开具有 root 或 sudo 权限的终端。
运行以下命令:
sudo sh -c "$(curl -fsSlL https://github.com/observiq/bindplane-agent/releases/latest/download/install_unix.sh)" install_unix.sh等待安装完成。
运行以下命令,验证安装是否成功:
sudo systemctl status observiq-otel-collector该服务应显示为有效(正在运行)。
其他安装资源
如需了解其他安装选项和问题排查信息,请参阅 Bindplane 代理安装指南。
配置 Bindplane 代理以注入日志并将其发送到 Google SecOps
找到配置文件
Linux:
sudo nano /etc/bindplane-agent/config.yamlWindows:
notepad "C:\Program Files\observIQ OpenTelemetry Collector\config.yaml"
修改配置文件
将
config.yaml的全部内容替换为以下配置:receivers: filelog: include: - 'C:\uberAgent\logs\*.log' - 'C:\uberAgent\logs\*.csv' start_at: beginning poll_interval: 5s exporters: chronicle/uberagent: compression: gzip creds_file_path: 'C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json' customer_id: '<customer_id>' endpoint: malachiteingestion-pa.googleapis.com log_type: UBERAGENT raw_log_field: body ingestion_labels: env: production service: pipelines: logs/uberagent_to_chronicle: receivers: - filelog exporters: - chronicle/uberagent
配置参数
替换以下占位符:
接收器配置:
include:uberAgent 日志文件的路径:- Windows(本地):
C:\uberAgent\logs\*.log和C:\uberAgent\logs\*.csv - Windows(文件共享):
\\SERVER\Share\uberagent-logs\*.log - 根据您的 uberAgent 文件输出配置调整路径
- Windows(本地):
start_at:设置为beginning可读取现有日志,设置为end可仅读取新条目poll_interval:检查新日志数据的频率(默认值:5s)
导出器配置:
uberagent:导出器的描述性名称creds_file_path:提取身份验证文件的完整路径:- Linux:
/etc/bindplane-agent/ingestion-auth.json - Windows:
C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json
- Linux:
<customer_id>:上一步中的客户 IDendpoint:区域端点网址:- 美国:
malachiteingestion-pa.googleapis.com - 欧洲:
europe-malachiteingestion-pa.googleapis.com - 亚洲:
asia-southeast1-malachiteingestion-pa.googleapis.com - 如需查看完整列表,请参阅区域级端点
- 美国:
UBERAGENT:日志类型,与在 Chronicle 中显示的完全一致ingestion_labels:YAML 格式的可选标签(例如env: production)
流水线配置:
uberagent_to_chronicle:流水线的描述性名称
保存配置文件
- 修改后,保存文件:
- Linux:依次按
Ctrl+O、Enter和Ctrl+X - Windows:依次点击文件 > 保存
- Linux:依次按
重启 Bindplane 代理以应用更改
如需在 Linux 中重启 Bindplane 代理,请运行以下命令:
sudo systemctl restart observiq-otel-collector验证服务是否正在运行:
sudo systemctl status observiq-otel-collector检查日志是否存在错误:
sudo journalctl -u observiq-otel-collector -f
如需在 Windows 中重启 Bindplane 代理,请选择以下选项之一:
以管理员身份运行命令提示符或 PowerShell:
net stop observiq-otel-collector && net start observiq-otel-collector服务控制台:
- 按
Win+R,输入services.msc,然后按 Enter 键。 - 找到 observIQ OpenTelemetry 收集器。
- 右键点击并选择重新启动。
验证服务是否正在运行:
sc query observiq-otel-collector检查日志是否存在错误:
type "C:\Program Files\observIQ OpenTelemetry Collector\log\collector.log"
- 按
配置 uberAgent 文件输出
uberAgent 支持多个输出后端。如需将数据导出为文件以供 Bindplane 代理收集,请执行以下操作:
- 在端点上或通过组策略打开 uberAgent 配置文件 (
uberAgent.conf)。 配置基于文件的输出接收器:
[Receiver] Name = FileOutput Type = File Path = C:\uberAgent\logs\配置要导出的指标和来源类型:
- 进程:进程启动/停止事件、资源使用情况。
- 登录:用户登录/注销事件。
- 网络:网络连接事件。
- 应用:应用使用情况和错误。
保存配置并重启 uberAgent 服务。
验证日志文件是否正在配置的输出目录中创建。
确保 Bindplane 代理对日志目录和文件具有读取权限。
UDM 映射表
| 日志字段 | UDM 映射 | 逻辑 |
|---|---|---|
| SessionRpLatencyMs2、SessionHRes、SessionVRes、SessionColorDepth、SessionClientPlatform、SessionClientVersion、SessionClientOsLanguage、SessionPublishedName、SessionPublishedAppsCtx、SessionAppStateCtx、SessionEncryptionCtx、SessionClientTypeCtx、SessionBrokerDnsVmw、SessionBrokerUrlVmw、SessionBrokerTunneledVmw、SessionBrokerTunnelUrlVmw、SessionBrokerRemoteIpVmw、SessionBrokerUserVmw、SessionBrokerDomainVmw、SessionClientTimezoneVmw、SessionClientIdVmw、SessionTypeVmw、SessionBrokerType、SessionFgAppId、SessionFgAppVersion、SessionFgProcessName、SessionFgProcessId、SessionFgBrowserType、SessionFgBrowserActiveTabHost、SessionFgWindowTitle、SessionClientHwIdCtx2、SessionRoundTripTimeMs、SessionFps、SessionTransportProtocols、SessionProcessCount、SessionIOMB、SessionCPUTimeMs、SessionConnectionState、SessionUser、SessionIOCount、SessionNetKBPS、SessionWorkingSetMB、SessionCPUUsagePercent、SessionIOPS、SessionClientName、SessionIOLatencyMs、PowerSupportsS3、IsBatteryPresent、PowerSupportsS1、PowerSupportsS2、PowerSupportsS5、CPUMaxMhz、BaseboardSerial、CtxMachineCatalogName、AdDomainDns、HwHypervisorVendor、OsBuild、HwBiosVersion、PowerSupportsS4、HwIsVirtualMachine、IsUpsPresent、PowerSupportsConnectedStandby、OsInstallDate、Sourcetype、uberagent_index_name、data_stream.namespace、data_stream.dataset、data_stream.type、data_stream.subset、CPUCoresLogical、AdOu、AdDomainNetBios、logstash_pipeline、AdSite、CtxFarmName、CPUSockets、OsSpName、OsName、OsType、OsUpdateBuildRevision、ComputerNameCanonical、ComputerNameDn、CtxDeliveryGroupName、tags、user_agent.original | additional.fields | 从列出的字段合并为键值对 |
| metadata.event_type | 如果 has_principal 为 true 且 has_target 为 false,则设置为 STATUS_UPDATE;如果两者均为 true,则设置为 NETWORK_CONNECTION;否则设置为 GENERIC_EVENT | |
| SessionGUID | metadata.product_log_id | 直接复制值 |
| user_agent.original | network.http.parsed_user_agent | 已转换为已解析的用户代理 |
| user_agent.original | network.http.user_agent | 直接复制值 |
| SessionTransportProtocols | network.ip_protocol | 如果匹配 (?i)udp,则设置为 UDP;如果匹配 (?i)tcp,则设置为 TCP |
| SessionID | network.session_id | 直接复制值 |
| SessionClientUserDomain | principal.administrative_domain | 直接复制值 |
| CPUCoresPhysical、RAMSizeGB、CPUName、HwManufacturer、OsArchitecture、BIOSSerial、HwModel | principal.asset.hardware | 已合并到硬件对象中 |
| SessionClientDomain、host | principal.asset.hostname | 如果 SessionClientDomain 不为空,则使用 SessionClientDomain 中的值,否则使用 host |
| prin_ip、SessionClientIp、system_ip | principal.asset.ip | 如果 prin_ip 不为空,则为 prin_ip 中的值;否则为 SessionClientIp;否则为 system_ip |
| SessionClientDomain、host | principal.hostname | 如果 SessionClientDomain 不为空,则使用 SessionClientDomain 中的值,否则使用 host |
| prin_ip、SessionClientIp、system_ip | principal.ip | 如果 prin_ip 不为空,则为 prin_ip 中的值;否则为 SessionClientIp;否则为 system_ip |
| SessionClientMac | principal.mac | SessionClientMac 中的值,其中 - 替换为 :,并转换为小写 |
| SessionClientPlatform | principal.platform | 如果匹配 (?i)windows,则设置为 WINDOWS |
| SessionClientVersion | principal.platform_version | 如果匹配 (?i)windows,则设置为值 |
| SessionUser、SessionClientUser | principal.user.user_display_name | 如果 SessionUser 中的值不为空,则使用该值,否则使用 SessionClientUser 中的值 |
| SessionBrokerRemoteIpVmw | target.ip | 直接复制值 |
| SessionBrokerUserVmw | target.user.user_display_name | 直接复制值 |
| SessionClientIdVmw | target.user.userid | 直接复制值 |
| metadata.product_name | 设置为“UBERAGENT” | |
| metadata.vendor_name | 设置为“UBERAGENT” |
更新日志
需要更多帮助?获得社区成员和 Google SecOps 专业人士的解答。