收集 Ubika WAF 記錄

支援的服務:

本文說明如何使用 Bindplane 代理程式,將 Ubika WAF 記錄檔擷取至 Google Security Operations。

Ubika WAF (原名 DenyAll) 是網頁應用程式防火牆,可為地端部署網頁應用程式和服務提供 HTTP 流量檢查、機器人防護和 API 安全性。

事前準備

請確認您符合下列必要條件:

  • Google SecOps 執行個體
  • Windows Server 2016 以上版本,或搭載 systemd 的 Linux 主機
  • Bindplane 代理程式與 Ubika WAF 設備之間的網路連線
  • 如果透過 Proxy 執行,請確保防火牆通訊埠已根據 Bindplane 代理程式需求開啟
  • 具備 Ubika WAF 管理控制台的特殊存取權,以及管理員權限

取得 Bindplane 代理程式的 Google SecOps 憑證

如要向 Google SecOps 驗證 Bindplane 代理程式,請選擇下列其中一種方法:

  • 新部署作業:使用 Chronicle API (選項 1)。
  • 舊版部署作業:在 2027 年 7 月 20 日停用 Ingestion API 前,請繼續使用擷取驗證檔案 (選項 2)。
  1. 登入 Google Cloud 控制台,選取連結至 Google SecOps 執行個體的 Google Cloud 專案。
  2. 依序前往「IAM & Admin」(IAM 與管理) >「Service Accounts」(服務帳戶)。
  3. 按一下「建立服務帳戶」。
  4. 請提供下列設定詳細資料:
    • 服務帳戶名稱:輸入帳戶名稱 (例如 bindplane-ingest)。
    • 「服務帳戶說明」:輸入說明 (例如 Bindplane agent log ingestion)。
  5. 點按「Create and continue」(建立並繼續)。
  6. 在「將專案存取權授予這個服務帳戶」部分,按一下「選取角色」,然後選取「Chronicle 編輯者」。
  7. 依序點選「繼續」和「完成」。
  8. 按一下您建立的服務帳戶,然後前往「金鑰」分頁。
  9. 依序點選「新增金鑰」>「建立新的金鑰」。
  10. 選取「JSON」,然後點選「建立」。金鑰檔案會下載到電腦。
  11. 將金鑰檔案儲存為 Bindplane 收集器目錄中的 ingestion-auth.json (Linux 上的 /opt/observiq-otel-collector/ingestion-auth.json 或 Windows 上的 C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json),或更新 config.yaml 中的 creds_file_path,使其與儲存路徑相符。
  12. 依序前往「IAM 與管理」>「設定」,然後複製「專案編號」。設定匯出工具時會用到。

方法 2:下載擷取驗證檔案 (舊版)

  1. 登入 Google SecOps 控制台。
  2. 依序前往「SIEM 設定」>「收集代理程式」。
  3. 下載擷取驗證檔案。
  4. 將檔案安全地儲存在要安裝 Bindplane 代理程式的系統中。

取得 Google SecOps 客戶 ID

  1. 登入 Google SecOps 控制台。
  2. 依序前往「SIEM 設定」 > 「設定檔」。
  3. 複製並儲存「機構詳細資料」專區中的「客戶 ID」。

安裝 Bindplane 代理程式

請按照下列操作說明,在 Windows 或 Linux 作業系統上安裝 Bindplane 代理程式。

Windows 安裝

  1. 以管理員身分開啟命令提示字元或 PowerShell。
  2. 執行下列指令:

    msiexec /i "https://github.com/observIQ/bindplane-agent/releases/latest/download/observiq-otel-collector.msi" /quiet
    
  3. 等待安裝完成。

  4. 執行下列指令,確認安裝成功:

    sc query observiq-otel-collector
    

    服務應顯示為「RUNNING」。

安裝 Linux

  1. 開啟具有 root 或 sudo 權限的終端機。
  2. 執行下列指令:

    sudo sh -c "$(curl -fsSlL https://github.com/observiq/bindplane-agent/releases/latest/download/install_unix.sh)" install_unix.sh
    
  3. 等待安裝完成。

  4. 執行下列指令,確認安裝成功:

    sudo systemctl status observiq-otel-collector
    

    服務應顯示為「active (running)」。

其他安裝資源

如需其他安裝選項和疑難排解資訊,請參閱 Bindplane 代理程式安裝指南。

設定 Bindplane 代理程式,擷取系統記錄檔並傳送至 Google SecOps

找出設定檔

  • Linux:

    sudo nano /opt/observiq-otel-collector/config.yaml
    
  • Windows:

    notepad "C:\Program Files\observIQ OpenTelemetry Collector\config.yaml"
    

編輯設定檔

  • 將 config.yaml 的全部內容替換為下列設定:

    receivers:
      tcplog:
        listen_address: "0.0.0.0:514"
    
    exporters:
      chronicle/ubika_waf:
        protocol: https
        # Region of your instance, for example us, europe, asia-southeast1
        location: <LOCATION>
        # Project number of the Google Cloud project linked to the instance
        project: '<PROJECT_NUMBER>'
        compression: gzip
        creds_file_path: '/opt/observiq-otel-collector/ingestion-auth.json'
        customer_id: '<customer_id>'
        endpoint: chronicle.googleapis.com
        log_type: UBIKA_WAF
        raw_log_field: body
    
    service:
      pipelines:
        logs/ubika_waf_to_chronicle:
          receivers:
            - tcplog
          exporters:
            - chronicle/ubika_waf
    

設定參數

請替換下列預留位置:

  • 接收器設定:

    • listen_address:要監聽的 IP 位址和通訊埠:
      • 0.0.0.0:在所有介面上監聽 (建議)
      • 通訊埠 514 是標準 syslog 通訊埠 (在 Linux 上需要根目錄;非根目錄請使用 1514)
  • Exporter 設定:

    • creds_file_path:服務帳戶 JSON 金鑰檔案的完整路徑 (選項 1):
      • Linux:/opt/observiq-otel-collector/ingestion-auth.json
      • Windows:C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json
    • customer_id:從 Google SecOps 控制台複製的客戶 ID
    • location:將 <LOCATION> 替換為 Google SecOps 執行個體的區域 (例如 us、europe 或 asia-southeast1)。匯出工具會在這個值前面加上 chronicle.googleapis.com。如需完整清單,請參閱「區域性端點」。
    • project:將 <PROJECT_NUMBER> 替換為「IAM 與管理」>「設定」中的專案編號。
    • endpoint:維持設為 chronicle.googleapis.com。

舊版 Ingestion API 匯出工具

  • 如果您使用選項 2 的擷取驗證檔案,請將 exporters 區塊替換為下列內容。將 creds_file_path 設為擷取驗證檔案的路徑。如果執行個體位於美國境外,請將 malachiteingestion-pa.googleapis.com 替換為區域端點 (例如 europe-malachiteingestion-pa.googleapis.com)。

    exporters:
      chronicle/ubika_waf:
        compression: gzip
        creds_file_path: '/opt/observiq-otel-collector/ingestion-auth.json'
        customer_id: '<customer_id>'
        endpoint: malachiteingestion-pa.googleapis.com
        log_type: UBIKA_WAF
        raw_log_field: body
    

儲存設定檔

  • 編輯完成後,請儲存檔案:
    • Linux:依序按下 Ctrl+O、Enter 和 Ctrl+X
    • Windows:依序點選「檔案」>「儲存」

重新啟動 Bindplane 代理程式,套用變更

  • 如要在 Linux 重新啟動 Bindplane 代理程式,請執行下列指令:

    sudo systemctl restart observiq-otel-collector
    
    1. 確認服務是否正在執行:

      sudo systemctl status observiq-otel-collector
      
    2. 查看記錄檔是否有錯誤:

      sudo journalctl -u observiq-otel-collector -f
      
  • 如要在 Windows 中重新啟動 Bindplane 代理程式,請選擇下列任一選項:

    • 以管理員身分開啟命令提示字元或 PowerShell:

      net stop observiq-otel-collector && net start observiq-otel-collector
      
    • 服務控制台:

      1. 按下 Win+R,輸入 services.msc,然後按下 Enter 鍵。
      2. 找出「observIQ OpenTelemetry Collector」。
      3. 按一下滑鼠右鍵,然後選取「重新啟動」。
      4. 確認服務是否正在執行:

        sc query observiq-otel-collector
        
      5. 查看記錄檔是否有錯誤:

        type "C:\Program Files\observIQ OpenTelemetry Collector\log\collector.log"
        

設定 Ubika WAF syslog 轉送

  1. 登入 Ubika WAF 管理控制台。
  2. 依序前往「Management」>「Logs」>「Syslog Configuration」。
  3. 按一下「新增」,建立新的系統記錄目的地。
  4. 提供下列設定詳細資料:
    • Syslog 伺服器:輸入 Bindplane 代理程式主機的 IP 位址。
    • 「Port」(通訊埠):輸入 514。
    • 通訊協定:選取「TCP」。
    • 格式:選取預設的系統記錄格式。
  5. 選取要轉送的記錄類型:
    • 安全性警示記錄
    • 存取記錄檔
    • 稽核記錄
    • 系統事件記錄
  6. 按一下「儲存」,套用設定。
  7. 檢查 Bindplane 代理程式記錄,確認系統是否正在傳送記錄。

UDM 對應表

記錄欄位 UDM 對應 邏輯
sqliFingerprint_label、eaNewRulesWarningMode_label、eaTotalScore_label、matching_part_key_label、matching_part_key_match_label、partKeyOperator_label、partKeyPattern_label、partValue_label、partValueMatch_label、partValueOperator_label、partValuePatternName_label、partValuePatternUid_label、partValuePatternVersion_label、scoringlistRuleId_label、scoringlistRuleWeight_label、ConfigurationUid_list、Matched_Rule_ID_list additional.fields 已與 eventt.tokens.sqliFingerprint、eventt.tokens.eaNewRulesWarningMode、eventt.tokens.eaTotalScore、matchingPart.partKey、matchingPart.partKeyMatch、matchingPart.partKeyOperator、matchingPart.partKeyPattern、matchingPart.partValue、matchingPart.partValueMatch、matchingPart.partValueOperator、matchingPart.partValuePatternName、matchingPart.partValuePatternUid、matchingPart.partValuePatternVersion、matchingPart.scoringlistRuleId、matchingPart.scoringlistRuleWeight、eventt.tokens.securityExceptionConfigurationUids、eventt.tokens.securityExceptionMatchedRuleUids 中的標籤合併
context.applianceName intermediary.application 直接從 context.applianceName 複製的值
inter_ip intermediary.asset.ip 從 inter_ip 合併 (如果 IP 衍生自 context.backendHost)
context.backendHost intermediary.hostname 如果不是 IP,則從 context.backendHost 設定
inter_ip intermediary.ip 從 inter_ip 設定 (如果 IP 衍生自 context.backendHost)
context.applianceUid intermediary.file.sha1 直接從 context.applianceUid 複製的值
has_principal、has_target、has_network、has_principal_user、has_target_resource metadata.event_type 如果 has_principal、has_target、has_network,則設為「NETWORK_HTTP」;如果 has_principal、has_principal_user,則設為「USER_COMMUNICATION」;如果 has_principal,則設為「STATUS_UPDATE」;如果 has_target_resource,則設為「USER_RESOURCE_ACCESS」;否則設為「GENERIC_EVENT」
tokens.eventType、type、eventt.tokens.eventType、eventData.tokens.eventType metadata.product_event_type tokens.eventType 的值 (如有設定),否則為 type,否則為 eventt.tokens.eventType,否則為 eventData.tokens.eventType
eventUid, logAlertUid, eventt.eventUid, tempData.uid, eventData.eventUid metadata.product_log_id 如果已設定,則為 eventUid 的值;否則為 logAlertUid、eventt.eventUid、tempData.uid 或 eventData.eventUid
metadata.product_name 設為「UBIKA_WAF」
metadata.vendor_name 設為「UBIKA_WAF」
uri_protocol, request.protocol network.application_protocol 如果 uri_protocol == "HTTP" 或 request.protocol == "HTTP",則設為「HTTP」
uri_method、request.method network.http.method 如果已設定 uri_method,則為該值,否則為 request.method
uri_path、request.path、header.value network.http.referral_url 如果已設定 uri_path,則為該值;否則為 request.path;否則為 Referer 的 header.value
uri_res_code network.http.response_code 從 uri_res_code 轉換為整數
user_agent, header.value network.http.user_agent 如果已設定,則為 user_agent 的值;否則為 User-Agent 的 header.value
target_hostname、header.value、request.hostname、tempData.request.hostname principal.asset.hostname 如果已設定,則為 target_hostname 的值;否則,如果為 Host 且不是 IP,則為 header.value;如果不是 IP,則為 request.hostname;否則為 tempData.request.hostname
src_ip、request.ipSrc、source_ip principal.asset.ip 從 src_ip、request.ipSrc、source_ip 合併 (如果 Host 和 IP 則從 header.value)
target_hostname、header.value、request.hostname、tempData.request.hostname principal.hostname 如果已設定 target_hostname,則為 target_hostname 的值,否則如果 Host 不是 IP,則為 header.value,否則如果不是 IP,則為 request.hostname,否則為 tempData.request.hostname
src_ip、request.ipSrc、source_ip principal.ip 從 src_ip、request.ipSrc、source_ip 合併 (如果 Host 和 IP,則從 header.value)
src_port、header.value principal.port 如果已設定 src_port,則為 src_port 的值,否則為 header.value (如果是 X-Forwarded-Port),轉換為整數
request.requestUid, tempData.request.requestUid principal.user.userid 如果已設定 request.requestUid,則為該值,否則為 tempData.request.requestUid
cookie_label、header_label、reverseProxyName_label、reverseProxyUid_label、tunnelName_label、tunnelUid_label、workflowName_label、workflowUid_label security_result.about.resource.attribute.labels 與 request.cookies、request.headers、context.reverseProxyName、context.reverseProxyUid、context.tunnelName、context.tunnelUid、context.workflowName、context.workflowUid 中的標籤合併
vlan_label、riskLevel_label、riskLevelOWASP_label、logAlertUid_label、engine_name_label、resolveType_label、part_label、cwe_label、icxPolicyName_label、icxPolicyUid_label、icxRuleName_label、icxRuleUid_label、eaPolicyName_label、eaPolicyUid_label、eaRuleId_label、eaStaticPolicyUid_label、tag_label、geoipCode_label、geoipName_label、appliance_id_label、backendHost_label、reverseProxyName_label、reverseProxyUid_label、tunnelName_label、tunnelUid_label、workflowName_label、workflowUid_label、reason_label、timestampImport_label、matching_cwe_label、matching_part_label、match_riskLevel_label、match_riskLevelOWASP_label、partValue_label、partValueMatch_label security_result.detection_fields 與來自 vlan、tokens.riskLevel、tokens.riskLevelOWASP、logAlertUid、eventt.tokens.engineName、eventt.tokens.resolveType、eventt.tokens.part、eventt.tokens.cwe、eventt.tokens.icxPolicyName、eventt.tokens.icxPolicyUid、eventt.tokens.icxRuleName、eventt.tokens.icxRuleUid、eventt.tokens.eaPolicyName、eventt.tokens.eaPolicyUid、eventt.tokens.eaRuleId、eventt.tokens.eaStaticPolicyUid、tempData.context.tags、tempData.context.geoipCode、tempData.context.geoipName、tempData.context.applianceUid、tempData.context.backendHost、tempData.context.reverseProxyName、tempData.context.reverseProxyUid、tempData.context.tunnelName、tempData.context.tunnelUid、tempData.context.workflowName、tempData.context.workflowUid、eventt.tokens.reason、tempData.timestampImport、matchingPart.cwe、matchingPart.part、matchingPart.riskLevel、matchingPart.riskLevelOWASP、matchingPart.partValue、matchingPart.partValueMatch 的標籤合併
desc、tokens.customMessage、eventt.tokens.customMessage、eventData.tokens.customMessage security_result.description 如果已設定,則為 desc 的值,否則為 tokens.customMessage,否則為 eventt.tokens.customMessage,否則為 eventData.tokens.customMessage
tokens.severity、eventt.tokens.severity、severity_level security_result.severity 如果嚴重性為 1-3,則設為 INFORMATIONAL;如果嚴重性為 4-5,則設為 CRITICAL;如果嚴重性為 6-7,則設為 MEDIUM;否則設為 UNKNOWN_SEVERITY
tokens.reason、eventt.tokens.reason、eventData.tokens.reason security_result.summary 如果已設定,則為 tokens.reason 中的值;否則為 eventt.tokens.reason,否則為 eventData.tokens.reason
tokens.attackFamily, eventt.tokens.attackFamily, eventData.tokens.attackFamily security_result.threat_name 如果已設定,則為 tokens.attackFamily 的值;否則為 eventt.tokens.attackFamily;否則為 eventData.tokens.attackFamily
source_ip src.ip 從 source_ip 設定 (如果主機和 IP 來自 header.value)
target_hostname target.asset.hostname 直接從 target_hostname 複製的值
request.ipDst, target_ip_label target.asset.ip 合併自 request.ipDst、target_ip_label
tempData.request.path target.file.full_path 直接從 tempData.request.path 複製的值
target_hostname, header.value target.hostname 如果已設定 target_hostname,則為該屬性的值,否則為主機的 header.value
request.ipDst、target_ip_label target.ip 合併自 request.ipDst、target_ip_label
target_port、request.portDst、context.backendPort、tempData.request.portDst、tempData.context.backendPort target.port target_port 的值 (如有設定),否則為 request.portDst,否則為 context.backendPort,否則為 tempData.request.portDst,否則為 tempData.context.backendPort,轉換為整數
engineUid_label, engine_name_label, cwe_label, resolveType_label, part_label, matching_cwe_label, matching_part_label, match_riskLevel_label, match_riskLevelOWASP_label, matching_part_key_label, matching_part_key_match_label, partKeyOperator_label, partKeyPattern_label, partValue_label, partValueMatch_label, partValueOperator_label, partValuePatternName_label, partValuePatternUid_label, partValuePatternVersion_label, scoringlistRuleId_label, scoringlistRuleWeight_label target.resource.attribute.labels 已與下列項目的標籤合併:tokens.engineUid、tokens.engineName、tokens.cwe、tokens.resolveType、tokens.part、eventData.tokens.engineUid、eventData.tokens.engineName、eventData.tokens.cwe、eventData.tokens.resolveType、eventData.tokens.part、matchingPart.cwe、matchingPart.part、matchingPart.riskLevel、matchingPart.riskLevelOWASP、matchingPart.partKey、matchingPart.partKeyMatch、matchingPart.partKeyOperator、matchingPart.partKeyPattern、matchingPart.partValue、matchingPart.partValueMatch、matchingPart.partValueOperator、matchingPart.partValuePatternName、matchingPart.partValuePatternUid、matchingPart.partValuePatternVersion、matchingPart.scoringlistRuleId、matchingPart.scoringlistRuleWeight
target_path target.url 直接從 target_path 複製的值
headers.value event.idm.read_only_udm.security_result.about.resource.attribute.labels 從變更記錄對應
key event.idm.read_only_udm.security_result.about.resource.attribute.labels 從變更記錄對應
X-Forwarded-Host event.idm.read_only_udm.security_result.about.resource.attribute.labels 從變更記錄對應
tokens.ipReputationIp event.idm.read_only_udm.principal.ip 從變更記錄對應
tokens.ipReputationIp event.idm.read_only_udm.principal.asset.ip 從變更記錄對應
tokens.matchingParts event.idm.read_only_udm.additional.fields 從變更記錄對應
request.body event.idm.read_only_udm.additional.fields 從變更記錄對應
unique_id1 event.idm.read_only_udm.additional.fields 從變更記錄對應
thread_id event.idm.read_only_udm.additional.fields 從變更記錄對應
tokens.ipReputationScore event.idm.read_only_udm.additional.fields 從變更記錄對應
tokens.eaTotalScore event.idm.read_only_udm.additional.fields 從變更記錄對應
tokens.eaPolicyUid event.idm.read_only_udm.additional.fields 從變更記錄對應
tokens.eaPolicyName event.idm.read_only_udm.additional.fields 從變更記錄對應
tokens.eaStaticPolicyUid event.idm.read_only_udm.additional.fields 從變更記錄對應
tokens.eaRuleId event.idm.read_only_udm.additional.fields 從變更記錄對應
tokens.eaNewRulesWarningMode event.idm.read_only_udm.additional.fields 從變更記錄對應
internal_timestamp event.idm.read_only_udm.additional.fields 從變更記錄對應
tokens.securityExceptionConfigurationUid event.idm.read_only_udm.additional.fields 從變更記錄對應
tokens.icxPolicyName event.idm.read_only_udm.security_result.detection_fields 從變更記錄對應
tokens.icxPolicyUid event.idm.read_only_udm.security_result.detection_fields 從變更記錄對應
tokens.icxRuleName event.idm.read_only_udm.security_result.detection_fields 從變更記錄對應
tokens.icxRuleUid event.idm.read_only_udm.security_result.detection_fields 從變更記錄對應
tokens.ipReputationThreats event.idm.read_only_udm.security_result.detection_fields 從變更記錄對應
message_component event.idm.read_only_udm.target.resource.attribute.labels 從變更記錄對應

變更記錄

查看這個剖析器的變更記錄

還有其他問題嗎?向社群成員和 Google SecOps 專家尋求解答。