收集 Vectra Alerts 記錄
本文說明如何使用 Vectra SIEM 連接器和 Bindplane,將 Vectra 快訊記錄檔擷取至 Google Security Operations。
Vectra AI 是網路偵測與應變平台,可針對雲端、資料中心和物聯網環境中的威脅偵測,產生安全性警示。這個平台會運用 AI 輔助的行為分析,即時找出隱藏的網路攻擊。
事前準備
請確認您符合下列必要條件:
- Google SecOps 執行個體
- Windows Server 2016 以上版本,或搭載
systemd的 Linux 主機 - Bindplane 代理程式與 Vectra AI 平台之間的網路連線
- 如果是在 Proxy 後方執行,請確認防火牆通訊埠已按照 Bindplane 代理程式規定開啟
- 具備 Vectra AI 平台特殊存取權的管理員權限
取得 Bindplane 代理程式的 Google SecOps 憑證
如要向 Google SecOps 驗證 Bindplane 代理程式,請選擇下列其中一種方法:
- 新部署作業:使用 Chronicle API (選項 1)。
- 舊版部署作業:在 2027 年 7 月 20 日停用 Ingestion API 前,請繼續使用擷取驗證檔案 (選項 2)。
方法 1:為 Chronicle API 建立服務帳戶 (建議)
- 登入 Google Cloud 控制台,選取連結至 Google SecOps 執行個體的 Google Cloud 專案。
- 依序前往 「IAM & Admin」(IAM 與管理) >「Service Accounts」(服務帳戶)。
- 按一下「建立服務帳戶」。
- 提供下列設定詳細資料:
- 「Service account name」(服務帳戶名稱):輸入帳戶名稱 (例如
bindplane-ingest)。 - 服務帳戶說明:輸入說明 (例如
Bindplane agent log ingestion)。
- 「Service account name」(服務帳戶名稱):輸入帳戶名稱 (例如
- 點按「Create and continue」(建立並繼續)。
- 在「將專案存取權授予這個服務帳戶」部分,按一下「選取角色」,然後選取「Chronicle 編輯者」。
- 依序點選「繼續」和「完成」。
- 按一下您建立的服務帳戶,然後前往「金鑰」分頁標籤。
- 依序點選「新增金鑰」>「建立新的金鑰」。
- 選取「JSON」,然後按一下「建立」。金鑰檔案會下載到電腦。
- 將金鑰檔案儲存為 Bindplane 收集器目錄中的
ingestion-auth.json(Linux 為/opt/observiq-otel-collector/ingestion-auth.json,Windows 為C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json),或更新config.yaml中的creds_file_path,使其與儲存檔案的路徑相符。 - 依序前往「IAM 與管理」>「設定」,然後複製「專案編號」。匯出工具設定時會用到。
方法 2:下載擷取驗證檔案 (舊版)
- 登入 Google SecOps 控制台。
- 依序前往「SIEM 設定」>「收集代理程式」。
- 下載擷取驗證檔案。
- 將檔案安全地儲存在要安裝 Bindplane 代理程式的系統上。
取得 Google SecOps 客戶 ID
- 登入 Google SecOps 控制台。
- 依序前往「SIEM 設定」 > 「設定檔」。
複製並儲存「機構詳細資料」專區中的「客戶 ID」。
安裝 Bindplane 代理程式
請按照下列操作說明,在 Windows 或 Linux 作業系統上安裝 Bindplane 代理程式。
Windows 安裝
- 以管理員身分開啟命令提示字元或 PowerShell。
執行下列指令:
msiexec /i "https://github.com/observIQ/bindplane-agent/releases/latest/download/observiq-otel-collector.msi" /quiet等待安裝完成。
執行下列指令,確認安裝成功:
sc query observiq-otel-collector
服務應顯示為「RUNNING」。
安裝 Linux
- 開啟具有 root 或 sudo 權限的終端機。
執行下列指令:
sudo sh -c "$(curl -fsSlL https://github.com/observiq/bindplane-agent/releases/latest/download/install_unix.sh)" install_unix.sh等待安裝完成。
執行下列指令,確認安裝成功:
sudo systemctl status observiq-otel-collector
服務應顯示為「active (running)」。
其他安裝資源
如需其他安裝選項和疑難排解資訊,請參閱 Bindplane 代理程式安裝指南。
設定 Bindplane 代理程式,擷取系統記錄並傳送至 Google SecOps
找出設定檔
Linux:
sudo nano /opt/observiq-otel-collector/config.yamlWindows:
notepad "C:\Program Files\observIQ OpenTelemetry Collector\config.yaml"
編輯設定檔
將
config.yaml的全部內容替換為下列設定:receivers: udplog: listen_address: "0.0.0.0:514" exporters: chronicle/vectra_alerts: protocol: https # Region of your instance, for example us, europe, asia-southeast1 location: <LOCATION> # Project number of the Google Cloud project linked to the instance project: '<PROJECT_NUMBER>' compression: gzip creds_file_path: '/opt/observiq-otel-collector/ingestion-auth.json' customer_id: '<customer_id>' endpoint: chronicle.googleapis.com log_type: VECTRA_ALERTS raw_log_field: body service: pipelines: logs/vectra_alerts_to_chronicle: receivers: - udplog exporters: - chronicle/vectra_alerts
設定參數
請替換下列預留位置:
接收器設定:
listen_address:要接聽的 IP 位址和通訊埠:0.0.0.0:在所有介面上監聽 (建議)- 通訊埠
514是標準 syslog 通訊埠 (在 Linux 上需要根目錄;非根目錄請使用1514)
Exporter 設定:
creds_file_path:服務帳戶 JSON 金鑰檔案的完整路徑 (選項 1):- Linux:
/opt/observiq-otel-collector/ingestion-auth.json - Windows:
C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json
- Linux:
customer_id:從 Google SecOps 控制台複製的客戶 IDlocation:將<LOCATION>替換為 Google SecOps 執行個體的區域 (例如us、europe或asia-southeast1)。匯出工具會以這個值做為chronicle.googleapis.com的前置字元。如需完整清單,請參閱「區域性端點」。project:將<PROJECT_NUMBER>替換為「IAM 與管理」>「設定」中的專案編號。endpoint:請將此值設為chronicle.googleapis.com。
舊版 Ingestion API 匯出工具
如果您使用方式 2 的擷取驗證檔案,請將
exporters區塊替換成下列內容。將creds_file_path設為擷取驗證檔案的路徑。如果執行個體位於美國境外,請將malachiteingestion-pa.googleapis.com替換為區域端點 (例如europe-malachiteingestion-pa.googleapis.com)。exporters: chronicle/vectra_alerts: compression: gzip creds_file_path: '/opt/observiq-otel-collector/ingestion-auth.json' customer_id: '<customer_id>' endpoint: malachiteingestion-pa.googleapis.com log_type: VECTRA_ALERTS raw_log_field: body
儲存設定檔
- 編輯完畢後,請儲存檔案:
- Linux:依序按下
Ctrl+O、Enter和Ctrl+X - Windows:依序點選「檔案」>「儲存」
- Linux:依序按下
重新啟動 Bindplane 代理程式,套用變更
如要在 Linux 重新啟動 Bindplane 代理程式,請按照下列步驟操作:
執行下列指令:
sudo systemctl restart observiq-otel-collector確認服務是否正在執行:
sudo systemctl status observiq-otel-collector查看記錄檔是否有錯誤:
sudo journalctl -u observiq-otel-collector -f
如要在 Windows 重新啟動 Bindplane 代理程式,請按照下列步驟操作:
您可以選擇下列其中一個選項:
以管理員身分開啟命令提示字元或 PowerShell:
net stop observiq-otel-collector && net start observiq-otel-collector服務控制台:
- 按下
Win+R,輸入services.msc,然後按下 Enter 鍵。 - 找出「observIQ OpenTelemetry Collector」。
- 按一下滑鼠右鍵,然後選取「重新啟動」。
- 按下
確認服務是否正在執行:
sc query observiq-otel-collector查看記錄檔是否有錯誤:
type "C:\Program Files\observIQ OpenTelemetry Collector\log\collector.log"
設定轉送 Vectra 警報的系統記錄檔
部署 Vectra SIEM 連接器,將快訊資料轉送至 Bindplane 代理程式。
- 部署 Vectra SIEM 連接器 (可做為 Docker 容器或獨立應用程式)。
- 使用 Vectra AI 平台網址 (例如
https://your-tenant.vectra.ai) 和 API 憑證設定連接器。 - 使用下列參數,將輸出目的地設為 syslog:
- Syslog 伺服器:輸入 Bindplane 代理程式主機的 IP 位址。
- Port:輸入
514(或 Bindplane 代理程式中設定的通訊埠)。 - 「通訊協定」:選取「UDP」 (與 Bindplane 接收器設定相符)。
- 選取要轉送的事件類別:
- 偵測項目
- 稽核
- 健康狀態事件
啟動連接器,並查看 Bindplane 代理程式記錄,確認系統是否轉送警告記錄。
UDM 對應表
| 記錄欄位 | UDM 對應 | 邏輯 |
|---|---|---|
| assigned_date | additional.fields.assigned_date_label | 設定鍵為「Assigned Date」的標籤,並從 assigned_date 取得值 |
| assigned_to | additional.fields.assigned_to_label | 將標籤的鍵設為「Assigned To」,值設為 assigned_to |
| c_score | additional.fields.c_score_label | 使用索引鍵「c_score」和 c_score 中的值設定標籤 |
| category | security_result.category_details | 直接複製值 |
| 確定度 | additional.fields.certainty_label | 設定標籤,鍵為「Certainty」,值為 certainty |
| created_timestamp | metadata.event_timestamp | 轉換時使用的格式為 yyyy-MM-ddTHH:mm:ssZ |
| custom_detection | additional.fields.custom_detection_label | 將標籤設為鍵「Custom Detection」和值 custom_detection |
| data_source.connection_id | security_result.detection_fields.connection_id_label | 將標籤鍵設為「Connection ID」,值則設為 data_source.connection_id |
| data_source.connection_name | security_result.detection_fields.connection_name_label | 將標籤設為鍵「Connection Name」和 data_source.connection_name 的值 |
| data_source.type | security_result.detection_fields.data_source_type_label | 將標籤設為鍵「Data Source Type」和 data_source.type 的值 |
| 說明 | metadata.description | 直接複製值 |
| 偵測 | additional.fields.detection_label | 使用「Detection」鍵和偵測值設定標籤 |
| detection_category | additional.fields.detection_category_label | 使用「Detection Category」鍵和 detection_category 中的值設定標籤 |
| detection_type | additional.fields.detection_type_label | 將標籤設為鍵「Detection Type」和值「detection_type」 |
| detection_url | principal.url | 直接複製值 |
| filtered_by_ai | additional.fields.filtered_by_ai_label | 設定標籤,鍵為「Filtered By AI」,值為 filtered_by_ai |
| filtered_by_rule | additional.fields.filtered_by_rule_label | 將標籤設為鍵「Filtered By Rule」和 filtered_by_rule 的值 |
| filtered_by_user | additional.fields.filtered_by_user_label | 設定索引鍵為「Filtered By User」的標籤,並從 filtered_by_user 取得值 |
| first_timestamp | additional.fields.first_timestamp_label | 設定標籤,鍵為「First Timestamp」,值為 first_timestamp |
| gd_first_timestamp | security_result.detection_fields.gd_first_timestamp_label | 使用「first_timestamp」鍵和 gd_first_timestamp 中的值設定標籤 |
| gd_grouping_field | security_result.detection_fields.gd_grouping_field_label | 將標籤設為鍵「grouping_field」和 gd_grouping_field 的值 |
| gd_last_timestamp | security_result.detection_fields.gd_last_timestamp_label | 使用「group_details_last_timestamp」鍵和 gd_last_timestamp 中的值設定標籤 |
| gd_uuid | security_result.detection_fields.gd_uuid_label | 使用「gd_uuid」鍵和 gd_uuid 中的值設定標籤 |
| grp_description | security_result.detection_fields.grp_description_label | 使用「grp_description」鍵和 grp_description 中的值設定標籤 |
| grp_id | security_result.detection_fields.grp_id_label | 將標籤設為鍵「grp_id」和 grp_id 的值 |
| grp_last_modified | security_result.detection_fields.grp_last_modified_label | 設定標籤,並將鍵設為「grp_last_modified」,值設為 grp_last_modified |
| grp_last_modified_by | security_result.detection_fields.grp_last_modified_by_label | 設定標籤,鍵為「grp_last_modified_by」,值為 grp_last_modified_by |
| grp_name | security_result.detection_fields.grp_name_label | 使用鍵「grp_name」和來自 grp_name 的值設定標籤 |
| grp_type | security_result.detection_fields.grp_type_label | 使用「grp_type」鍵和 grp_type 中的值設定標籤 |
| id | metadata.product_log_id | 直接複製值 |
| 中介 | 中介 | 直接複製值 |
| is_custom_model | additional.fields.is_custom_model_label | 使用鍵「is_custom_model」和值 (來自 is_custom_model) 設定標籤 |
| is_marked_custom | additional.fields.is_marked_custom_label | 設定標籤,鍵為「is_marked_custom」,值為 is_marked_custom |
| is_targeting_key_asset | additional.fields.is_targeting_key_asset_label | 使用鍵「is_targeting_key_asset」和來自 is_targeting_key_asset 的值設定標籤 |
| is_triaged | additional.fields.is_triaged_label | 設定標籤,鍵為「is_triaged」,值為 is_triaged |
| last_timestamp | additional.fields.last_timestamp_label | 將標籤設為鍵「last_timestamp」和值「last_timestamp」 |
| 附註 | additional.fields.note_label | 設定標籤,鍵為「note」,值為附註內容 |
| note_modified_by | additional.fields.note_modified_by_label | 將標籤鍵設為「note_modified_by」,值設為 note_modified_by |
| note_modified_timestamp | additional.fields.note_modified_timestamp_label | 設定標籤,鍵為「note_modified_timestamp」,值為 note_modified_timestamp |
| 附註 | additional.fields.notes_label | 設定標籤,鍵為「notes」,值來自附註 |
| 主體 | 主體 | 直接複製值 |
| security_result | security_result | 直接複製值 |
| 感應器 | additional.fields.sensor_label | 使用「sensor」鍵和感應器值設定標籤 |
| sensor_name | additional.fields.sensor_name_label | 設定標籤,鍵為「sensor_name」,值來自 sensor_name |
| src | src | 直接複製值 |
| src_account | additional.fields.src_account_label | 設定標籤,鍵為「src_account」,值為 src_account |
| src_host.certainty | additional.fields.src_certainty_label | 設定標籤,鍵為「src_host_certainty」,值為 src_host.certainty |
| src_host.id | principal.user.userid | 直接複製值 |
| gd_src_host_ip、src_ip、src_host.ip | principal.ip | 從 gd_src_host_ip、src_ip、src_host.ip 合併;最後一次合併勝出 |
| src_ip、src_host.ip | principal.asset.ip | 從 src_ip、src_host.ip 合併;最後合併的項目優先 |
| src_host.is_key_asset | additional.fields.src_host_is_key_asset_label | 將標籤設為鍵「src_host_is_key_asset」和 src_host.is_key_asset 的值 |
| src_host.name | principal.hostname | 直接複製值 |
| src_host.threat | additional.fields.src_host_threat_label | 設定標籤,鍵為「src_host_threat」,值來自 src_host.threat |
| src_host.url | src.url | 直接複製值 |
| src_host_group_description | security_result.detection_fields.src_host_group_description_label | 設定標籤,鍵為「src_host_group_description」,值來自 src_host_group_description |
| src_host_group_id | security_result.detection_fields.src_host_group_id_label | 設定標籤,鍵為「src_host_group_id」,值為 src_host_group_id |
| src_host_group_last_modified | security_result.detection_fields.src_host_group_last_modified_label | 設定標籤,鍵為「src_host_group_last_modified」,值來自 src_host_group_last_modified |
| src_host_group_last_modified_by | security_result.detection_fields.src_host_group_last_modified_by_label | 設定標籤,鍵為「src_host_group_last_modified_by」,值為 src_host_group_last_modified_by |
| src_host_group_name | security_result.detection_fields.src_host_group_name_label | 使用「src_host_group_name」中的索引鍵「src_host_group_name」和值設定標籤 |
| src_host_group_type | security_result.detection_fields.src_host_group_type_label | 使用「src_host_group_type」鍵和 src_host_group_type 中的值設定標籤 |
| 最終的隱藏狀態 | security_result.detection_fields.state_label | 設定標籤,鍵為「state」,值為州別 |
| summary.num_attempts | additional.fields.num_attempts_label | 設定標籤,鍵為「num_attempts」,值為 summary.num_attempts |
| 目標 | 目標 | 直接複製值 |
| dst_host_ip, dst_ip1 | target.ip | 從 dst_host_ip、dst_ip1 合併;以最後合併者為準 |
| 標記 | additional.fields.tags_label | 設定標籤,鍵為「tags」,值則來自標記 |
| t_score | additional.fields.t_score_label | 使用鍵「t_score」和來自 t_score 的值設定標籤 |
| targets_key_asset | additional.fields.targets_key_asset_label | 將標籤設為鍵「targets_key_asset」和 targets_key_asset 的值 |
| 威脅 | security_result.detection_fields.threat_label | 將標籤設為「threat」鍵和威脅值 |
| triage_rule_id | security_result.rule_id | 直接複製值 |
| 類型 | additional.fields.type_label | 使用「type」鍵和來自型別的值設定標籤 |
| 網址 | metadata.url_back_to_product | 直接複製值 |
| uuid1 | security_result.detection_fields.uuid_label | 設定標籤,鍵為「uuid」,值為 uuid1 |
| dst_host_id | security_result.detection_fields.dst_host_id_label | 使用索引鍵「dst_host_id」和 dst_host_id 中的值設定標籤 |
| dst_host_name | security_result.detection_fields.dst_host_name_label | 設定標籤,鍵為「dst_host_name」,值來自 dst_host_name |
| dst_port1 | security_result.detection_fields.dst_port_label | 設定索引鍵為「dst_port」的標籤,並從 dst_port1 取得值 |
| dst_last_timestamp | security_result.detection_fields.dst_last_timestamp_label | 使用「dst_last_timestamp」鍵和 dst_last_timestamp 中的值設定標籤 |
| metadata.event_type | 如果 has_principal == "true" 且 has_target == "true",則設為「NETWORK_CONNECTION」;如果 has_user == "true",則設為「USER_UNCATEGORIZED」;如果 has_principal == "true",則設為「STATUS_UPDATE」;否則設為「GENERIC_EVENT」 | |
| metadata.product_name | 設為「Vectra Alerts」 | |
| metadata.vendor_name | 設為「Vectra Alerts」 |
變更記錄
還有其他問題嗎?向社群成員和 Google SecOps 專家尋求解答。