收集 Veeam 記錄
本文說明如何使用 Bindplane 代理,將 Veeam 記錄檔擷取至 Google Security Operations。
Veeam Backup & Replication 是資料保護平台,可為備份工作、複製工作、還原作業和系統事件產生 syslog 訊息。剖析器會使用 grok 模式從 syslog 訊息擷取欄位,並對應至統合式資料模型 (UDM)。
事前準備
請確認您符合下列必要條件:
- Google SecOps 執行個體
- Windows Server 2016 以上版本,或搭載
systemd的 Linux 主機 - Bindplane 代理程式與 Veeam Backup & Replication 伺服器之間的網路連線
- 如果透過 Proxy 執行,請確保防火牆通訊埠已根據 Bindplane 代理程式需求開啟
- Veeam 的特殊存取權
取得 Bindplane 代理程式的 Google SecOps 憑證
如要向 Google SecOps 驗證 Bindplane 代理程式,請選擇下列其中一種方法:
- 新部署作業:使用 Chronicle API (選項 1)。
- 舊版部署作業:繼續使用擷取驗證檔案 (選項 2),直到 Ingestion API 於 2027 年 7 月 20 日停用。
方法 1:為 Chronicle API 建立服務帳戶 (建議)
- 登入 Google Cloud 控制台,選取連結至 Google SecOps 執行個體的 Google Cloud 專案。
- 依序前往 「IAM & Admin」(IAM 與管理) >「Service Accounts」(服務帳戶)。
- 按一下「建立服務帳戶」。
- 請提供下列設定詳細資料:
- 「Service account name」(服務帳戶名稱):輸入帳戶名稱 (例如
bindplane-ingest)。 - 服務帳戶說明:輸入說明 (例如
Bindplane agent log ingestion)。
- 「Service account name」(服務帳戶名稱):輸入帳戶名稱 (例如
- 點按「Create and continue」(建立並繼續)。
- 在「將專案存取權授予這個服務帳戶」部分,按一下「選取角色」,然後選取「Chronicle 編輯者」。
- 依序點選「繼續」和「完成」。
- 按一下您建立的服務帳戶,然後前往「金鑰」分頁標籤。
- 依序點選「新增金鑰」>「建立新的金鑰」。
- 選取「JSON」,然後點選「建立」。金鑰檔案會下載到電腦。
- 將金鑰檔案儲存為 Bindplane 收集器目錄中的
ingestion-auth.json(Linux 為/opt/observiq-otel-collector/ingestion-auth.json,Windows 為C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json),或更新config.yaml中的creds_file_path,使其與儲存檔案的路徑相符。 - 依序前往「IAM 與管理」>「設定」,然後複製「專案編號」。匯出工具設定時會用到。
方法 2:下載擷取驗證檔案 (舊版)
- 登入 Google SecOps 控制台。
- 依序前往「SIEM Settings」 > 「Collection Agents」。
- 下載擷取驗證檔案。
- 將檔案安全地儲存在要安裝 Bindplane 代理程式的系統上。
取得 Google SecOps 客戶 ID
- 登入 Google SecOps 控制台。
- 依序前往「SIEM 設定」 > 「設定檔」。
複製並儲存「機構詳細資料」部分的客戶 ID。
安裝 Bindplane 代理程式
請按照下列操作說明,在 Windows 或 Linux 作業系統上安裝 Bindplane 代理程式。
Windows 安裝
- 以管理員身分開啟「命令提示字元」或「PowerShell」。
執行下列指令:
msiexec /i "https://github.com/observIQ/bindplane-agent/releases/latest/download/observiq-otel-collector.msi" /quiet等待安裝完成。
執行下列指令,確認安裝成功:
sc query observiq-otel-collector服務應顯示為「RUNNING」。
安裝 Linux
- 開啟具有 root 或 sudo 權限的終端機。
執行下列指令:
sudo sh -c "$(curl -fsSlL https://github.com/observiq/bindplane-agent/releases/latest/download/install_unix.sh)" install_unix.sh等待安裝完成。
執行下列指令,確認安裝成功:
sudo systemctl status observiq-otel-collector服務應顯示為「active (running)」。
其他安裝資源
如需其他安裝選項和疑難排解資訊,請參閱 Bindplane 代理程式安裝指南。
設定 Bindplane 代理程式,擷取系統記錄並傳送至 Google SecOps
找出設定檔
Linux:
sudo nano /opt/observiq-otel-collector/config.yamlWindows:
notepad "C:\Program Files\observIQ OpenTelemetry Collector\config.yaml"
編輯設定檔
將
config.yaml的全部內容替換為下列設定:receivers: udplog: listen_address: "0.0.0.0:514" exporters: chronicle/veeam: protocol: https # Region of your instance, for example us, europe, asia-southeast1 location: <LOCATION> # Project number of the Google Cloud project linked to the instance project: '<PROJECT_NUMBER>' compression: gzip creds_file_path: '/opt/observiq-otel-collector/ingestion-auth.json' customer_id: '<customer_id>' endpoint: chronicle.googleapis.com log_type: VEEAM raw_log_field: body service: pipelines: logs/veeam_to_chronicle: receivers: - udplog exporters: - chronicle/veeam
設定參數
替換下列預留位置:
接收器設定:
listen_address:要監聽的 IP 位址和通訊埠:0.0.0.0:在所有介面上監聽 (建議)- 通訊埠
514是標準 syslog 通訊埠 (在 Linux 上需要根目錄;非根目錄請使用1514)
匯出工具設定:
creds_file_path:服務帳戶 JSON 金鑰檔案的完整路徑 (選項 1):- Linux:
/opt/observiq-otel-collector/ingestion-auth.json - Windows:
C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json
- Linux:
customer_id:從 Google SecOps 控制台複製的客戶 IDlocation:將<LOCATION>替換為 Google SecOps 執行個體的區域 (例如us、europe或asia-southeast1)。匯出工具會以這個值做為chronicle.googleapis.com的前置字元。如需完整清單,請參閱「區域性端點」。project:依序前往「IAM 與管理」>「設定」,然後將<PROJECT_NUMBER>替換為專案編號。endpoint:維持設為chronicle.googleapis.com。
舊版擷取 API 匯出工具
如果您使用選項 2 的擷取驗證檔案,請將
exporters區塊替換為下列內容。將creds_file_path設為擷取驗證檔案的路徑。如果執行個體位於美國境外,請將malachiteingestion-pa.googleapis.com替換為區域端點 (例如europe-malachiteingestion-pa.googleapis.com)。exporters: chronicle/veeam: compression: gzip creds_file_path: '/opt/observiq-otel-collector/ingestion-auth.json' customer_id: '<customer_id>' endpoint: malachiteingestion-pa.googleapis.com log_type: VEEAM raw_log_field: body
儲存設定檔
- 編輯完成後,請儲存檔案:
- Linux:依序按下
Ctrl+O、Enter和Ctrl+X - Windows:依序點選「檔案」 > 「儲存」
- Linux:依序按下
重新啟動 Bindplane 代理程式,套用變更
如要在 Linux 中重新啟動 Bindplane 代理程式,請執行下列指令:
sudo systemctl restart observiq-otel-collector確認服務是否正在執行:
sudo systemctl status observiq-otel-collector檢查記錄是否有錯誤:
sudo journalctl -u observiq-otel-collector -f
如要在 Windows 中重新啟動 Bindplane 代理程式,請選擇下列其中一個選項:
以管理員身分開啟命令提示字元或 PowerShell:
net stop observiq-otel-collector && net start observiq-otel-collector服務控制台:
- 按下
Win+R鍵,輸入services.msc,然後按下 Enter 鍵。 - 找出「observIQ OpenTelemetry Collector」。
- 按一下滑鼠右鍵,然後選取「重新啟動」。
確認服務正在執行:
sc query observiq-otel-collector查看記錄檔是否有錯誤:
type "C:\Program Files\observIQ OpenTelemetry Collector\log\collector.log"
- 按下
設定 Veeam 的系統記錄
- 登入 Veeam Backup & Replication 控制台。
- 依序點選「選單」>「選項」>「SIEM 整合」。
- 在「Syslog 伺服器」部分,按一下「新增」。
- 請提供下列設定詳細資料:
- 名稱:輸入 Bindplane 代理程式 IP 位址和通訊埠編號 (例如
192.168.1.1:514)。 - 傳輸:根據 Bindplane 代理程式設定,選取「UDP」或「TCP」。
- 名稱:輸入 Bindplane 代理程式 IP 位址和通訊埠編號 (例如
- 按一下「確定」儲存設定。
UDM 對應表
| 記錄欄位 | UDM 對應 | 邏輯 |
|---|---|---|
application |
principal.application |
直接對應至 grok 模式擷取的 application 欄位。 |
CredentialId |
principal.resource.attribute.labels.[] |
直接從 kv 篩選器擷取的 CredentialId 欄位對應。系統會建立索引鍵為「CredentialId」的標籤。 |
date_2、time_2、year |
metadata.event_timestamp |
系統會使用 date 篩選器串連並剖析 date_2、time_2 和 year 欄位,建立 metadata.event_timestamp。 |
date_2、time_2 |
metadata.event_timestamp |
系統會使用 date 篩選器串連及剖析 date_2 和 time_2 欄位,建立 metadata.event_timestamp。 |
deviceId |
principal.resource.product_object_id |
直接從 kv 篩選器擷取的 deviceId 欄位對應。 |
description |
security_result.description |
直接對應至 grok 模式擷取的 description 欄位。 |
error_code |
security_result.detection_fields.[] |
直接對應至 grok 模式擷取的 error_code 欄位。系統會建立含有「error_code」鍵的標籤。 |
executing_feature |
principal.hostname、principal.asset.hostname |
直接對應至 grok 模式擷取的 executing_feature 欄位。 |
host |
principal.hostname、principal.asset.hostname |
直接對應至 grok 模式擷取的 host 欄位。 |
ManagementIP |
principal.ip、principal.asset.ip |
直接從 kv 篩選器擷取的 ManagementIP 欄位對應。 |
pid |
principal.process.pid |
直接從 grok 模式擷取的 pid 欄位對應。 |
previousSeverity |
security_result.severity_details |
直接從 grok 模式擷取的 previousSeverity 欄位對應。 |
prod_event_type |
metadata.product_event_type |
直接對應至 grok 模式擷取的 prod_event_type 欄位。 |
query |
security_result.detection_fields.[] |
直接對應至 grok 模式擷取的 query 欄位。建立含有「query」鍵的標籤。 |
reportingAddress |
principal.ip、principal.asset.ip |
直接對應至 grok 模式擷取的 reportingAddress 欄位。 |
severity |
security_result.severity |
對應自「severity」欄位。這個值是根據 severity 欄位,由條件邏輯決定 (ERROR、MAJOR/WARN、INFO 對應至特定 UDM 嚴重性值)。 |
src_ip |
principal.ip、principal.asset.ip |
直接從 grok 模式擷取的 src_ip 欄位對應。 |
summary |
security_result.summary |
直接從 grok 模式擷取的 summary 欄位對應。 |
target_ip |
target.ip、target.asset.ip |
直接從 grok 模式擷取的 target_ip 欄位對應。 |
thread_id |
security_result.detection_fields.[] |
直接從 grok 模式擷取的 thread_id 欄位對應。系統會建立索引鍵為「thread_id」的標籤。 |
| (不適用) | event_type |
由剖析器中的邏輯決定。如果 principal 和 target 都有 MID 資料,則為 NETWORK_UNCATEGORIZED。如果只有 principal 具有 MID 資料,則為 STATUS_UPDATE。否則為 GENERIC_EVENT。 |
| (不適用) | metadata.event_type |
複製自內部產生的 event_type 欄位。 |
| (不適用) | metadata.vendor_name |
硬式編碼為「VEEAM」。 |
| (不適用) | metadata.product_name |
硬式編碼為「Veeam」。 |
| (不適用) | event.timestamp |
事件時間戳記取自記錄項目的 collection_time 欄位。 |
enterpriseId |
additional.fields |
從變更記錄對應 |
recipient_emailid |
additional.fields |
從變更記錄對應 |
description |
metadata.description |
從變更記錄對應 |
version |
additional.fields |
從變更記錄對應 |
categoryId |
additional.fields |
從變更記錄對應 |
instanceId |
additional.fields |
從變更記錄對應 |
VbrVersion |
metadata.product_version |
從變更記錄對應 |
變更記錄
還有其他問題嗎?向社群成員和 Google SecOps 專業人員尋求解答。