收集電壓記錄

支援的服務:

本文說明如何使用 Bindplane 代理程式,將 Voltage SecureMail 記錄檔擷取至 Google Security Operations。

Voltage SecureMail 是電子郵件加密平台,可針對電子郵件加密/解密事件、政策執行和管理動作產生系統記錄訊息。

事前準備

請確認您符合下列必要條件:

  • Google SecOps 執行個體
  • Windows Server 2016 以上版本,或搭載 systemd 的 Linux 主機
  • Bindplane 代理程式與 Voltage SecureMail 伺服器之間的網路連線
  • 如果透過 Proxy 執行,請確保防火牆通訊埠已根據 Bindplane 代理程式需求開啟
  • Voltage SecureMail 管理控制台的特殊權限存取權

取得 Bindplane 代理程式的 Google SecOps 憑證

如要向 Google SecOps 驗證 Bindplane 代理程式,請選擇下列其中一種方法:

  • 新部署作業:使用 Chronicle API (選項 1)。
  • 舊版部署作業:繼續使用擷取驗證檔案 (選項 2),直到 Ingestion API 於 2027 年 7 月 20 日停用。
  1. 登入 Google Cloud 控制台,選取連結至 Google SecOps 執行個體的 Google Cloud 專案。
  2. 依序前往「IAM & Admin」(IAM 與管理) >「Service Accounts」(服務帳戶)。
  3. 按一下「建立服務帳戶」。
  4. 請提供下列設定詳細資料:
    • 「Service account name」(服務帳戶名稱):輸入帳戶名稱 (例如 bindplane-ingest)。
    • 服務帳戶說明:輸入說明 (例如 Bindplane agent log ingestion)。
  5. 點按「Create and continue」(建立並繼續)。
  6. 在「將專案存取權授予這個服務帳戶」部分,按一下「選取角色」,然後選取「Chronicle 編輯者」。
  7. 依序點選「繼續」和「完成」。
  8. 按一下您建立的服務帳戶,然後前往「金鑰」分頁。
  9. 依序點選「新增金鑰」>「建立新的金鑰」。
  10. 選取「JSON」,然後按一下「建立」。金鑰檔案會下載到電腦。
  11. 將金鑰檔案儲存為 Bindplane 收集器目錄中的 ingestion-auth.json (Linux 上的 /opt/observiq-otel-collector/ingestion-auth.json 或 Windows 上的 C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json),或更新 config.yaml 中的 creds_file_path,使其與儲存路徑相符。
  12. 依序前往「IAM & Admin」(IAM 與管理) >「Settings」(設定),然後複製「Project number」(專案編號)。匯出工具設定時會用到。

方法 2:下載擷取驗證檔案 (舊版)

  1. 登入 Google SecOps 控制台。
  2. 依序前往「SIEM Settings」 > 「Collection Agents」。
  3. 下載擷取驗證檔案。
  4. 將檔案安全地儲存在要安裝 Bindplane 代理程式的系統上。

取得 Google SecOps 客戶 ID

  1. 登入 Google SecOps 控制台。
  2. 依序前往「SIEM 設定」 > 「設定檔」。
  3. 複製並儲存「機構詳細資料」部分的客戶 ID。

安裝 Bindplane 代理程式

請按照下列操作說明,在 Windows 或 Linux 作業系統上安裝 Bindplane 代理程式。

Windows 安裝

  1. 以管理員身分開啟命令提示字元或 PowerShell。
  2. 執行下列指令:

    msiexec /i "https://github.com/observIQ/bindplane-agent/releases/latest/download/observiq-otel-collector.msi" /quiet
    
  3. 等待安裝完成。

  4. 執行下列指令,確認安裝成功:

    sc query observiq-otel-collector
    

    服務應顯示為「RUNNING」。

安裝 Linux

  1. 開啟具有 root 或 sudo 權限的終端機。
  2. 執行下列指令:

    sudo sh -c "$(curl -fsSlL https://github.com/observiq/bindplane-agent/releases/latest/download/install_unix.sh)" install_unix.sh
    
  3. 等待安裝完成。

  4. 執行下列指令,確認安裝成功:

    sudo systemctl status observiq-otel-collector
    

    服務應顯示為「active (running)」。

其他安裝資源

如需其他安裝選項和疑難排解資訊,請參閱 Bindplane 代理程式安裝指南。

設定 Bindplane 代理程式,擷取系統記錄並傳送至 Google SecOps

找出設定檔

  • Linux:

    sudo nano /opt/observiq-otel-collector/config.yaml
    
  • Windows:

    notepad "C:\Program Files\observIQ OpenTelemetry Collector\config.yaml"
    

編輯設定檔

  • 將 config.yaml 的全部內容替換為下列設定:

    receivers:
      udplog:
        listen_address: "0.0.0.0:514"
    
    exporters:
      chronicle/voltage:
        protocol: https
        # Region of your instance, for example us, europe, asia-southeast1
        location: <LOCATION>
        # Project number of the Google Cloud project linked to the instance
        project: '<PROJECT_NUMBER>'
        compression: gzip
        creds_file_path: '/opt/observiq-otel-collector/ingestion-auth.json'
        customer_id: '<customer_id>'
        endpoint: chronicle.googleapis.com
        log_type: VOLTAGE
        raw_log_field: body
    
    service:
      pipelines:
        logs/voltage_to_chronicle:
          receivers:
            - udplog
          exporters:
            - chronicle/voltage
    

設定參數

請替換下列預留位置:

  • 接收器設定:

    • listen_address:要監聽的 IP 位址和通訊埠:
      • 0.0.0.0 在所有介面接聽電話 (建議)
      • 通訊埠 514 是標準 syslog 通訊埠 (在 Linux 上需要根目錄;非根目錄請使用 1514)
  • 匯出工具設定:

    • creds_file_path:服務帳戶 JSON 金鑰檔案的完整路徑 (選項 1):
      • Linux:/opt/observiq-otel-collector/ingestion-auth.json
      • Windows:C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json
    • customer_id:從 Google SecOps 控制台複製的客戶 ID
    • location:將 <LOCATION> 替換為 Google SecOps 執行個體的區域 (例如 us、europe 或 asia-southeast1)。匯出工具會以這個值做為 chronicle.googleapis.com 的前置字元。如需完整清單,請參閱「區域性端點」。
    • project:依序前往「IAM 與管理」>「設定」,然後將 <PROJECT_NUMBER> 替換為專案編號。
    • endpoint:維持設為 chronicle.googleapis.com。

舊版擷取 API 匯出工具

  • 如果您使用選項 2 的擷取驗證檔案,請將 exporters 區塊替換為下列內容。將 creds_file_path 設為擷取驗證檔案的路徑。如果執行個體位於美國境外,請將 malachiteingestion-pa.googleapis.com 替換為區域端點 (例如 europe-malachiteingestion-pa.googleapis.com)。

    exporters:
      chronicle/voltage:
        compression: gzip
        creds_file_path: '/opt/observiq-otel-collector/ingestion-auth.json'
        customer_id: '<customer_id>'
        endpoint: malachiteingestion-pa.googleapis.com
        log_type: VOLTAGE
        raw_log_field: body
    

儲存設定檔

  • 編輯完畢後,請儲存檔案:
    • Linux:依序按下 Ctrl+O、Enter 和 Ctrl+X
    • Windows:依序點選「檔案」>「儲存」

重新啟動 Bindplane 代理程式,套用變更

  • 如要在 Linux 重新啟動 Bindplane 代理程式,請執行下列指令:

    sudo systemctl restart observiq-otel-collector
    
    1. 確認服務正在執行:

      sudo systemctl status observiq-otel-collector
      
    2. 查看記錄檔是否有錯誤:

      sudo journalctl -u observiq-otel-collector -f
      
  • 如要在 Windows 中重新啟動 Bindplane 代理程式,請選擇下列其中一個選項:

    • 以管理員身分開啟命令提示字元或 PowerShell:

      net stop observiq-otel-collector && net start observiq-otel-collector
      
    • 服務控制台:

      1. 按下 Win+R 鍵,輸入 services.msc,然後按下 Enter 鍵。
      2. 找出「observIQ OpenTelemetry Collector」。
      3. 按一下滑鼠右鍵,然後選取「重新啟動」。
      4. 確認服務是否正在執行:

        sc query observiq-otel-collector
        
      5. 查看記錄檔是否有錯誤:

        type "C:\Program Files\observIQ OpenTelemetry Collector\log\collector.log"
        

在 Voltage SecureMail 中設定系統記錄檔

  1. 登入 Voltage SecureMail 管理控制台。
  2. 依序前往 「System」 > 「Syslog Settings」。
  3. 提供下列設定詳細資料:
    • 伺服器位址:輸入 Bindplane 代理程式 IP 位址。
    • 「Port」(通訊埠):輸入 514。
    • 「通訊協定」:選取「UDP」。
    • Facility:選取適當的系統記錄設施。
    • 「記錄層級」:選取所需的記錄層級。
  4. 按一下 [儲存]。

UDM 對應表

記錄欄位 UDM 對應 邏輯
attemptedAuthMethods_label additional.fields 已合併
authTokens_label additional.fields 已合併
elapsedTimeMillis_label additional.fields 已合併
isUserPassSet_label additional.fields 已合併
keyId_label additional.fields 已合併
leadingDigits_label additional.fields 已合併
masked_label additional.fields 已合併
merchantId_label additional.fields 已合併
out_label additional.fields 已合併
phaseBit_label additional.fields 已合併
proxyType_label additional.fields 已合併
rollover_label additional.fields 已合併
trailingDigits_label additional.fields 已合併
AuthenticationMethod extensions.auth.mechanism 已對應:USER_PASSWORD → mechanism
mechanism extensions.auth.mechanism 已合併
has_principal extensions.auth.type 對應:true → AUTHTYPE_UNSPECIFIED
proxyConnectionIp intermediary.asset.ip 已合併
inter_hostname intermediary.hostname 直接對應
proxyConnectionIp intermediary.ip 已合併
description metadata.description 直接對應
has_principal metadata.event_type 對應:true → USER_LOGIN、true → NETWORK_CONNECTION、true → STATUS_UPDATE
has_user metadata.event_type 對應:true → USER_UNCATEGORIZED
prod_event_name metadata.product_event_type 直接對應
event_id metadata.product_log_id 直接對應
cef_product metadata.product_name 直接對應
version metadata.product_version 直接對應
request network.http.referral_url 直接對應
length network.received_bytes 直接對應
requestTimeMillis network.session_duration.nanos 直接對應
timeMillis network.session_duration.seconds 直接對應
sessionid network.session_id 直接對應
cvProduct observer.application 直接對應
cvapi_label observer.labels 已合併
cvdevice_label observer.labels 已合併
cvframework_label observer.labels 已合併
cvos observer.platform 對應:Li → LINUX、Win → WINDOWS
requestClientApplication principal.application 直接對應
src_hostname principal.asset.hostname 直接對應
ip principal.asset.ip 已合併
src_ip principal.asset.ip 已合併
src_hostname principal.hostname 直接對應
ip principal.ip 已合併
src_ip principal.ip 已合併
src_port principal.port 已重新命名/對應
identity principal.user.email_addresses 對應:(.*)@(.*) → identity
user principal.user.userid 直接對應
username principal.user.userid 直接對應
sec_action security_result.action 已合併
msg security_result.description 直接對應
CachedAuthentication_label security_result.detection_fields 已合併
acceptBadData_label security_result.detection_fields 已合併
algorithm_label security_result.detection_fields 已合併
authMethodName_label security_result.detection_fields 已合併
authTimeMillis_label security_result.detection_fields 已合併
authType_label security_result.detection_fields 已合併
format_label security_result.detection_fields 已合併
fullIdentity_label security_result.detection_fields 已合併
hsmEnabled_label security_result.detection_fields 已合併
returnEncryptedKeyOption_label security_result.detection_fields 已合併
returnFullIdentity_label security_result.detection_fields 已合併
wrappedMode_label security_result.detection_fields 已合併
severity security_result.severity 已對應:"0", "1", "2" → INFORMATIONAL、"3", "4" → LOW、"5", "6" → MEDIUM、`"7"`...
severity security_result.severity_details 直接對應
district target.administrative_domain 直接對應
shost target.asset.hostname 直接對應
dst_ip target.asset.ip 已合併
shost target.hostname 直接對應
dst_ip target.ip 已合併
cmd_line target.process.command_line 直接對應
pid target.process.pid 直接對應
path target.resource.name 直接對應
tar_user target.user.userid 直接對應
不適用 extensions.auth.type 常數:AUTHTYPE_UNSPECIFIED
不適用 metadata.event_type 常數:USER_LOGIN
不適用 metadata.product_name 常數:VOLTAGE
不適用 metadata.vendor_name 常數:VOLTAGE
不適用 observer.platform 常數:LINUX
不適用 security_result.severity 常數:INFORMATIONAL
district event.idm.read_only_udm.target.administrative_domain 從變更記錄對應
identity event.idm.read_only_udm.principal.user.email_addresses 從變更記錄對應
src event.idm.read_only_udm.principal.ip 和 event.idm.read_only_udm.principal.asset.ip 從變更記錄對應
username event.idm.read_only_udm.principal.user.userid 從變更記錄對應
shost event.idm.read_only_udm.target.hostname 和 event.idm.read_only_udm.target.asset.hostname 從變更記錄對應
requestClientApplication event.idm.read_only_udm.principal.application 從變更記錄對應
length event.idm.read_only_udm.network.received_bytes 從變更記錄對應
AuthenticationMethod event.idm.read_only_udm.extensions.auth.mechanism 從變更記錄對應
cvProduct event.idm.read_only_udm.observer.application 從變更記錄對應
cvapi event.idm.read_only_udm.observer.labels 從變更記錄對應
cvframework event.idm.read_only_udm.observer.labels 從變更記錄對應
cvdevice event.idm.read_only_udm.observer.labels 從變更記錄對應
cvos event.idm.read_only_udm.observer.platform 從變更記錄對應
msg event.idm.read_only_udm.security_result.description 從變更記錄對應
proxyConnectionIp event.idm.read_only_udm.intermediary.ip 和 event.idm.read_only_udm.intermediary.asset.ip 從變更記錄對應
: event.idm.read_only_udm.additional.fields 從變更記錄對應
, event.idm.read_only_udm.additional.fields 從變更記錄對應
and event.idm.read_only_udm.additional.fields 從變更記錄對應
cached event.idm.read_only_udm.security_result.detection_fields 從變更記錄對應
fullIdentity event.idm.read_only_udm.security_result.detection_fields 從變更記錄對應
algorithm event.idm.read_only_udm.security_result.detection_fields 從變更記錄對應
returnEncryptedKeyOption event.idm.read_only_udm.security_result.detection_fields 從變更記錄對應
authMethodName event.idm.read_only_udm.security_result.detection_fields 從變更記錄對應
authType event.idm.read_only_udm.security_result.detection_fields 從變更記錄對應
authTimeMillis event.idm.read_only_udm.security_result.detection_fields 從變更記錄對應
hsmEnabled event.idm.read_only_udm.security_result.detection_fields 從變更記錄對應
wrappedMode event.idm.read_only_udm.security_result.detection_fields 從變更記錄對應
format event.idm.read_only_udm.security_result.detection_fields 從變更記錄對應
returnFullIdentity event.idm.read_only_udm.security_result.detection_fields 從變更記錄對應
acceptBadData event.idm.read_only_udm.security_result.detection_fields 從變更記錄對應
CachedAuthentication event.idm.read_only_udm.security_result.detection_fields 從變更記錄對應

變更記錄

查看這個剖析器的變更記錄

還有其他問題嗎?向社群成員和 Google SecOps 專業人員尋求解答。