收集 PTC Windchill 日志
本文档介绍了如何使用 Bindplane 将 PTC Windchill 日志注入 Google Security Operations。
PTC Windchill 是一个产品生命周期管理 (PLM) 平台,用于管理工程和制造团队的产品数据、流程和协作。该平台会从本地服务器部署生成访问、审核和配置更改日志。
准备工作
请确保满足以下前提条件:
- Google SecOps 实例
- Windows Server 2016 或更高版本,或具有
systemd的 Linux 主机 - Bindplane 代理与 PTC Windchill 服务器之间的网络连接
- 如果通过代理运行,请确保防火墙端口根据 Bindplane 代理要求处于开放状态
- 对 PTC Windchill 服务器具有管理员权限的特权访问权限
获取 Bindplane 代理的 Google SecOps 凭据
如需向 Google SecOps 验证 Bindplane 代理的身份,请选择以下方法之一:
- 新部署:使用 Chronicle API(方法 1)。
- 旧版部署:继续使用注入身份验证文件(方法 2),直到注入 API 于 2027 年 7 月 20 日停用为止。
方法 1:为 Chronicle API 创建服务帐号(推荐)
- 登录 Google Cloud 控制台,然后选择与您的 Google SecOps 实例关联的 Google Cloud 项目。
- 依次前往 IAM 和管理 > 服务账号。
- 点击创建服务账号 。
- 提供以下配置详细信息:
- 服务账号名称:输入账号的名称(例如
bindplane-ingest)。 - 服务账号说明:输入说明(例如
Bindplane agent log ingestion)。
- 服务账号名称:输入账号的名称(例如
- 点击创建并继续 。
- 在向此服务帐号授予对项目的访问权限 部分,点击选择角色 ,然后选择 Chronicle Editor 。
- 点击继续 ,然后点击完成 。
- 点击您创建的服务帐号,然后前往密钥 标签页。
- 依次点击添加密钥 > 创建新密钥。
- 选择 JSON ,然后点击创建 。密钥文件会下载到您的计算机上。
- 将密钥文件另存为 Bindplane 收集器目录中的
ingestion-auth.json(在 Linux 上为/opt/observiq-otel-collector/ingestion-auth.json,在 Windows 上为C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json),或者更新creds_file_path在config.yaml中以与您保存该文件的路径匹配。 - 依次前往 IAM 和管理 > 设置 ,然后复制项目编号 。您需要此编号进行导出器配置。
方法 2:下载注入身份验证文件(旧版)
- 登录 Google SecOps 控制台。
- 依次前往 SIEM 设置 > 收集代理。
- 下载注入身份验证文件 。
- 将该文件安全地保存在将安装 Bindplane 代理的系统上。
获取 Google SecOps 客户 ID
- 登录 Google SecOps 控制台。
- 依次前往 SIEM 设置 > 个人资料。
从组织详细信息 部分复制并保存客户 ID 。
安装 Bindplane 代理
按照以下说明在 Windows 或 Linux 操作系统上安装 Bindplane 代理。
Windows 安装
- 以管理员身份打开命令提示符 或 PowerShell 。
运行以下命令:
msiexec /i "https://github.com/observIQ/bindplane-agent/releases/latest/download/observiq-otel-collector.msi" /quiet等待安装完成。
运行以下命令,验证安装是否成功:
sc query observiq-otel-collector
该服务应显示为正在运行 。
Linux 安装
- 使用 root 或 sudo 权限打开终端。
运行以下命令:
sudo sh -c "$(curl -fsSlL https://github.com/observiq/bindplane-agent/releases/latest/download/install_unix.sh)" install_unix.sh等待安装完成。
运行以下命令,验证安装是否成功:
sudo systemctl status observiq-otel-collector
该服务应显示为活跃 (正在运行) 。
其他安装资源
如需了解其他安装选项和问题排查信息,请参阅 Bindplane 代理安装指南。
配置 Bindplane 代理以注入 Syslog 并发送到 Google SecOps
找到配置文件
Linux:
sudo nano /opt/observiq-otel-collector/config.yamlWindows:
notepad "C:\Program Files\observIQ OpenTelemetry Collector\config.yaml"
修改配置文件
将
config.yaml的全部内容替换为以下配置:receivers: tcplog: listen_address: "0.0.0.0:514" exporters: chronicle/windchill: protocol: https # Region of your instance, for example us, europe, asia-southeast1 location: <LOCATION> # Project number of the Google Cloud project linked to the instance project: '<PROJECT_NUMBER>' compression: gzip creds_file_path: '/opt/observiq-otel-collector/ingestion-auth.json' customer_id: '<customer_id>' endpoint: chronicle.googleapis.com log_type: WINDCHILL raw_log_field: body service: pipelines: logs/windchill_to_chronicle: receivers: - tcplog exporters: - chronicle/windchill
配置参数
替换以下占位符:
接收器配置:
listen_address:要监听的 IP 地址和端口:0.0.0.0以监听所有接口(推荐)- 端口
514是标准 Syslog 端口(在 Linux 上需要 root 权限;对于非 root 用户,请使用1514)
导出器配置:
creds_file_path:服务帐号 JSON 密钥文件的完整路径(方法 1):- Linux:
/opt/observiq-otel-collector/ingestion-auth.json - Windows:
C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json
- Linux:
customer_id:从 Google SecOps 控制台复制的客户 IDlocation:将<LOCATION>替换为 Google SecOps 实例的区域(例如us、europe或asia-southeast1)。导出器会使用此值为chronicle.googleapis.com添加前缀。如需查看完整列表,请参阅区域级端点。project:将<PROJECT_NUMBER>替换为 IAM 和管理 > 设置 中的项目编号。endpoint:保持设置为chronicle.googleapis.com。
旧版注入 API 导出器
如果您使用方法 2 中的注入身份验证文件,请将
exporters块替换为以下内容。将creds_file_path设置为注入身份验证文件的路径,并且如果您的实例位于美国境外,请将malachiteingestion-pa.googleapis.com替换为您的 区域级端点(例如europe-malachiteingestion-pa.googleapis.com)。exporters: chronicle/windchill: compression: gzip creds_file_path: '/opt/observiq-otel-collector/ingestion-auth.json' customer_id: '<customer_id>' endpoint: malachiteingestion-pa.googleapis.com log_type: WINDCHILL raw_log_field: body
保存配置文件
- 修改后,保存文件:
- Linux:按
Ctrl+O,然后按Enter,再按Ctrl+X - Windows:依次点击文件 > 保存
- Linux:按
重启 Bindplane 代理以应用更改
如需在 Linux 中重启 Bindplane 代理,请执行以下操作:
运行以下命令:
sudo systemctl restart observiq-otel-collector验证服务是否正在运行:
sudo systemctl status observiq-otel-collector检查日志中的错误:
sudo journalctl -u observiq-otel-collector -f
如需在 Windows 中重启 Bindplane 代理,请执行以下操作:
请从下列选项中选择一项:
- 以管理员身份运行命令提示符或 PowerShell:
net stop observiq-otel-collector && net start observiq-otel-collector- 服务控制台:
- 按
Win+R,输入services.msc,然后按 Enter 键。 - 找到 observIQ OpenTelemetry Collector 。
- 右键点击并选择重启 。
- 按
验证服务是否正在运行:
sc query observiq-otel-collector检查日志中的错误:
type "C:\Program Files\observIQ OpenTelemetry Collector\log\collector.log"
配置 PTC Windchill Syslog 转发
- 以管理员身份登录 PTC Windchill 服务器。
配置 rsyslog 或 Syslog 代理以转发 Windchill 应用日志。修改 rsyslog 配置:
sudo nano /etc/rsyslog.d/windchill.conf添加以下代码行,以将 Windchill 日志文件转发到 Bindplane 代理:
# Forward PTC Windchill logs to Bindplane agent module(load="imfile") input(type="imfile" File="/path/to/windchill/logs/*.log" Tag="windchill" Severity="info" Facility="local0") if $syslogtag == 'windchill' then @@<bindplane-ip>:514- 将
/path/to/windchill/logs/替换为实际的 Windchill 日志目录路径。 - 将
<bindplane-ip>替换为 Bindplane 代理主机的 IP 地址。
- 将
重启 rsyslog 服务:
sudo systemctl restart rsyslog通过检查 Bindplane 代理日志,验证日志是否正在发送。
UDM 映射表
| 日志字段 | UDM 映射 | 逻辑 |
|---|---|---|
| eventlabel | metadata.description | 直接复制值 |
| eventtime | metadata.event_timestamp | 使用日期过滤器转换,格式为 SYSLOGTIMESTAMP、ISO8601 |
| metadata.event_type | 如果 has_principal == "true" 且 has_principal_user == "true" 且 has_target == "true",则设置为 "USER_LOGIN";如果 has_target_resource == "true",则设置为 "USER_RESOURCE_ACCESS";如果 has_principal == "true" 且 has_principal_user == "true",则设置为 "USER_UNCATEGORIZED";如果 has_principal == "true",则设置为 "STATUS_UPDATE";否则设置为 "GENERIC_EVENT" | |
| dbschema | metadata.ingestion_labels | 与 db_schema 对象合并(key="DBSCHEMA", value=dbschema) |
| dbname | metadata.product_deployment_id | 直接复制值 |
| eventlabel、description | metadata.product_event_type | 如果 description 不为空,则取 description 中的值,否则取 eventlabel 中的值 |
| context | metadata.product_log_id | 直接复制值 |
| version | metadata.product_version | 直接复制值 |
| ohost | observer.hostname | 如果 ohost 不是 IP,则直接复制值 |
| ohost | observer.ip | 如果 ohost 是 IP,则直接复制值 |
| domainpath | principal.administrative_domain | 直接复制值 |
| ipaddress | principal.asset.hostname | 如果 ipaddress 不是 IP,则直接复制值 |
| ipaddress | principal.asset.ip | 如果 ipaddress 是 IP,则直接复制值 |
| ipaddress、phost | principal.hostname | 如果 ipaddress 不是 IP,则取 ipaddress 中的值,否则如果 phost 不是 IP,则取 phost 中的值 |
| ipaddress、phost | principal.ip | 如果 ipaddress 是 IP,则取 ipaddress 中的值,否则如果 phost 是 IP,则取 phost 中的值 |
| folderpath | principal.process.file.full_path | 直接复制值 |
| user_product_object_id | principal.user.product_object_id | 直接复制值 |
| user_display_name | principal.user.user_display_name | 直接复制值 |
| username、user_userid | principal.user.userid | 如果 username 不为空,则取 username 中的值,否则取 user_userid 中的值 |
| domain_name | target.domain.name | 直接复制值 |
| target_path | target.file.full_path | 直接复制值 |
| namespace | target.namespace | 直接复制值 |
| lifecyclestate、targetname、targetnumber、targettype | target.resource.attribute.labels | 与 lifecyclestate_label(key="lifecyclestate", value=lifecyclestate)、targetname_label(key="targetname", value=targetname)、targetnumber_label(key="targetnumber", value=targetnumber)、targettype_label(key="targettype", value=targettype)合并 |
| target_number | target.resource.id | 直接复制值 |
| target_name | target.resource.name | 直接复制值 |
| target_identity | target.resource.product_object_id | 直接复制值 |
| target_subtype | target.resource.resource_subtype | 直接复制值 |
| metadata.product_name | 设置为“Windchill” | |
| metadata.vendor_name | 设置为“PTC” |
更新日志
需要更多帮助?获得社区成员和 Google SecOps 专业人士的解答。