收集 PTC Windchill 記錄

支援的國家/地區:

本文說明如何使用 Bindplane 將 PTC Windchill 記錄擷取至 Google Security Operations。

PTC Windchill 是產品生命週期管理 (PLM) 平台,用於管理產品資料、程序,以及工程和製造團隊之間的協作。平台會從地端伺服器部署作業產生存取、稽核和設定變更記錄。

事前準備

請確認您已完成下列事前準備事項:

  • Google SecOps 執行個體
  • Windows Server 2016 以上版本,或搭載 systemd 的 Linux 主機
  • Bindplane 代理程式與 PTC Windchill 伺服器之間的網路連線
  • 如果透過 Proxy 執行,請確保防火牆通訊埠已根據 Bindplane 代理程式需求開啟
  • 具備管理員權限的 PTC Windchill 伺服器特殊存取權

取得 Google SecOps 擷取驗證檔案

  1. 登入 Google SecOps 控制台。
  2. 依序前往「SIEM 設定」>「收集代理程式」
  3. 下載擷取驗證檔案,並將檔案安全地儲存在要安裝 Bindplane 的系統中。

取得 Google SecOps 客戶 ID

  1. 登入 Google SecOps 控制台。
  2. 依序前往「SIEM 設定」>「設定檔」
  3. 複製並儲存「機構詳細資料」部分中的客戶 ID

安裝 Bindplane 代理程式

請按照下列操作說明,在 Windows 或 Linux 作業系統上安裝 Bindplane 代理程式。

Windows 安裝

  1. 以管理員身分開啟「命令提示字元」或「PowerShell」
  2. 執行下列指令:

    msiexec /i "https://github.com/observIQ/bindplane-agent/releases/latest/download/observiq-otel-collector.msi" /quiet
    
  3. 等待安裝完成。

  4. 執行下列指令,確認安裝成功:

    sc query observiq-otel-collector
    

服務應顯示為「RUNNING」

Linux 安裝

  1. 開啟具有根層級或 sudo 權限的終端機。
  2. 執行下列指令:

    sudo sh -c "$(curl -fsSlL https://github.com/observiq/bindplane-agent/releases/latest/download/install_unix.sh)" install_unix.sh
    
  3. 等待安裝完成。

  4. 執行下列指令,確認安裝成功:

    sudo systemctl status observiq-otel-collector
    

服務應顯示為有效 (執行中)

其他安裝資源

如需其他安裝選項和疑難排解資訊,請參閱 Bindplane 代理程式安裝指南

設定 Bindplane 代理程式,擷取系統記錄檔並傳送至 Google SecOps

找出設定檔

  • Linux:

    sudo nano /etc/bindplane-agent/config.yaml
    
  • Windows:

    notepad "C:\Program Files\observIQ OpenTelemetry Collector\config.yaml"
    

編輯設定檔

  • config.yaml 的所有內容替換為下列設定:

    receivers:
      tcplog:
        listen_address: "0.0.0.0:514"
    
    exporters:
      chronicle/windchill:
        compression: gzip
        creds_file_path: '/etc/bindplane-agent/ingestion-auth.json'
        customer_id: '<customer_id>'
        endpoint: malachiteingestion-pa.googleapis.com
        log_type: WINDCHILL
        raw_log_field: body
    
    service:
      pipelines:
        logs/windchill_to_chronicle:
          receivers:
            - tcplog
          exporters:
            - chronicle/windchill
    

設定參數

替換下列預留位置:

  • 接收器設定:

    • listen_address:要接聽的 IP 位址和通訊埠:
      • 0.0.0.0,監聽所有介面 (建議)
      • 通訊埠 514 是標準的系統記錄通訊埠 (在 Linux 上需要根層級權限;非根層級權限請使用 1514)
  • 匯出工具設定:

    • creds_file_path:擷取驗證檔案的完整路徑:
      • Linux/etc/bindplane-agent/ingestion-auth.json
      • WindowsC:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json
    • customer_id:從 Google SecOps 控制台複製的客戶 ID
    • endpoint:區域端點網址:
      • 美國malachiteingestion-pa.googleapis.com
      • 歐洲europe-malachiteingestion-pa.googleapis.com
      • 亞洲asia-southeast1-malachiteingestion-pa.googleapis.com
      • 如需完整清單,請參閱「區域端點

儲存設定檔

  • 編輯完成後,請儲存檔案:
    • Linux:依序按下 Ctrl+OEnterCtrl+X
    • Windows:依序點選「檔案」>「儲存」

重新啟動 Bindplane 代理程式,以套用變更

如要在 Linux 中重新啟動 Bindplane 代理程式,請執行下列步驟:

  1. 執行下列指令:

    sudo systemctl restart observiq-otel-collector
    
  2. 確認服務正在執行:

    sudo systemctl status observiq-otel-collector
    
  3. 檢查記錄中是否有錯誤:

    sudo journalctl -u observiq-otel-collector -f
    

如要在 Windows 中重新啟動 Bindplane 代理程式,請按照下列步驟操作:

  1. 您可以選擇下列其中一個選項:

    • 以管理員身分開啟命令提示字元或 PowerShell:
    net stop observiq-otel-collector && net start observiq-otel-collector
    
    • 服務控制台:
      1. 按下 Win+R,輸入 services.msc,然後按下 Enter 鍵。
      2. 找出 observIQ OpenTelemetry Collector
      3. 按一下滑鼠右鍵,然後選取「重新啟動」
  2. 確認服務正在執行:

    sc query observiq-otel-collector
    
  3. 檢查記錄中是否有錯誤:

    type "C:\Program Files\observIQ OpenTelemetry Collector\log\collector.log"
    

設定 PTC Windchill 系統記錄轉送

  1. 以管理員身分登入 PTC Windchill 伺服器。
  2. 設定 rsyslog 或 syslog 代理程式,轉送 Windchill 應用程式記錄。編輯 rsyslog 設定:

    sudo nano /etc/rsyslog.d/windchill.conf
    
  3. 新增下列幾行,將 Windchill 記錄檔轉送至 Bindplane 代理程式:

    # Forward PTC Windchill logs to Bindplane agent
    module(load="imfile")
    input(type="imfile" File="/path/to/windchill/logs/*.log" Tag="windchill" Severity="info" Facility="local0")
    if $syslogtag == 'windchill' then @@<bindplane-ip>:514
    
    • /path/to/windchill/logs/ 替換為實際的 Windchill 記錄目錄路徑。
    • <bindplane-ip> 替換為 Bindplane 代理程式主機的 IP 位址。
  4. 重新啟動 rsyslog 服務:

    sudo systemctl restart rsyslog
    
  5. 檢查 Bindplane 代理程式記錄,確認記錄是否已傳送。

UDM 對應表

記錄欄位 UDM 對應 邏輯
eventlabel metadata.description 直接複製值
eventtime metadata.event_timestamp 使用日期篩選器轉換,格式為 SYSLOGTIMESTAMP、ISO8601
metadata.event_type 如果 has_principal == "true"、has_principal_user == "true" 且 has_target == "true",則設為「USER_LOGIN」;如果 has_target_resource == "true",則設為「USER_RESOURCE_ACCESS」;如果 has_principal == "true" 且 has_principal_user == "true",則設為「USER_UNCATEGORIZED」;如果 has_principal == "true",則設為「STATUS_UPDATE」;否則設為「GENERIC_EVENT」
dbschema metadata.ingestion_labels 已與 db_schema 物件合併 (key=「DBSCHEMA」,value=dbschema)
dbname metadata.product_deployment_id 直接複製值
eventlabel、description metadata.product_event_type 如果說明不為空白,則取自說明,否則取自 eventlabel
context metadata.product_log_id 直接複製值
版本 metadata.product_version 直接複製值
ohost observer.hostname 如果 ohost 不是 IP,則直接複製值
ohost observer.ip 如果 ohost 是 IP,則直接複製值
domainpath principal.administrative_domain 直接複製值
ipaddress principal.asset.hostname 如果 ipaddress 不是 IP,則直接複製值
ipaddress principal.asset.ip 如果 ipaddress 是 IP,則直接複製值
ipaddress、phost principal.hostname 如果不是 IP,則為 ipaddress 的值;如果不是 IP,則為 phost 的值
ipaddress、phost principal.ip 如果是 IP,則為 ipaddress 的值;如果是 IP,則為 phost 的值
資料夾路徑 principal.process.file.full_path 直接複製值
user_product_object_id principal.user.product_object_id 直接複製值
user_display_name principal.user.user_display_name 直接複製值
username、user_userid principal.user.userid 如果使用者名稱不為空值,則取自使用者名稱,否則取自 user_userid
domain_name target.domain.name 直接複製值
target_path target.file.full_path 直接複製值
命名空間 target.namespace 直接複製值
lifecyclestate、targetname、targetnumber、targettype target.resource.attribute.labels 與 lifecyclestate_label (key="lifecyclestate",value=lifecyclestate)、targetname_label (key="targetname",value=targetname)、targetnumber_label (key="targetnumber",value=targetnumber)、targettype_label (key="targettype",value=targettype) 合併
target_number target.resource.id 直接複製值
target_name target.resource.name 直接複製值
target_identity target.resource.product_object_id 直接複製值
target_subtype target.resource.resource_subtype 直接複製值
metadata.product_name 設為「Windchill」
metadata.vendor_name 設為「PTC」

變更記錄

查看這個剖析器的變更記錄

還有其他問題嗎?向社群成員和 Google SecOps 專業人員尋求答案。