收集 Yubico OTP 日志
本文档介绍了如何使用 Bindplane 代理将 Yubico OTP 日志注入到 Google Security Operations。
Yubico OTP 是一种基于硬件的动态密码身份验证协议。YubiKey 验证服务器 (ykval) 是一种自托管 PHP 应用,用于验证动态密码生成器并通过 syslog(LOG_LOCAL0 功能)记录验证请求。
准备工作
请确保满足以下前提条件:
- Google SecOps 实例
- Windows Server 2016 或更高版本,或者具有
systemd的 Linux 主机 - Bindplane 代理与 YubiKey 验证服务器之间的网络连接
- 如果通过代理运行,请确保防火墙端口根据 Bindplane 代理要求处于开放状态
- 已配置 syslog 输出的自托管 YubiKey 验证服务器 (ykval)
获取 Bindplane 代理的 Google SecOps 凭据
如需对 Bindplane 代理进行 Google SecOps 身份验证,请选择以下方法之一:
- 新部署:使用 Chronicle API(方法 1)。
- 旧版部署:继续使用注入身份验证文件(方法 2),直到注入 API 于 2027 年 7 月 20 日停用为止。
方法 1:为 Chronicle API 创建服务帐号(推荐)
- 登录 Google Cloud 控制台,然后选择与您的 Google SecOps 实例关联的 Google Cloud 项目。
- 依次前往 IAM 和管理 > 服务账号。
- 点击创建服务账号 。
- 提供以下配置详细信息:
- 服务账号名称:输入账号的名称(例如
bindplane-ingest)。 - 服务账号说明:输入说明(例如
Bindplane agent log ingestion)。
- 服务账号名称:输入账号的名称(例如
- 点击创建并继续 。
- 在向此服务帐号授予对项目的访问权限 部分,点击选择角色 ,然后选择 Chronicle Editor 。
- 点击继续 ,然后点击完成 。
- 点击您创建的服务帐号,然后前往密钥 标签页。
- 依次点击添加密钥 > 创建新密钥。
- 选择 JSON ,然后点击创建 。密钥文件会下载到您的计算机上。
- 将密钥文件另存为 Bindplane 收集器目录中的
ingestion-auth.json(在 Linux 上为/opt/observiq-otel-collector/ingestion-auth.json,在 Windows 上为C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json),或者更新creds_file_path在config.yaml中以与您保存该文件的路径一致。 - 依次前往 IAM 和管理 > 设置 ,然后复制项目编号 。您需要此编号进行导出器配置。
方法 2:下载注入身份验证文件(旧版)
- 登录 Google SecOps 控制台。
- 依次前往 SIEM 设置 > 收集代理。
- 下载注入身份验证文件 。
- 将该文件安全地保存在将安装 Bindplane 代理的系统上。
获取 Google SecOps 客户 ID
- 登录 Google SecOps 控制台。
- 依次前往 SIEM 设置 > 个人资料。
从组织详细信息 部分复制并保存客户 ID 。
安装 Bindplane 代理
按照以下说明在 Windows 或 Linux 操作系统上安装 Bindplane 代理。
Windows 安装
- 以管理员身份打开命令提示符 或 PowerShell 。
运行以下命令:
msiexec /i "https://github.com/observIQ/bindplane-agent/releases/latest/download/observiq-otel-collector.msi" /quiet等待安装完成。
运行以下命令,验证安装是否成功:
sc query observiq-otel-collector该服务应显示为 RUNNING 。
Linux 安装
- 打开具有根权限或 sudo 权限的终端。
运行以下命令:
sudo sh -c "$(curl -fsSlL https://github.com/observiq/bindplane-agent/releases/latest/download/install_unix.sh)" install_unix.sh等待安装完成。
运行以下命令,验证安装是否成功:
sudo systemctl status observiq-otel-collector该服务应显示为 active (running) 。
其他安装资源
如需了解其他安装选项和问题排查信息,请参阅 Bindplane 代理安装指南。
配置 Bindplane 代理以注入 syslog 并发送到 Google SecOps
找到配置文件
Linux:
sudo nano /opt/observiq-otel-collector/config.yamlWindows:
notepad "C:\Program Files\observIQ OpenTelemetry Collector\config.yaml"
修改配置文件
将
config.yaml的全部内容替换为以下配置:receivers: udplog: listen_address: "0.0.0.0:514" exporters: chronicle/yubico_otp: protocol: https # Region of your instance, for example us, europe, asia-southeast1 location: <LOCATION> # Project number of the Google Cloud project linked to the instance project: '<PROJECT_NUMBER>' compression: gzip creds_file_path: '/opt/observiq-otel-collector/ingestion-auth.json' customer_id: '<customer_id>' endpoint: chronicle.googleapis.com log_type: YUBICO_OTP raw_log_field: body service: pipelines: logs/yubico_to_chronicle: receivers: - udplog exporters: - chronicle/yubico_otp
配置参数
替换以下占位符:
接收器配置:
listen_address:要监听的 IP 地址和端口:0.0.0.0以监听所有接口(推荐)- 端口
514是标准 syslog 端口(在 Linux 上需要 root 权限;对于非 root 用户,请使用1514)
导出器配置:
creds_file_path:服务帐号 JSON 密钥文件的完整路径(方法 1):- Linux:
/opt/observiq-otel-collector/ingestion-auth.json - Windows:
C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json
- Linux:
customer_id:从 Google SecOps 控制台复制的客户 IDlocation:将<LOCATION>替换为 Google SecOps 实例的区域(例如us、europe或asia-southeast1)。导出器会使用此值为chronicle.googleapis.com添加前缀。如需查看完整列表,请参阅区域级端点。project:将<PROJECT_NUMBER>替换为 IAM 和管理 > 设置 中的项目编号。endpoint:保持设置为chronicle.googleapis.com。
旧版注入 API 导出器
如果您使用方法 2 中的注入身份验证文件,请将
exporters代码块替换为以下内容。将creds_file_path设置为注入身份验证文件的路径,并且如果您的实例位于美国境外,请将malachiteingestion-pa.googleapis.com替换为您的 区域级端点(例如europe-malachiteingestion-pa.googleapis.com)。exporters: chronicle/yubico_otp: compression: gzip creds_file_path: '/opt/observiq-otel-collector/ingestion-auth.json' customer_id: '<customer_id>' endpoint: malachiteingestion-pa.googleapis.com log_type: YUBICO_OTP raw_log_field: body
保存配置文件
- 修改后,请保存该文件:
- Linux:按
Ctrl+O,然后按Enter,再按Ctrl+X - Windows:依次点击文件 > 保存
- Linux:按
重启 Bindplane 代理以应用更改
如需在 Linux 中重启 Bindplane 代理,请运行以下命令:
sudo systemctl restart observiq-otel-collector验证服务是否正在运行:
sudo systemctl status observiq-otel-collector检查日志中的错误:
sudo journalctl -u observiq-otel-collector -f
如需在 Windows 中重启 Bindplane 代理,请选择以下选项之一:
以管理员身份运行命令提示符或 PowerShell:
net stop observiq-otel-collector && net start observiq-otel-collector“服务”控制台:
- 按
Win+R,输入services.msc,然后按 Enter 键。 - 找到 observIQ OpenTelemetry Collector 。
- 右键点击并选择重启 。
验证服务是否正在运行:
sc query observiq-otel-collector检查日志中的错误:
type "C:\Program Files\observIQ OpenTelemetry Collector\log\collector.log"
- 按
配置 ykval syslog 转发
验证 ykval syslog 输出是否已配置。将以下内容添加到
/etc/rsyslog.d/ykval.conf(或适用于您的 syslog 守护程序的等效内容):local0.* @<BINDPLANE_AGENT_IP>:514重启 rsyslog 服务:
sudo systemctl restart rsyslog通过检查 Bindplane 代理日志,验证 OTP 验证请求是否正在转发。
UDM 映射表
| 日志字段 | UDM 映射 | 逻辑 |
|---|---|---|
| token1、token2、token3、token4 | additional.fields | 如果 token1 不为空,则从 additional_token1 合并;如果 token2 不为空,则从 additional_token2 合并;如果 token3 不为空,则从 additional_token3 合并;如果 token4 不为空,则从 additional_token4 合并 |
| token1、token2 | extensions.auth.mechanism | 如果 token1 或 token2 不为空,则设置为“OTP” |
| extensions.auth.type | 如果说明与 authenticated、wrong、logged in 匹配,则设置为“AUTHTYPE_UNSPECIFIED” | |
| intermediary | intermediary | 已合并 |
| description | metadata.description | 直接复制的值 |
| description、audit_type、product_event、has_principal_machine_field、has_principal_user_id | metadata.event_type | 如果说明与 authenticated、wrong、logged in 匹配,则设置为 USER_LOGIN;否则,如果 audit_type 与 audit 匹配,且 has_principal_machine_field 为 true,且 has_principal_user_id 为 true,则设置为 SYSTEM_AUDIT_LOG_UNCATEGORIZED;否则,如果 has_principal_machine_field 为 true,则设置为 STATUS_UPDATE;否则,如果 has_principal_user_id 为 true,则设置为 USER_UNCATEGORIZED;否则设置为 GENERIC_EVENT |
| product_event | metadata.product_event_type | 直接复制的值 |
| observer | observer.hostname | 如果观测者不是 IP,则进行设置 |
| observer | observer.ip | 如果观测者是 IP,则进行合并 |
| principal | principal | 已重命名 |
| sdomain | principal.administrative_domain | 直接复制的值 |
| domain_name | principal.domain.name | 直接复制的值 |
| node | principal.hostname | 直接复制的值 |
| cwd、exe | principal.process.file.full_path | 如果 cwd 不为空,则设置为 cwd;否则,如果 exe 不为空,则设置为 exe |
| ppid | principal.process.parent_process.pid | 直接复制的值 |
| pid | principal.process.pid | 直接复制的值 |
| uid、gid、euid、suid、fsuid、egid、sgid、fsgid、comm、subj、key、arch、name、ouid、ogid、inode、cap_fp、cap_fi、cap_fe、mode、proctitle | principal.resource.attribute.labels | 如果字段不为空,则与相应标签合并 |
| user | principal.user.email_addresses | 如果用户与电子邮件地址模式匹配,则进行合并 |
| user | principal.user.user_display_name | 如果用户与电子邮件地址模式不匹配,则进行设置 |
| suser、user_id、auid | principal.user.userid | 如果 suser 不为空,则设置为 suser;否则,如果 user 不为空且 grok 成功,则设置为 user_id;否则,如果 auid 不为空,则设置为 auid |
| security_result | security_result | 已合并 |
| description、status | security_result.action | 如果说明与 success 或 logged in 匹配,或者 status 为 GRANTED,则设置为 ALLOW;否则,如果说明与 wrong 匹配,则设置为 BLOCK |
| severity | security_result.severity | 如果严重级别与 (?i)(low|Unknown|info) 匹配,则设置为 LOW |
| summary | security_result.summary | 直接复制的值 |
| target | target | 已重命名 |
| hostname、server、src_ip | target.hostname | 如果 hostname 不为空,则设置为 hostname;否则,如果 server 不为空,则设置为 server;否则,如果 src_ip 不是 IP,则设置为 src_ip |
| src_ip | target.ip | 如果 src_ip 是 IP,则进行合并 |
| product | metadata.product_name | 直接复制的值 |
| vendor | metadata.vendor_name | 直接复制的值 |
更新日志
需要更多帮助?获得社区成员和 Google SecOps 专业人士的解答。