收集 Zix Email Encryption 日志
本文档介绍了如何使用 Bindplane 代理将 Zix Email Encryption 日志注入到 Google Security Operations 中。
Zix Email Encryption(现为 OpenText ZixEncrypt)是一个电子邮件加密和 DLP 平台,用于确保电子邮件通信安全和合规性。它会在 ZixGateway 设备上生成 SMTP 事务日志和加密事件日志。
准备工作
请确保满足以下前提条件:
- Google SecOps 实例
- Windows Server 2016 或更高版本,或者具有
systemd的 Linux 主机 - Bindplane 代理与 Zix Email Encryption 设备之间的网络连接
- 如果通过代理运行,请确保防火墙端口符合 Bindplane 代理要求
- 具有管理员权限的 Zix Email Encryption 设备 (ZixGateway) 的特权访问权限
- 对 Zix Email Encryption 日志文件(SMTP 事务日志、加密事件日志)的访问权限
获取 Bindplane 代理的 Google SecOps 凭据
如需向 Google SecOps 验证 Bindplane 代理的身份,请选择以下方法之一:
- 新部署:使用 Chronicle API(方法 1)。
- 旧版部署:继续使用注入身份验证文件(方法 2),直到注入 API 于 2027 年 7 月 20 日停用为止。
方法 1:为 Chronicle API 创建服务帐号(推荐)
- 登录 Google Cloud 控制台,然后选择与您的 Google SecOps 实例关联的 Google Cloud 项目。
- 依次前往 IAM 和管理 > 服务账号。
- 点击创建服务账号 。
- 提供以下配置详细信息:
- 服务账号名称:输入账号的名称(例如
bindplane-ingest)。 - 服务账号说明:输入说明(例如
Bindplane agent log ingestion)。
- 服务账号名称:输入账号的名称(例如
- 点击创建并继续 。
- 在向此服务帐号授予对项目的访问权限 部分,点击选择角色 ,然后选择 Chronicle Editor 。
- 点击继续 ,然后点击完成 。
- 点击您创建的服务帐号,然后前往密钥 标签页。
- 依次点击添加密钥 > 创建新密钥。
- 选择 JSON ,然后点击创建 。密钥文件会下载到您的计算机上。
- 将密钥文件另存为 Bindplane 收集器目录中的
ingestion-auth.json(在 Linux 上为/opt/observiq-otel-collector/ingestion-auth.json,在 Windows 上为C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json),或者更新creds_file_path在config.yaml中以与您保存该文件的路径匹配。 - 依次前往 IAM 和管理 > 设置 ,然后复制项目编号 。您需要此编号进行导出器配置。
方法 2:下载注入身份验证文件(旧版)
- 登录 Google SecOps 控制台。
- 依次前往 SIEM 设置 > 收集代理。
- 下载注入身份验证文件 。
- 将该文件安全地保存在将安装 Bindplane 代理的系统上。
获取 Google SecOps 客户 ID
- 登录 Google SecOps 控制台。
- 依次前往 SIEM 设置 > 个人资料。
从组织详细信息 部分复制并保存客户 ID 。
安装 Bindplane 代理
按照以下说明在 Windows 或 Linux 操作系统上安装 Bindplane 代理。
Windows 安装
- 以管理员身份打开命令提示符 或 PowerShell 。
运行以下命令:
msiexec /i "https://github.com/observIQ/bindplane-agent/releases/latest/download/observiq-otel-collector.msi" /quiet等待安装完成。
运行以下命令,验证安装是否成功:
sc query observiq-otel-collector该服务应显示为正在运行 。
Linux 安装
- 使用 root 或 sudo 权限打开终端。
运行以下命令:
sudo sh -c "$(curl -fsSlL https://github.com/observiq/bindplane-agent/releases/latest/download/install_unix.sh)" install_unix.sh等待安装完成。
运行以下命令,验证安装是否成功:
sudo systemctl status observiq-otel-collector该服务应显示为活跃 (正在运行) 。
其他安装资源
如需了解其他安装选项和问题排查信息,请参阅 Bindplane 代理安装指南。
配置 Bindplane 代理以注入 syslog 并将其发送到 Google SecOps
找到配置文件
Linux:
sudo nano /opt/observiq-otel-collector/config.yamlWindows:
notepad "C:\Program Files\observIQ OpenTelemetry Collector\config.yaml"
修改配置文件
将
config.yaml的全部内容替换为以下配置:receivers: filelog: include: - /var/log/zix/*.log - /opt/zix/logs/*.log start_at: beginning exporters: chronicle/zix_email: protocol: https # Region of your instance, for example us, europe, asia-southeast1 location: <LOCATION> # Project number of the Google Cloud project linked to the instance project: '<PROJECT_NUMBER>' compression: gzip creds_file_path: '/opt/observiq-otel-collector/ingestion-auth.json' customer_id: '<customer_id>' endpoint: chronicle.googleapis.com log_type: ZIX_EMAIL_ENCRYPTION raw_log_field: body ingestion_labels: env: production service: pipelines: logs/zix_to_chronicle: receivers: - filelog exporters: - chronicle/zix_email
配置参数
替换以下占位符:
接收器配置:
filelog:用于从磁盘收集日志文件的接收器类型include:要监控的文件路径或 glob 模式的列表:- Linux:
/var/log/zix/*.log或/opt/zix/logs/*.log - Windows:
C:\Program Files\Zix\logs\*.log - 调整路径以与您的 ZixGateway 日志文件位置匹配
- Linux:
start_at:设置为beginning以从头开始读取现有日志文件,或设置为end以仅读取新条目
导出器配置:
zix_email:导出器的说明性名称creds_file_path:服务帐号 JSON 密钥文件的完整路径(方法 1):- Linux:
/opt/observiq-otel-collector/ingestion-auth.json - Windows:
C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json
- Linux:
<customer_id>:上一步中的客户 IDlocation:将<LOCATION>替换为 Google SecOps 实例的区域(例如us、europe或asia-southeast1)。导出器会使用此值为chronicle.googleapis.com添加前缀。如需查看完整列表,请参阅区域级端点。project:将<PROJECT_NUMBER>替换为 IAM 和管理 > 设置 中的项目编号。endpoint:保持设置为chronicle.googleapis.com。ZIX_EMAIL_ENCRYPTION:日志类型,与 Chronicle 中显示的内容完全一致ingestion_labels:YAML 格式的可选标签(例如env: production)
流水线配置:
zix_to_chronicle:流水线的说明性名称
旧版注入 API 导出器
如果您使用方法 2 中的注入身份验证文件,请将
exporters块替换为以下内容。将creds_file_path设置为注入身份验证文件的路径,如果您的实例位于美国境外,请将malachiteingestion-pa.googleapis.com替换为您的 区域级端点(例如europe-malachiteingestion-pa.googleapis.com)。exporters: chronicle/zix_email: compression: gzip creds_file_path: '/opt/observiq-otel-collector/ingestion-auth.json' customer_id: '<customer_id>' endpoint: malachiteingestion-pa.googleapis.com log_type: ZIX_EMAIL_ENCRYPTION raw_log_field: body ingestion_labels: env: production
保存配置文件
- 修改后,保存文件:
- Linux:按
Ctrl+O,然后按Enter,再按Ctrl+X - Windows:依次点击文件 > 保存
- Linux:按
重启 Bindplane 代理以应用更改
如需在 Linux 中重启 Bindplane 代理,请运行以下命令:
sudo systemctl restart observiq-otel-collector验证服务是否正在运行:
sudo systemctl status observiq-otel-collector检查日志中的错误:
sudo journalctl -u observiq-otel-collector -f
如需在 Windows 中重启 Bindplane 代理,请选择以下选项之一:
以管理员身份运行命令提示符或 PowerShell:
net stop observiq-otel-collector && net start observiq-otel-collector服务控制台:
- 按
Win+R,输入services.msc,然后按 Enter 键。 - 找到 observIQ OpenTelemetry Collector 。
- 右键点击并选择重启 。
验证服务是否正在运行:
sc query observiq-otel-collector检查日志中的错误:
type "C:\Program Files\observIQ OpenTelemetry Collector\log\collector.log"
- 按
配置 Zix Email Encryption 日志收集
Bindplane 代理直接从 ZixGateway 设备文件系统收集日志文件。
验证日志文件位置
- 登录 ZixGateway 管理控制台。
- 依次前往监控 > 日志。
验证日志文件目录:
- Linux:
/var/log/zix/或/opt/zix/logs/ - Windows:
C:\Program Files\Zix\logs\
- Linux:
确认 SMTP 事务日志和加密事件日志正在写入预期位置。
如果日志目录与默认目录不同,请更新 Bindplane 代理
config.yaml中的include路径。
UDM 映射表
| 日志字段 | UDM 映射 | 逻辑 |
|---|---|---|
| intermediary | intermediary | 从 intermediary 合并 |
| relay_host | intermediary.hostname | 直接从 relay_host 复制的值 |
| relay_ip | intermediary.ip | 从 relay_ip 合并 |
| relay_port | intermediary.port | 从 relay_port 转换为整数的值 |
| message_details | metadata.description | 直接从 smtp、smtpd、cleanup 或 error 块中的 message_details 复制的值 |
| principal_hostname, sender_email | metadata.event_type | 如果 principal_hostname 和 sender_email 不为空,则设置为“EMAIL_TRANSACTION”;否则,如果 principal_hostname 和 (target_host 或 target_ip) 不为空,则设置为“NETWORK_CONNECTION”;否则,如果 principal_hostname 不为空且 (target_host 或 target_ip) 为空,则设置为“STATUS_UPDATE”;否则,设置为“GENERIC_EVENT” |
| metadata.product_name | 设置为“Zix Email Encryption” | |
| metadata.vendor_name | 设置为“Zix” | |
| message | network.application_protocol | 如果 message 与 smtp 或 smtpd 匹配,则设置为“SMTP” |
| sender_email | network.email.from | 如果 sender_email 与电子邮件正则表达式匹配,则直接复制值 |
| subject | network.email.subject | 从 subject 合并 |
| recipient_email | network.email.to | 如果与电子邮件正则表达式匹配,则从 recipient_email 合并 |
| data_size | network.received_bytes | 从 data_size 转换为 uinteger 的值 |
| tls_cipher | network.tls.cipher | 直接从 tls_cipher 复制的值 |
| cert_data | network.tls.client.certificate.issuer | 直接从 cert_data 复制的值 |
| daemon | principal.application | 直接从 daemon 复制的值 |
| principal_hostname | principal.hostname | 直接从 principal_hostname 复制的值 |
| file | principal.process.file.full_path | 直接从 file 复制的值 |
| pid | principal.process.pid | 直接从 pid 复制的值 |
| principal.resource.type | 如果 daemon 是 cleanup,则设置为“CLEANUP_MESSAGE_ID” | |
| sender_email | principal.user.user_display_name | 如果 sender_email 与电子邮件正则表达式不匹配,则直接复制值 |
| user_id | principal.user.userid | 如果 user_id 不为空,则取自 user_id;否则,取自 else 块中的 user_id |
| security_result | security_result | 从 security_result 合并 |
| security_action | security_result.action | 从 security_action 合并 |
| failure_reason | security_result.description | 直接从 failure_reason 复制的值 |
| security_summary | security_result.summary | 直接从 security_summary 复制的值 |
| file | target.file.full_path | 直接从 file 复制的值 |
| target_host | target.hostname | 直接从 target_host 复制的值 |
| target_ip | target.ip | 从 target_ip 合并 |
| target_port | target.port | 从 target_port 转换为整数的值 |
| message_id | target.resource.name | 直接从 message_id 复制的值 |
| recipient_email | target.user.user_display_name | 如果 recipient_email 与电子邮件正则表达式不匹配,则直接复制值 |
更新日志
需要更多帮助?获得社区成员和 Google SecOps 专业人士的解答。